WLAN Verschlüsselung funktioniert nicht

Dieses Thema im Forum "SuSE / OpenSuSE" wurde erstellt von ccc, 23.06.2005.

  1. ccc

    ccc Routinier

    Dabei seit:
    01.11.2003
    Beiträge:
    288
    Zustimmungen:
    0
    hi

    folgendes problem:
    habe PC, SUSE 9.1 und wireless karte von Netgear WG311T mit Atheros Chip.

    Ohne Verschlüsselung die WLAN Verbindung funktioniert einwandfrei.
    Madwifi treiber ath_pci wird korrekt erkannt
    sobald ich die Verschlüsselung einschalte,
    funktioniert nicht mehr.

    egal ob ich die Einstellungen von meiner wireless Karte mit dem Yast
    WEP Mode von open zu shared ändere, oder vom command line eingebe:
    Code:
    # iwconfig ath0 key restricted [1] 123456789
    # iwconfig ath0 key [1] restricted
    
    iwconfig, zeigt immer Security mode:open
    Code:
    # iwconfig
    lo        no wireless extensions.
    
    ath0      IEEE 802.11b  ESSID:"myessid"  Nickname:"linux"
              Mode:Managed  Frequency:2.457GHz  Access Point: FF:FF:FF:FF:FF:FF
              Bit Rate=1Mb/s   Tx-Power:off   Sensitivity=0/3
              Retry:off   RTS thr:off   Fragment thr:off
              Encryption key:0123-4567-89   Security mode:open
              Power Management:off
              Link Quality:0/94  Signal level:-95 dBm  Noise level:-95 dBm
              Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
              Tx excessive retries:0  Invalid misc:0   Missed beacon:0
    es scheint, dass Madwifi kein WEP unterstützt, obwohl gemäss diesem link sollte:
    http://www.mattfoster.clara.co.uk/madwifi-4.htm

    "First of all, MADwifi supports WEP, which is generally configured through iwconfig.
    You can also get Shared Key going using iwpriv authmode 2 and iwconfig together."

    leider bei mir funktioniert nicht:
    # iwpriv ath0 authmode 2
    Invalid command : authmode

    habe viel gegoogelt und in anderen linux foren probiert, aber bis jetzt hoffnugslos.
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. devilz

    devilz Pro*phet
    Administrator

    Dabei seit:
    01.05.2002
    Beiträge:
    12.244
    Zustimmungen:
    0
    Ort:
    Hessen
    Hast du mal die CVS Treiber probiert?

    Eventl. mag der Treiber deine Karte nicht richtig ...
     
  4. ccc

    ccc Routinier

    Dabei seit:
    01.11.2003
    Beiträge:
    288
    Zustimmungen:
    0
    nein, habe ich nicht probiert,

    aber SUSE 9.3 installiert und es funktioniert bestens.
     
  5. R-F-E

    R-F-E Jungspund

    Dabei seit:
    18.05.2005
    Beiträge:
    13
    Zustimmungen:
    0
    ich habe bei Suse 9.3 alles eingestellt..

    und bei mir funzzt es nicht...
    scheint an der verschlüsselung zu liegen..
    KInternet sagt zwar immer "You connected succesfully to: <ESSID>"
    aber wenn ich dann firefox oder konqueror öffne und ne URL eingebe wird der server nicht gefunden...
    Das Problem habe ich unter Windows auch, wenn ich einen falschen key eingebe...
    aber ich kann euch versichern: ich habe es 100mal probiert...
    und mind. 70 mal davon war der key richtig...

    Was habe ich falsch eingestellt?
    achja: habe ein RT2500 Wlan karte
     
  6. ccc

    ccc Routinier

    Dabei seit:
    01.11.2003
    Beiträge:
    288
    Zustimmungen:
    0
    du machst sicher richtig, es fehlt aber am fein tunning.
    als erstes sollest du von command line probieren:
    Code:
    iwpriv ath0 authmode 2
    ping dein_wlan_router
    wenn es funktioniert, dann solltest du in etc/sysconfig/network/dein_wlan_config_file folgenden code hinfügen:
    Code:
    WIRELESS_IWPRIV_OPTIONS='authmode 2'[code]
    
    und falls nach dem restart immer noch nicht geht, dann in /etc/sysconfig/kernel unter MODULES_LOADED_ON_BOOT 
    
    ath_pci 
    
    zusätzlich eintragen.
    
    gruss und lass es bitte wissen, ob klappt's
    ccc
     
  7. R-F-E

    R-F-E Jungspund

    Dabei seit:
    18.05.2005
    Beiträge:
    13
    Zustimmungen:
    0
    thx für die schnelle antwort...
    habe deine anweisungen (fast) genau ausgeführt (habe das pingen da mittendrin vergessen... daran solls aber nicht liegen, oder? sonst habe ich alles so gemacht, wie du gesagt hast)

    aber es funzzt nicht...
    hat sich praktisch nichts geändert
     
  8. #7 ccc, 07.08.2005
    Zuletzt bearbeitet: 07.08.2005
    ccc

    ccc Routinier

    Dabei seit:
    01.11.2003
    Beiträge:
    288
    Zustimmungen:
    0
    dann poste bitte dein:

    ifconfig
    iwconfig
    etc/sysconfig/network/dein_wlan_config_file
    route -n
    IP von deinem wlan router

    welchen wlan router hast du ?
    ist die wlan karte auf dhcp eingestellt oder hast du fixe IP vergeben ?

    gruss
    ccc
     
  9. #8 Leno, 07.08.2005
    Zuletzt bearbeitet: 27.04.2007
    Leno

    Leno -

    Dabei seit:
    26.10.2003
    Beiträge:
    139
    Zustimmungen:
    0
    -
     
  10. ccc

    ccc Routinier

    Dabei seit:
    01.11.2003
    Beiträge:
    288
    Zustimmungen:
    0
    sorry, habe übersehen dass nicht die gleiche wlan karte ist !
     
  11. R-F-E

    R-F-E Jungspund

    Dabei seit:
    18.05.2005
    Beiträge:
    13
    Zustimmungen:
    0
    wenn ich das in die konsole eingebe kommt:
    "invalid command: authmode"
    Die Sachen:

    ifcfg-wlan-id(etc/sysconfig/network/dein_wlan_config_file):
    BROADCAST='192.168.1.255'
    IPADDR='192.168.1.3'
    MTU=''
    NAME='Micro-Star International Ralink RT2500 802.11 Cardbus Reference Card'
    NETMASK='255.255.255.0'
    NETWORK='192.168.1.0'
    REMOTE_IPADDR=''
    STARTMODE='auto'
    UNIQUE='VQ+S.ub0c+SvzfD3'
    USERCONTROL='yes'
    WIRELESS_AUTH_MODE='sharedkey'
    WIRELESS_KEY_1=''
    WIRELESS_KEY_2=''
    WIRELESS_KEY_3=''
    WIRELESS_NICK=''
    WIRELESS_POWER='yes'
    WIRELESS_WPA_PSK='*************'
    _nm_name='bus-pci-0000:00:09.0'
    WIRELESS_ESSID='ArcorWirelessLAN'
    WIRELESS_KEY_0='s:***********'
    BOOTPROTO='static'
    WIRELESS_NWID=''
    WIRELESS_KEY=''
    WIRELESS_DEFAULT_KEY='0'
    WIRELESS_KEY_LENGTH='128'
    WIRELESS_AP=''
    WIRELESS_BITRATE='auto'
    WIRELESS_CHANNEL=''
    WIRELESS_MODE='Managed'
    WIRELESS_FREQUENCY=''
    WIRELESS_IWPRIV_OPTIONS='authmode 2'

    ifconfig:

    eth0 Link encap:Ethernet HWaddr 00:0B:6A:14:24:58
    inet addr:192.168.0.44 Bcast:192.168.0.255 Mask:255.255.255.0
    inet6 addr: fe80::20b:6aff:fe14:2458/64 Scope:Link
    UP BROADCAST MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:17 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:0 (0.0 b) TX bytes:1560 (1.5 Kb)
    Interrupt:10 Base address:0xd400

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:106 errors:0 dropped:0 overruns:0 frame:0
    TX packets:106 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:6650 (6.4 Kb) TX bytes:6650 (6.4 Kb)

    ra0 Link encap:Ethernet HWaddr 00:11:09:5A:C4:A9
    inet addr:192.168.1.3 Bcast:192.168.1.255 Mask:255.255.255.0
    inet6 addr: fe80::211:9ff:fe5a:c4a9/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:12 errors:0 dropped:0 overruns:0 frame:0
    TX packets:56 errors:4 dropped:4 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:1490 (1.4 Kb) TX bytes:2862 (2.7 Kb)
    Interrupt:11 Base address:0x4000


    iwconfig:
    lo no wireless extensions.

    sit0 no wireless extensions.

    eth0 no wireless extensions.

    ra0 RT2500 Wireless ESSID:"ArcorWirelessLAN" Nickname:"linux"
    Mode:Managed Frequency=2.452 GHz Access Point: 00:A0:C5:EC:65:A3
    Bit Rate=54 Mb/s
    RTS thr:off Fragment thr:off
    Encryption key:5745-5042-7572-6B48-656C-6552-70 Security mode:restricted
    Link Quality=79/100 Signal level:-207 dBm Noise level:-256 dBm
    Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
    Tx excessive retries:0 Invalid misc:0 Missed beacon:0

    route -n
    Kernel IP routing table
    Destination Gateway Genmask Flags Metric Ref Use Iface
    192.168.1.0 0.0.0.0 255.255.255.0 U 0 0 0 ra0
    192.168.0.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0
    169.254.0.0 0.0.0.0 255.255.0.0 U 0 0 0 eth0
    127.0.0.0 0.0.0.0 255.0.0.0 U 0 0 0 lo
    0.0.0.0 192.168.1.1 0.0.0.0 UG 0 0 0 ra0
     
  12. ccc

    ccc Routinier

    Dabei seit:
    01.11.2003
    Beiträge:
    288
    Zustimmungen:
    0
    probiere mal bitte:

    # ifconfig eth0 down
    # ping router

    sonst

    # iwpriv ra0 mode 0
    # ping router

    du kannst mode mit dem parameter zwischen 0 und 3 probieren
     
  13. #12 Leno, 07.08.2005
    Zuletzt bearbeitet: 27.04.2007
    Leno

    Leno -

    Dabei seit:
    26.10.2003
    Beiträge:
    139
    Zustimmungen:
    0
    -
     
  14. R-F-E

    R-F-E Jungspund

    Dabei seit:
    18.05.2005
    Beiträge:
    13
    Zustimmungen:
    0
    also ich selbst habe den router nicht konfiguriert...
    das ganze läuft über "shared"
    wie man sieht nutze ich eine feste IP und kein dhcp
    nutze WEP(oder WPA... ist doch das gleiche) verschlüsselung..
    den key habe ich selbstverständlich durch * ersetzt

    acces control?
    kp... noch nie gehört

    was meinst du denn: welchen chipsatz sollte ich mir kaufen?
     
  15. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  16. ccc

    ccc Routinier

    Dabei seit:
    01.11.2003
    Beiträge:
    288
    Zustimmungen:
    0
    andere frage

    hast du nur mit dem WEP probiert ?
     
  17. R-F-E

    R-F-E Jungspund

    Dabei seit:
    18.05.2005
    Beiträge:
    13
    Zustimmungen:
    0
    was meinst du?
    ob ich versucht habe die verschlüsselung am router auszuschalten?
    ne das habe ich nicht prob.
    die muss aber so oder so aktiv sein...
    es hilft mir nichts, wenn ich die raus nehme..
    viel zu großer sicherheits risiko
     
Thema:

WLAN Verschlüsselung funktioniert nicht

Die Seite wird geladen...

WLAN Verschlüsselung funktioniert nicht - Ähnliche Themen

  1. Kann bei WLAN nur ohne Verschlüsselung ins Internet

    Kann bei WLAN nur ohne Verschlüsselung ins Internet: Habe gestern Ubuntu 6.06.1 auf meinen Rechner installiert und wollte WLAN einrichtung! Hab alles probiert mit Verschlüsselung ins Internet zu...
  2. SUSE 9.3 WLAN keine IP bei Verschlüsselung

    SUSE 9.3 WLAN keine IP bei Verschlüsselung: Hallo zusammen, hoffentlich kann mir hier einer weiterhelfen. :-) Ich habe unter SUSE 9.3 Pro eine DLINK G520 Wlankarte installiert. Klappt...
  3. Routing 2 Subnetze (WLAN und ETH)

    Routing 2 Subnetze (WLAN und ETH): Hallo, hoffe ich bin hier richtig. Ich habe ein Raspberry Pi welcher als WLAN-Accesspoint dient. Dabei sehen die Interfaces wie folgt aus: wlan1...
  4. Installation, aber wo hin mit dem WLAN Passwort?

    Installation, aber wo hin mit dem WLAN Passwort?: Hallo, ich hab nicht gewußt wohin mit dem Wlan-Passwort (WPA2). Dadurch habe ich MidnightBSD gefunden und da installier ich was, aber es ist...
  5. Raspberry Pi 3 mit WLAN und Bluetooth

    Raspberry Pi 3 mit WLAN und Bluetooth: Die Gerüchteküche um einen neuen Raspberry Pi köchelt schon seit einigen Monaten. Jetzt gibt es erste konkrete Hinweise, was Nutzer von dem neuen...