nvidia-Treiber Problem unter Sid

Dieses Thema im Forum "Debian/Ubuntu/Knoppix" wurde erstellt von schwedenmann, 26.08.2007.

  1. #1 schwedenmann, 26.08.2007
    schwedenmann

    schwedenmann Foren Gott

    Dabei seit:
    18.11.2003
    Beiträge:
    2.635
    Zustimmungen:
    2
    Ort:
    Wegberg
    Hallo


    OS: Sid
    Kernel : 2.6.22.1-k7 (Debian-image)
    Graka fx5200 sowie in einem andern ystem Fx6200
    nvidia-Treiber : NVIDIA-Linux-x86-100.14.11-pkg1.run


    Da es bei debian nur Nvidia-Pakete für 2.6.18.-4-k7 gibt, muß ich den obigen originalen nvidia-Treiber benutzen.

    Treiber ausführbar gemacht. läßt sich auc aufrufen, nur er installiert nichts.
    Im log steht

    No precompiled kernel interface was founf match your kernel.

    kernel-headrs sind aber installiert.

    Muß ich jetzt die kernel-sourcen installieren, oder reicht ev. das Debian-Paket
    nvidia-kernel-source
    damit die nvidia-Treiberinstallation ribungslos durchläuft ?


    mfg
    schwedenmann
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. defcon

    defcon Kaiser
    Moderator

    Dabei seit:
    22.08.2005
    Beiträge:
    1.486
    Zustimmungen:
    1
    Ort:
    Bruchsal
    Hm.... also ich hab auch den Kernel 2.6.22 (allerdings aus sid geklaut für lenny), und nur die dazugehörigen linux-headers-$(uname -r). Die Installation hat bei mir wunderbar funktioniert.
     
  4. #3 schwedenmann, 26.08.2007
    schwedenmann

    schwedenmann Foren Gott

    Dabei seit:
    18.11.2003
    Beiträge:
    2.635
    Zustimmungen:
    2
    Ort:
    Wegberg
    Linux-headers

    Hallo


    Ich hab heute erst bei Sid auf 2.6.22-1-k7 upgedatet, per apt-get dabei werden die heaers automatisch mit installiert.
    Danach habe ich dann ein init1 gemacht und den nvidia-Treiebr versucht zu installieren.

    Kann es ev. an dem fehlenden Reboot, nach dem Kernelupdate, liegen ?

    Es lag noch ein kernel 2.6.12-1-k7 auf dem System, auch mit dazugehörigen headern.

    mfg
    schwedenmann
     
  5. defcon

    defcon Kaiser
    Moderator

    Dabei seit:
    22.08.2005
    Beiträge:
    1.486
    Zustimmungen:
    1
    Ort:
    Bruchsal
    Nach dem Kernelupdate sollte man schon rebooten.
    Mach doch mal in der Konsole uname -r dann siehste ja mit welchem Kernel du hier bist.
     
  6. #5 schwedenmann, 26.08.2007
    schwedenmann

    schwedenmann Foren Gott

    Dabei seit:
    18.11.2003
    Beiträge:
    2.635
    Zustimmungen:
    2
    Ort:
    Wegberg
    nvidia

    Hallo


    Kernel ist 2.6.22.-1-k7

    init 1

    nvidia kann nicht installiert werden, wieder Meldung wie im ersten post.

    Headers sind auch installeirt (2.6.22.-1-k7).

    no precompiled kernel interface found!

    Er will dann von nvidia.com ein passendes kernel interface downloaden, aber ich habe ja kein Netzwerk in init 1.

    mfg
    schwedenmann
     
  7. #6 Goodspeed, 26.08.2007
    Goodspeed

    Goodspeed Foren Gott
    Moderator

    Dabei seit:
    21.04.2004
    Beiträge:
    4.165
    Zustimmungen:
    1
    Ort:
    Dresden
    Das ist doch alles "normal" ...
    Nvidia liefert für einige Distributionen fertige Kernel-Module aus. Für Debian u.a. nicht ...
    Bringt nix ... gibts eh nicht.
    Wenn er fragt, ob er bei Nvidia.com suchen soll -> nein und er fängt mit bauen an.

    Warum nimmst Du eigentlich nicht den module-assistanten?
     
  8. #7 schwedenmann, 26.08.2007
    schwedenmann

    schwedenmann Foren Gott

    Dabei seit:
    18.11.2003
    Beiträge:
    2.635
    Zustimmungen:
    2
    Ort:
    Wegberg
    nvidia

    Hallo


    Habe ich noch nie benutzt.

    Eine andere, wahrscheinlich, umständlichere Methode, wäre
    nvidia-kernel-source installeien, entpacken und dan per debian/rules binary-modules ein nvidia kernel modul bauen und dann per dpkg -i installeiren, wenn ich die Docu von nvidia-kenel-source richtig verstanden habe.


    Geht daß per module-assistant entsprechend ?

    mfg
    schwedenmann
     
  9. #8 z-shell, 26.08.2007
    z-shell

    z-shell Debianator

    Dabei seit:
    30.05.2007
    Beiträge:
    434
    Zustimmungen:
    0
    Ort:
    /home/z-shell
    Code:
    xserver-xorg-video-nv
    Was haelst du davon?
     
  10. #9 schwedenmann, 26.08.2007
    schwedenmann

    schwedenmann Foren Gott

    Dabei seit:
    18.11.2003
    Beiträge:
    2.635
    Zustimmungen:
    2
    Ort:
    Wegberg
    nvidia

    Hallo


    Xserver-xorg-video-nv

    ist natürlich klar, in der entsprechenden Section hab ich natürlich nv eingetragen, vorher stand ati drin.

    Nur ich bräuchte eben 3D.

    mfg
    schwedenmann
     
  11. #10 z-shell, 26.08.2007
    z-shell

    z-shell Debianator

    Dabei seit:
    30.05.2007
    Beiträge:
    434
    Zustimmungen:
    0
    Ort:
    /home/z-shell
    Code:
    /etc/init.d/gdm stop
    sh NVIDIDA*.run


    Code:
    m-a update
    m-a prepare
    m-a a-i <treibername>
    man m-a
     
  12. #11 schwedenmann, 26.08.2007
    schwedenmann

    schwedenmann Foren Gott

    Dabei seit:
    18.11.2003
    Beiträge:
    2.635
    Zustimmungen:
    2
    Ort:
    Wegberg
    module-assistant

    Hallo


    Danke an @googspeed + z-shell für den Tip mit dem module-assistant.


    m-a prepare
    m-a auto-install nvidia
    apt-get install nvidia-glx

    + editieren der xorg.conf sollten zum Ziel führen


    mfg
    schwedenmann
     
  13. blinx

    blinx Eroberer

    Dabei seit:
    22.06.2006
    Beiträge:
    63
    Zustimmungen:
    0
    Probleme mit NVIDIA hatte ich schon genug.
    /etc/init.d/gdm stop
    (vorher entfernen!: sh NVIDIA*.run --uninstall)
    sh NVIDIA*.run --x-module-path=/usr/lib/xorg/modules
    modprobe -r nvidia
    modprobe nvidia (nun sollte eine Ausgabe kommen!)
    /etc/init.d/gdm start

    So funktioniert es bei mir!

    Gruß
    Benny
     
  14. #13 schwedenmann, 26.08.2007
    schwedenmann

    schwedenmann Foren Gott

    Dabei seit:
    18.11.2003
    Beiträge:
    2.635
    Zustimmungen:
    2
    Ort:
    Wegberg
    Nochmal nvidia unter Sid

    Hallo


    ich hae jetzt per module-assistant ein nvidia-Modul ertsellt , installeirt + nvidia-glx, scheint auch insoweit geklappt zu haben, ein modul nvidia erscheint jetzt bei lsmod, user ist in gruppe video und die xorg.conf ist nat. schon angepaßt.

    Wie erkenne ich jetzt ob 3D aktiviert ist ?
    glxgears gibt es anscheinend unter debian nciht, weder als root, noch als user und Spiele mit 3D wie tuxracer hab ich nciht installiert.

    mfg
    schwedenmann
     
  15. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  16. #14 Factory, 26.08.2007
    Factory

    Factory Routinier

    Dabei seit:
    21.12.2004
    Beiträge:
    445
    Zustimmungen:
    0
    Ort:
    Bochum - NRW
    Es gab schon mal diesen Thread da wurde auch die lösung gepostet !

    Naja ehm wie erkennst du es wenn in der xorg.conf stadt "nv" nvidia steht hast 3D drine automatisch weil der treiber 3d unertstüzt bzw. dafür ist das es geht... hatte das selbe unter debian Sid und nun auch unter Etch was eig mehr Sid is da ich Unstable fahre.

    Lad dir 3d Game sollte es ruckeln weisst 3D ist aus was ich aber bezweifel wenn nvidia in der conf steht.


    MfG Factory
     
  17. #15 Goodspeed, 26.08.2007
    Goodspeed

    Goodspeed Foren Gott
    Moderator

    Dabei seit:
    21.04.2004
    Beiträge:
    4.165
    Zustimmungen:
    1
    Ort:
    Dresden
    Doch ... ist im Paket "mesa-utils" ... genauso wie glxinfo ...
     
Thema:

nvidia-Treiber Problem unter Sid

Die Seite wird geladen...

nvidia-Treiber Problem unter Sid - Ähnliche Themen

  1. Nvidia-Treiber Problem

    Nvidia-Treiber Problem: Hi, immer wenn ich versuche den Nvidia Treiber per modprobe zuladen passiert folgendes: error running install command for nvidiaIch habe den...
  2. nvidia-Treiber macht Probleme

    nvidia-Treiber macht Probleme: Hallo zusammen, mein System hängt sich nach kurzer Zeit auf. Nachdem ich zuerst die RAm vermutete und dann mein WLAN, hat sich nach einer...
  3. Nvidia-Treiber mit Unterstützung für Optimus

    Nvidia-Treiber mit Unterstützung für Optimus: Der als Beta bezeichnete proprietäre Linux-Treiber 319.12 von Nvidia bietet erstmals rudimentäre Unterstützung für Optimus. Weiterlesen...
  4. nvidia-Treiber: Virtuelle Terminals bleiben schwarz

    nvidia-Treiber: Virtuelle Terminals bleiben schwarz: Hallo allerseits. (Oh man, seit vier Jahren das erste Mal wieder hier, echt spannend, sich selbst als Vierzehnjährigen zu erleben ;D) Aber nun zu...
  5. NVIDIA-Treiber instabil mit neuem Kernel

    NVIDIA-Treiber instabil mit neuem Kernel: HALLO Seit ich am 14.Oct meinen Kernel von 2.6.26 auf 2.6.27 aktualisiert habe, stürzt der X-Server einige Minuten nach dem Start wieder ab....