OpenSuse 11.3 Nvidia Treiber installieren

Dieses Thema im Forum "SuSE / OpenSuSE" wurde erstellt von @->-, 17.07.2010.

  1. #1 @->-, 17.07.2010
    Zuletzt von einem Moderator bearbeitet: 17.07.2010
    @->-

    @->- Guest

    Hallo,

    sitze hier an einem Problem bei der Installation der aktuellen Nvidia Treiber (256.35) unter OpenSuse 11.3. Da es leider noch keine fertigen Treiber im Repo gibt und der nouveau für ständigen abstürzen sorgt muss ich also die Originalen Treiber von Nvidia selbst installieren.

    Leider klappt es mal wieder nicht und ich finde auch keine Lösung. Alle notwendigen Pakete sind installiert wie gcc, make, kernel-source usw. nach dem bau der Module kommt nur diese Meldung:

    Code:
    ERROR: Unable to load the kernel module 'nvidia.ko'. This happens most
    frequently when this kernel module was built against the wrong or
    improperly configured kernel sources, with a version of gcc that differs
    from the one used to build the target kernel, or if a driver such as
    rivafb/nvidiafb is present and prevents the NVIDIA kernel module from
    obtaining ownership of the NVIDIA graphics device(s), or NVIDIA GPU
    installed in this system is not supported by this NVIDIA Linux graphics
    driver release.
    Hat vielleicht jemand einen Ratschlag?

    Grüße

    EDIT
    Das Problem hat sich erledigt. Nach langer Suche habe ich die Lösung gefunden. Das System einfach starten mit der Option "nomodeset" und schon klappt es.
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 Gast123, 18.07.2010
  4. #3 gt4raser, 23.07.2010
    gt4raser

    gt4raser Foren As

    Dabei seit:
    30.12.2007
    Beiträge:
    219
    Zustimmungen:
    0
    Hallo,

    Ich habe nun auch mein System von 11.2 auf 11.3 aktualisiert. Dabei wurde wieder der nouveau-Treiber installiert.
    Also dachte ich kein Problem, über Yast installiere ich den Treiber zurück. Bild Endnummer 35.
    Aber sobald ich den drin habe startet das System nicht mehr. Bilder mit Endnummer 39 & 40.
    Auch mit der Bootoption nomodeset startet das System nicht .
    Nachdem ich wieder zurück bin auf den Standard (Bildnr 36) geht das System wieder.

    Was habe ich falsch gemacht? Wollte gerne wieder die 3D-Unterstützung aktivieren.

    Gruß GT4 Raser
     

    Anhänge:

  5. @->-

    @->- Guest

    Hast du schon das hier Probiert:

    Zusätzlich kannst du noch in die /etc/modeprobe.d/50-blacklist.conf
    Code:
    blacklist nouveau
    eintragen.

    Grüße
     
  6. #5 gt4raser, 23.07.2010
    Zuletzt bearbeitet: 23.07.2010
    gt4raser

    gt4raser Foren As

    Dabei seit:
    30.12.2007
    Beiträge:
    219
    Zustimmungen:
    0
    Ich dachte es reicht wenn man Treiber über Yast deinstalliert?
    Werde es mal in den nächsten Tagen probieren.

    Gruß GT4 Raser

    PS: Zitat:
    Zitat von opensuse.org
    Es kann aber unter Umständen dazu kommen das trotz Eintrag dennoch DRM-Module geladen werden. Dies lässt sich ganz einfach umgehen in dem durch einen festen Eintrag über YaST → System → Editor für /etc/sysconfig unter → Kernel → NO_KMS_IN_INITRD die Variable auf yes umgestellt wird.

    Das habe ich nach geschaut. Hier ist schon der Eintrag auf YES.
    Hab gerade die Blacklist.conf bearbeitet. Werde es gleich noch mal probieren.

    PPS: Blacklisten hat auch nicht funktioniert, System will einfach nicht starten.

    Gruß
     
  7. #6 gt4raser, 26.07.2010
    gt4raser

    gt4raser Foren As

    Dabei seit:
    30.12.2007
    Beiträge:
    219
    Zustimmungen:
    0
    Hallo,

    Mitlereile startet mein X-Server gar nicht mehr. Ich denke ich habe mir die xorg.conf zerschossen. Alle Tips aus dem Netz die wieder zu reparieren schlagen fehl. Das System will einfach nicht mehr grafisch starten. Ich komme immer nur auf die Konsole.
    Wie kann ich mein System wieder in den Standart (nouveau) bringen?
     
  8. sinn3r

    sinn3r Law & Order
    Moderator

    Dabei seit:
    28.12.2006
    Beiträge:
    2.764
    Zustimmungen:
    0
    Ort:
    Wentorf
    Was sagt den
    Code:
    grep "EE" /var/log/Xorg.0.log
    ?
     
  9. #8 gt4raser, 26.07.2010
    gt4raser

    gt4raser Foren As

    Dabei seit:
    30.12.2007
    Beiträge:
    219
    Zustimmungen:
    0
    Hab nur ein Bild angehängt, da es vom Blackberry mühsam ist die ganze Meldung abzutippen.

    Hoffentlich sieht jemand den Fehler.
     

    Anhänge:

  10. #9 tuxlover, 27.07.2010
    tuxlover

    tuxlover Der den Tux knuddelt

    Dabei seit:
    26.10.2005
    Beiträge:
    2.106
    Zustimmungen:
    0
    Ort:
    berlin
    Leute ihr müsst nur die nvidia repositories in yast/zypper hinzufügen:

    ftp://download.nvidia.com/opensuse/11.3/

    alles andere macht yast für euch... wählt den richtigen treiber, deaktiviert kms und sorgt dafür dass der andere nouveau treiber beim booten nicht mit geladen wird.
     
  11. #10 gt4raser, 27.07.2010
    gt4raser

    gt4raser Foren As

    Dabei seit:
    30.12.2007
    Beiträge:
    219
    Zustimmungen:
    0
    Hallo,

    Genau das habe ich so gemacht. Aber esgeht nicht. Vielleicht geht es so mit dem neueren Treiber von nVidia. Aber mit der Version 175.14. hat es halt so nicht funktioniert.
    Nun stehe ich vor dem Problem das mein X-Server nicht mehr geht.

    Gruß GT4 Raser
     
  12. nighT

    nighT Guest

    Auf jeden Fall scheint er zu Vesuchen ein "vnc" Modul zu laden. Dieses würde ich zu Erst aus der Moduls-Sektion löschen.
    Irgendwo scheint des Weiteren kein Driver/Identifier angegeben zu sein. Wobei diese Sache laut der Fehlermeldung ignoriert wird.
    Evtl. hast du ja irgendwie die Möglichkeit uns deine xorg.conf hochzuladen. Live CD o.ä. Das wäre wohl die beste Lösung, um nach dem Problem zu suchen.

    Ansonsten kannst du die Xorg.conf per
    Code:
    X -configure
    
    neu erstellen lassen. Die neu erstellte Config landet dann in dem Verzeichnis, in dem du dich befindest. Diese musst du noch nach /etc/X11/ kopieren.
    Vielleicht Helfen dir diese Tipps zumindest, dein X-Server wieder zum starten zu bewegen.
     
  13. #12 gt4raser, 27.07.2010
    gt4raser

    gt4raser Foren As

    Dabei seit:
    30.12.2007
    Beiträge:
    219
    Zustimmungen:
    0
    Hallo,

    Habe versucht über die Aktualisierungs-Option diesen VNC zu deinstallieren. Dann ein X -configure gemacht, und mit
    Code:
    cp /root/xorg.config.new /etc/X11/xorg.conf
    die Datei rüberkopiert. Aber das System kommt immer noch nicht hoch.

    So nun hänge ich mal meine xorg.conf an.

    Code:
    Section "ServerLayout"
    	Identifier     "X.org Configured"
    	Screen      0  "Screen0" 0 0
    	InputDevice    "Mouse0" "CorePointer"
    	InputDevice    "Keyboard0" "CoreKeyboard"
    EndSection
    
    Section "Files"
    	ModulePath   "/usr/lib/xorg/modules/updates"
    	ModulePath   "/usr/lib/xorg/modules"
    	FontPath     "/usr/share/fonts/misc:unscaled"
    	FontPath     "/usr/share/fonts/TTF/"
    	FontPath     "/usr/share/fonts/OTF/"
    	FontPath     "/usr/share/fonts/Type1/"
    	FontPath     "/usr/share/fonts/100dpi:unscaled"
    	FontPath     "/usr/share/fonts/75dpi:unscaled"
    	FontPath     "/usr/share/fonts/URW/"
    	FontPath     "/usr/share/fonts/cyrillic:unscaled"
    	FontPath     "/usr/share/fonts/misc/sgi:unscaled"
    	FontPath     "/usr/share/fonts/truetype/"
    EndSection
    
    Section "Module"
    	Load  "vnc"
    	Load  "dri"
    	Load  "glx"
    	Load  "dri2"
    	Load  "record"
    	Load  "extmod"
    	Load  "dbe"
    EndSection
    
    Section "InputDevice"
    	Identifier  "Keyboard0"
    	Driver      "kbd"
    EndSection
    
    Section "InputDevice"
    	Identifier  "Mouse0"
    	Driver      "mouse"
    	Option	    "Protocol" "auto"
    	Option	    "Device" "/dev/input/mice"
    	Option	    "ZAxisMapping" "4 5 6 7"
    EndSection
    
    Section "Monitor"
    	Identifier   "Monitor0"
    	VendorName   "Monitor Vendor"
    	ModelName    "Monitor Model"
    EndSection
    
    Section "Device"
            ### Available Driver options are:-
            ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
            ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
            ### [arg]: arg optional
            #Option     "SWcursor"           	# [<bool>]
            #Option     "HWcursor"           	# [<bool>]
            #Option     "NoAccel"            	# [<bool>]
            #Option     "ShadowFB"           	# [<bool>]
            #Option     "VideoKey"           	# <i>
    	Identifier  "Card0"
    	Driver      "nouveau"
    	VendorName  "nVidia Corporation"
    	BoardName   "NV34M [GeForce FX Go5200 64M]"
    	BusID       "PCI:1:0:0"
    EndSection
    
    Section "Screen"
    	Identifier "Screen0"
    	Device     "Card0"
    	Monitor    "Monitor0"
    	SubSection "Display"
    		Viewport   0 0
    		Depth     1
    	EndSubSection
    	SubSection "Display"
    		Viewport   0 0
    		Depth     4
    	EndSubSection
    	SubSection "Display"
    		Viewport   0 0
    		Depth     8
    	EndSubSection
    	SubSection "Display"
    		Viewport   0 0
    		Depth     15
    	EndSubSection
    	SubSection "Display"
    		Viewport   0 0
    		Depth     16
    	EndSubSection
    	SubSection "Display"
    		Viewport   0 0
    		Depth     24
    	EndSubSection
    EndSection
    
    
    Hoffe nun mal das irgendwer was sieht, womit ich das Ding wieder zum laufen bekomme.

    Gruß GT4 Raser
     
  14. #13 gt4raser, 30.07.2010
    gt4raser

    gt4raser Foren As

    Dabei seit:
    30.12.2007
    Beiträge:
    219
    Zustimmungen:
    0
    Hallo,

    Hat den niemand einen Tipp für mich?
    Möchte mein ganzes System nicht neu installieren.

    Gruß GT4 Raser
     
  15. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  16. #14 nighT, 30.07.2010
    Zuletzt von einem Moderator bearbeitet: 30.07.2010
    nighT

    nighT Guest

    Ich verstehe gerade nicht, was du uns mit diesem Satz sagen willst?! Du brauchst vnc eigentlich garnicht? Dann würde ich die folgende Zeile erstrecht löschen. Frisst nur Resourcen und ist, wenn du ihn nicht verwendest, total sinnlos.

    Das VNC-Modul kannst du ganz simpel deaktivieren, indem du die Zeile
    Code:
    Load  "vnc"
    in "Section Modules" löschst.
    Ansonsten zusätzlich über YAST deinstallieren, wenn du es nicht benötigst...

    Ich bin davon ausgegangen, dass du VNC brauchst. Darum wäre es erstmal interessant gewesen zu testen, ob das VNC Modul die Probleme verursacht.

    Des weiteren könntest du mal versuchen, ganz ohne xorg.conf zu booten. Einfach irgendwo hinverschieben und schauen was passiert. Ich kenne mich zwar mit openSuse nicht aus, aber ich nehme mal an, das dbus auch dort die grundlegende Systemkonfiguration/Geräteerkennung übernimmt.


    [edit] @devilz: Die Boarduhr geht ja immernoch 32Minuten vor?! Ich hoffe mal, dass das Problem mit dem neuen vBulletin gelöst wird ;) [/edit]
     
  17. #15 gt4raser, 31.07.2010
    gt4raser

    gt4raser Foren As

    Dabei seit:
    30.12.2007
    Beiträge:
    219
    Zustimmungen:
    0
    Hallo,

    Hab nun so ziemlich alle Hinweise ausprobiert. Aber nichts hat geholfen. Habe nun meine Home-Partition auf einen Stick gesichert und das ganze System neu aufgesetzt.
    Danach ging es wie beschrieben mit der Installation des nVidia-Treibers.
    Nun gibt es aber das nächste Problem. Bei meinem 2. Monitor komme ich nicht über die Auflösung von 640x480 drüber hinaus. Normal ist 1024x768. Diese Auflösung kann ich zwar aktivieren aber dann ist das Bild größer wie der Monitor und "schiebt" wenn ich in die Ecken des Monitors komme.
    Und die Composit wird dabei deaktiviert.

    Beim Nouveau-Treiber habe ich zwar den 2. Monitor in der vollen Auflösung, aber auch wieder keine Composit.

    Möchte aber gerne beides nutzen.

    Hat jeman einen Tip?

    Gruß GT4 Raser8)
     
Thema:

OpenSuse 11.3 Nvidia Treiber installieren

Die Seite wird geladen...

OpenSuse 11.3 Nvidia Treiber installieren - Ähnliche Themen

  1. [HowTo] NVidia und 3D unter SuSE/openSUSE

    [HowTo] NVidia und 3D unter SuSE/openSUSE: NVidia und 3D unter SuSE/openSUSE Da dieses Thema immer wieder ein Problem zu sein scheint, hier mal ein kleines HowTo, das auch für Noobs...
  2. openSUSE10.3 & NVIDIA8600GT ?

    openSUSE10.3 & NVIDIA8600GT ?: Hallo Habe gerade von WinXP auf openSUSE10.3 gewechselt, also bin noch Anfänger und habe eigentlich alles ohne fehler installieren können, aber...
  3. OpenSUSE 10.3, 3D-Beschleunigung, NVIDIA Geforce 7600 Go, Problem mit Einrichtung

    OpenSUSE 10.3, 3D-Beschleunigung, NVIDIA Geforce 7600 Go, Problem mit Einrichtung: Hallo, ich bin blutiger Anfänger auf dem Gebiet OpenSUSE und Linux, möchte aber gerne auf das System umsteigen da ich es durchaus ansprechend...
  4. Hilfe für NVIDIA Grafiktreiber für openSUSE 10.2

    Hilfe für NVIDIA Grafiktreiber für openSUSE 10.2: Hallo, Achtung, ich bin extremer Linuxfrischling!!! Ich habe folgendes Problem: Ich habe openSuse von DVD parallel zu Windows installiert....
  5. Opensuse 10.2 + Nvidia treiber = Schwarzer Bildschrim

    Opensuse 10.2 + Nvidia treiber = Schwarzer Bildschrim: Hi, ich hab OpenSuse 10.2 und eine Geforce FX 5200. Opensuse lief die ganze zeit. Dann hab ich mir mal gedacht das ich den Nvidia treiber...