Ati-Treiber bringt mich um den Verstand

Dieses Thema im Forum "Debian/Ubuntu/Knoppix" wurde erstellt von Emess, 09.01.2010.

  1. #1 Emess, 09.01.2010
    Zuletzt bearbeitet: 09.01.2010
    Emess

    Emess Turmspringer

    Dabei seit:
    08.10.2006
    Beiträge:
    1.045
    Zustimmungen:
    0
    Ort:
    Odenwald
    Blöderweise habe ich mich entschlossen Squeeze und Lenny neu auzuspielen. Weil ich hoffte ich könnte doch auf meine Fritzbox mit Linux zugreifen (geht seltsamerweise nur wenn ich das Lankabel vorher ins alte Notebook einstecke und eimmal starte, Danach geht es auch am neuen Notebook). Aber drauf gesch......!

    Habe Squeeze heut schon 3x installiert! Jedesmal wnn den Atitreiber installiere kann nach einem reboot den Kde nicht mehr starten.
    Jetzt habe ich verucht die ATI mit ATI Catalyst Control Center zu konfigurieren. Dann kommt aber dieser Fehler

    Code:
    Beim Initialisieren der Catalyst Control Center Linux-Version ist ein Problem aufgetreten.
     Mögliche Gründe dafür sind:
    
    Es ist kein ATI-Grafiktreiber installiert oder der ATI-Treiber funktioniert nicht ordnungsgemäß.
    Bitte installieren Sie den richtigen Treiber für Ihre ATI-Hardware oder verwenden 
    Sie den Befehl aticonfig.
    Also habe ich aticonfig --initial uns sicherheitshalber auch modprobe fglrx ausgeführt.

    Ich bin mit meinem Latein am Ende. :hilfe2:

    ps. das ist der Treiber von der Ati Seite "ati-driver-installer-9-12-x86.x86_64.run"

    Und hier noch die fglrx install.log.

    Code:
    Unloading radeon module...
    Unloading drm module...
    [Message] Kernel Module : Trying to install a precompiled kernel module.
    [Message] Kernel Module : Precompiled kernel module version mismatched.
    [Message] Kernel Module : Found kernel module build environment, generating kernel module now.
    AMD kernel module generator version 2.1
    doing Makefile based build for kernel 2.6.x and higher
    rm -rf *.c *.h *.o *.ko *.GCC* .??* *.symvers
    make -C /lib/modules/2.6.30-2-686/build SUBDIRS=/lib/modules/fglrx/build_mod/2.6.x modules
    make[1]: Entering directory `/usr/src/linux-headers-2.6.30-2-686'
      CC [M]  /lib/modules/fglrx/build_mod/2.6.x/firegl_public.o
    In file included from /lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:443:
    /lib/modules/fglrx/build_mod/2.6.x/drm_proc.h: In function ‘FGLDRM__vma_info’:
    /lib/modules/fglrx/build_mod/2.6.x/drm_proc.h:497: warning: format ‘%08lx’ expects type ‘long unsigned int’, but argument 5 has type ‘phys_addr_t’
    /lib/modules/fglrx/build_mod/2.6.x/firegl_public.c: In function ‘firegl_init_devices’:
    /lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:974: warning: integer constant is too large for ‘unsigned long’ type
      CC [M]  /lib/modules/fglrx/build_mod/2.6.x/kcl_acpi.o
      CC [M]  /lib/modules/fglrx/build_mod/2.6.x/kcl_agp.o
      CC [M]  /lib/modules/fglrx/build_mod/2.6.x/kcl_debug.o
      CC [M]  /lib/modules/fglrx/build_mod/2.6.x/kcl_ioctl.o
      CC [M]  /lib/modules/fglrx/build_mod/2.6.x/kcl_io.o
      CC [M]  /lib/modules/fglrx/build_mod/2.6.x/kcl_pci.o
      CC [M]  /lib/modules/fglrx/build_mod/2.6.x/kcl_str.o
      CC [M]  /lib/modules/fglrx/build_mod/2.6.x/kcl_wait.o
      LD [M]  /lib/modules/fglrx/build_mod/2.6.x/fglrx.o
      Building modules, stage 2.
      MODPOST 1 modules
      CC      /lib/modules/fglrx/build_mod/2.6.x/fglrx.mod.o
      LD [M]  /lib/modules/fglrx/build_mod/2.6.x/fglrx.ko
    make[1]: Leaving directory `/usr/src/linux-headers-2.6.30-2-686'
    build succeeded with return value 0
    duplicating results into driver repository...
    done.
    [COLOR=Red]You must change your working directory to /lib/modules/fglrx
    and then call ./make_install.sh in order to install the built module.
    - recreating module dependency list
    - trying a sample load of the kernel modules
    done.[/COLOR]
    
    

    was genau heißt das rot makierte?
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 Goodspeed, 09.01.2010
    Goodspeed

    Goodspeed Foren Gott
    Moderator

    Dabei seit:
    21.04.2004
    Beiträge:
    4.165
    Zustimmungen:
    1
    Ort:
    Dresden
    Warum nimmste nicht ein einfach die Treiberpakete aus dem Repo und den module-assistant?
    Hast Du denn einen passenden Chipsatz (für die Mobile-Chips gibts of eigene Treiber)?
     
  4. Emess

    Emess Turmspringer

    Dabei seit:
    08.10.2006
    Beiträge:
    1.045
    Zustimmungen:
    0
    Ort:
    Odenwald
    Die Karte ist ein ATI HD4330 und ich hab schon den richtigen runtergeladen. Den Debian hatte ich auch schon probiert, aber das hat leider auch nicht geklappt.

    Wenn den Von Debian nochmal probieren würde, welche pakete müsste ich den dann installieren. Und bekomm den z.Z. nicht richtig installierten einfach mit ./fglrx-uninstall.sh restlosweg?
     
  5. #4 kartoffel200, 10.01.2010
    kartoffel200

    kartoffel200 AMD Fanboy Since 2003

    Dabei seit:
    12.03.2007
    Beiträge:
    938
    Zustimmungen:
    0
    Ort:
    L wie localhost
    Hast du alles installiert was in den Requirements steht?
    Lässt du dir Pakete bilden oder machst einfach alles automatisch?
     
  6. Emess

    Emess Turmspringer

    Dabei seit:
    08.10.2006
    Beiträge:
    1.045
    Zustimmungen:
    0
    Ort:
    Odenwald
    habe das einfach mal ausgeführt
    Code:
    ./make_install.sh in order to install the built module.
    
    jetzt läufts.
     
Thema:

Ati-Treiber bringt mich um den Verstand

Die Seite wird geladen...

Ati-Treiber bringt mich um den Verstand - Ähnliche Themen

  1. Ati-Treiber bringt mich um den Verstand

    Ati-Treiber bringt mich um den Verstand: servus, hab auch probleme mit meinem ati treiber, hab den von der ati seite runtergeladen. ati-driver-installer-10-3-x86.x86_64.run heißt der...
  2. noch mal ne Frage zum Kernel-update und Ati-Treiber

    noch mal ne Frage zum Kernel-update und Ati-Treiber: Beim letzten kernel-update Gestern war es wieder der Fall, dass bevor X gestartet wird der Bildschirm schwarz bleibt. Gelöst hab ich das immer...
  3. Probleme mit ati-treiber und Mehrdisplay-Betrieb

    Probleme mit ati-treiber und Mehrdisplay-Betrieb: Hallo zusammen, ich habe Probleme meine Monitore vernünftig darzustellen. Mein System mit CentOS 5.5: HP nw8240 - mit nativer Auflösung von...
  4. OpenSource ATI-Treiber: Automatische Konfiguration (zwei X-Screens)

    OpenSource ATI-Treiber: Automatische Konfiguration (zwei X-Screens): Hallo, gibt es irgendeine Möglichkeit/Tool, die xorg.conf automatisch zu genereieren lassen, wie es z.B. der proprietäre ATI oder...
  5. Ati-Treiber hat sich im System festgebissen

    Ati-Treiber hat sich im System festgebissen: Hallo erstmal! Habe mir auf meiner Workstation den Ati-Treiber "ati-driver-installer-9.2-x86.x86_64" installiert. Hat auch prima geklappt! Bis...