Kein WLAN bei Raspbian

Dieses Thema im Forum "Internet, lokale Netzwerke und Wireless Lan" wurde erstellt von jkoel, 06.06.2013.

  1. jkoel

    jkoel Foren As

    Dabei seit:
    08.01.2009
    Beiträge:
    83
    Zustimmungen:
    0
    Hallo,

    ich auf meinem Raspberry Pi mit aktuellem Raspbain in der Datei /etc/network/interfaces diese Einstellungen

    In der Datei wpa_supplicant.conf steht

    Dabei handelt es sich exakt um die Standardeinstellungen nach der Installation. Damit konnte ich zwischen LAN und WLAN hin und her wechseln - dachte ich zumindest. Das heißt wenn LAn-Kabel dran und WLAN-Stick nicht Netzwerk über LAN, wenn kein LAN-Kabel aber WLAN-Stick Netzwerk über WLAn. Wenn beides LAN. Treiber ist keiner nötig, da der 8188CUS auch ohne Treiber läuft. LAN geht, aber ich bekomme keine LAN-Verbindung. Ich habe alle Daten x-mal gecheckt, die sind korrekt. Habe den Pi jetzt eine Weile nicht mehr genutzt, aber ich dachte es sollte gehen. Ist da doch etwas falsch?

    jkoel
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 marcellus, 07.06.2013
    marcellus

    marcellus Kaiser

    Dabei seit:
    09.05.2007
    Beiträge:
    1.392
    Zustimmungen:
    0
    Hast du das interface vllt auf manuell gestellt und die ip, gateway usw einfach nirgendwo eingetragen?

    Wenn du deinen wlan stick ansteckst was taucht dann in /var/log/messages auf?
     
  4. jkoel

    jkoel Foren As

    Dabei seit:
    08.01.2009
    Beiträge:
    83
    Zustimmungen:
    0
    Ich hatte das auch schon auf DHCP gestellt, klappte auch nicht. Eine feste IP habe ich nicht eingestellt, wüsste jetzt auch nicht wo ich diese eingeben müsste. Doch sicher auch in /etc/network/interfaces?

    Da steht gar nichts drin. Die jüngsten Einträge sind von Gestern. Ich habe den Pi nur mit LAN-Kabel gestartet, dann den Stick angesteckt. Ich musste dann die SSH-Verbindung neu aufbauen. In der Log-Datei stehen aber keine neuen Einträge vom 07.06.2013.
     
  5. #4 marcellus, 09.06.2013
    marcellus

    marcellus Kaiser

    Dabei seit:
    09.05.2007
    Beiträge:
    1.392
    Zustimmungen:
    0
    Die idee ist eher die config anzusehen, wenn du gerade die wlan karte ansteckst, also "ifconfig", wenn du die gewünschte situation erreicht hast.

    Wenn du dir direkt ein keyboard + bildschirm ansteckst ist das konfiguriren von dem netzwerk übrigens etwas bequemer, wenn du dir nicht die ganze zeit die anschlüsse killst.

    Schau dir http://wiki.debian.org/NetworkConfiguration#Configuring_the_interface_manually an

    Gib auch noch die ausgabe von "iwconfig" dazu und schau, ob sich das ganze überhaupt aktiviert hat, die Netzwerk konfiguration läuft aber genauso ab, wie in debian, mit dem link da solltest du ganz gut auskommen.
     
  6. #5 jkoel, 09.06.2013
    Zuletzt bearbeitet: 09.06.2013
    jkoel

    jkoel Foren As

    Dabei seit:
    08.01.2009
    Beiträge:
    83
    Zustimmungen:
    0
    Ich hab die Einstellungen jetzt mal auf static gestellt und die IP und alles eingegeben. Sieht dann so aus:
    Geht damit aber weiterhin nicht. Hätte ich etwas anderes auch verändern sollen? Nach der Debian-Wiki habe ich auch schon einen alten (jetzt defekten) WLAN-Stick erfolgreich zum laufen gebracht - aber halt NUR den Stick, LAN ging dann nicht. Müsste denn LAN und WLAN überhaupt mit den o.g. Standardeinstellungen in /etc/network/interfaces gehen?

    Minotor anscließen ist blöd, da der HDMI-Port des Pi nicht mehr geht und mein Monitor kein Cinch hat.

    Das kommt wenn ich ifconfig eingebe

    Und das bei iwconfig

    edit
    Ich hab jetzt nochmal versucht WLAN über Wifi-Config (Symbol auf dem Desktop) einzustellen. Wenn ich da auf scan gehe findet er kein Netzwerk. Auch kann ich dort keinen Adapter einstellen. Der Adapter wird ja aber gefunden wie man oben sieht, ist er irgendwie nicht aktiv?

    edit1
    Auch die Ausgabe "iwlist wlan0 scan" bringt "No scan results". Bei wlan1 kommr "Interface doesn't support scanning" - evtl. da es überhaupt kein wlan1 gibt (die Eingabe war nur ein Versuch).
     
  7. jkoel

    jkoel Foren As

    Dabei seit:
    08.01.2009
    Beiträge:
    83
    Zustimmungen:
    0
    Es geht jetzt, ohen dass ich sagen kann wieso. Ich habe in /etc/network/interfaces alles so gelassen nur bei WLAN dhcp eingestellt. Dann eine /etc/wpa.conf erstellt und dort die ganzen Einstellungen reingesetzt und in der /etc/network/interfaces auf die wpa.conf verwiesen. Was jetzt der Unterschied zwischen wpa_supplicant und wpa.conf ist versteh ich nicht so recht. Evtl. gibt es auch keinen und es lag an den Einstelungen in der wpa.conf? Dort habe ich (nach einer Anleitung für den Pi) folgendes eingetragen:

    Ich bekomme sogar über LAN und WLAN gleichzeitig eine Verbindung (das soll so nicht genutzt werden, war nur ein Versuch wie der Pi reagiert wenn beides angeschlossen ist), wobei dann im Fritzbox-Menüpunkt Heimnetzwerk bei der IP der WLAN-Verbindung ein Pfeil zur LAN ist, evtl. eine Art "Weiterleitung"?
     
  8. #7 marcellus, 09.06.2013
    marcellus

    marcellus Kaiser

    Dabei seit:
    09.05.2007
    Beiträge:
    1.392
    Zustimmungen:
    0
    Hast du den network manager laufen, oder machst verwaltest du das Netzwerk über die config files?

    Wenn du da grafisch rein mischt macht das normal nur probleme. Du kannst das ganze auch über den network manager machen, wenn dir das lieber ist, aber entscheid dich für eins und bleib dabei.
     
  9. jkoel

    jkoel Foren As

    Dabei seit:
    08.01.2009
    Beiträge:
    83
    Zustimmungen:
    0
    Nein, über grafische Oberfläche hab ich nichts eingestellt. Habs versucht (wie oben beschrieben), klappte ja aber nicht. Vorher hab ich alles über Konsole gemacht.
     
  10. #9 marcellus, 09.06.2013
    marcellus

    marcellus Kaiser

    Dabei seit:
    09.05.2007
    Beiträge:
    1.392
    Zustimmungen:
    0
    Eine Weiterleitung wirds nicht geben, du kannst, abgesehen vom default gateway beliebig viele interfaces betreiben.

    Deine Wlan karte hat sich nicht mit dem wlan assioziiert, hast du den wpa_supplicant überhaupt installiert? läuft er?

    Was gibt iwconfig aus, wenn du

    Code:
    wpa_supplicant -iwlan0 -c/etc/wpa.conf
    das sollte sich nicht in den Hintergrund legen, sondern meldungen ausgeben, was gerade passiert, wenn du die shell frei haben willst gib den Parameter "-B" dazu
     
  11. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  12. jkoel

    jkoel Foren As

    Dabei seit:
    08.01.2009
    Beiträge:
    83
    Zustimmungen:
    0
    Jetzt steh ich aber blöd da, denn es scheint in der Tat nicht installiert zu sein. Dann frag ich mich wieso es vor einiger Zeit mal klappte? Hat wpa_supplicant irgendwelche Vorteile gegenüber meinem Vorgehen?
     
  13. #11 marcellus, 10.06.2013
    marcellus

    marcellus Kaiser

    Dabei seit:
    09.05.2007
    Beiträge:
    1.392
    Zustimmungen:
    0
    Nur das du ohne wpa_supplicant nur verbindungen zu unverschlüsselten und wep verschlüsselten wlans aufbauen kannst.
    Sprich komplett nutzlos.

    Deine config ist aber für wpa_supplicant, der wird von den debian internen netzwerk scripten angeworfen, das händische starten gibt dir nur mehr informationen, wenn du nachvollziehen willst wieso etwas nicht geht.
     
Thema:

Kein WLAN bei Raspbian

Die Seite wird geladen...

Kein WLAN bei Raspbian - Ähnliche Themen

  1. Kein SSH/Ping über WLAN mit gentoo

    Kein SSH/Ping über WLAN mit gentoo: Hallo zusammen, ich habe ein folgendes Problem mit meinem WLAN- stick (LevelOne WNC-0305USB USB wlan stick). Ich bekomme kein Ping bzw. ich...
  2. CentOS 6.5 auf ThinkPad X200 kein WLAN

    CentOS 6.5 auf ThinkPad X200 kein WLAN: Hallo zusammen, ich versuche seit ein paar Tagen auf meinen ThinkPad X200 die Intel WLAN-Karte zu nutzen, leider ohne Erfolg bis jetzt. Ich habe...
  3. kubuntu 9.10 kein wlan und keine tastatur

    kubuntu 9.10 kein wlan und keine tastatur: hallo zusammen, seit dem ich auf meinem lenovo t500 von kubuntu 9.4 auf 9.10 geupdatet habe ich zwei riesen probleme. erstens das wlan will nicht...
  4. Ubuntu 9.04: keine WLAN-Verbindung

    Ubuntu 9.04: keine WLAN-Verbindung: Ich habe Ubuntu 9.04 installiert und wollte mich nun mit meinem WLAN verbinden. Frage 1: -------- Mein WLAN-Gerät bietet mir nur eine...
  5. Kein WLAN mit eigenem Kernel 2.6.31

    Kein WLAN mit eigenem Kernel 2.6.31: [GELÖST] Kein WLAN (Intel) mit eigenem Kernel 2.6.31 Hallo, ich habe mir gestern einen eigenen Vanilla-RT-Kernel (2.6.31-rt11) mit ein paar...