Internetsharing

Dieses Thema im Forum "Internet, lokale Netzwerke und Wireless Lan" wurde erstellt von Carpocalypse, 01.02.2015.

  1. #1 Carpocalypse, 01.02.2015
    Carpocalypse

    Carpocalypse Grünschnabel

    Dabei seit:
    01.02.2015
    Beiträge:
    9
    Zustimmungen:
    0
    Hi,

    ich habe vor meinen Nertzwerk fähigen Receiver per LAN an meinen RaspberryPi an zuschliesen um dann dort das Internet, welches über WLAN tadelos funktionert, zu teilen.

    Receiver <-> RPi <-> FritzBox

    der RPi ist über WLAN mit der FritzBox verbunden, sowie per LAN mit dem Receiver.

    Hier meine /etc/network/interfaces
    Code:
    auto lo eth0
    
    iface lo inet loopback
    iface eth0 inet static
      address 192.168.137.1
      netwask 255.255.255.0
      network 192.168.137.0
    
    allow-hotplug wlan0
    iface wlan0 inet manual
    wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf
    iface default inet dhcp
    

    Der Receiver hat folgende einstellungen.

    IP: 192.168.137.2
    GW: 192.168.137.1
    DNS: 192.168.137.1

    ich kann vom RPi meinen Receiver an pingen. komme jedoch nicht mit dem Receiver ins Internet. Nach weiterem googeln habe ich dies hier gefunden:

    Code:
    echo "net.ipv4.ip_forward=1" >> /etc/sysctl.conf
    echo "1" > /proc/sys/net/ipv4/ip_forward
    iptables -t nat -A POSTROUTING -o wlan0 -j MASQUERADE
    iptables -A FORWARD -i wlan0 -o eth0 -m state --state RELATED,ESTABLISHED -j ACCEPT
    iptables -A FORWARD -i eth0 -o wlan0 -j ACCEPT
    
    Hat aber auch nichts gebracht. (wobei ich nicht weis was da überhaupt getan wird)

    Ich hoffe ihr könnt mir helfen. Ich komme nicht mehr weiter.

    Danke.
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 Gast123, 01.02.2015
    Gast123

    Gast123 Guest

    Kommst du denn von dem Router aus ins Internet?
    Laut deiner Konfiguration ist ja das WiFi Interface deines Routers auf "manual" gesetzt.
    Welches Gateway und welcher DNS Server ist im Receiver eingetragen? Dies sollte der Router sein.
     
  4. #3 Carpocalypse, 01.02.2015
    Carpocalypse

    Carpocalypse Grünschnabel

    Dabei seit:
    01.02.2015
    Beiträge:
    9
    Zustimmungen:
    0
    Ja, Internet funktioniert. Auch mit dem RPi habe ich zugriff auf das Internet.
    Habe die WLAN konfiguration bereits vorher aus einem Tutorial übernommen.

    Ich hatte, wie oben geschrieben, den RPi als Gateway sowie als DNS eingetragen, da ich dachte das dieser direkt dazwischen sitzt.
    Habe dem Receiver nun den Gateway/DNS des Routers gegeben, was leider auch keinen erfolg brachte.
     
  5. #4 Gast123, 01.02.2015
    Gast123

    Gast123 Guest

    Entschuldige bitte, ich hatte das mit der IP Konfiguration überlesen.
    Mit "Router" meinte ich deinen RasPi, denn das soll ja seine Funktion sein.
    Wenn IP Forwardong im Kernel aktiv ist, sowie die Routen richtig konfiguriert, dann muss das Routung eigentlich funktioneiren.
    Was sagt denn deine Firewallkonfiguration?
    PS: was sagt denn route auf dem Raspi?
     
  6. #5 Carpocalypse, 01.02.2015
    Zuletzt bearbeitet: 03.02.2015
    Carpocalypse

    Carpocalypse Grünschnabel

    Dabei seit:
    01.02.2015
    Beiträge:
    9
    Zustimmungen:
    0
    Firewall läuft läuft soweit ich weiß keine auf dem Raspi, zumindest habe ich nachträglich keine installiert. Als OS läuft Raspian (Debian). Kann man irgendwie überprüfen ob eine Firewall läuft?

    route gibt folgendes aus:
    Code:
    Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
    default         fritz.box       0.0.0.0         UG    0      0        0 wlan0
    192.168.137.0   *               255.255.255.0   U     0      0        0 eth0
    192.168.178.0   *               255.255.255.0   U     0      0        0 wlan0
    
    habe damit auch schon ein bisschen herum gespielt, was jedoch wirklich mehr probieren war als zu wissen was man tut. Kenne bin da nur wenig aus.
     
  7. #6 Gast123, 02.02.2015
    Zuletzt von einem Moderator bearbeitet: 03.02.2015
    Gast123

    Gast123 Guest

    Die Firewallkonfiguration kannst du mit
    Code:
    iptables -S -tnat
    iptables -S -tmangle
    iptables -S -tfilter
    anschauen.
    Läuft auf dem Router (RaPi) denn ein DNS Dienst?
    Ansonsten überlass die DNS-Auflösung der FritzBox.
    D.h.: Auf dem Receiver als Gateway den RasPi einrichten und als Nameserver die FritzBox.
    Das sollte mit der Routenkonfiguration so funktionieren.

    MfG

    Schard

    PS: Nicht vergessen, eine statische (Rück-) Route ins Netzwerk 192.168.137.0/24 in der FritzBox zu hinterlegen!
     
  8. #7 Carpocalypse, 02.02.2015
    Carpocalypse

    Carpocalypse Grünschnabel

    Dabei seit:
    01.02.2015
    Beiträge:
    9
    Zustimmungen:
    0
    So also ich habe nun dem Receiver als Gateway den RPi eingetragen, als DNS Server hat er die fritzBox. Desweiteren habe ich in der fritzBox bei "IPv4-Routen" das Netz vom eth0 am RPi eingetragen sowie als Gateway die IP welche die fritzBox dem RPi vergeben hat.
    Resultat, ich komme von jedem Gerät was ich mit der fritzBox verbinde auf die Web-Oberfläche vom Receiver. Was für mich bedeutet das IP-forwarding auf dem RPi funktioniert.
    Leider hat der Receiver nach wie vor kein Zugriff auf das INternet.

    Hier mal die Ausgabe von iptables. Falls diese benötigt wird.

    Muss ich dem RPi nicht auch noch eine route von eth0 zur fritzBox mitgeben? in etwa sowas hier:

    dann erhalte ich jedoch folgende Meldung.

    an dieser Stelle ersmal ein dickes Danke für Deine Mühen.
     
  9. #8 Gast123, 03.02.2015
    Zuletzt von einem Moderator bearbeitet: 03.02.2015
    Gast123

    Gast123 Guest

    Gut!
    Auch richtig.
    D.h. sogar, dass das Routing funktioniert.
    Kannst du denn vom Receiver WAN-IP Adressen direkt ansprechen? Damit könnte man das Problem auf mangelnde DNS Auflösung beschränken.
    Probier mal bitte, folgende IP-Adressen anzupingen:
    Code:
    Non-authoritative answer:
    Name:	google.de
    Address: 173.194.112.223
    Name:	google.de
    Address: 173.194.112.216
    Name:	google.de
    Address: 173.194.112.207
    Name:	google.de
    Address: 173.194.112.215
    
    Ich bin mir nicht sicher, ob die forwarding-rules nötig sind.
    Im Zweifel mal die Tabellen flushen
    Code:
    iptables -F
    und ohne die Regeln versuchen.

    Nein. Dazu ist die FritzBox auf dem RasPi als Standard-Gateway eingetragen, dessen Aufgabe es ist, Adressen anderer Netzwerke zu routen.

    Bitte. :)

    PS:
    • Da deine IP-Tables policy auf ACCEPT steht, sind die FORWARD-Regeln zwecklos.
    • Die von dir zitierte Route, die du versucht hast einzutragen, wäre so wie so falsch, also lass sie besser weg. ;)
     
  10. #9 Carpocalypse, 03.02.2015
    Carpocalypse

    Carpocalypse Grünschnabel

    Dabei seit:
    01.02.2015
    Beiträge:
    9
    Zustimmungen:
    0
    Ich kann dem Receiver nur eine IP-Adresse, NETMASK, Gateway, Primary-DNS und Secondery-DNS angeben. Mehr kann ich an dem Gerät nicht einstellen. Proxy wäre noch möglich, spielt hier jedoch keine rolle.

    Auch das hat leider nichts gebracht.
     
  11. #10 Gast123, 04.02.2015
    Gast123

    Gast123 Guest

    Du sollst die genannten IP-Adressen versuchen anzusprechen.
    Wie stellst du denn fest, dass der Receiver keinen Internetzugang hat?
    Er muss ja igendeinen Web-Client (Webbrowser o.ä.) haben, wo man (normalerweise) Hostnamen oder URLs eingibt.
    An deren Statt mal bitte o.g. IP-Adressen verscuhen.

    MfG

    Schard

    PS: Poste bitte an dieser Stelle auch noch ein Mal die genauen DNS und Gateway -Einträge des Receivers.
     
  12. #11 Carpocalypse, 05.02.2015
    Carpocalypse

    Carpocalypse Grünschnabel

    Dabei seit:
    01.02.2015
    Beiträge:
    9
    Zustimmungen:
    0
    Verstehe ich Dich richtig das ich vom Receiver versuchen soll eine IP anzu pingen? Wie soll ich das denn machen?

    Ich versuche ein Internetradio zu streamen

    Ich kann von einen PC per Browser auf den Receiver drauf zugreifen. Der Receiver an sich hat keinen Browser.

    IP: 192.168.137.2
    GATEWAY: 192.168.137.1 (RPi)
    Primary-DNS: 192.168.178.1 (fritzBox)
    Secondery-DNS: -

    Vlt. zur besseren Orientierung es handelt sich um einen DENON AVR 4311
     
  13. #12 Gast123, 05.02.2015
    Gast123

    Gast123 Guest

    Ping wäre eine gute Option. Wenn der Receiver dies nicht unterstützt, dann schließe doch mal einen anderen PC statt des Receivers mit dessen Netzwerkkonfiguration dort an und teste das Pinging wie o.g. Dann auch am besten ein
    Code:
    nslookup google.com
    hinterher schicken.
     
  14. #13 Carpocalypse, 05.02.2015
    Carpocalypse

    Carpocalypse Grünschnabel

    Dabei seit:
    01.02.2015
    Beiträge:
    9
    Zustimmungen:
    0
    Ich weis nicht wieso, aber es funktioniert auf einmal. Ich habe gestern Abend bevor ich ins Bett bin noch ein Update auf dem RPi gestartet. Heute hat dann auf einmal auf anhieb alles funktioniert. Ich habe keine weiteren Änderungen vorgenommen.

    Eine weitere Frage habe ich noch. Der Receiver unterstüzt Airplay. Wenn ich ihn jedoch an dem RPi anschließe wird er von meinem iPad nicht gefunden. Ich denke mal das es daran liegt, dass das iPad nur im gleichen Adress Bereich nach Geräten sucht.
    wenn ich dem Reicer/RPi nun eine Adresse gebe welche dem 192.168.178.0 Netz zugehörig ist sollte es doch funktionieren? Oder gibt es dann irgendwelche Probleme?
    Die fritzBox vergibt erst ab 192.168.178.20 Adressen. Dann sollte ich doch die Adressen von 192.168.178.2 bis .19 vergeben können.
     
  15. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  16. #14 Gast123, 07.02.2015
    Gast123

    Gast123 Guest

    In der Tat komisch.
    Das ist gut möglich. Bei proprietären Protokollen würde ich im Zweifel allerdings den Hersteller kontaktieren.
    Das geht dann aber nicht mit einem Router dazwischen. Routen kann man nur zwischen verschiedenen Netzwerken.
    Innerhalb gleicher Netzwerke weiterzuleiten, wäre switching.
    Dann gehts halt ein OSI-Layer nach unten. Auch wirst du dann ohne ein Managment Interface am RasPi zu haben, Probleme bekommen, auf diesen zuzugreifen, da du die Switching Interfaces (WiFi und Ethernet Interface in deinem Fall) im promiscuous Modus betreiben musst / solltest.
    Klar. Feuer Frei.
     
  17. #15 Carpocalypse, 08.02.2015
    Carpocalypse

    Carpocalypse Grünschnabel

    Dabei seit:
    01.02.2015
    Beiträge:
    9
    Zustimmungen:
    0
    Mhm, das klingt mir dann doxh ein wenig zu kompliziert. ?(

    Da ich nicht unbedingt auf Airplay angewiesen bin, lasse ich das erstmal so wie es ist. Und freue mich darüber das der Rest endlich funktioniert ;)

    Nochmals danke für die Hilfe.
     
Thema:

Internetsharing