fwbuilder

wizzardxx

Mitglied
Beiträge
32
Hallo,
kann einer einem Linux Noob mal erklären wie man den fwbuilder von www.fwbuilder.org installiert ???
Ich bekomme immer die Meldung das der für bestimmte rpms noch irgendwelche lisigc und gkmm packete benötigt. Wenn ich die dann bei z.b rpmseek suche gibt es die nich für rh 8.0.
Also falls einer den fwbuilder unter 8.0 schon mal erfolgreich installiert hat wäre ich für eine kleine Anleitung sehr Dankbar.
Wie gesagt bin noch Linux Nooby
 

Andre

Foren Gott
Beiträge
3.876
hab das noch nicht getestet...aber wenns extra pakete für rh8 gibt sollte es sich auch installieren lassen...
versuch doch mal das teil aus den sourcen zu bauen....und ne genaue fehlermeldung wär auch gut....damit man weis, welche pakete genau fehlen ...
gruss Andre
 

wizzardxx

Mitglied
Beiträge
32
hmmm

so habe mir mal die src dateien gesaugt und die 2 tar.gz entpackt.
wenn ich jetzt die rpm´s installieren will kommt die fehlermeldung:
cannot create %sourcedir /usr/src/redhat/SOURCES
Nach dem entpacken mit zcat libfwbuilder-0.10.8.tar.gz | tar xvf -
soll ich ins fwbuilder verzeichnis wechseln. $ cd libfwbuilder
aber das verzeichniss findet der nicht. ich bin dann ins verzeichnis
fwbuilder-1.0.9 gewechselt und wollte diese sachen ausführen:

$ ./autogen.sh --prefix=/usr/local
$ make
$ su
# make install
Dann kommt die Fehlermeldung: you need autoconfig to generate the makefile.
./autogen.sh line 23 libtoolize: command not found
./autogen.sh line 25 aclocal: command not found
./autogen.sh line 28 ./configure: Datei oder Verzeichnis nicht gefunden.

Danke nochmal für die Hilfe.
 

Tarzipan

Eroberer
Beiträge
71
der log lässt schließen, dass du keine entwicklungsumgebung installiert hast. du brauchst halt automake, autoconf, make und ganz wichtig GCC!!!
vielleicht kann man bei RH ja auch nach ketegorien software installieren. ich habe zwar RH 7.3 auf dem schrank , aber mkd9.1 installiert :P
 

wizzardxx

Mitglied
Beiträge
32
libsigc-1.0.so.0

So ich habe jetzt alle Packete installiert.
Mir fehlt jetzt nur noch eins.
libsigc-1.0.so.0
Weiss jemand wo ich das bekomme ???

thx...
 

wizzardxx

Mitglied
Beiträge
32
autostart der Iptables

So jetzt habe ich es endkich geschaft diesen fwbuilder zu installieren und konfigurieren.
Klappt auch alles Super.
Aber jetzt möchte ich das die neuen Regeln beim Systemstart geladen werden. Habe 2 Dinge gemacht die aber nicht funktionieren. Muss den fwbuilder immer per Hand starten damit die Regeln greifen.

1.) in /etc/init.d/iptables folgendes eingefügt:

case "$1" in
start)
start
####### FWBUILDER SCRIPT
/etc/fwbuilder/firewall.fw
###################
;;
usw.

2. also root folgenden Befehl ausgeführt: /sbin/service iptables save

Das habe ich von der Redhat Seite aufgegriffen aber wenn ich Linux reboote ladet er immer noch die Standart Regeln der Firewall.

Was kann man noch machen ????

thx
wizzardxx
 

wizzardxx

Mitglied
Beiträge
32
Hat sich erledigt

OK habe es hinbekommen.
Wen es interessiert:

mit dem Programm "setup" unter "System Services" den
Punkt "iptables" ausgeschaltet, und in der /etc/rc.d/rc.local eine Zeile angefuegt, die das Script startet.

also z.B:

/etc/fwbuilder/firewall.fw
 

Ähnliche Themen

Keine grafische Oberfläche (Debian Installation)

PATH wird nicht richtig durchsucht

Keine Zugriff von Windows 10 auf Sambafreigaben

Lokales Netzwerk einrichten... Anleitung ohne 3 Kapitel bla blub?

openn SuSE 13.1 - 64-BIt erlaubt nicht mehr als 20GB für /root

Oben