dedicated server suse update

webdepp

Grünschnabel
Beiträge
4
Tach auch !

1. frisch registriert hier... in diesem Sinne: HI zusammen :)
2. *nix-Noob...habt nachsicht ;)


Ich möchte auf meinem Strato-Dedicated ein Suse-Update durchführen.
Dafür hab ich apt4suse installiert
In der Datei /etc/apt/sources.list hab ich die 9.3 durch 10.0 ersetzt.

Jetzt will der jede Menge Depedencies von mir

Code:
#apt update
#apt upgrade
Reading Package Lists... Done
Building Dependency Tree... Done
You might want to run `apt-get --fix-broken install' to correct these.
The following packages have unmet dependencies:
  perl-spamassassin: Depends: perl (= 5.8.7) but 5.8.6-5.3 is installed
E: Unmet dependencies. Try using --fix-broken.

# apt install perl
Reading Package Lists... Done
Building Dependency Tree... Done
You might want to run `apt-get --fix-broken install' to correct these:
The following packages have unmet dependencies:
  perl-Archive-Tar: Depends: perl (= 5.8.6) but 5.8.7-5.3 is to be installed
  perl-Bootloader: Depends: perl (= 5.8.6) but 5.8.7-5.3 is to be installed
  perl-Config-Crontab: Depends: perl (= 5.8.6) but 5.8.7-5.3 is to be installed
  perl-DBD-mysql: Depends: perl (= 5.8.6) but 5.8.7-5.3 is to be installed
  perl-DBI: Depends: perl (= 5.8.6) but 5.8.7-5.3 is to be installed
  perl-Data-ShowTable: Depends: perl (= 5.8.6) but 5.8.7-5.3 is to be installed
  perl-Digest-HMAC: Depends: perl (= 5.8.6) but 5.8.7-5.3 is to be installed
  perl-Digest-SHA1: Depends: perl (= 5.8.6) but 5.8.7-5.3 is to be installed
  perl-GD: Depends: perl (= 5.8.6) but 5.8.7-5.3 is to be installed
  perl-HTML-Parser: Depends: perl (= 5.8.6) but 5.8.7-5.3 is to be installed
  perl-HTML-Tagset: Depends: perl (= 5.8.6) but 5.8.7-5.3 is to be installed
  perl-IO-Socket-SSL: Depends: perl (= 5.8.6) but 5.8.7-5.3 is to be installed
  perl-IO-Zlib: Depends: perl (= 5.8.6) but 5.8.7-5.3 is to be installed
  perl-Net-DNS: Depends: perl (= 5.8.6) but 5.8.7-5.3 is to be installed
  perl-Net_SSLeay: Depends: perl (= 5.8.6) but 5.8.7-5.3 is to be installed
  perl-Parse-RecDescent: Depends: perl (= 5.8.6) but 5.8.7-5.3 is to be installed
  perl-URI: Depends: perl (= 5.8.6) but 5.8.7-5.3 is to be installed
  perl-X500-DN: Depends: perl (= 5.8.6) but 5.8.7-5.3 is to be installed
  perl-gettext: Depends: perl (= 5.8.6) but 5.8.7-5.3 is to be installed
  perl-libwww-perl: Depends: perl (= 5.8.6) but 5.8.7-5.3 is to be installed
  yast2-core: Depends: perl (= 5.8.6) but 5.8.7-5.3 is to be installed
E: Unmet dependencies. Try 'apt-get --fix-broken install' with no packages (or specify a solution).

Man bemerke - das ist nur Perl...Wieviele mögen da noch kommen ?!
Soll ich da jetzt allen Ernstes 1000+x Pakete von hand einzeln neu installieren (abschreiben, apt-install-eintippen, blabla) ??

Oder crasht mir da eh mein gesamtes System ? :D

Kurz gefragt - wie löse ich das Problem mit atp. Oder wie kann ich sonst mein Linux über Netzwerk bzw. FTP updaten ?


Gruß, Tobi
 

marcellus

Kaiser
Beiträge
1.392
Du hast bei suse ein tool namens yast, das ist unter anderem dein packetmanager damit solltest du direkt auf suse 10.0 updaten können ohne irgendwie herumspielen zu müssen.

edit: yast2 ist iirc die konsolenversion von dem programm, falls du keine grafik hast
 
Zuletzt bearbeitet:

webdepp

Grünschnabel
Beiträge
4
Thx for feedback, but:

Du meinst das andersrum..
Yast(1) ist natürlich die Konsolenversion, Yast2 grafisch ;)

rufe ich "yast" über Konsole auf (x bzw. gnome iss nixx bei dedicated-serverin grundausstattung), habe ich u.a. die Auswahl:

"Installationsquelle wechseln" - du meinst das ?

(Ich hatte die letzten 3 tage Putty so ca. 100mal offen...meinste ich hätte diesen Menüpunkt registriert ?
ich glaub, ich bin zu Windoof-bescheuert... Und morgen erzähl ich ner blonden Kundin wieder, sie solle gefälligst lesen, was da auf dem Bildschirm steht :oldman X( )

1. kay... mein verständnis reicht soweit, dass ich mir vorstellen kann, ich wähle nen tp.server/verzeichnis/10.2 aus... der zieht daher die rpms...
[EDIT]Yast nutzt doch rpms ? [/EDIT]

Allerdings sind i.A. keine Versionen im Verzeichnispfad für das aktuelle Suseupdate angelegt (tu-chemnitz) angelegt ?! komisch...

Und den eigentlichen Update-vorgang starte ich dann wiederum mit yast->"Online-Update" ?

Sorry für die blöde Fragerei, aber ist n Produktiv-System... Lieber dumm fragen als alles zerschießen ^^

2. Was könnnt ihr empfehlen... 10.0 soll stabil sein, was man so liest.
10.1 scheiße ^^
und 10.2 ist ein Faktor für jede Menge geteilter Meinungen...

Ja huch, was nehm ich denn da ?


Festgestellt habe ich...
Es gibt nur noch begrenzt neue rpms für 10.0.....das meiste 10.1...und kaum (ich glaube garnixx) für 10.2 - da wahrscheinlich alles aktuell... Je älter, desto früher stoße ich an ein neues OS-Update, mangels neuer, benötigter Programmversionen für nicht mehr supportete (-> keine passenden rpms mehr) Suse-Versionen - Der Grund für mein update.

Andererseits soll es stabil laufen, und keine probleme verursachen..

Nötig ist, wenn wir gerade dabei sind - das läuft eher in punkto "dumme und zu oft gestellte Fragen" und artet schnell in einen Glaubenskrieg aus, ich weiß - trotzdem muss ich fragen (für mein Seelenheil) :D :

Webserver = Apache, Mysql, php, irgendein ftp-server, multidomainfähiger mailserver [bislang verwende ich qmail+vpopmail...aber das soll, wie gelesen, auch recht veraltet sein....Alternative: Courier ? oder...öhm...was ?] ... gibt wohl inzwischen auch mailserver mit integrierter antispam&-virus lösung...da spar ich mir meinen spamassassin,....

Ja, glaube, das wars.. Hat jemand zu diesem Thema auch interessante Links (Gegenüberstellungen etc. [v.a. multidomainfähiger mailserver, noob-bedienbar spätestens über webmin])

Danke euch :)
 
Zuletzt bearbeitet:

Ähnliche Themen

Ich mag Dovecot nicht ...

./easy-wi_install.sh install Script

rpm mittels yum

Installationsabbruch

Paket Updates laufen plötzlich nicht mehr?

Oben