Centos und Apache (VirtualHost)

Corovus

Grünschnabel
Beiträge
4
Hallo,

ich bin gerade dabei die Firmenseiten unserer Unternehmensgruppe neu zu gestalten. Insgesammt sind es 3 Unternehmen.

Als Server wurde mir ein Centos6 Server zur Verfügung gestellt, auf dem ich Apache, mysql, php installiert habe. Soweit war das auch alles kein Problem. Ich hab dann nach dieser Anleitung: https://www.digitalocean.com/community/tutorials/how-to-set-up-apache-virtual-hosts-on-centos-6 die VirtualHosts konfiguriert, da alle Seiten auf dem selben Server gehostet werden sollen.

Ich hab dann entsprechend der Anleitung 3 Verzeichnisse firma1.com/public_html ; firma2.com/public_html; firma3.com/public_html im var/www Verzeichnis des Centos Servers angelegt und die Informationen wie z.b. "DocumentRoot ect" in der httpd.conf Datei eingetragen.

Kurz zur Erinnerung, der CentosServer ist nur von unserem Firmennetzwerk aus erreichbar, also sozusagen "lokal". In der Anleitung zu den VirtalHosts steht "The first VirtualHost section is used for requests without a known server name" und genau das passiert auch, es wird die Seite aufgerufen die ich zuerst in den VirtualHosts eingetragen habe.

ABER, wie kann ich jetzt die anderen beiden Seiten intern aufrufen? Bei allen Anleitungen zu VirtualHosts wird ja immer davon ausgeganen, dass der Server über das Internet erreichbar ist und man über den ServerNamen zu den einzelnen Seiten kommt, aber das funktioniert ja in einer lokalen Umgebung nicht.

Ich weiß ja nicht ob ich einfach nur zu blöd bin aber nach 1-2 Stunden Suche und rumprobieren hab ich aufgegeben und hoffe das mir einer von euch weiterhelfen kann.
 

marce

Kaiser
Beiträge
1.300
wenn Du einen lokalen DNS-Server hast kannst Du das gewünschte Verhalten auch so erreichen.

Ohne DNS-Server oder Zugriffmöglichkeit auf die etc/hosts-Datei aller Clients wirst Du um IP- oder Port-basierte VHosts nicht herum kommen.

... oder halt einfach unterhalb des Default-VHosts Unterverzeichnisse anlegen und über diese auf die einzelne Webseiten zugreifen.
 

Ähnliche Themen

Vhosts mal wieder

Xampp (Lampp) Vhost Einstellungen ???

Apache zu langsam ?

CGI laesst sich nicht ausfuehren

apache - unschoene [warn] meldung

Oben