SUSE / Apache gehackt ???

Dieses Thema im Forum "SuSE / OpenSuSE" wurde erstellt von jgrieb, 17.02.2009.

  1. #1 jgrieb, 17.02.2009
    Zuletzt bearbeitet: 17.02.2009
    jgrieb

    jgrieb Jungspund

    Dabei seit:
    17.02.2009
    Beiträge:
    17
    Zustimmungen:
    0
    Brauche dringend Hilfe.
    Ich habe seit heute folgendes Problem. Kann meinen Apache nicht mehr erreichen. Weder lokal noch übers Internet.
    Mein Router scheint zu funktionieren. Ping von außen geht.
    Mails werden an meinen Mailserver weitergeleitet (ist ein anderer Computer, aber für mich ein Zeichen, dass der Router funktioniert). Routerkonfiguration ist ok, wurde auch nicht verändert. An der Apache-Konfiguration konnte ich über YAST keine Veränderung feststellen.
    In meinem lokalen Netz kann ich auf den SUSE-Server über VNC oder Samba zugreifen. Netzwerkverbindung funktioniert also auch. Vom Suse-Server komme ich auch ins Internet.
    Das Problem scheint also auf den Apache begrenzt zu sein.
    Habe mehrere virtuelle Hosts auf dem Apache. Bin mit meinem Latein so ziemlich am Ende.
    Weiß jemand Rat? Bin für jeden Hinweis dankbar.
    Habe SUSE 9.3
    Und da ist noch was. Wenn ich den Suse-Server neu boote, und das Anmeldefenster erscheint, dann steht im Benutzer-name schon "Root" drin. Das war meiner Meinung nach vorher nicht so. Ich glaube, da waren alle Felder leer.
    :hilfe2:
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. daboss

    daboss Keine Macht für niemand!

    Dabei seit:
    05.01.2007
    Beiträge:
    1.294
    Zustimmungen:
    0
    Ort:
    sydney.australia.world
    Relativ alte Betreibssystem-Version, hm?
    Hast du dir (u.A.) mal
    Code:
    tail /var/log/apache2/*.log
    angeschaut?
     
  4. marce

    marce Kaiser

    Dabei seit:
    01.08.2007
    Beiträge:
    1.054
    Zustimmungen:
    8
    (1) Suse 9.3 ist alt, da könntest Du mal über ein Update nachdenken.
    (2) läuft der Server? Was steht im Logfile? Wie groß sind die Logfiles?
     
  5. T-One

    T-One Routinier

    Dabei seit:
    14.10.2008
    Beiträge:
    478
    Zustimmungen:
    3
    Ort:
    Österreich
    wie daboss meinte die logs anschaun und mal kucken was ein restart des apache bringt.
    /etc/init.d/apache(2) restart

    könnte vielleicht interessante fehlermeldungen ausspucken.
     
  6. foexle

    foexle Kaiser

    Dabei seit:
    02.05.2007
    Beiträge:
    1.104
    Zustimmungen:
    0
    Ort:
    Saarbrücken
    vorallem nicht die
    history vergessen ...
    wenn sie nicht gelöscht wurde, wirst du da direkt sehen ob jmd auf deinem system war ode rnicht
     
  7. jgrieb

    jgrieb Jungspund

    Dabei seit:
    17.02.2009
    Beiträge:
    17
    Zustimmungen:
    0
    Problem gelöst

    Es funktioniert wieder alles.
    Ich weiß allerdings nicht warum. Im log-Verzeichnis ist eine Datei rc.out mit heutigem Datum. Da stand drin, dass das Document-Root für meinen Standard-Server nicht existiert.
    Diese Einstellung habe ich korrigiert und plötzlich habe ich wieder Zugriff auf alle virtuellen Hosts.
    Nur folgendes verstehe ich dabei nicht:
    1. Meinen Standard-Server habe ich bereits vor Wochen in ein neues Verzeichnis gelegt und mit dieser Einstellung hat bisher alles funktioniert (Außer wahrscheinlich der Standardserver). Ich habe zwischenzeitlich auch mehrmals gebootet.
    2. Was hat die Einstellung des Root-Verzeichisses für den Standardserver mit dem Zugriff auf die anderen VHosts zu tun.

    Was meint Ihr? kann das die wirkliche Ursache gewesen sein?

    Für Eure schnelle Hilfe erst einmal vielen Dank.

    Zum Abschluß noch eine Frage zum Update auf eine neuere SUSE Version.
    Ich komme eigentlich aus der Windows-Welt und habe auf Grund meiner Erfahrungen mit MS-Server-Updates immer Bedenken gehabt SUSE upzudaten.
    Wie gehe ich dabei vor um keine Bauchlandung zu machen.
    Übrigens: Habe auch mit Foren keine große Erfahrung --> gehört das in einen neuen Thread?
    Danke
     
  8. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  9. #7 gropiuskalle, 17.02.2009
    gropiuskalle

    gropiuskalle terra incognita

    Dabei seit:
    01.07.2006
    Beiträge:
    4.857
    Zustimmungen:
    0
    Ort:
    Berlin
    Bedenken solltest Du aufgrund der völlig veralteten und somit nicht mehr mit updates versorgten Distribution haben, denn das ist echt ein Sicherheitsrisiko.

    Du könntest /home unformatiert einbinden und somit zumindest Deine bisherigen user-Konfigurationsdateien übernehmen. Vermutlich spielt das bei Dir aber keine Rolle. Das System selbst, sprich die root-Partition, wirst Du jedoch aufgeben müssen, denn ein upgrade von der 9.3 auf eine aktuelle Version wird nicht funktionieren.

    Normalerweise ja, aber Du wirst dafür vorraussichtlich nicht gekreuzigt werden oder sowas. Willkommen im Unixboard!
     
  10. jgrieb

    jgrieb Jungspund

    Dabei seit:
    17.02.2009
    Beiträge:
    17
    Zustimmungen:
    0
    Vielen dank für die Hinweise.
    Dann werde ich demnächst mal eine aktuelle SUSE-Version installieren.
     
Thema:

SUSE / Apache gehackt ???

Die Seite wird geladen...

SUSE / Apache gehackt ??? - Ähnliche Themen

  1. opensuse10.2: apache + postgres

    opensuse10.2: apache + postgres: Hallo zusammen, ich habe meinen postgresql server fertig und kann remote darauf zugreifen (pgAdminIII). Jetzt dachte ich bau mal schnell den...
  2. webserver apache mysql php unter opensuse 10.2

    webserver apache mysql php unter opensuse 10.2: hallo, man hört so unterschiedliche meinungen, was das betreiben eines webservers betrifft. um konkreter zu werden: Welches ist die bessere...
  3. Apache Version anzeige SUSE

    Apache Version anzeige SUSE: Hallo, wie kann ich mir unter Open Suse die Apache Version anzeigen lassen. "httpd -v" funktioniert ja unter Suse leider nicht. Danke für alle...
  4. Scalix 11 und openSuSE 10.1 Error 403 & Error 503 (Apache2)

    Scalix 11 und openSuSE 10.1 Error 403 & Error 503 (Apache2): Hallo, ich habe ein Problem mit Scalix 11 unter openSuSE 10.1. Ich denke, das ich es soweit angeschränkt habe das es daran liegt, dass Tomcat...
  5. Apache-Service mit SSL (Suse 10.1)

    Apache-Service mit SSL (Suse 10.1): Halli Hallo Ihr da draussen! Das ist mein erster Post hier im Forum und ich habe direkt mal ne Frage zu meinem Suse 10.1. Ich habe Apache...