RT2500 / WLan-Klarte installieren

Dieses Thema im Forum "Sonstiges" wurde erstellt von kiko, 15.01.2006.

  1. kiko

    kiko Grünschnabel

    Dabei seit:
    15.01.2006
    Beiträge:
    6
    Zustimmungen:
    0
    Hi
    Ich habe ein Problem.
    Einmal bin ich nicht der größte Linux User.

    Undzwar will ich meine WLan-Karte installieren.
    Klappt leider noch nicht so wie ich will.

    Daten:
    SuSe Linux 9.2
    Kernel: 2.6.8-24
    WLan-Karte: PCI 54mbit FL-WL400P
    Chipsatz: RT2500

    Was ist bisher schon versucht habe:

    Mir unter folgender Seite die Treiber für die Karte runtergeladen:
    http://rt2x00.serialmonkey.com/wiki/index.php/Downloads
    Diese dann ins Verzeichnis /home/user/ kopiert.
    Als nächstes die Konsole geöffnet und mich als su angemeldet.
    Danach:
    Code:
    cp /home/[b]user[/b]/rt2500-1.1.0-b3.tar.gz /usr/src
    
    Somit ist die Datei rt2500-1.1.0-b3.tar.gz im Ordner /usr/src
    Nun:
    Code:
    tar -xvzf /usr/src/rt2500-1.1.0-b3.tar.gz
    
    Damit war die Datei entpackt und es war nen Ordner rt2500-1.1.0-b3 im im Verzeichnis /usr/src.
    Danach:
    Code:
    cd /usr/src/rt2500-1.1.0-b3/Module
    
    Danach habe ich folgende 3 Befehle versucht, welche alle einen Fehler ausgaben:
    Code:
    make install
    make
    make debug
    
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. devilz

    devilz Pro*phet
    Administrator

    Dabei seit:
    01.05.2002
    Beiträge:
    12.244
    Zustimmungen:
    0
    Ort:
    Hessen
    Könntest du die Fehler mal posten die du erhälst ?
     
  4. kiko

    kiko Grünschnabel

    Dabei seit:
    15.01.2006
    Beiträge:
    6
    Zustimmungen:
    0
    Hi
    Dank dir für die schnelle Antwort:
    Also Fehler bei make:
    Code:
    make[1] Entering directory 'usr/src/linux-2.6.8-24-obj/1386/smp'
    make[1] *** Keine Regel, um »modules« zu erstellen. Schluss.
    make[1] Leaving directory 'usr/src/linux-2.6.8-24-obj/1386/smp'
    rt2500.ki failed to build!
    make *** [module] Fehler 1
    
    Bei make install ... ist es alles das selbe, nur, dass statt make halt make install .... steht.
    Wär dir / euch ercht dankbar, wenn Ihr helfen könntet.
    kiko
     
  5. devilz

    devilz Pro*phet
    Administrator

    Dabei seit:
    01.05.2002
    Beiträge:
    12.244
    Zustimmungen:
    0
    Ort:
    Hessen
    Code:
    mobilix:/usr/src/rt2500-1.1.0-b3/Module # make
    make[1]: Entering directory `/usr/src/linux-2.6.11.4-21.10-obj/i386/default'
    make -C ../../../linux-2.6.11.4-21.10 O=../linux-2.6.11.4-21.10-obj/i386/default modules
      CC [M]  /usr/src/rt2500-1.1.0-b3/Module/rtmp_main.o
      CC [M]  /usr/src/rt2500-1.1.0-b3/Module/mlme.o
      CC [M]  /usr/src/rt2500-1.1.0-b3/Module/connect.o
      CC [M]  /usr/src/rt2500-1.1.0-b3/Module/sync.o
      CC [M]  /usr/src/rt2500-1.1.0-b3/Module/assoc.o
      CC [M]  /usr/src/rt2500-1.1.0-b3/Module/auth.o
      CC [M]  /usr/src/rt2500-1.1.0-b3/Module/auth_rsp.o
      CC [M]  /usr/src/rt2500-1.1.0-b3/Module/rtmp_data.o
      CC [M]  /usr/src/rt2500-1.1.0-b3/Module/rtmp_init.o
      CC [M]  /usr/src/rt2500-1.1.0-b3/Module/sanity.o
      CC [M]  /usr/src/rt2500-1.1.0-b3/Module/rtmp_wep.o
      CC [M]  /usr/src/rt2500-1.1.0-b3/Module/wpa.o
      CC [M]  /usr/src/rt2500-1.1.0-b3/Module/md5.o
      CC [M]  /usr/src/rt2500-1.1.0-b3/Module/rtmp_tkip.o
      CC [M]  /usr/src/rt2500-1.1.0-b3/Module/rtmp_info.o
      CC [M]  /usr/src/rt2500-1.1.0-b3/Module/eeprom.o
      LD [M]  /usr/src/rt2500-1.1.0-b3/Module/rt2500.o
      Building modules, stage 2.
      MODPOST
      CC      /usr/src/rt2500-1.1.0-b3/Module/rt2500.mod.o
      LD [M]  /usr/src/rt2500-1.1.0-b3/Module/rt2500.ko
    make[1]: Leaving directory `/usr/src/linux-2.6.11.4-21.10-obj/i386/default'
    
    (Gebaut auf einem SuSE 9.3 ...)

    Also ich würde mal sagen das es an deinem SuSE 9.2 liegt ... nutzt du denn SMP, also hast du ne Pentium4HT CPU oder ein DUAL Prozessor Mainboard?
    Ansonsten nimm mal den default Kernel ohne SMP und installier dazu die passenden Sourcen ....
     
  6. kiko

    kiko Grünschnabel

    Dabei seit:
    15.01.2006
    Beiträge:
    6
    Zustimmungen:
    0
    Hi
    Ich habe nen P4 mit HT ja?!
    Was soll ich denn nun machen damits fuzt ^^
    kiko
     
  7. devilz

    devilz Pro*phet
    Administrator

    Dabei seit:
    01.05.2002
    Beiträge:
    12.244
    Zustimmungen:
    0
    Ort:
    Hessen
    Du könntest den CVS Treiber mal probieren ....
     
  8. kiko

    kiko Grünschnabel

    Dabei seit:
    15.01.2006
    Beiträge:
    6
    Zustimmungen:
    0
    Wo gibts den?!
    kiko

    ps:
    google findet ja bekanntlich alles ^.^
    edit:
    Damit hat es dann aber zutun?!
    Wär echt saugeil
     
  9. devilz

    devilz Pro*phet
    Administrator

    Dabei seit:
    01.05.2002
    Beiträge:
    12.244
    Zustimmungen:
    0
    Ort:
    Hessen
    http://rt2x00.serialmonkey.com/wiki/index.php/Downloads

    Ziemlich unten auf der Seite - rt2500 nightly CVS tarball: rt2500-CVS

    Das sind dann die frischesten Treiber - Entwicklerversion halt ...

    Wenn es damit nicht geht, solltest du Testweise einen anderen Kernel (nicht SMP) von der SuSE CD installieren inkl. den Sourcen ...
    Oder du kontaktierst mal einen Entwickler der Treiber ...
     
  10. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  11. kiko

    kiko Grünschnabel

    Dabei seit:
    15.01.2006
    Beiträge:
    6
    Zustimmungen:
    0
    Also das mist CSV - Version klappet auch nicht.
    Woran kann es denn leigen.
    Muss man make neuinstallieren?!
    kernel installation ... musst das sein ^.^
    kiko
     
  12. devilz

    devilz Pro*phet
    Administrator

    Dabei seit:
    01.05.2002
    Beiträge:
    12.244
    Zustimmungen:
    0
    Ort:
    Hessen
    Ich wüßte sonst keine andere Lösung - oder du aktualisierst mal auf eine aktuellere SuSE Version ;)
     
Thema:

RT2500 / WLan-Klarte installieren

Die Seite wird geladen...

RT2500 / WLan-Klarte installieren - Ähnliche Themen

  1. Wlan will nicht mehr (rt2500pci)

    Wlan will nicht mehr (rt2500pci): Als ich mal wieder meinen Desktop eingeschaltet habe musste ich festellen, dass mein Wlan (rt2500pci) nicht mehr will. Wieso weiß ich allerdings...
  2. Kann mir Fehler beim installieren vom rt2500 Modul nicht erklären

    Kann mir Fehler beim installieren vom rt2500 Modul nicht erklären: Habe mir einen neuen Rechner gebaut. Lenny installiert- alles einwandfrei. Unter Squeeze lässt sich allerdings der Wlan Treiber rt2500 nicht...
  3. Unterschied zwischen RT2500 + RT2500pci

    Unterschied zwischen RT2500 + RT2500pci: Hintergrund: Wlan unter Squeeze mit RT2500pci ist grotten lahm. Hier mal der Unterschied: Squeeze mit RT2500pci und wpa_supplicant wlan0...
  4. RT2500 Modul vom Kernel 2.6.28.2. verwenden

    RT2500 Modul vom Kernel 2.6.28.2. verwenden: Ich hab es immer noch nicht geschafft mein WLAN zu laufen zu bringen, glaube aber jetzt zu wissen woran es liegt. Und habe ich nach einem Howto...
  5. Fehler beim installieren von rt2500, genau beschrieben

    Fehler beim installieren von rt2500, genau beschrieben: Habe mir Gestern einen neuen Kernel installiert (2.6.28.2 von Kernel.org) Um meine Wlankarte mit RT2500er Chip zu installieren hab ich mir zuerst...