Probleme mit autostart und neustart

Dieses Thema im Forum "SuSE / OpenSuSE" wurde erstellt von Gebath, 06.09.2006.

  1. Gebath

    Gebath Guest

    ich habe SuSE10.1 und habe 2 Problemchen:
    1. Startet immer ZEN und nicht smart obwohl ich eigentlihc das verwenden will..., außerdem startet der Networkmanager nicht automatisch und stellt auch nur nach eingabe des WPA-Schlüssels verbinden (der nicht gespeichert wird).
    2. benötige ich nervigerweise immer ein root-passwort um den Rechner auszuschalten oder neuzustsarten

    wie lassen sich meine Problemchen lösen
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 supersucker, 06.09.2006
    supersucker

    supersucker Foren Gott

    Dabei seit:
    21.02.2005
    Beiträge:
    3.873
    Zustimmungen:
    0
    Zu 1 kann ich dir nichts sagen, weil ich kein Suse verwende und wenn ich solche und andere Beiträge zu Suse lese, weiss ich auch wieder warum.....
    OT
    Wieviele verschiedene updater und paketmanager gibts bei suse eigentlich?
    /OT

    zu 2.

    - sudo installieren
    - mit visudo /etc/sudoers editieren
    - deinem user rechte auf /sbin/shutdown geben

    dann kannst du auch als user runterfahren.
     
  4. #3 Gebath, 06.09.2006
    Zuletzt von einem Moderator bearbeitet: 06.09.2006
    Gebath

    Gebath Guest

    hab ich nicht ganz verstanden wie sry. ich hab sudo installiert aber welche datei muss ich nun konkret wie verändern? (linux-anfänger)
    nach dem lesen der man-page bin ich soweit dass ich weiß dass ich "visudo -f sudoers" also root ausführen sollte (oder irre ich) aber dann erhalte ich eine leere Seite mit lediglich einigen Zeilen mit einer Welle am Anfang und null inhalt...
     
  5. #4 supersucker, 06.09.2006
    supersucker

    supersucker Foren Gott

    Dabei seit:
    21.02.2005
    Beiträge:
    3.873
    Zustimmungen:
    0
    Eine exzellente deutsche Anleitung findest du hier

    Das ist zwar der gentoo-guide, funktioniert aber genauso unter suse.
     
  6. Gebath

    Gebath Guest

    ok habe ich alles richtig verstanden?
    also root: "visudo -f sudoers" eingeben
    dann einfach "username localhost = /sbin/shutdown"
    wobei clemens auch variable ist und wenn alle User das dürfen sollen kann ich auch einfach "ALL" statt "username" verwenden. dann einfach Esc drücken und ":wq" beenden oder?
     
  7. #6 supersucker, 06.09.2006
    supersucker

    supersucker Foren Gott

    Dabei seit:
    21.02.2005
    Beiträge:
    3.873
    Zustimmungen:
    0
    Code:
    visudo -f /etc/sudoers
    Ansonsten hast du das richtig verstanden.
     
  8. Gebath

    Gebath Guest

    dürfte irgendwas nicht stimmen... muss noch immer pw eingeben
    sollte es vllt. wie im Beispiel /etc/shutdown -h now heißen?
    kann mir eigentlihc keiner mit meinem autostartproblem helfen?
     
  9. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  10. #8 DennisM, 06.09.2006
    DennisM

    DennisM Moderator u. Newsposter

    Dabei seit:
    08.05.2004
    Beiträge:
    4.883
    Zustimmungen:
    0
    Ort:
    GER/NRW/Essen
    Benutze einfach einen Displaymanager wie KDM oder GDM, dann kannst du den Rechner ganz einfach wie im Windows (per Button) runterfahren.

    Vorrausgesetzt du benutzt KDE oder GNOME.

    MFG

    Dennis
     
  11. #9 Gebath, 06.09.2006
    Zuletzt von einem Moderator bearbeitet: 06.09.2006
    Gebath

    Gebath Guest

    da muss ich wiedersprechen denn das geht eben nicht genau um das geht es mir! es hat mich selbst auch verwundert aber es ist so. er verlangt immer ein root-pw bevor er alles richtig startet (also das mit schwarzem hintergrund und schrift die durchrattert....
    EDIT: verwende KDE in der neuesten Version...
     
Thema:

Probleme mit autostart und neustart

Die Seite wird geladen...

Probleme mit autostart und neustart - Ähnliche Themen

  1. Probleme beim Autostart von KlamAV

    Probleme beim Autostart von KlamAV: Hallo zusammen, ich habe seit kurzem KlamAV und Dazuko auf meinem Rechner mit openSuse 10.2 installiert. Beides läuft, allerdings mit zwei...
  2. grub-pc Probleme bei upgrade

    grub-pc Probleme bei upgrade: Hallo, ich habe beim dist-upgrade folgendes Problem: ---------- Nach dieser Operation werden 0 B Plattenplatz zusätzlich benutzt. Trigger für...
  3. Probleme mit YUM

    Probleme mit YUM: Hallo, ich habe CentOs 7 als Dualboot mit Windows 7 auf einen Dell Latitude E5510 installiert. Dies hat soweit auch alles geklappt. Leider habe...
  4. Forscher analysieren Durchsatzprobleme im Linux-Scheduler

    Forscher analysieren Durchsatzprobleme im Linux-Scheduler: Eine Gruppe von Forschern hat Fälle identifiziert, in denen der Scheduler im Linux-Kernel falsche Entscheidungen trifft und die CPUs nicht so gut...
  5. München: LiMux als Sündenbock für IT-Probleme?

    München: LiMux als Sündenbock für IT-Probleme?: Im Münchner Stadtrat soll später in diesem Jahr erneut über den Einsatz von Linux in der Stadtverwaltung diskutiert werden. Die Grünen vermuten,...