nVidia-Treiber installieren klappt nicht

Dieses Thema im Forum "SuSE / OpenSuSE" wurde erstellt von cfx, 19.10.2006.

  1. cfx

    cfx Mitglied

    Dabei seit:
    19.10.2006
    Beiträge:
    39
    Zustimmungen:
    0
    Hi,
    seit letztem Wochenende bin ich nun stolzer Besitzer von Suse Linux 10.1 :)

    Bisher habe ich auch eigentlich alles alleine hinbekommen, bloß diese dummen nVidia-Treiber krieg ich nicht installiert.
    Ich besitze eine GeForce FX 5700 Graka.

    Folgendermaßen bin ich vorgegangen:
    - Ich habe diesen Treiber heruntergeladen (x86)
    - Ich habe mich als root angemeldet
    - Ich habe die Pakete "kernel-source", "gcc" und "make" installiert
    - Ich habe den Runlevel 3 geladen
    - ...und schließlich wollte ich /root/Desktop/NVIDIA ausführen, aber jedes mal erscheint "Permission denied"

    Ich frag mich, was man eigentlich noch alles beachten muss ! :think:

    Btw, hab ich auch noch 'ne 2. Frage, die den Fenstermanager unter Gnome betrifft. Der lädt nämlich nach der normalen Benutzeranmeldung (Ich hab nur einen Benutzer [=Ich]) extrem lange. Ich weiß nicht, ob das mit ein paar Einstellungen zu tun hat, da ich einfach zu viel dran rumgespielt hab. ^_^"
    Deswegen meld ich mich jetzt öfter als root an, da's hier einfach schneller geht.

    Danke im Voraus.
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 ElektroPunk, 19.10.2006
    Zuletzt bearbeitet: 19.10.2006
    ElektroPunk

    ElektroPunk INSUBORDINANT

    Dabei seit:
    06.07.2006
    Beiträge:
    139
    Zustimmungen:
    0
    Ort:
    Konstanz
    Hi,

    wahrscheinlich musst du die Dateiberechtigung mit chmod auf ausfürbar setzen.
    Oder unter gnome rechte mMaustasre auf den Treiber->Eigenschaften->Zugriffsrechte.

    Schau dir am besten die Anleitung auch mal an! http://www.suse.de/~sndirsch/nvidia-installer-HOWTO.html

    MFG
    ElektroPunk
     
  4. #3 cfx, 19.10.2006
    Zuletzt bearbeitet: 19.10.2006
    cfx

    cfx Mitglied

    Dabei seit:
    19.10.2006
    Beiträge:
    39
    Zustimmungen:
    0
    Ach sieh an. So einfach geht das. ^_^"
    Kann man die Zugriffsrechte nicht auch irgendwo voreinstellen?

    Übrigens hat sich das Gnome-Lade-Problem gerade von selbst behoben, dafür ist aber ein anderes freundlicherweise an seine Stelle getreten. ;-)

    Nachdem die Treiber-Installation abgeschlossen war, hab ich sax2 -m 0=nvidia in die Konsole eingegeben (wie es mir irgendwo auch so gezeigt wurde) und neugestartet. Beim ersten Ausführen von SaX2 erschien die Fehlermeldung "ZMD wird anscheinend nicht ausgeführt" - welche allerdings kein zweites mal auftrat.
    Außerdem erscheint beim Start eines dieser tollen vorinstallierten Spiele immer noch die Meldung "Unterstützung für 3D-Hardware nicht verfügbar".
    Was behebt dieses Problem?
     
  5. #4 ElektroPunk, 19.10.2006
    Zuletzt bearbeitet: 19.10.2006
    ElektroPunk

    ElektroPunk INSUBORDINANT

    Dabei seit:
    06.07.2006
    Beiträge:
    139
    Zustimmungen:
    0
    Ort:
    Konstanz
    Hi,

    voreinstellen der Berechtigungen? keine Ahnung.

    Poste doch bitte mal deine /etc/X11/xorg.conf

    Vielleicht liegts auch daran, normal muss nach der installation dieses ausgeführt werden.

    sax2 -r -m 0=nvidia (also mit option r)

    MFG
    ElektroPunk
     
  6. #5 cfx, 19.10.2006
    Zuletzt bearbeitet: 20.10.2006
    cfx

    cfx Mitglied

    Dabei seit:
    19.10.2006
    Beiträge:
    39
    Zustimmungen:
    0
    Hmm, ich kenne mich mit der Linux-Konsole noch so gut wie gar nicht aus.
    Kannst du mir z. B. sagen wofür dieses -r oder -m steht?

    Hier die xorg.conf:
    Btw, warum muss ich eigentlich den Datei-Browser verwenden und kann nicht die Konsole dafür nehmen? Immer dieses "Permission denied" - trotz root.
     
  7. #6 ElektroPunk, 19.10.2006
    ElektroPunk

    ElektroPunk INSUBORDINANT

    Dabei seit:
    06.07.2006
    Beiträge:
    139
    Zustimmungen:
    0
    Ort:
    Konstanz
    Für -r -m gib einfach mal sax2 --help ein.

    Möglicherweise musst noch Sax 2 aufrufen und einen haken für 3d unterstützung setzen.

    MFG
    ElektroPunk
     
  8. cfx

    cfx Mitglied

    Dabei seit:
    19.10.2006
    Beiträge:
    39
    Zustimmungen:
    0
    Ich will nicht nerven, aber wie kann ich Linux "überreden" die 3D-Hardware zu erkennen. Die Treiber sind installiert und laufen soweit problemlos.
    Es fehlt halt bloß noch irgendwo ein entsprechender Eintrag.
     
  9. Fuel

    Fuel Tripel-As

    Dabei seit:
    12.12.2005
    Beiträge:
    169
    Zustimmungen:
    0
    Ort:
    Soltau
    Versuch es mal mit YAST-Hardware-Grafikkarte und Monitor.
     
  10. cfx

    cfx Mitglied

    Dabei seit:
    19.10.2006
    Beiträge:
    39
    Zustimmungen:
    0
    Ja, ich hab die nVidia-Einstellungen bereits alle gecheckt.
    Sowohl über SaX2 als auch Anwendungen/System/Weitere Programme/NVIDIA X Server Settings
    Das Häkchen für 3D-Beschleunigung ist übrigens schon gesetzt.
    Das Problem ist halt bloß, dass ich nicht weiß, was den Fehler verursacht !

    Ich werde noch mal etwas googlen ... :hilfe2:
     
  11. #10 supersucker, 20.10.2006
    supersucker

    supersucker Foren Gott

    Dabei seit:
    21.02.2005
    Beiträge:
    3.873
    Zustimmungen:
    0
    Prüf mal ob die 3d-Beschleunigung wirklich aktiviert ist durch

    Code:
    glxinfo | grep direct
    in der Konsole ausführen und Ergebnis hier posten.
     
  12. cfx

    cfx Mitglied

    Dabei seit:
    19.10.2006
    Beiträge:
    39
    Zustimmungen:
    0
    Konsole:
     
  13. #12 supersucker, 20.10.2006
    supersucker

    supersucker Foren Gott

    Dabei seit:
    21.02.2005
    Beiträge:
    3.873
    Zustimmungen:
    0
    Ja,

    dann sollte eigentlich alles in Ordnung sein.

    Kriegst du denn noch die Fehlermeldung?
     
  14. cfx

    cfx Mitglied

    Dabei seit:
    19.10.2006
    Beiträge:
    39
    Zustimmungen:
    0
    Natürlich.:D
    :oldman "Unterstützung für 3D-Hardware nicht verfügbar" :oldman

    ...schön, dass Linux immer Probleme schafft, wo scheinbar keine sind.
     
  15. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  16. #14 supersucker, 20.10.2006
    supersucker

    supersucker Foren Gott

    Dabei seit:
    21.02.2005
    Beiträge:
    3.873
    Zustimmungen:
    0
    Änder mal deine xorg-conf so (backup machen nicht vergessen)

    Code:
    Section "Module"
    	Load	"bitmap"
    	Load	"dbe"
    	Load	"ddc"
    	Load	"extmod"
    	Load	"freetype"
    	Load	"glx"
    	Load	"int10"
    	Load	"record"
    	Load	"type1"
    	Load	"vbe"
    EndSection
    
    
    Section "Device"
        Identifier	"Geforce"
        VendorName 	"nvidia"
        Driver 	"nvidia"
        BusID  	"AGP:01:00:00"
        Option      "RenderAccel"			"true"
    
    EndSection
    starte X neu und probiers nochmal.
     
  17. cfx

    cfx Mitglied

    Dabei seit:
    19.10.2006
    Beiträge:
    39
    Zustimmungen:
    0
    Was soll ich sagen?
    Das Grafiksystem ist beim Start ziemlich abgeschmiert.
    Gut, dass ich ein Backup gemacht hatte! :rolleyes:

    Gibt es vielleicht noch andere riskante Möglichkeiten, die das Adrenalin so richtig ansteigen lassen? ;)

    Nebenbei hab ich mal noch das Paket compat-expat1 installiert.
    ...und irgendwo wurde von einem kernel-header geredet. Was ist das und brauch ich das?
     
Thema:

nVidia-Treiber installieren klappt nicht

Die Seite wird geladen...

nVidia-Treiber installieren klappt nicht - Ähnliche Themen

  1. Debian Etch Nvidia-Treiber installieren

    Debian Etch Nvidia-Treiber installieren: Hallo, ich weiß das Thema ist schon überall behandelt worden und ich habe jetzt zwei Tage nach einer Lösung gesucht. Jetzt bin ich nur noch...
  2. nVidia-Treiber neu installieren?

    nVidia-Treiber neu installieren?: Hallo! Also im vorhinein tut es mir schonmal leid, falls die Frage zu dumm gestellt ist, oder falls ich nicht ausreichend gesucht habe (meiner...
  3. Fedora Core 2 Nvidia-Treiber installieren mit Kernel-devel-2.9.6-1.667

    Fedora Core 2 Nvidia-Treiber installieren mit Kernel-devel-2.9.6-1.667: hallo an alle, alles begann mit meinem wunsch et zu spielen. also download et-linux-2.60.x86.run von idsoftware und installation, alles ohne...
  4. Nvidia-Treiber mit Unterstützung für Optimus

    Nvidia-Treiber mit Unterstützung für Optimus: Der als Beta bezeichnete proprietäre Linux-Treiber 319.12 von Nvidia bietet erstmals rudimentäre Unterstützung für Optimus. Weiterlesen...
  5. nvidia-Treiber: Virtuelle Terminals bleiben schwarz

    nvidia-Treiber: Virtuelle Terminals bleiben schwarz: Hallo allerseits. (Oh man, seit vier Jahren das erste Mal wieder hier, echt spannend, sich selbst als Vierzehnjährigen zu erleben ;D) Aber nun zu...