OpenSUSE 10.3, 3D-Beschleunigung, NVIDIA Geforce 7600 Go, Problem mit Einrichtung

Dieses Thema im Forum "SuSE / OpenSuSE" wurde erstellt von Kayne607, 03.12.2007.

  1. #1 Kayne607, 03.12.2007
    Kayne607

    Kayne607 Grünschnabel

    Dabei seit:
    03.12.2007
    Beiträge:
    6
    Zustimmungen:
    0
    Hallo,

    ich bin blutiger Anfänger auf dem Gebiet OpenSUSE und Linux, möchte aber gerne auf das System umsteigen da ich es durchaus ansprechend finde (Freiheit von Microsoft usw. ).

    Ich habe ein Problem mit der Konfiguration von Open SUSE 10.3. Genauer gesagt es geht um die 3D Beschleunigung einer NVIDIA Geforce 7600 Go Karte.

    Ich habe das ganze Wochenende Google durchwühlt und jede Menge Anleitungen zur Installation des Treibers der Karte erhalten. Jedoch hat bis jetzt nichts dazu geführt die 3D Unterstützung aktivieren zu können, bzw. Anwendungen zu starten welche eine 3D Unterstützung benötigen.


    Grafikkarte: NVIDIA Geforce 7600 Go
    Betriebssystem: OpenSuse 10.3 AMD64

    Vorgehensweise:

    Versuch der Treiberinstallation über Yast.

    Ich habe wie in diversen Anleitungen beschrieben über Yast versucht den Treiber zu installieren. Dabei Installationsquelle angegeben (Servername: download.nvidia.com; Verzeichnis opensuse/10.3 Seite usw.) wie in der Anleitung beschrieben und den Treiber x11-video-nvidiaG01 und nvidia-gfxG01-kmp-… installiert. Hat auch alles geklappt. Daraufhin Neustart. Klappt auch. Nur die 3D Unterstützung konnte immer noch nicht konfiguriert werden.

    Ich habe daraufhin das Konfigurationsprogramm von Nvidia; nvidia-xconfig; gestartet. Neustart. Nach dem Neustart bekam ich die Fehlermeldung dass der X server nicht gestartet werden konnte (your graphic Interface). Habe dann die alte Konfiguration wiederhergestellt um wieder ins graphische Interface gelangen zu können.


     Treiber deinstalliert

    Versuch der manuellen Treiberinstallation

    Habe von der NVIDIA Seite den Treiber Linux AMD64/EM64T: » 100.14.23 (Veröffentlichungsdatum: 19.10.2007), NVIDIA-Linux-x86_64-100.14.23-pkg2.run heruntergeladen und als root im Textmodus installiert.

    Installation klappt wunderbar. Kernel wird neu kompiliert. Usw. Danach Meldung dass Treiber installiert ist. Als letztes wurde ich gefragt ob das Installationsprogramm den X-Server konfigurieren soll.
    Wenn ich das machen lasse tritt obiges Problem auf (X-Server startet nicht, nur Textmodus) wenn ich das verweigere, ganz normaler start, jedoch 3D Beschleunigung nicht verfügbar.


    Habe alle Schritte korrekt durchgeführt und auch mit Sax2 usw. konfiguriert. Nach Anleitung auf http://de.opensuse.org/NVIDIA halt.


    Ich wäre wirklich glücklich wenn mir jemand Hilfe geben könnte. Bin wie oben schon geschrieben blutiger Anfänger und weiß nach einem verzweifelten Kampf am Wochenende nicht mehr weiter. Evtl. hatte jemand das gleiche Problem und kann mir beschreiben wie er es gelöst hat.

    Vielen Dank schon jetzt!

    Mit freundlichen Grüßen,
    Kayne607
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 Keruskerfürst, 03.12.2007
    Keruskerfürst

    Keruskerfürst Kaiser

    Dabei seit:
    12.02.2006
    Beiträge:
    1.366
    Zustimmungen:
    0
    1. System starten
    2. Auf die Textkonsole wechseln
    3. init 3 eingeben
    4. Treiber installieren
    5. sax2 -m0=nvidia
    6. Treiber konfigurieren lassen
     
  4. #3 supersucker, 03.12.2007
    supersucker

    supersucker Foren Gott

    Dabei seit:
    21.02.2005
    Beiträge:
    3.873
    Zustimmungen:
    0
    Mach mal

    Code:
    egrep "(WW)|(EE)" > ~/Desktop/xorg_errors
    wenn das wieder auftritt und poste dann den Inhalt der Datei xorg_errors (findest du auf deinem Desktop).
     
  5. #4 gropiuskalle, 03.12.2007
    Zuletzt bearbeitet: 03.12.2007
    gropiuskalle

    gropiuskalle terra incognita

    Dabei seit:
    01.07.2006
    Beiträge:
    4.857
    Zustimmungen:
    0
    Ort:
    Berlin
    Genauer:

    Code:
    sax2 -r -m 0=nvidia
    Ansonsten würde ich das genau so machen, wie von Keruskerfürst vorgeschlagen (danach noch ein 'init 5', um auf die grafische Oberfläche zurückzugelangen), so klappt das bei immer sehr zuverlässig.

    Das ganze als root ausführen.

    Mit 'Auf die Textkonsole wechseln' ist hier der Wechsel per 'Alt + Strg + F1' gemeint (z.B. im Anmeldedialog).
     
  6. #5 Kayne607, 03.12.2007
    Zuletzt bearbeitet: 03.12.2007
    Kayne607

    Kayne607 Grünschnabel

    Dabei seit:
    03.12.2007
    Beiträge:
    6
    Zustimmungen:
    0
    Vielen Dank für den Hinweis. Ich möchte mich entschuldigen dass ich dies nicht beachtet habe (Multiposting) . Ich bin aber wirklich am verzweifeln.

    Ich habe bereits das Troubleshooting Kapitel abgearbeitet: Immer der gleiche Fehler!



    Auch steht, nachdem ich den Treiber installiert habe direkt danach (ohne Neustart) in SAX2 wechsle und die Konfiguration Teste, in der log Datei Xorg.99.log ganz am Ende etwas dass ein Monitor erkannt wurde aber keine brauchbare Konfiguration aufweist.

    Vielen Dank!

    Kayne607

    P.S.:
    Multipost Hinweis:
    Ich habe den Beitrag bei folgenden Foren aufgrund meiner wachsenden Verzweiflung, gepostet:

    http://www.linux-club.de/ftopic88813.html
    http://www.linux-forum.de/wieder-ma...schleunigung-bzw-treiber-10147.html#post29340
    http://www.unixboard.de/vb3/showthread.php?p=268895#post268895
    .
    .
    .
    EDIT (autom. Beitragszusammenführung) :
    .

    Das ist die genaue Meldung (Fehler).

    (EE) Screen(s) found, but none have a usable configuration.


    Mit Zitat antworten
    Bin jetz echt am verzweifeln. Habe insgesamt ca. 10 Stunden in Google gesucht und 8 Stunden am PC probiert. Nichts hilft.

    Antworten gibt es zum Thema logisch 1000, aber was soll ich tun wenn nix hilft.
     
  7. #6 Keruskerfürst, 03.12.2007
    Keruskerfürst

    Keruskerfürst Kaiser

    Dabei seit:
    12.02.2006
    Beiträge:
    1.366
    Zustimmungen:
    0
    Poste mal das ganze /var/log/xorg.0.log.
     
  8. #7 Kayne607, 04.12.2007
    Kayne607

    Kayne607 Grünschnabel

    Dabei seit:
    03.12.2007
    Beiträge:
    6
    Zustimmungen:
    0
    Hallo,

    sorry hatte gestern Abend keine Zeit mehr was am Rechner zu machen.

    Habe heute früh in der x.org.99.log oder so den Eintrag, ganz am Ende,:

    (EE) Screen(s) found, but none have a usable configuration.
    Fatal Server Error: No screens found


    entdeckt.

    Habe das Troubleshooting wie im Wikibook beschrieben (Bildschirmerkennung) durchgespielt. Echt alle Möglichkeiten.

    Keine Lösung. Gleicher Fehler.

    Ich werd noch Wahnsinnig. Denke langsam dass ich auf ein anderes System umsteige.

    Vielleicht findet doch noch wer eine Lösung.


    Danke.


    Kayne607
     
  9. Mike1

    Mike1 Niederösterreicher

    Dabei seit:
    21.12.2006
    Beiträge:
    1.376
    Zustimmungen:
    0
    Ort:
    Österreich
    Poste doch mal die ganze /etc/X11/xorg.conf und /var/log/xorg.0.log, vielleicht weiß ja dann jemand weiter...

    Und wenn ich mal einfach nicht weiterkomm....einfach mal ne Runde relaxxen und dann nochmal versuchen....hat keinen Sinn 10h lang verzweifelt rumzuprobieren und dabei vielleicht noch was kaputt zu machen... ;)
     
  10. #9 2TAKTER, 04.12.2007
    2TAKTER

    2TAKTER Foren As

    Dabei seit:
    26.11.2007
    Beiträge:
    94
    Zustimmungen:
    0
    Ort:
    Würzburg (zugezogen)
    Bis dahin vollkommen richtig....

    Dann in der Datei /etc/X11/xorg.conf im Abschnitt Device
    die Option "Driver" auf "nvidia" stellen. Der Xserver hat auch bei mir da immernoch "nv" drin gehabt. Dies sind zwar auch nvidia-treiber, allerdings nur die offenen.
    Nun kannst du auch die Hardware-Beschleunigung aktivieren. Nvidia bringt da was mit, was sich NV-GLX schimpft. Viel habe ich damit noch nicht unternommen aber die Einrichtung ist recht einfach.

    Hier ein Auszug von http://de.opensuse.org/NV-GLX
    Code:
    Section "Device"
      ...
      Option       "AddARGBGLXVisuals" "true"
      Option       "AllowGLXWithComposite" "true"
      ...
    EndSection
    
    Section "Extensions"
      Option       "Composite" "on"
    EndSection
    Hast du alle Änderungen übernommen, kannst du mittels STRG+ALT+BACKSPACE den Xserver neu starten (im init3 natürlich nicht nötig da ja keiner läuft :think:).

    Übrigens, auch wenn du SuSE verwendest, http://wiki.ubuntuusers.de ist dennoch ne super referenz für Standardconfigs.
     
  11. #10 Kayne607, 05.12.2007
    Kayne607

    Kayne607 Grünschnabel

    Dabei seit:
    03.12.2007
    Beiträge:
    6
    Zustimmungen:
    0
    Hallo,

    ich habe gestern noch ewig rumprobiert und nichts hinbekommen.
    Ich denke dass ich irgendwas falsch mache. Irgendein falsch installierter Triber oder falscher Parameter oder so.

    Ich habe mir, bevor mich der Wahnsinn packt, nun die DVD "OpenSUSE 10.3 Vorkon" bestellt. Hier sind laut Autor die Treiber im Paket integriert und werden auch automatisch konfiguriert. Die 20 Euro sinds mir jetz mal wert um zu versuchen ob es so klappen wird. Bevor ich den Laptop zum Fenster rauswerf :-)

    Ich werde euch berichten obs hingehauen hat und wie das Software Paket sonst so ist.

    MfG


    Kayne607
     
  12. #11 Kayne607, 07.12.2007
    Kayne607

    Kayne607 Grünschnabel

    Dabei seit:
    03.12.2007
    Beiträge:
    6
    Zustimmungen:
    0
    Hallo,

    so die Version ist angekommen.

    Doch die nächste schreckensmeldung.

    Habe alles installiert. Wollte nun das erste mal starten.

    Dann kommen die ganzen Meldungen was alles gestartet wurde.

    Bei Punkt:

    ...trying to set up timer as ExtINT IRQ... works.

    bleibt das Notebook hängen.

    Langsam dreh ich echt durch. Was kann das nun wieder sein?


    MfG Kayne607
     
  13. #12 Kayne607, 11.12.2007
    Kayne607

    Kayne607 Grünschnabel

    Dabei seit:
    03.12.2007
    Beiträge:
    6
    Zustimmungen:
    0
    Hallo,

    super, das System läuft! Oh man war das ein Kampf!

    Also das mit dem Treiber von NVIDIA, welcher angeblich bei OpenSUSE Vorkon automatisch nach Neuanmeldung installiert wird, hat auch nicht geklappt. Nach der Abmeldung und Neuanmeldung hat sich gar nichts getan!

    Habe den Treiber daraufhin mittels der "One Klick" Methode installiert.
    Danach habe ich die Monitorerkennung ausgeschaltet (EDID oder so).

    Dann habe ich per Sax2 einen VESA Monitor der etwa gleichen Auflösung usw. wie der Notebookmonitor eingestellt.

    Dann noch NVIDIA GLX aktiviert.

    Dann ging erstmal wieder nichts. Also wieder der alte Fehler (wie ganz oben)

    Nun ja, nach Neustart kam der Fehler mit dem "IRQ....EPIC bla bla" oder so.

    Hab dann al Bootoption noepic eingetragen und schon ging alles. NVIDIA Bild beim Start. 3D unterstützung. Tolle Sache. Aber merkwürdiger Ablauf.

    Die OpenSUSE Vorkon DVD werd ich trotzdem behalten. Ist sehr viel Zusatzsoftware drauf welche ich mir sonst runterladen müsste. Und ein bisschen Spielerei muss schon sein.

    Ich bedanke mich für alle Antworten welche mir immer schnell gegeben wurden. Letztendlich denke ich haben diese die Lösung gebracht. Wenn ich auch noch nicht weis an was es nun letztlich gelegen hat. Aber es läuft.

    Danke nochmal,

    Kayne607
     
  14. #13 AgentD!, 19.01.2008
    Zuletzt bearbeitet: 19.01.2008
    AgentD!

    AgentD! TechnOverload

    Dabei seit:
    15.02.2004
    Beiträge:
    215
    Zustimmungen:
    0
    Ort:
    Köln
    Hallo,
    ich habe ein ähnliches Problem. Ich habe vor kurzem wieder Open SuSe10.3 auf meinem Desktoprechner installiert. Ich hatte vor 4 Jahren SuSe 9.3 gehabt. Jetzt will ich 3D aktivieren mit meiner NVidia Karte: 6800LE von Leadtek. Es ist eine 8x AGP. Ich habe soweit den Treiber installieren können. Hat auch gut geklappt. Jedoch bekomme ich die Meldung: 3D kann nicht aktiviert werden, da diese Grafikkarte kein 3D unterstützt. :think: Ich habe den neuesten Treiber von Nvidia geladen. Die Kernelsources installiert und alles nach Anleitungt installiert.
    Ich bekomme das einfach nicht hin und ich würde gerne den 3D Desktop nutzen :(
    Damals unter SuSe 9.0 und 9.3 hatte ich noch eine Nvidia 4200 oder so und da hat es wunderbar funktioiniert mit der 3D-Beschleunigung. Ich koinnte das damals problemlos installieren. Ist aber auch schon 4 Jahre her, sodaß ich fast alles wieder vergessen habe.

    Hat da jemand vielleicht eine Idee?

    Ich habe auch in der Xorg.conf (heisst die glaube ich) nachgeschaut und da steht auch nvidia als Treiber und nicht nv.
    Halt so wie es sein sollte.

    Ich hoffe jemand hat da ein paar Tips.

    Gruß

    D!
     
  15. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  16. #14 gropiuskalle, 20.01.2008
    gropiuskalle

    gropiuskalle terra incognita

    Dabei seit:
    01.07.2006
    Beiträge:
    4.857
    Zustimmungen:
    0
    Ort:
    Berlin
    Was Dir YaST oder sonstwer zu erzählen versucht, ist erstmal nicht weiter relevant - gerade SaX2 gibt die Option der 3D-Beschleunigung selbst nach richtiger Konfiguration häufig falsch an.

    Wirklich verläßlich ist die Ausgabe folgenden Befehls:

    Code:
    glxinfo | grep direct
    Würde der NVidia-Treiber bei Dir nicht laufen, würde der Start des X-Servers schon an der in Deiner Xorg.conf fixierten Option "nvidia" scheitern.
     
  17. #15 AgentD!, 20.01.2008
    Zuletzt bearbeitet: 20.01.2008
    AgentD!

    AgentD! TechnOverload

    Dabei seit:
    15.02.2004
    Beiträge:
    215
    Zustimmungen:
    0
    Ort:
    Köln
    Ok, ich werde es mal machen

    Danke erst mal

    Gruß

    D!
    .
    .
    .
    EDIT (autom. Beitragszusammenführung) :
    .

    die Ausgabe sagt:

    directrendering= yes

    mehr nicht
     
Thema:

OpenSUSE 10.3, 3D-Beschleunigung, NVIDIA Geforce 7600 Go, Problem mit Einrichtung

Die Seite wird geladen...

OpenSUSE 10.3, 3D-Beschleunigung, NVIDIA Geforce 7600 Go, Problem mit Einrichtung - Ähnliche Themen

  1. OpenSuse Conference vom 22. bis 26. Juni in Nürnberg

    OpenSuse Conference vom 22. bis 26. Juni in Nürnberg: Zum mittlerweile achten Mal findet die OpenSuse Conference statt. In diesem Jahr wird sie vom 22. bis 26. Juni in Nürnberg abgehalten. Der Call...
  2. OpenSuse Conference vom 22. bis 26. Juni in Nürnberg

    OpenSuse Conference vom 22. bis 26. Juni in Nürnberg: Zum mittlerweile achten Mal findet die OpenSuse Conference statt. In diesem Jahr wird sie vom 22. bis 26. Juni in Nürnberg abgehalten. Der Call...
  3. OpenSuse bietet aktuelles KDE mit LEAP oder Tumbleweed

    OpenSuse bietet aktuelles KDE mit LEAP oder Tumbleweed: OpenSuse bietet zwei neue Images an, die die neuesten KDE-Pakete aus den Git-Repositories enthalten. Die Images basieren auf den Varianten Leap...
  4. Opensuse 13.1 erreicht Evergreen-Phase

    Opensuse 13.1 erreicht Evergreen-Phase: Version 13.1 der Linux-Distribution Opensuse hat jetzt das Ende ihrer regulären Lebensdauer erreicht. Doch im Rahmen des Evergreen-Projektes wird...
  5. Opensuse Leap jetzt in öffentlichen Clouds verfügbar

    Opensuse Leap jetzt in öffentlichen Clouds verfügbar: In den öffentlichen Clouds von Amazon, Google und Microsoft stehen ab sofort virtuelle Maschinen mit Opensuse Leap 42.1 zur Verfügung. Weiterlesen...