NVIDIA Treiber und Ubuntu 8.04 = Problem

Dieses Thema im Forum "Debian/Ubuntu/Knoppix" wurde erstellt von w4ri0r, 18.07.2008.

  1. w4ri0r

    w4ri0r Jungspund

    Dabei seit:
    23.04.2008
    Beiträge:
    18
    Zustimmungen:
    0
    Hallo zusammen,

    also ich hab hier ein Notebook(Acer Aspire 5610) auf dem ich Ubuntu installiert habe, was vom USB-Stick auch ohne Probleme ging.

    Ich habe nach ein wenig Gefrickel bis auf die NVIDIA Treiber alles ans laufen bekommen.

    Der Quelloffene Treiber "nv" läuft eigentlich ohne Probleme.
    Aber auch da meckert der XServer, in dem Logfile "/var/log/gdm/:0.Log" steht das die Module "glx" und "dri2" nicht geladen werden können obwohl ich in der xorg.conf diese Module nicht geladen habe.

    Aber zu dem Eigentlichen Problem:
    Ich habe mir die Treiber von der NVIDIA Seite heruntergeladen. In der Version 96.43.07 vom 16.07.2008. Nachdem ich meinen Kernel von der Version 2.6.26-3-generic auf die Version 2.6.26-4-generic aktualisiert habe, läuft die Installation auch durch.

    nach einem "make oldconfig" in /usr/src/linux-headers-2.6.26-4-generic" wurden nach einem Neustart auch die entsprechenden Module geladen:

    lsmod | grep nv:
    Code:
    nvidia               4716560  0
    i2c_core               30228  1 nvidia
    agpgart                40392  2 nvidia,intel_agp
    
    Nach der Installation, habe ich dann ein "nvidia-xconfig" ausgeführt.
    Wenn ich dann den xserver starte, erkennt er meine Grafikkarte nicht und startet gnome dann in so einem "low-grafics" Mode, was nicht so das wahre ist.

    Was mich auch ein wenig verwundert ist, das der Treiber nie in der Liste der "restricted-drivers" auftaucht.

    Das Packet "linux-restricted-modules" für meinen Kernel habe ich natürlich auch installiert.

    Hat da einer von eucht evtl. noch eine Idee, ich sehe den Wald vor lauter Bäumen nicht mehr.


    Die xorg.conf:
    Code:
    # nvidia-xconfig: X configuration file generated by nvidia-xconfig
    # nvidia-xconfig:  version 1.0  (buildmeister@builder57)  Wed Jul  2 12:30:48 PDT 2008
    
    # xorg.conf (X.Org X Window System server configuration file)
    #
    # This file was generated by dexconf, the Debian X Configuration tool, using
    # values from the debconf database.
    #
    # Edit this file with caution, and see the xorg.conf manual page.
    # (Type "man xorg.conf" at the shell prompt.)
    #
    # This file is automatically updated on xserver-xorg package upgrades *only*
    # if it has not been modified since the last upgrade of the xserver-xorg
    # package.
    #
    # If you have edited this file but would like it to be automatically updated
    # again, run the following command:
    #   sudo dpkg-reconfigure -phigh xserver-xorg
    
    Section "ServerLayout"
        Identifier     "Default Layout"
        Screen         "Default Screen" 0 0
        InputDevice    "Generic Keyboard" "CoreKeyboard"
        InputDevice    "Configured Mouse"
    EndSection
    
    Section "Module"
        Load           "glx"
    EndSection
    
    Section "InputDevice"
        Identifier     "Generic Keyboard"
        Driver         "kbd"
        Option         "XkbRules" "xorg"
        Option         "XkbModel" "pc105"
        Option         "XkbLayout" "de"
        Option         "XkbVariant" "nodeadkeys"
        Option         "XkbOptions" "lv3:ralt_switch"
    EndSection
    
    Section "InputDevice"
        Identifier     "Configured Mouse"
        Driver         "mouse"
        Option         "CorePointer"
    EndSection
    
    Section "Monitor"
        Identifier     "Configured Monitor"
    EndSection
    
    Section "Device"
        Identifier     "Configured Video Device"
        Driver         "nvidia"
    EndSection
    
    Section "Screen"
        Identifier     "Default Screen"
        Device         "Configured Video Device"
        Monitor        "Configured Monitor"
        SubSection     "Display"
            Modes      "nvidia-auto-select"
        EndSubSection
    EndSection
    
    die :0.Log:
    Code:
    This is a pre-release version of the X server from The X.Org Foundation.
    It is not supported in any way.
    Bugs may be filed in the bugzilla at http://bugs.freedesktop.org/.
    Select the "xorg" product for bugs you find in this release.
    Before reporting bugs in pre-release versions please check the
    latest version in the X.Org Foundation git repository.
    See http://wiki.x.org/wiki/GitPage for git access instructions.
    
    X.Org X Server 1.4.99.905 (1.5.0 RC 5)
    Release Date: 5 September 2007
    X Protocol Version 11, Revision 0
    Build Operating System: Linux Ubuntu (xorg-server 2:1.4.99.905-0ubuntu4)
    Current Operating System: Linux Laptop 2.6.26-4-generic #1 SMP Mon Jul 14 18:39:53 UTC 2008 i686
    Build Date: 16 July 2008  03:37:29PM
     
    	Before reporting problems, check http://wiki.x.org
    	to make sure that you have the latest version.
    Module Loader present
    Markers: (--) probed, (**) from config file, (==) default setting,
    	(++) from command line, (!!) notice, (II) informational,
    	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    (==) Log file: "/var/log/Xorg.0.log", Time: Fri Jul 18 09:43:41 2008
    (==) Using config file: "/etc/X11/xorg.conf"
    (EE) module ABI major version (0) doesn't match the server's version (1)
    (EE) Failed to load module "glx" (module requirement mismatch, 0)
    (EE) Failed to load module "dri2" (module does not exist, 0)
    The XKEYBOARD keymap compiler (xkbcomp) reports:
    > Warning:          Type "ONE_LEVEL" has 1 levels, but <RALT> has 2 symbols
    >                   Ignoring extra symbols
    Errors from xkbcomp are not fatal to the X server
    
    ls -la "/usr/lib/xorg/modules/drivers/"
    Code:
    drwxr-xr-x 2 root root    1616 2008-07-18 08:51 .
    drwxr-xr-x 8 root root     744 2008-07-17 22:27 ..
    -rw-r--r-- 1 root root  130600 2008-07-08 00:47 apm_drv.so
    -rw-r--r-- 1 root root   22392 2008-07-08 00:49 ark_drv.so
    -rw-r--r-- 1 root root    5480 2008-07-08 01:22 ati_drv.so
    -rw-r--r-- 1 root root    9640 2008-07-09 14:42 ch7017.so
    -rw-r--r-- 1 root root    5596 2008-07-09 14:42 ch7xxx.so
    -rw-r--r-- 1 root root  146928 2008-07-08 00:50 chips_drv.so
    -rw-r--r-- 1 root root   38884 2008-07-08 00:51 cirrus_alpine.so
    -rw-r--r-- 1 root root   14152 2008-07-08 00:51 cirrus_drv.so
    -rw-r--r-- 1 root root   31012 2008-07-08 00:51 cirrus_laguna.so
    -rw-r--r-- 1 root root   14048 2008-07-08 00:53 dummy_drv.so
    -rw-r--r-- 1 root root   22540 2008-07-08 00:58 fbdev_drv.so
    -rw-r--r-- 1 root root  275868 2008-07-08 12:37 geode_drv.so
    -rw-r--r-- 1 root root  288376 2008-07-08 01:02 glint_drv.so
    -rw-r--r-- 1 root root   59484 2008-07-08 00:53 i128_drv.so
    -rw-r--r-- 1 root root   48044 2008-07-08 01:01 i740_drv.so
    lrwxrwxrwx 1 root root      12 2008-07-17 20:40 i810_drv.so -> intel_drv.so
    -rw-r--r-- 1 root root  360728 2008-07-09 14:42 intel_drv.so
    -rw-r--r-- 1 root root    9604 2008-07-09 14:42 ivch.so
    -rw-r--r-- 1 root root   10332 2007-09-07 23:54 libmm.so
    -rw-r--r-- 1 root root  197056 2008-07-08 01:06 mach64_drv.so
    -rw-r--r-- 1 root root  172168 2008-07-08 01:05 mga_drv.so
    -rw-r--r-- 1 root root   73652 2008-07-08 00:55 neomagic_drv.so
    -rw-r--r-- 1 root root  274272 2008-07-08 01:05 nsc_drv.so
    -rw-r--r-- 1 root root  161620 2008-07-08 06:08 nv_drv.so
    -rwxr-xr-x 1 root root 1294600 2008-07-18 08:51 nvidia_drv.so
    -rw-r--r-- 1 root root  319448 2008-07-08 01:22 openchrome_drv.so
    -rw-r--r-- 1 root root   79300 2007-09-07 23:54 psb_drv.so
    -rw-r--r-- 1 root root  102312 2008-07-08 01:09 r128_drv.so
    -rw-r--r-- 1 root root  548340 2008-07-08 01:22 radeon_drv.so
    -rw-r--r-- 1 root root  250960 2008-07-08 01:10 radeonhd_drv.so
    -rw-r--r-- 1 root root   38944 2008-07-08 01:09 rendition_drv.so
    -rw-r--r-- 1 root root   56252 2008-07-08 01:11 s3_drv.so
    -rw-r--r-- 1 root root   72596 2008-07-08 01:12 s3virge_drv.so
    -rw-r--r-- 1 root root  139464 2008-07-08 01:13 savage_drv.so
    -rw-r--r-- 1 root root    5512 2008-07-09 14:42 sil164.so
    -rw-r--r-- 1 root root   93876 2008-07-08 00:55 siliconmotion_drv.so
    -rw-r--r-- 1 root root  593744 2008-07-08 01:16 sis_drv.so
    -rw-r--r-- 1 root root   76020 2008-07-08 01:15 sisusb_drv.so
    -rw-r--r-- 1 root root   68820 2008-07-08 01:15 tdfx_drv.so
    -rw-r--r-- 1 root root    9608 2008-07-09 14:42 tfp410.so
    -rw-r--r-- 1 root root   51548 2008-07-08 01:42 tga_drv.so
    -rw-r--r-- 1 root root  161244 2008-07-08 01:17 trident_drv.so
    -rw-r--r-- 1 root root   51220 2008-07-08 01:17 tseng_drv.so
    -rw-r--r-- 1 root root   18044 2008-07-08 01:24 v4l_drv.so
    -rw-r--r-- 1 root root   22316 2008-07-08 08:47 vesa_drv.so
    -rw-r--r-- 1 root root   22404 2008-07-08 01:19 vga_drv.so
    -rw-r--r-- 1 root root   47524 2008-07-08 01:19 vmware_drv.so
    -rw-r--r-- 1 root root   26452 2008-07-08 01:19 voodoo_drv.so
    -rw-r--r-- 1 root root   26780 2008-07-08 12:37 ztv_drv.so
    
    ls -la "/usr/lib/xorg/modules/extensions"
    Code:
    drwxr-xr-x 2 root root    248 2008-07-18 08:51 .
    drwxr-xr-x 8 root root    744 2008-07-17 22:27 ..
    -rw-r--r-- 1 root root  17876 2008-07-16 17:52 libdbe.so
    -rw-r--r-- 1 root root  34396 2008-07-16 17:52 libdri.so
    -rw-r--r-- 1 root root 129520 2008-07-16 17:52 libextmod.so
    lrwxrwxrwx 1 root root     18 2008-07-18 08:51 libglx.so -> libglx.so.96.43.07
    -rwxr-xr-x 1 root root 676012 2008-07-18 08:51 libglx.so.96.43.07
    -rw-r--r-- 1 root root  36436 2008-07-16 17:52 libxtrap.so
    
    
    Im übrigen kann ich die Treiber nicht über Synaptic oder mit hilfe von apt-get installieren, er stürzt dabei immer ab. Auch wenn ich "nvidia-installer --update" ausführe lädt er zwar einen anderen Treiber herunter aber bei dem erstellen der Kernelmodule stürzt er ab.

    ich hoffe einer von euch hat da eine Idee :-)

    OS: Ubuntu 8.04 x86
    Kernel: 2.6.26-4-generic
    Grafikkarte: GeForce GO 7300 128MB
    GCC: v.4.3.1

    Falls Ihr sonst noch irgendwelche Informationen braucht, gebe ich sie euch natürlich gerne ;-)

    Greetz

    w4ri0r
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. foexle

    foexle Kaiser

    Dabei seit:
    02.05.2007
    Beiträge:
    1.104
    Zustimmungen:
    0
    Ort:
    Saarbrücken
    hi,
    also ich hatte auch nen Aspire mit nem GeForce GO 5300 drin
    das Problem bei Acer ist, das die eigene Chipsätze da einbauen.
    Also bei mir liefen fast keine Treiber, ausser die, die auf der Acer Page angeboten wurden.
    Ausserdem ist es ratsam nicht den nv sondern den nvidia treiber zu nehmen.
    nv treiber ist sehr alt und bin mir nicht einmal sicher, ob der überhaupt glx unterstützung hat, müsste ich mal nachlesen :>

    aber ich sehe in deiner xorg.conf hast du den nvidia treiber inst.

    Ich denke das ist zurückzuführen auf die besch*** treiber politik von acer. Da wirst du noch einiges zu knabbern haben, das betrifft nicht nur die Grafikchips !
    Einfach Support anschreiben das die dir einen Treiber empfehlen sollen, der läuft, anders wirst du nur rumprobieren.
    Zumindest war es bei mir so, evtl hat sich das ja gebessert, aber was du hier schilderst, hört sich schwer danach an.
     
  4. towo

    towo Haudegen

    Dabei seit:
    16.05.2003
    Beiträge:
    649
    Zustimmungen:
    1
    Ort:
    Pößneck
    Nur mal so als Info, kein Nvidia-Treiber unterstützt zur Zeit Xserver-Xorg 1.5.0!
    Wieso installierst Du dir auch solch ein Prerelease?
     
  5. #4 Goodspeed, 18.07.2008
    Goodspeed

    Goodspeed Foren Gott
    Moderator

    Dabei seit:
    21.04.2004
    Beiträge:
    4.165
    Zustimmungen:
    1
    Ort:
    Dresden
    Was ist denn das für ein komischer Treiber? Auf der Nvidia-Seite springt mich Version 173.14.05 an ...

    @towo: Wer sagt, dass der aktuelle nicht mit 1.5 kann?
     
  6. #5 Wolfgang, 18.07.2008
    Wolfgang

    Wolfgang Foren Gott

    Dabei seit:
    24.04.2005
    Beiträge:
    3.978
    Zustimmungen:
    0
    Ort:
    Erfurt
    Der 96-er ist für ältere Grafikkarten GF4 und älter.
     
  7. #6 w4ri0r, 18.07.2008
    Zuletzt bearbeitet: 18.07.2008
    w4ri0r

    w4ri0r Jungspund

    Dabei seit:
    23.04.2008
    Beiträge:
    18
    Zustimmungen:
    0
    Danke erstmal für die Antworten.

    Also der Treiber springt mich auf der Nvidia Seite an^^
    http://www.nvidia.de/object/linux_display_archive_de.html
    (Wenn ich den Link mal so Posten darf?)

    @ Wolfgang: Naja ich kenn mich mit den NVIDIA Treibern nicht so aus,
    ich favorisiere normalerweise eher die ATI Fraktion.

    Der schien mir recht aktuell zu sein^^
    OK, naja aber ich habe dann "nvidia-installer --update" ausgeführt und dann hat der den 173er heruntergeladen, aber er ist bei der Installation abgestürzt.

    Ich hab ein dist-upgrade gemacht und dabei hat er den XServer auf den neuesten Stand gebracht. Ich muss mal meine Sourcelist überprüfen, ich denke da werden noch ein paar Einträge drinnen stehen, denen ich das zu verdanken habe.

    Aber ich habe auch noch nichts davon gehört, das die NVIDIA Treiber inkompatibel zu dem 1.5.0er sein sollen.

    Aber habt Ihr denn eine Idee woran das liegen könnte das der Treiber
    nicht in der Liste der proprietären Treiber steht?

    Greetz

    w4ri0r
     
  8. #7 supersucker, 18.07.2008
    supersucker

    supersucker Foren Gott

    Dabei seit:
    21.02.2005
    Beiträge:
    3.873
    Zustimmungen:
    0
    Naja,

    wir hatten ja schon festgestellt, das das hier

    nicht gut ist.

    Das hier

    ist allerdings sehr merkwürdig.

    Poste mal

    Code:
    hwinfo --gfxcard
     
  9. w4ri0r

    w4ri0r Jungspund

    Dabei seit:
    23.04.2008
    Beiträge:
    18
    Zustimmungen:
    0
    Der Output von hwinfo --gfxcard

    Code:
    15: PCI 100.0: 0300 VGA compatible controller (VGA)             
      [Created at pci.310]
      UDI: /org/freedesktop/Hal/devices/pci_10de_1d7
      Unique ID: VCu0.RcF5D7jda81
      Parent ID: vSkL.rxAOeWuq8i6
      SysFS ID: /devices/pci0000:00/0000:00:01.0/0000:01:00.0
      SysFS BusID: 0000:01:00.0
      Hardware Class: graphics card
      Model: "nVidia Quadro NVS 110M/GeForce Go 7300"
      Vendor: pci 0x10de "nVidia Corporation"
      Device: pci 0x01d7 "Quadro NVS 110M/GeForce Go 7300"
      SubVendor: pci 0x1025 "Acer Incorporated [ALI]"
      SubDevice: pci 0x0090 
      Revision: 0xa1
      Driver: "nvidia"
      Driver Modules: "nvidia"
      Memory Range: 0xd1000000-0xd1ffffff (rw,non-prefetchable)
      Memory Range: 0xc0000000-0xcfffffff (rw,prefetchable)
      Memory Range: 0xd0000000-0xd0ffffff (rw,non-prefetchable)
      IRQ: 16 (1 event)
      I/O Ports: 0x3c0-0x3df (rw)
      Module Alias: "pci:v000010DEd000001D7sv00001025sd00000090bc03sc00i00"
      Driver Info #0:
        XFree86 v4 Server Module: nv
      Driver Info #1:
        XFree86 v4 Server Module: nvidia
        3D Support: yes
      Config Status: cfg=new, avail=yes, need=no, active=unknown
      Attached to: #30 (PCI bridge)
    
    Primary display adapter: #15
    
    
    dann muss ich jetzt wohl nen downgrade des xorg machen.

    Greetz

    w4ri0r
     
  10. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  11. w4ri0r

    w4ri0r Jungspund

    Dabei seit:
    23.04.2008
    Beiträge:
    18
    Zustimmungen:
    0
    Guten morgen zusammen.

    also ich hab mich mal dran gemacht und versucht den 173er Treiber zu installieren.
    Erstmal hat der wegen meinem Compiler gemeckert, da dieser anscheinend nicht in der selben Version ist wie der mit dem der Kernel kompiliert wurde.

    Dann bin ich darauf gestoßen, das man diese Überprüfung umgehen kann - ich weiß das ist nicht gut und man sollte es eigentlich nicht machen.

    Wenn ich die Überprüfung umgehe komme ich genau einen Schritt weiter, dann stürzt die Installationsroutine wieder ab.

    Hier mal ein Auszug des Logfiles:
    Code:
    nvidia-installer log file '/var/log/nvidia-installer.log'
    creation time: Sat Jul 19 11:35:14 2008
    
    option status:
      license pre-accepted    : false
      update                  : false
      force update            : false
      expert                  : false
      uninstall               : false
      driver info             : false
      no precompiled interface: false
      no ncurses color        : false
      query latest driver ver : false
      OpenGL header files     : false
      no questions            : false
      silent                  : false
      XFree86 install prefix  : /usr/X11R6
      OpenGL install prefix   : /usr
      Installer install prefix: /usr
      kernel include path     : (not specified)
      kernel install path     : (not specified)
      proc mount point        : /proc
      ui                      : (not specified)
      tmpdir                  : /tmp
      ftp site                : ftp://download.nvidia.com
    
    Using: nvidia-installer ncurses user interface
    -> License accepted.
    -> No precompiled kernel interface was found to match your kernel; would you li
       ke the installer to attempt to download a kernel interface for your kernel f
       rom the NVIDIA ftp site (ftp://download.nvidia.com)? (Answer: Yes)
    -> No matching precompiled kernel interface was found on the NVIDIA ftp site;
       this means that the installer will need to compile a kernel interface for
       your kernel.
    -> Kernel include path: '/lib/modules/2.6.26-4-generic/build/include'
    -> Cleaning kernel module build directory.
       executing: 'cd ./usr/src/nv; make clean'...
       rm -f nv.o os-agp.o os-interface.o os-registry.o  nv-linux.o nv_compiler.h *
       .d NVdriver nvidia.o
    -> Building kernel module:
       executing: 'cd ./usr/src/nv; make nvidia.o SYSINCLUDE=/lib/modules/2.6.26-4-
       generic/build/include'...
       echo \#define NV_COMPILER \"`cc -v 2>&1 | tail -n 1`\" > nv_compiler.h
       cc -c -Wall -Wimplicit -Wreturn-type -Wswitch -Wformat -Wchar-subscripts -Wp
       arentheses -Wpointer-arith -Wcast-qual -Wno-multichar  -O -MD -D__KERNEL__ -
       DMODULE -D_LOOSE_KERNEL_NAMES -DNTRM -D_GNU_SOURCE -D_LOOSE_KERNEL_NAMES -D_
       _KERNEL__ -DMODULE  -DNV_MAJOR_VERSION=1 -DNV_MINOR_VERSION=0 -DNV_PATCHLEVE
       L=4496  -DNV_UNIX   -DNV_LINUX   -DNV_INT64_OK   -DNVCPU_X86       -I. -I/li
       b/modules/2.6.26-4-generic/build/include -Wno-cast-qual nv.c
       In file included from /lib/modules/2.6.26-4-generic/build/include/linux/pref
       etch.h:14,
                        from /lib/modules/2.6.26-4-generic/build/include/linux/list
       .h:6,
                        from /lib/modules/2.6.26-4-generic/build/include/linux/modu
       le.h:9,
                        from nv-linux.h:28,
                        from nv.c:14:
       /lib/modules/2.6.26-4-generic/build/include/asm/processor.h:112: error: ‘C
       ONFIG_X86_L1_CACHE_SHIFT’ undeclared here (not in a function)
       /lib/modules/2.6.26-4-generic/build/include/asm/processor.h:112: error: requ
       ested alignment is not a constant
       In file included from /lib/modules/2.6.26-4-generic/build/include/linux/pref
       etch.h:14,
    
    Ich wollte nicht das ganze File posten da es doch ziemlich lang ist.
    Falls bedarf besteht kann ich auch noch mehr posten.

    Die Frage ist jetzt, kommten die Fehler von der anderen GCC Version oder fehlt mir da wieder irgendetwas.

    Greetz

    w4ri0r
     
  12. w4ri0r

    w4ri0r Jungspund

    Dabei seit:
    23.04.2008
    Beiträge:
    18
    Zustimmungen:
    0
    [gelöst] NVIDIA Treiber und Ubuntu 8.04 = Problem

    Also,

    ich hab hier keine Antworten mehr bekommen, da sich normale Menschen auch mal ein Wochenende gönnen. Aber mich hat der Ehrgeiz gepackt^^

    Ich habe den NVIDIA Treiber auch mit der "Xserver-Xorg 1.5.0" Version ans laufen bekommen, es hat mich zwar einigen Gehirnschmalz gekostet und ich habe jetzt Rückenschmerzen vom krummen sitzen aber es lüppt.

    Da der 96er Treiber, der sich "ohne Probleme" installieren ließ, ja nicht für meine Graka geeignet ist musste ich mir den 173er besorgen. Der sich aber überhaupt nicht kompilieren ließ.

    Nach dem Versuch meinen Xserver einem Downgrade zu unterziehen, hatte ich keine GUI mehr. Was ich nicht so gut fand, die ältere Version des Xorg ließ sich nicht installieren da die Abhängigkeiten nicht aufgelöst werden konnten - weiß der Teufel warum. Also blieb mir nichts anderes übrig als das Pre-Release wieder zu installieren.

    Dann ging das ganze Spiel wieder von vorne los.
    Mir war aber aufgefallen, das sich die Installationsroutine des NVIDIA-Treibers Daten von einem Server holt, diesen habe ich mir dann mal etwas genauer angeguckt. Dort habe ich noch eine andere Treiberversion gefunden.
    Von der Downloadseite bekommt man folgende Version angeboten "NVIDIA-Linux-x86-173.14.05-pkg1.run" auf dem FTP-Server konnte man aber auch diese Version herunterladen: "NVIDIA-Linux-x86-173.14.05-pkg0.run".
    Die Version ist zwar geschlagene 8MB kleiner, aber was hab ich zu verlieren.

    Auf Anhieb ließ sich diese Version natürlich auch nicht installieren. Die Anzahl der Fehlermeldungen in der Log-Datei war jedoch deutlich geringer. Dann hab ich die Datei entpacken lassen und die 2 Fehler in der Quellcode Datei von Hand behoben.
    Daraufhin ließ sich der Treiber auch anstandslos kompilieren.

    Danach noch kurz "modprobe nvidia" und schon war das Modul geladen.

    Beim booten war mir dann noch ein Fehler aufgefallen, die restricted Treiber konnten nicht initialisiert werden da das Verzeichnis "/lib/modules/2.6.26-4-generic/volation" nicht existierte. Das Verzeichnis habe ich dann kurzerhand erstellt. Beim nächsten Start des Rechners konnte ich dann auch das schöne NVIDIA-Logo sehen.

    Compiz-fusion läuft jetzt auch ohne Probleme.

    Ich danke euch für eure Hilfe.

    Greetz

    w4ri0r
     
Thema:

NVIDIA Treiber und Ubuntu 8.04 = Problem

Die Seite wird geladen...

NVIDIA Treiber und Ubuntu 8.04 = Problem - Ähnliche Themen

  1. Grafiktreiber von Nvidia und AMD mit Vulkan-Unterstützung

    Grafiktreiber von Nvidia und AMD mit Vulkan-Unterstützung: Nvidia und AMD haben Betaversionen ihrer Linux-Grafiktreiber herausgegeben, die erstmals die neue 3D-Schnittstelle Vulkan unterstützen. Aber auch...
  2. Grafiktreiber von Nvidia und AMD mit Vulkan-Unterstützung

    Grafiktreiber von Nvidia und AMD mit Vulkan-Unterstützung: Nvidia und AMD haben Betaversionen ihrer Linux-Grafiktreiber herausgegeben, die erstmals die neue 3D-Schnittstelle Vulkan unterstützen. Aber auch...
  3. Nvidia aktualisiert Vulkan-Treiber

    Nvidia aktualisiert Vulkan-Treiber: Eine Woche nach der Freigabe der ersten Version von Vulkan hat der US-amerikanische Hersteller Nvidia seine Treiber einem Update unterzogen. Auch...
  4. Nvidia aktualisiert Legacy-Treiber

    Nvidia aktualisiert Legacy-Treiber: Nvidia hat im Laufe der letzten Woche aktualisierte Versionen der Legacy-Treiber für die Chipsätze der GeForce-Familie 6, 7, 8 und 9...
  5. Treiberaktualisierung bei Nvidia-Grafikkarten

    Treiberaktualisierung bei Nvidia-Grafikkarten: Nvidia hat Version 352.41 seines proprietären Grafiktreibers herausgegeben. In erster Linie fügt der Treiber Unterstützung für neue Grafikchips...