Mandriva Linux 2007 ATI 8.33.6 Treiber mit ATI X1950 Pro Agp

Dieses Thema im Forum "Mandriva" wurde erstellt von truthy, 21.01.2007.

  1. #1 truthy, 21.01.2007
    Zuletzt bearbeitet: 21.01.2007
    truthy

    truthy Mitglied

    Dabei seit:
    21.01.2007
    Beiträge:
    35
    Zustimmungen:
    0
    Hallo Leute, bin hier Newbie und hoffe ihr könnt mir helfen.

    Ich habe vor kurzem versucht meine neue Grafikkarte Sapphire Radeon X1950 Pro 512MB AGP unter Mandriva Linux 2007 zum laufen zu bringen.

    Die Auswahl von Generischen Treibern schlug bisher immer fehl (bis auf vesa)- also hab ich mir die neueste version runtergeladen (8.3.6) und diese automatisch installieren lassen ...

    Nachdem dann endlich wieder der xserver lief stellte ich fest dass der treiber nicht wirklich richtig installiert ist und die karte weder erkannt noch 3d fähig war.
    Deswegen wollte ich das ganze noch einmal neu installieren. Hab aus der *.run-datei mit buildpkg 3 rpms für mandriva 2007 erstellt
    (die alten versionen deinstalliert) und die neuen installiert.
    soweit so gut - die installation war erfolgreich. Als ich dann allerdings in XFdrake auf Radeon (fglrx) umgestellte bekam ich nur einen schwarzen Schirm nach dem starten des xservers ... aber keine fehlermeldung

    folgende pakete sind bei mir für ati installiert:
    ati-kernel-2.6.17-5mdv-8.28.8-1mdk (eine neueren hab ich nicht gefunden)
    atieventsd-8.33.6-1mdv2007.0
    dkms-ati-8.33.6-1mdv2007.0
    ati-8.33.6-1mdv2007.0
    als X.org version 7.1.0

    Ich werde meine funktionierende "2d" xorg.conf und die nicht funktionierende xorg.conf.false als auch die Xorg.0.log anhängen.

    Falls jemand mir irgendwie helfen kann, bitte melden!

    lg
    truthy
     

    Anhänge:

  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 slash-ex, 21.01.2007
    slash-ex

    slash-ex Doppel-As

    Dabei seit:
    04.10.2006
    Beiträge:
    130
    Zustimmungen:
    0
    du darfst kein composite aktiv haben bei ati und dir fehlt die dri section in der xorg.conf

    zudem würde ich mal durch ein lsmod gucken ob der treiber geladen wurde.
     
  4. truthy

    truthy Mitglied

    Dabei seit:
    21.01.2007
    Beiträge:
    35
    Zustimmungen:
    0
    also es geht hier mehr um die xorg.conf.false - dass ist die conf wenn ich über XFdrake Radeon (fglrx) auwähle (und bei der dann meines wissens der ati-treiber geladen werden sollte) und bei der ist Composite nicht aktiv. Bei der xorg.conf schon, da ich wenn ich es ausschalte grafikfehler bekomme ...

    wenn ich lsmod in der konsole eingebe erhalte ich u.a. dieses ergebnis
    (allerdings mit der xorg.conf "2D")
    video size 12934 used by 0
    agpgart size 27240 used by 2 fglrx, intel_agp

    Welche Einträge ich in der xorg.conf.false (nicht die xorg.conf "2d") dri section schreiben soll weiss ich wirklich nicht - bitte genauer beschreiben.
     
  5. #4 truthy, 21.01.2007
    Zuletzt bearbeitet: 21.01.2007
    truthy

    truthy Mitglied

    Dabei seit:
    21.01.2007
    Beiträge:
    35
    Zustimmungen:
    0
    Aktuelle xorg.conf und xorg.0.log

    Also hier noch einmal die xorg.conf und Xorg.0.log
    nachdem ich in XFdrake auf Ati Radeon (fglrx) umgestellt und neu gestartet habe

    ... bei der konfiguration bekomm ich einen schwarzen schirm

    die xorg.conf = xorg.conf.false von vorher (die 1. xorg.conf ist meine jetzige Einstellung - dachte nur es würde etwas helfen zum Vergleich eine funktionierende zu posten ...)
    und die Xorg.0.log = sollte diesmal die richtig zugehörige zur xorg.conf sein
     

    Anhänge:

  6. #5 slash-ex, 21.01.2007
    slash-ex

    slash-ex Doppel-As

    Dabei seit:
    04.10.2006
    Beiträge:
    130
    Zustimmungen:
    0
    habe ich dir nicht was zum thema lsmod geschrieben? oder wie soll ich das verstehen. fkt. bei dir nun 3d oder nicht?
     
  7. #6 truthy, 21.01.2007
    Zuletzt bearbeitet: 21.01.2007
    truthy

    truthy Mitglied

    Dabei seit:
    21.01.2007
    Beiträge:
    35
    Zustimmungen:
    0
    Also 3D geht bei mir NICHT - sorry für die verwirrung :rolleyes:

    ich hab keine ahnung von lsmod. deswegen hab ichs einfach in die console eingegeben (wie ich weiter oben bereits geschrieben habe) und die 2 lines rausgeschrieben wo ich glaube dass si etwas mit grafik zu tun haben:

    video size 12934 used by 0
    agpgart size 27240 used by 2 fglrx, intel_agp

    falls man zum thema lsmod irgendwas anderes machen muss bitte link schicken oder mitteilen!

    was vielleicht noch ganz wichtig ist, die beiden haben genau dasselbe problem wie ich: http://www.unixboard.de/vb3/showthread.php?p=203662#post203662

    Meine graka (X1950 Pro AGP) hat 2x DVI und keinen analog Ausgang - ich verwende allerdings einen adapter von dvi auf analog weil mein tft nur analog kann. (vielleicht ist das irgendwie wichtig)

    hab mein problem auch bereits der ATI Linux Crew Driver Feedback Program Crew mitgeteilt.

    Da ich ja einen analogen TFT von Gericom habe der eigentlich nur 60hz kann, wollte ich fragen ob bei mir in der xorg.conf die frequenzen richtig eingestellt sind - wär auch ein grund für nen schwarzen schirm
     
  8. #7 slash-ex, 21.01.2007
    slash-ex

    slash-ex Doppel-As

    Dabei seit:
    04.10.2006
    Beiträge:
    130
    Zustimmungen:
    0
    deine xorg.conf hat 2 mal ne monitor section. aber ansonsten gehe ich mal davon aus das das modul geladen wurde...(hättest einfach den output von lsmod posten sollen^^)
    und deine config sieht auch ansonsten korrekt aus. mehr als ein load "dri" und ein fglrx braucht man eigentlich nicht?!

    evtl solltest du die ganzen options deaktivieren. ich habe jetzt leider keine ati karte mehr. somit kann ich hier wenig pobieren.
     
  9. #8 truthy, 22.01.2007
    Zuletzt bearbeitet: 22.01.2007
    truthy

    truthy Mitglied

    Dabei seit:
    21.01.2007
    Beiträge:
    35
    Zustimmungen:
    0
    ... naja alle änderungen in der xorg.conf haben zu keiner veränderung geführt (dri etc.) - immer noch 2d.

    wenn ich über XFdrake auf Radeon (fglrx) umstelle immer noch schwarzer schirm.

    so ... hab jetzt alles aus der xorg.conf rausgelöscht was mir spanisch vorkam.
    anbei noch ein screenshot von der hardwaresektion des kontrollzentrums
    und der output von lsmod.

    und fglrxinfo ergibt bei mir folgendes:
    X Error of failed request: GLXBadContext
    Major opcode of failed request: 144 (GLX)
    Minor opcode of failed request: 5 (X_GLXMakeCurrent)
    Serial number of failed request: 15
    Current serial number in output stream: 15

    Vielleicht fällt dir ja noch was ein - wär super. :hilfe2:
     

    Anhänge:

  10. #9 truthy, 22.01.2007
    Zuletzt bearbeitet: 22.01.2007
    truthy

    truthy Mitglied

    Dabei seit:
    21.01.2007
    Beiträge:
    35
    Zustimmungen:
    0
    hier noch ein letztes mal die xorg.conf.fglrx und Xorg.0.log.fglrx
    nachdem sie XFdrake auf Radeon (fglrx) umgestellt hat
    mit schwarzen Schirm ohne Fehlermeldung ;(

    hab übrigens mein problem woanders auch nochmal zusammengefasst - falls es hier mit meinen dateiuploads zu verwirrend werden sollte ...
    http://www.linux-forum.de/showthread.php?t=2761
     

    Anhänge:

  11. truthy

    truthy Mitglied

    Dabei seit:
    21.01.2007
    Beiträge:
    35
    Zustimmungen:
    0
    vielleicht ist mein problem doch einfacher zu lösen als ich gedacht habe ...
    also ich habe diese 3 selbst generierten rpms und den ati-kernel installiert:
    ati-kernel-2.6.17-5mdv-8.28.8-1mdk
    atieventsd-8.33.6-1mdv2007.0
    dkms-ati-8.33.6-1mdv2007.0
    ati-8.33.6-1mdv2007.0
    als X.org version 7.1.0

    wie kann ich jetzt diesen treiber laden - sodass er wenn ich als root lsmod eingebe aufscheint
    oder reicht es einfach in die xorg.conf driver auf 'fglrx' zu ändern?

    aticonfig und fglrxinfo gehen bei mir nur wenn ich über das automatisierte setup der ati-driver-installer-8.33.6-x86.x86_64.run installiere.
     
  12. #11 BessenOlli, 23.01.2007
    BessenOlli

    BessenOlli Grünschnabel

    Dabei seit:
    23.01.2007
    Beiträge:
    6
    Zustimmungen:
    0
    Hi.

    Komme über Google nach hier.

    Habe genau das gleiche Problem - Bildschirm schwarz. Habe einen Röhrenmonitor (Syncmaster 950p+) an einer Radeon 9800pro. Treiber ist der aktuellste, 8.33.6.

    Habe extra "rpm-build installiert" damit mir das Ding die RPMs für Mandriva 2007 erstellt. Die 3 Dateien dann installiert, aber dann beim umstellen auf den "proprietären Treiber" wurde der Bildschirm schwarz.

    Da ich erst eine knappe Woche mit Linux dran bin war ich dann erstmal ratlos, bekomme mein System nur wieder zu Gesicht wenn ich nochmal neu als Update installiere (geht sehr flott) und am Ende in der Konfiguration im Setup sage, dass ich nicht den gefundenen "proprietären Treiber" benutzen möchte.

    Habe dann nochmal die .run Datei von ATi installiert, diesmal nicht distributions-spezifisch. Dachte erst das hätte geholfen, weil ich nun "ATi Control" Im Menü hatte (was vorher nicht der Fall war), aber Pustekuchen. Wieder Bildschirm schwarz. In den letzten 4 STunden habe ich ca. 4-5 mal das Update-Setup durchlaufen, weil ich als Newbie noch keinen Plan von den entsprechenden Konsolen-Befehlen oder so habe.

    Gott sei dank habe ich hier jetzt direkt 2 aktuele Topics zum Thema gefunden, dann bin ich zumindest nicht allein. :)

    Irgendwer muss doch eine Lösung kennen...
     
  13. #12 truthy, 24.01.2007
    Zuletzt bearbeitet: 24.01.2007
    truthy

    truthy Mitglied

    Dabei seit:
    21.01.2007
    Beiträge:
    35
    Zustimmungen:
    0
    @BessenOlli
    willkommen im club :headup:

    wenn ich ne lösung gefunden hab meld ich mich

    lg
    .
    .
    .
    EDIT (autom. Beitragszusammenführung) :
    .

    Bin inzwischen einen Riesenschritt weitergekommen. Und zwar hab ich es geschafft den 3D support zu aktivieren - nur gibts da leider wieder ein kleines problem:

    damit das geht muss ich Composite ausschalten - nur wenn ich das mache habe ich lauter Grafikfehler - sprich fenster überlappen sich und man sieht nur etwas richtig wenn man es markiert.

    naja des is doch schon mal was :)

    fglrxinfo ohne Composite
    display: :0.0 screen: 0
    OpenGL vendor string: ATI Technologies Inc.
    OpenGL renderer string: Radeon X1950 Series Generic
    OpenGL version string: 2.0.6286 (8.33.6)

    fglrxinfo mit Composite
    Xlib: extension "XFree86-DRI" missing on display ":0.0".
    display: :0.0 screen: 0
    OpenGL vendor string: Mesa project: www.mesa3d.org
    OpenGL renderer string: Mesa GLX Indirect
    OpenGL version string: 1.2 (1.5 Mesa 6.5)

    In der log sind jetzt auch nur mehr warnings und keine errors mehr seit ich aiglx ausgeschalten hab:
    (WW) fglrx: No matching Device section for instance (BusID PCI:1:0:1) found
    (WW) fglrx(0): board is an unknown third party board, chipset is supported
    (WW) fglrx(0): Option "VendorName" is not used
    (WW) fglrx(0): Option "ModelName" is not used

    und so sieht jetzt meine (fast) funktionierende xorg.conf aus:
    Code:
    # File generated by XFdrake (rev 57713)
    # **********************************************************************
    # Refer to the xorg.conf man page for details about the format of
    # this file.
    # **********************************************************************
    
    Section "ServerLayout"
    	Identifier     "layout1"
    	Screen      0  "aticonfig-Screen[0]" 0 0
    	InputDevice    "Keyboard1" "CoreKeyboard"
    	InputDevice    "Mouse1" "CorePointer"
    EndSection
    
    Section "Files"
    
        # font server independent of the X server to render fonts.
        # minimal fonts to allow X to run without xfs
    	FontPath     "unix/:-1"
    	FontPath     "/usr/share/fonts/misc:unscaled"
    EndSection
    
    Section "Module"
    	Load  "dbe" # Double-Buffering Extension
    	Load  "v4l" # Video for Linux
    	Load  "extmod"
    	Load  "type1"
    	Load  "freetype"
    	Load  "glx" # 3D layer
    EndSection
    
    Section "ServerFlags"
    
        #DontZap # disable <Crtl><Alt><BS> (server abort)
        # allows the server to start up even if the mouse does not work
        #DontZoom # disable <Crtl><Alt><KP_+>/<KP_-> (resolution switching)
    	Option	    "allowmouseopenfail"
    	Option      "AIGLX" "off"
    EndSection
    
    Section "InputDevice"
    	Identifier  "Keyboard1"
    	Driver      "kbd"
    	Option	    "XkbModel" "pc105"
    	Option	    "XkbLayout" "de(nodeadkeys)"
    	Option	    "XkbOptions" "compose:rwin"
    EndSection
    
    Section "InputDevice"
    	Identifier  "Mouse1"
    	Driver      "mouse"
    	Option	    "Protocol" "ExplorerPS/2"
    	Option	    "Device" "/dev/mouse"
    EndSection
    
    Section "Monitor"
    
        # Monitor preferred modeline (60.0 Hz vsync, 64.0 kHz hsync, ratio 5/4)
    	Identifier   "monitor1"
    	VendorName   "Plug'n Play"
    	ModelName    "FST1904K1"
    	HorizSync    24.0 - 80.0
    	VertRefresh  50.0 - 75.0
    	ModeLine     "1280x1024" 108.0 1280 1328 1440 1688 1024 1025 1028 1066 +hsync +vsync
    	ModeLine     "768x576" 50.0 768 832 846 1000 576 590 595 630
    	ModeLine     "768x576" 63.1 768 800 960 1024 576 578 590 616
    EndSection
    
    Section "Monitor"
    	Identifier   "aticonfig-Monitor[0]"
    	Option	    "VendorName" "ATI Proprietary Driver"
    	Option	    "ModelName" "Generic Autodetecting Monitor"
    	Option	    "DPMS" "true"
    EndSection
    
    Section "Device"
    	Identifier  "device1"
    	Driver      "fglrx"
    	Option	    "DPMS"
    EndSection
    
    Section "Device"
    	Identifier  "aticonfig-Device[0]"
    	Driver      "fglrx"
    EndSection
    
    Section "Screen"
    	Identifier "screen1"
    	Device     "device1"
    	Monitor    "monitor1"
    	DefaultDepth     24
    	SubSection "Display"
    		Depth     8
    		Modes    "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
    	EndSubSection
    	SubSection "Display"
    		Depth     15
    		Modes    "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
    	EndSubSection
    	SubSection "Display"
    		Depth     16
    		Modes    "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
    	EndSubSection
    	SubSection "Display"
    		Depth     24
    		Modes    "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
    	EndSubSection
    EndSection
    
    Section "Screen"
    	Identifier "aticonfig-Screen[0]"
    	Device     "aticonfig-Device[0]"
    	Monitor    "aticonfig-Monitor[0]"
    	DefaultDepth     24
    	SubSection "Display"
    		Viewport   0 0
    		Depth     24
    	EndSubSection
    EndSection
    
    Section "Extensions"
    	Option	    "Composite" "false"
    EndSection
    dass übrigens monitor, device und screen section doppelt sind ist schon so in ordnung weil bei mir auch bei lspci folgendes rauskommt:
    01:00.0 VGA compatible controller: ATI Technologies Inc Unknown device 7280
    01:00.1 Display controller: ATI Technologies Inc Unknown device 72a0

    also - es muss nur noch ein kleiner config fehler sein - vielleicht sieht ja wer welcher

    mfg
    truthy :rolleyes:
     
  14. #13 BessenOlli, 24.01.2007
    Zuletzt bearbeitet: 24.01.2007
    BessenOlli

    BessenOlli Grünschnabel

    Dabei seit:
    23.01.2007
    Beiträge:
    6
    Zustimmungen:
    0
    Also meine xorg.conf sieht so aus, falls das irgendwem was bringt:

    Code:
    # File generated by XFdrake (rev 57713)
    
    # **********************************************************************
    # Refer to the xorg.conf man page for details about the format of
    # this file.
    # **********************************************************************
    
    Section "Files"
        # font server independent of the X server to render fonts.
        FontPath "unix/:-1"
        
        # minimal fonts to allow X to run without xfs
        FontPath "/usr/share/fonts/misc:unscaled"
    EndSection
    
    Section "Extensions"
        Option "Composite"
    EndSection
    
    Section "ServerFlags"
        #DontZap # disable <Crtl><Alt><BS> (server abort)
        AllowMouseOpenFail # allows the server to start up even if the mouse does not work
        #DontZoom # disable <Crtl><Alt><KP_+>/<KP_-> (resolution switching)
    EndSection
    
    Section "Module"
        Load "dbe" # Double-Buffering Extension
        Load "v4l" # Video for Linux
        Load "extmod"
        Load "type1"
        Load "freetype"
        Load "glx" # 3D layer
        Load "dri" # direct rendering
    EndSection
    
    Section "InputDevice"
        Identifier "Keyboard1"
        Driver "kbd"
        Option "XkbModel" "pc105"
        Option "XkbLayout" "de(nodeadkeys)"
        Option "XkbOptions" "compose:rwin"
    EndSection
    
    Section "InputDevice"
        Identifier "Mouse1"
        Driver "mouse"
        Option "Protocol" "ExplorerPS/2"
        Option "Device" "/dev/mouse"
    EndSection
    
    Section "Monitor"
        Identifier "monitor1"
        VendorName "Plug'n Play"
        ModelName "S/M 950p+"
        HorizSync 30-110
        VertRefresh 50-160
        
        # TV fullscreen mode or DVD fullscreen output.
        # 768x576 @ 79 Hz, 50 kHz hsync
        ModeLine "768x576"     50.00  768  832  846 1000   576  590  595  630
        
        # 768x576 @ 100 Hz, 61.6 kHz hsync
        ModeLine "768x576"     63.07  768  800  960 1024   576  578  590  616
    EndSection
    
    Section "Device"
        Identifier "device1"
        VendorName "ATI Technologies Inc."
        BoardName "ATI Radeon (fglrx)"
        Driver "ati"
        Option "DPMS"
        Option "XaaNoOffscreenPixmaps" "1"
    EndSection
    
    Section "Screen"
        Identifier "screen1"
        Device "device1"
        Monitor "monitor1"
        DefaultColorDepth 24
        
        Subsection "Display"
            Depth 8
            Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
        EndSubsection
        
        Subsection "Display"
            Depth 15
            Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
        EndSubsection
        
        Subsection "Display"
            Depth 16
            Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
        EndSubsection
        
        Subsection "Display"
            Depth 24
            Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
        EndSubsection
    EndSection
    
    Section "ServerLayout"
        Identifier "layout1"
        InputDevice "Keyboard1" "CoreKeyboard"
        InputDevice "Mouse1" "CorePointer"
        Screen "screen1"
    EndSection
    
    Habe daran noch gar nichts manuell gemacht, da ich mich ja erst seit einer knappen Woche mit Linux befasse.


    PS: Ich überlege inzwischen schon ob ich meine 9800pro verkaufen sollte um mir eine 7600GS zu gönnen...





    edit



    So sieht die Datei unmittelbar nach der Installation von Mandriva Powerpack aus, wo der ATi Treiber in der Version 8.28.8 mit drin ist (und läuft):

    Code:
    # File generated by XFdrake (rev 57713)
    
    # **********************************************************************
    # Refer to the xorg.conf man page for details about the format of
    # this file.
    # **********************************************************************
    
    Section "Files"
        # font server independent of the X server to render fonts.
        FontPath "unix/:-1"
        
        # minimal fonts to allow X to run without xfs
        FontPath "/usr/share/fonts/misc:unscaled"
    EndSection
    
    Section "ServerFlags"
        #DontZap # disable <Crtl><Alt><BS> (server abort)
        AllowMouseOpenFail # allows the server to start up even if the mouse does not work
        #DontZoom # disable <Crtl><Alt><KP_+>/<KP_-> (resolution switching)
    EndSection
    
    Section "Module"
        Load "dbe" # Double-Buffering Extension
        Load "v4l" # Video for Linux
        Load "extmod"
        Load "type1"
        Load "freetype"
        Load "glx" # 3D layer
        Load "dri" # direct rendering
    EndSection
    
    Section "InputDevice"
        Identifier "Keyboard1"
        Driver "kbd"
        Option "XkbModel" "pc105"
        Option "XkbLayout" "de(nodeadkeys)"
        Option "XkbOptions" "compose:rwin"
    EndSection
    
    Section "InputDevice"
        Identifier "Mouse1"
        Driver "mouse"
        Option "Protocol" "ExplorerPS/2"
        Option "Device" "/dev/mouse"
    EndSection
    
    Section "Monitor"
        Identifier "monitor1"
        VendorName "Plug'n Play"
        ModelName "S/M 950p+"
        HorizSync 30-110
        VertRefresh 50-160
        
        # TV fullscreen mode or DVD fullscreen output.
        # 768x576 @ 79 Hz, 50 kHz hsync
        ModeLine "768x576"     50.00  768  832  846 1000   576  590  595  630
        
        # 768x576 @ 100 Hz, 61.6 kHz hsync
        ModeLine "768x576"     63.07  768  800  960 1024   576  578  590  616
    EndSection
    
    Section "Device"
        Identifier "device1"
        VendorName "ATI Technologies Inc."
        BoardName "ATI Radeon (fglrx)"
        Driver "fglrx"
        Option "DPMS"
        
        # === disable PnP Monitor  ===
        #Option                              "NoDDC"
        # === disable/enable XAA/DRI ===
        Option "no_accel"                   "no"
        Option "no_dri"                     "no"
        # === FireGL DDX driver module specific settings ===
        # === Screen Management ===
        Option "DesktopSetup"               "0x00000000" 
        Option "MonitorLayout"              "AUTO, AUTO"
        Option "IgnoreEDID"                 "off"
        Option "HSync2"                     "unspecified" 
        Option "VRefresh2"                  "unspecified" 
        Option "ScreenOverlap"              "0" 
        # === TV-out Management ===
        Option "NoTV"                       "yes"     
        Option "TVStandard"                 "NTSC-M"     
        Option "TVHSizeAdj"                 "0"     
        Option "TVVSizeAdj"                 "0"     
        Option "TVHPosAdj"                  "0"     
        Option "TVVPosAdj"                  "0"     
        Option "TVHStartAdj"                "0"     
        Option "TVColorAdj"                 "0"     
        Option "GammaCorrectionI"           "0x00000000"
        Option "GammaCorrectionII"          "0x00000000"
        # === OpenGL specific profiles/settings ===
        Option "Capabilities"               "0x00000000"
        # === Video Overlay for the Xv extension ===
        Option "VideoOverlay"               "on"
        # === OpenGL Overlay ===
        # Note: When OpenGL Overlay is enabled, Video Overlay
        #       will be disabled automatically
        Option "OpenGLOverlay"              "off"
        Option "CenterMode"                 "off"
        # === QBS Support ===
        Option "Stereo"                     "off"
        Option "StereoSyncEnable"           "1"
        # === Misc Options ===
        Option "UseFastTLS"                 "0"
        Option "BlockSignalsOnLock"         "on"
        Option "UseInternalAGPGART"         "no"
        Option "ForceGenericCPU"            "no"
        # === FSAA ===
        Option "FSAAScale"                  "1"
        Option "FSAADisableGamma"           "no"
        Option "FSAACustomizeMSPos"         "no"
        Option "FSAAMSPosX0"                "0.000000"
        Option "FSAAMSPosY0"                "0.000000"
        Option "FSAAMSPosX1"                "0.000000"
        Option "FSAAMSPosY1"                "0.000000"
        Option "FSAAMSPosX2"                "0.000000"
        Option "FSAAMSPosY2"                "0.000000"
        Option "FSAAMSPosX3"                "0.000000"
        Option "FSAAMSPosY3"                "0.000000"
        Option "FSAAMSPosX4"                "0.000000"
        Option "FSAAMSPosY4"                "0.000000"
        Option "FSAAMSPosX5"                "0.000000"
        Option "FSAAMSPosY5"                "0.000000"
    EndSection
    
    Section "Screen"
        Identifier "screen1"
        Device "device1"
        Monitor "monitor1"
        DefaultColorDepth 24
        
        Subsection "Display"
            Depth 8
            Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
        EndSubsection
        
        Subsection "Display"
            Depth 15
            Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
        EndSubsection
        
        Subsection "Display"
            Depth 16
            Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
        EndSubsection
        
        Subsection "Display"
            Depth 24
            Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
        EndSubsection
    EndSection
    
    Section "ServerLayout"
        Identifier "layout1"
        InputDevice "Keyboard1" "CoreKeyboard"
        InputDevice "Mouse1" "CorePointer"
        Screen "screen1"
    EndSection
    
    
    Allerdings bietet er mir bei Drak3D nur "XGL" an und ins System geht er auch nicht, wenn ich das aktiviere. Also ist auch alles keine gute Lösung...
     
  15. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  16. #14 truthy, 24.01.2007
    Zuletzt bearbeitet: 24.01.2007
    truthy

    truthy Mitglied

    Dabei seit:
    21.01.2007
    Beiträge:
    35
    Zustimmungen:
    0
    so, ich bin zwar auch ein linux-noob aber ich hab mich schon soweit durchgegoogelt und durch andere foren gelesen, dass ich glaube dir helfen zu können. vorausgesetzt du hast ein 32-bit system - von 64-bit systemen hab ich nämich keine ahnung!

    1.) deine graka Radeon 9800 pro wird zwar von jeder ati treiberversion unterstützt - ich würde dir aber empfehlen die neueste 8.33.6 zu verwenden, da bugs bei älteren versionen in dieser 'anscheinend' behoben wurden. (ich habe keine andere wahl als die neueste version zu verwenden weil meine graka in älteren gar nicht erst unterstützt wird)

    ad 1.) zur installation: schmeiss die 2 alten pakete der version 8.28.8 über die softwareverwaltung runter (ati-8.28.8 und dkms-ati-8.28.8 )

    2.) Wenn du das hast schreib als root XFdrake in eine konsole und wähle den vorgeschlagenen treiber (bei mir ist das nur vesa ...)
    das ist wichtig weil es wird dein backup der xorg.conf wenn etwas schief geht!
    dann in den ordner /etc/X11/ wechseln und alle anderen xorg.confs.* löschen (xorg.conf.old etc)
    --> dann abmelden und und X-server neu starten (geht recht einfach mit strg + alt + backspace)

    3.) dann installier deine aus dem installer selbst generierten rpms der 8.33.6 version
    (atieventsd-8.33.6-1mdv2007.0.i586.rpm, dkms-ati-8.33.6-1mdv2007.0.i586.rpm & ati-8.33.6-1mdv2007.0.i586.rpm)
    und installier das ganze über die 'normale' setup datei zusätzlich (sh ati-driver-installer-8.33.6-x86.x86_64.run)

    4.) So jetzt musst du noch in in einer console den befehl (aticonfig --initial --input=/etc/X11/xorg.conf) eingeben - aber nacher nicht abmelden!
    nun wechselst du in den ordner /etc/X11/ und bennennst die datei xorg.conf.old in zb xorg.conf.vesa um (muss man nicht - ist aber zwecks der ganzen verwirrung sinnvol), kannst dir die datei auch noch zusätzlich aufn desktop kopieren. (is dein backup)

    5.) nun wechselst du in den ordner /etc/X11/ und editierst die datei xorg.conf manuell. (öffnen mit kedit o.ä.). und zwar suchst du nach dem eintrag "vesa" und änderst ihn auf "fglrx" um. So jetzt startest du neu. Wenn du einen schwarzen schirm bekommst mit Strg + Alt +F1 oder F2 als root anmelden dann cd /var/log/ und dann kopierst du die aktuelle log datei (Xorg.0.log) zb auf den desktop. (mit cp Xorg.0.log /home/dein benutzername/Desktop/
    danach wechselst du nach cd /etc/X11/ und schreibst ls (für den ordnerinhalt, entspricht dir farbig) und benennst die die xorg-configurationen um (sprich die neue in zb xorg.conf.fglrx und dein backup xorg.conf.vesa in xorg.conf) das geht mit dem befehlen
    mv xorg.conf xorg.conf.fglrx
    mv xorg.conf.vesa xorg.conf
    danach reboot tippen und der Xserver sollte mit dem vesa treiber wieder laufen.

    Wenn der Xserver startet kopierst du die Xorg.0.log datei auch über einen Dateimanager.

    6.) Und jetzt kommen wird endlich zu dem teil wo wir festellen können wo der fehler bei deiner configuration liegt :D
    jetzt öffnest du mit zb kedit die vorher gespeicherte Xorg.0.log datei und suchst (strg + f) alle zeilen in den (EE) und (WW) am anfang steht, entspricht error und warning.
    Und diese Zeilen postest du dann hier damit ich dir sagen kann was genau du an der xorg.conf noch verändern musst.

    testen kannst du übrigens die 3D unsterstützung mit dem befehl fglrxinfo (danach sollte dann entweder was von mesa oder von ati dastehen - wenn etwas von ati dasteht bist du dann schon soweit wie ich *g*)
    ich weiss - sind ziemlich viele schritte, aber wenn du dich genau dran hältst glaub ich dass ich dir helfen kann.

    Wenn du das machst ersparst du dir viel an zeit und arbeit. :] hatte vorher auch eine GeForce 6800GT die auch volle 3D unterstützung unter linux hatte - ohne endlose configurationsversuche!
     
  17. #15 BessenOlli, 24.01.2007
    BessenOlli

    BessenOlli Grünschnabel

    Dabei seit:
    23.01.2007
    Beiträge:
    6
    Zustimmungen:
    0
    Bei Punkt 3): Erst die 3 einzelnen Dateien über Software-Installer drauf machen und danach mit dem .run-Installer von der Konsole aus noch mal drüber?
     
Thema:

Mandriva Linux 2007 ATI 8.33.6 Treiber mit ATI X1950 Pro Agp

Die Seite wird geladen...

Mandriva Linux 2007 ATI 8.33.6 Treiber mit ATI X1950 Pro Agp - Ähnliche Themen

  1. Linux-Distributor Mandriva wird abgewickelt

    Linux-Distributor Mandriva wird abgewickelt: Nach etlichen turbulenten Jahren wird der französische Linux-Distributor Mandriva komplett abgewickelt. Die Seiten des Unternehmens sind bereits...
  2. Mandriva Linux Security Advisory 2013-002

    Mandriva Linux Security Advisory 2013-002: Mandriva Linux Security Advisory 2013-002 - Google reported to Mozilla that TURKTRUST, a certificate authority in Mozillas root program, had...
  3. Mandriva Linux Security Advisory 2013-003

    Mandriva Linux Security Advisory 2013-003: Mandriva Linux Security Advisory 2013-003 - Google reported to Mozilla that TURKTRUST, a certificate authority in Mozillas root program, had...
  4. Mandriva Linux Security Advisory 2013-004

    Mandriva Linux Security Advisory 2013-004: Mandriva Linux Security Advisory 2013-004 - The replay-countermeasure functionality in the HTTP Digest Access Authentication implementation in...
  5. Mandriva Linux Security Advisory 2013-001

    Mandriva Linux Security Advisory 2013-001: Mandriva Linux Security Advisory 2013-001 - Versions of GnuPG less than or equal to 1.4.12 are vulnerable to memory access violations and public...