ATI Grafikkarte - Probleme mit Treiber

Dieses Thema im Forum "SuSE / OpenSuSE" wurde erstellt von xanderc, 02.05.2008.

  1. #1 xanderc, 02.05.2008
    xanderc

    xanderc Grünschnabel

    Dabei seit:
    02.05.2008
    Beiträge:
    7
    Zustimmungen:
    0
    Hi,

    hab ein kleines Problem, konnte leider keine Lösung durch die Suche finden.
    Problem 1:
    bin vor kurzem von WindowsXP auf opensuse 10.3 umgestiegen, somit kenne ich mich noch nicht wirklich aus .
    Problem2 (Hauptproblem):
    Habe in meinem Rechner eine Ati Radeon RX2600PRP.
    Natürlich wollte ich die auch unter Suse zum laufen kriegen.
    Also hab ich ein bisschen gegoogelt und bin am Ende auf dieser Seite stehen geblieben:
    http://wiki.linux-club.de/opensuse/Fglrx
    und weil sich das so toll angehört hat: Der einfachste Weg (ab openSUSE 10.3), habe ich mich entschlossen das durchzuführen.

    soweit so gut, nach einer weile hat er versucht ein paar pakete zu installieren, dabei tauchte ein konflikt auf, der besagt hatte, dass ein paar Pakete gebraucht werden. habe dann ein bisschen in yast rumgesucht und gesehen, dass die pakete vorhanden sind und den Konflikt auf ignorieren gestellt.
    Dann kamm die Meldung, dass alles erfolgreich installiert wurde, habe dann den befehl "sudo aticonfig --initial" ausgeführt und das Grafiksystem neu gestartet (wie in diesem LinuxClub beschrieben)
    dann Sax ausgeführt, ATI ist als grafikarte eingetragen
    unter Arbeitsplatz findet sich das:
    Hersteller: ATI Technologies Inc
    Modell: ATI Radeon HD 2600 Pro (RV630 9589)
    Treiber: fglrx (Keine 3D-Unterstützung)
    Ich habe momentan 2 Problemme damit:
    1. wie kriege ich die 3 D unterstützung?
    2. wenn ich eine Webseite oder irgend ein Ordner runterscrolle hängt das teil ziemlich, soll heissen, es läuft nicht flüssig wie davor, sondern ruckartig.

    Weiss jemand Rat?

    Schon mal danke im voraus,
    Gruß, xanderc
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. doc

    doc Kaffeetrinker

    Dabei seit:
    26.08.2006
    Beiträge:
    586
    Zustimmungen:
    0
    Ort:
    bremen
    da sollte aber fglrx stehen
     
  4. #3 xanderc, 02.05.2008
    xanderc

    xanderc Grünschnabel

    Dabei seit:
    02.05.2008
    Beiträge:
    7
    Zustimmungen:
    0
    das nenn ich schnell :)

    in Sax steht ATI ATI Radeon HD 2600 PRO (RV630 9589)
     
  5. doc

    doc Kaffeetrinker

    Dabei seit:
    26.08.2006
    Beiträge:
    586
    Zustimmungen:
    0
    Ort:
    bremen
    entscheidend ist was in deiner xorg.conf steht

    Driver "fglrx"

    da sollte sowas stehen, wenn da

    Driver "ati"

    steht, dann ist es falsch, mit sax kenne ich mich leider nicht aus.
     
  6. #5 xanderc, 02.05.2008
    Zuletzt bearbeitet: 02.05.2008
    xanderc

    xanderc Grünschnabel

    Dabei seit:
    02.05.2008
    Beiträge:
    7
    Zustimmungen:
    0
    Hier Ausschnitt aus xorg.conf:

    Section "Device"
    BoardName "ATI Radeon HD 2600 Pro (RV630 9589)"
    Driver "fglrx"
     
  7. #6 doc, 02.05.2008
    Zuletzt bearbeitet: 02.05.2008
    doc

    doc Kaffeetrinker

    Dabei seit:
    26.08.2006
    Beiträge:
    586
    Zustimmungen:
    0
    Ort:
    bremen
    Code:
    Section "DRI"
    	Group        "video"
    	Mode         0660
    EndSection
    
    so eine section bei dir vorhanden ?

    und bist du mitglied der gruppe video ?


    desweiteren musst du glx, und eventuell auch dri in der sectin module haben

    Code:
    Section "Module"
    	Load  "glx"
    	Load  "dri"
    EndSection
    
     
  8. #7 xanderc, 02.05.2008
    xanderc

    xanderc Grünschnabel

    Dabei seit:
    02.05.2008
    Beiträge:
    7
    Zustimmungen:
    0
    Ja, Sektion da
    Code:
    Section "DRI"
        Group      "video"
        Mode       0660
    EndSection

    Hier Section Module
    Code:
    Section "Module"
      Load         "glx"
      Load         "type1"
      Load         "extmod"
      Load         "dbe"
      Load         "freetype"
      Load         "dri"
    EndSection
    Mitglied der Gruppe Video?
    woher weiss man das?
     
  9. doc

    doc Kaffeetrinker

    Dabei seit:
    26.08.2006
    Beiträge:
    586
    Zustimmungen:
    0
    Ort:
    bremen
    z.B. ausgabe des befehls "groups" in der konsole

    Code:
    doc@chaos ~ $ groups 
    wheel audio cdrom video games doc plugdev
    aber vieleicht mal die ausgabe von:

    Code:
    grep EE /var/log/Xorg.0.log
    posten
     
  10. #9 xanderc, 02.05.2008
    xanderc

    xanderc Grünschnabel

    Dabei seit:
    02.05.2008
    Beiträge:
    7
    Zustimmungen:
    0
    Hier Ausgabe beider Befehle
    Code:
    xanderc@noname:~> groups
    users dialout video
    xanderc@noname:~> grep EE /var/log/Xorg.0.log
            (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    (II) Loading extension MIT-SCREEN-SAVER
    (EE) fglrx(0): atiddxDriScreenInit failed, GPS not been initialized.
    
     
  11. doc

    doc Kaffeetrinker

    Dabei seit:
    26.08.2006
    Beiträge:
    586
    Zustimmungen:
    0
    Ort:
    bremen
    einfach mal danach googlen. da gibs tausend treffer

    schon mal n neustart gemacht nach installation des treibers ?

    neuladen des moduls würde auch reichen, aber neustart ist am unkompliziertesten.

    und danach mal :

    http://linux.derkeiler.com/Mailing-Lists/SuSE/2008-01/msg02905.html

    oder/und

    http://www.phoronix.com/forums/showthread.php?t=6062

    anschauen wenns noch nicht geht, oder selber suchen ...
     
  12. #11 xanderc, 02.05.2008
    xanderc

    xanderc Grünschnabel

    Dabei seit:
    02.05.2008
    Beiträge:
    7
    Zustimmungen:
    0
    ja bereits mehrere neustarts

    habe gerade das mal ausprobiert:
    Code:
    # modprobe fglrx
    FATAL: Module fglrx not found.
    ähm was heisst das?
    was fehlt da genau?
     
  13. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  14. doc

    doc Kaffeetrinker

    Dabei seit:
    26.08.2006
    Beiträge:
    586
    Zustimmungen:
    0
    Ort:
    bremen
    das heisst das der Treiber(modul) nicht installiert ist.

    da war wohl doch nicht alles richtig.

    nutz mal die boardsuche, es gibt ne menge threads zu dem thema, ich kenne mich leider nicht mit suse aus, deswegen kann ich zur treiberinstallation dort nichts sagen.

    du könntest mal den treiber manuel installieren, aber dafür musst du auch alle vorher eventuell installierten fglrx treiber deinstallieren, aber da weiss ich jetzt auch nicht wie genau, aber auch das wurde schon mehrfach hier im board gesagt/fragt, also einfach mal die suche nutzen, oder warten bis ein suse experte dir hier helfen kann.
     
  15. #13 xanderc, 02.05.2008
    xanderc

    xanderc Grünschnabel

    Dabei seit:
    02.05.2008
    Beiträge:
    7
    Zustimmungen:
    0
    na gut, danke dir schon mal ;)
     
Thema:

ATI Grafikkarte - Probleme mit Treiber

Die Seite wird geladen...

ATI Grafikkarte - Probleme mit Treiber - Ähnliche Themen

  1. Grafikkartenprobleme unter Suse 10.2

    Grafikkartenprobleme unter Suse 10.2: Hallo hab eine Radeon 9600pro hab den treiber von ati runtergeladen Automated installer and Display Drivers for XFree86 4.3 and X.Org 6.7, 6.8,...
  2. Habe eine NVIDI GeForce 7600 GS Grafikkarte, die Probleme mit der Konfiguration macht

    Habe eine NVIDI GeForce 7600 GS Grafikkarte, die Probleme mit der Konfiguration macht: Im Arbeitsplatz steht folgendes: Hersteller: NVIDIA Corporation Modell: GeForce 7600 GS Treiber: unbekannt und in der Konsole bei...
  3. Probleme mit der Grafikkarte/Monitor

    Probleme mit der Grafikkarte/Monitor: Hallo, ich bin ganz neu hier und auch ganz neu bei Linux. Habe jetzt SuSE 9.3 auf meinem ACER TravelMate 4150 installiert. Aber ich bekomme die...
  4. Probleme mit Einrichtung - 2 Grafikkarten - 2 Monitore

    Probleme mit Einrichtung - 2 Grafikkarten - 2 Monitore: Irgendwie komme ich seit Tagen nicht wirklich weiter. Ich habe in meinem Rechner eine ATI Radeon (AGP) und eine ATI All-in-Wonder Pro Rage 3D...
  5. Treiberaktualisierung bei Nvidia-Grafikkarten

    Treiberaktualisierung bei Nvidia-Grafikkarten: Nvidia hat Version 352.41 seines proprietären Grafiktreibers herausgegeben. In erster Linie fügt der Treiber Unterstützung für neue Grafikchips...