Kernel Panic nach Knoppix-Installation???

Dieses Thema im Forum "Debian/Ubuntu/Knoppix" wurde erstellt von stoker23, 06.01.2006.

  1. #1 stoker23, 06.01.2006
    stoker23

    stoker23 Grünschnabel

    Dabei seit:
    06.01.2006
    Beiträge:
    7
    Zustimmungen:
    0
    Hallo,

    ich habe auf meinem Rechner Windows XP laufen und möchte durch den Grub-Manager von Knoppix die Wahl haben, welches System ich starte. Ich habe also mit Partition Magic erst mal eine für mich sinvvolle Partition angelegt und anschließend die Knoppix 4.0.2 CD gebootet. Hat alles 1A funktioniert. Anschließend dank SUDO KNOPPIX-INSTALLER Knoppix installiert. Nach dem Neustart kam der Boot-Manager; also Debian Linux ausgwählt. Beim Hochfahren kam dann allerdings leider die Meldung KERNEL PANIC-not syncing:VFS:Unaable to mount root fs on unkown block (6,8). Beim Googlen habe ich festgestellt, dass viele diese Meldung haben. Leider scheint es keine Patentlösung zu geben, da die Fehlermeldung wohl unterschiedlich Ursachen haben kann. Kann mir vielleicht trotzdem einer von Euch hilfen.....ich bin allerdings Linux.Newbie. Hier ist die Partition meiner 250GB-Platte:

    SDA1 NTFS 50GB - Systemplatte mit Windows XP
    SDA5 NTFS 50GB
    SDA6 EXT2 10GB - Knoppix-Installationspfad
    SDA7 SWAP 512MB
    SDA8 FAT32 10GB - will ich quasi als Schnittstelle zwischen XP und Linix verwende
    SDA9 NTFS 80GB
    SDA10 EXT2 38GB - /Home


    Ich habe eine S-ATA-Platte und habe gelesen, dass dies manchmal den Fehler verursachen kann...da die Platte aber unter Anwendung der Live-CD geht kann ich mir das eigentlich nicht vorstellen.

    Vielen Dank für eventuelle Hilfestellungen.

    stoker23
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 Goodspeed, 06.01.2006
    Goodspeed

    Goodspeed Foren Gott
    Moderator

    Dabei seit:
    21.04.2004
    Beiträge:
    4.165
    Zustimmungen:
    1
    Ort:
    Dresden
    Dann boote mal mit der Knoppix-CD und mounte mal sda6. (wird unter /mnt/sda6 eingehangen ... glaube ich).
    Und dann postest Du mal den Inhalt der folgenden 3 Dateien:

    /mnt/sda6/etc/fstab
    /mnt/sda6/boot/grub/menu.lst
    /mnt/sda6/boot/grub/device.map
     
  4. #3 stoker23, 06.01.2006
    stoker23

    stoker23 Grünschnabel

    Dabei seit:
    06.01.2006
    Beiträge:
    7
    Zustimmungen:
    0
    Also ich habe jetzt erst mal die Infos der drei Dateien besorgt. Danke für Dein Engagement:

    /mnt/sda6/etc/fstab

    # /etc/fstab: filesystem table.
    #
    # filesystem mountpoint type options dump pass
    /dev/sda6 / reiserfs defaults 0 1

    proc /proc proc defaults 0 0
    /dev/fd0 /floppy vfat defaults,user,noauto,showexec,umask=022 0 0
    usbfs /proc/bus/usb usbfs devmode=0666 0 0
    sysfs /sys sysfs defaults 0 0
    tmpfs /dev/shm tmpfs defaults 0 0
    /dev/cdrom /cdrom iso9660 defaults,ro,users,noexec,noauto 0 0
    /dev/cdrom1 /cdrom1 iso9660 defaults,ro,users,noexec,noauto 0 0
    /dev/dvd /dvd iso9660 defaults,ro,users,noexec,noauto 0 0
    # Added by KNOPPIX
    /dev/sda1 /mnt/sda1 ntfs noauto,users,exec,ro,umask=000 0 0
    # Added by KNOPPIX
    /dev/sda5 /mnt/sda5 ntfs noauto,users,exec,ro,umask=000 0 0
    # Added by KNOPPIX
    /dev/sda7 /mnt/sda7 auto noauto,users,exec 0 0
    # Added by KNOPPIX
    /dev/sda8 /mnt/sda8 vfat noauto,users,exec,umask=000 0 0
    # Added by KNOPPIX
    /dev/sda9 /mnt/sda9 ntfs noauto,users,exec,ro,umask=000 0 0
    # Added by KNOPPIX
    /dev/sda10 /mnt/sda10 ext2 noauto,users,exec 0 0


    /mnt/sda6/boot/grub/menu.lst

    # Deutsche Tastaturbelegung

    setkey y z
    setkey z y
    setkey Y Z
    setkey Z Y
    setkey equal parenright
    setkey parenright parenleft
    setkey parenleft asterisk
    setkey doublequote at
    setkey plus bracketright
    setkey minus slash
    setkey slash ampersand
    setkey ampersand percent
    setkey percent caret
    setkey underscore question
    setkey question underscore
    setkey semicolon less
    setkey less numbersign
    setkey numbersign backslash
    setkey colon greater
    setkey greater bar
    setkey asterisk braceright
    # menu.lst - See: grub(8), info grub, update-grub(8)
    # grub-install(8), grub-floppy(8),
    # grub-md5-crypt, /usr/share/doc/grub
    # and /usr/share/doc/grub-doc/.

    ## default num
    # Set the default entry to the entry number NUM. Numbering starts from 0, and
    # the entry number 0 is the default if the command is not used.
    #
    # You can specify 'saved' instead of a number. In this case, the default entry
    # is the entry saved with the command 'savedefault'.
    default 0

    ## timeout sec
    # Set a timeout, in SEC seconds, before automatically booting the default entry
    # (normally the first entry defined).
    timeout 5

    # Pretty colours
    color cyan/blue white/blue

    ## password ['--md5'] passwd
    # If used in the first section of a menu file, disable all interactive editing
    # control (menu entry editor and command-line) and entries protected by the
    # command 'lock'
    # e.g. password topsecret
    # password --md5 $1$gLhU0/$aW78kHK1QfV3P2b2znUoe/
    # password topsecret

    #
    # examples
    #
    # title Windows 95/98/NT/2000
    # root (hd0,0)
    # makeactive
    # chainloader +1
    #
    # title Linux
    # root (hd0,1)
    # kernel /vmlinuz root=/dev/hda2 ro
    #

    #
    # Put static boot stanzas before and/or after AUTOMAGIC KERNEL LIST

    ### BEGIN AUTOMAGIC KERNELS LIST
    ## lines between the AUTOMAGIC KERNELS LIST markers will be modified
    ## by the debian update-grub script except for the default options below

    ## DO NOT UNCOMMENT THEM, Just edit them to your needs

    ## ## Start Default Options ##
    ## default kernel options
    ## default kernel options for automagic boot options
    ## If you want special options for specifiv kernels use kopt_x_y_z
    ## where x.y.z is kernel version. Minor versions can be omitted.
    ## e.g. kopt=root=/dev/hda1 ro
    # kopt=root=/dev/sda6 ro ### isk_size=100000 init=/etc/init lang=de apm=power-off nomce quiet vga=791

    ## default grub root device
    ## e.g. groot=(hd0,0)
    # groot=(hd0,5)

    ## should update-grub create alternative automagic boot options
    ## e.g. alternative=true
    ## alternative=false
    # alternative=false

    ## should update-grub lock alternative automagic boot options
    ## e.g. lockalternative=true
    ## lockalternative=false
    # lockalternative=false

    ## altoption boot targets option
    ## multiple altoptions lines are allowed
    ## e.g. altoptions=(extra menu suffix) extra boot options
    ## altoptions=(recovery mode) single
    # altoptions=(recovery mode) single

    ## controls how many kernels should be put into the menu.lst
    ## only counts the first occurence of a kernel, not the
    ## alternative kernel options
    ## e.g. howmany=all
    ## howmany=7
    # howmany=all

    ## should update-grub create memtest86 boot option
    ## e.g. memtest86=true
    ## memtest86=false
    # memtest86=true

    ## ## End Default Options ##

    title Debian GNU/Linux, kernel 2.6.12 Default
    root (hd0,5)
    kernel /boot/vmlinuz root=/dev/sda6 ro ### isk_size=100000 init=/etc/init lang=de apm=power-off nomce quiet vga=791
    initrd /boot/initrd.img
    savedefault
    boot

    title Debian GNU/Linux, kernel 2.6.12
    root (hd0,5)
    kernel /boot/vmlinuz-2.6.12 root=/dev/sda6 ro ### isk_size=100000 init=/etc/init lang=de apm=power-off nomce quiet vga=791
    initrd /boot/initrd.img-2.6.12
    savedefault
    boot

    ### END DEBIAN AUTOMAGIC KERNELS LIST
    title Windows 2K/XP/2003 (sda1)
    chainloader (hd0,0)+1


    /mnt/sda6/boot/grub/device.map

    (hd0) /dev/sda
     
  5. #4 Goodspeed, 06.01.2006
    Goodspeed

    Goodspeed Foren Gott
    Moderator

    Dabei seit:
    21.04.2004
    Beiträge:
    4.165
    Zustimmungen:
    1
    Ort:
    Dresden
    Hmmm ... sieht eigentlich gut aus ...
    Kommt der Fehler bei beiden Debian-Einträgen?
     
  6. #5 stoker23, 06.01.2006
    stoker23

    stoker23 Grünschnabel

    Dabei seit:
    06.01.2006
    Beiträge:
    7
    Zustimmungen:
    0
    Ja, egal welchen Debian-Eintrag ich beim Bootmanager wähle, die Fehlermeldung ist immer die Gleiche. Wenn ich Boot-Manager einen Debian-Eintrag wähle und auf EDITIEREN gehe, dann wird folgendes angezeigt:

    root (hd0,5)
    kernel /boot/vmlinuz root=/dev/sda6 ro ### isk_size=100000 init=/etc->
    initrd/boot/initrd.img

    Bei anderen Debian-Eintrag sieht es genau so aus, außer das die Versionsnummer des Kernels noch aufgelistet ist.

    Hilft das irgendwie weiter?

    Danke
     
  7. #6 Wolfgang, 06.01.2006
    Wolfgang

    Wolfgang Foren Gott

    Dabei seit:
    24.04.2005
    Beiträge:
    3.978
    Zustimmungen:
    0
    Ort:
    Erfurt
    Steht das wirklich so drin, oder ist das ein Kopierfehler?
    IMHO muss dort statt ### ramdisk_size=... stehen.
    Bei dir ist das aber auskommentiert.

    Gruß Wolfgang
     
  8. theton

    theton Bitmuncher

    Dabei seit:
    27.05.2004
    Beiträge:
    4.820
    Zustimmungen:
    0
    Ort:
    Berlin, Germany
    Ich vermute mal, dass die Treiber fuer deinen SCSI-Controller nicht im initrd-Image sind.
     
  9. #8 Goodspeed, 06.01.2006
    Goodspeed

    Goodspeed Foren Gott
    Moderator

    Dabei seit:
    21.04.2004
    Beiträge:
    4.165
    Zustimmungen:
    1
    Ort:
    Dresden
    Wenn das der "normale" Knoppix-Kernel ist, sollten die schon drin sein ... sonst würde die CD ja auch nicht funktionieren ;)
     
  10. #9 stoker23, 06.01.2006
    stoker23

    stoker23 Grünschnabel

    Dabei seit:
    06.01.2006
    Beiträge:
    7
    Zustimmungen:
    0
    Also die Command-Line beim Boot-Manager sieht genau so aus wie ich es geschrieben habe.............dieses ### ISK_SIZE hatte mich auch etwas verwundert, deswegen hatte ich es mal hier reingeschrieben. Ich habe jetzt einfach mal die Command-Line auf gut Glück abgeändert und aus dem ISK_SIZE ein RAMDISK_SIZE gemacht und dann gebootet. Wie kann ich diese Abänderung denn eigentlich speichern? Beim Boot-Manager scheint das nicht zu gehen. Jedenfalls habe ich neu gebootet. Zuerst kam die Fehlermeldung UNKNOWN FILESYSTEM DEVFS, DEVFS NOT MOUNTED. Trotzdem konnte ich jetzt Knoppix hochfahren und arbeite jetzt gerade unter Knoppix. Also wie bekomme ic die Fehlermeldung weg und wie speichere ich die abgeänderte Command-Line?

    Vielen Dank.
     
  11. #10 Wolfgang, 06.01.2006
    Wolfgang

    Wolfgang Foren Gott

    Dabei seit:
    24.04.2005
    Beiträge:
    3.978
    Zustimmungen:
    0
    Ort:
    Erfurt
    Hallo
    Diese Einträge findest du in der Datei
    /boot/grub/menu.lst
    Die solltest du als root editieren.

    Gruß Wolfgang
     
  12. #11 stoker23, 06.01.2006
    stoker23

    stoker23 Grünschnabel

    Dabei seit:
    06.01.2006
    Beiträge:
    7
    Zustimmungen:
    0
    Okay, Datei gefunden und abgeändert . Aber:

    Das Dokument lässt sich nicht speichern, da Schreiben auf file:///boot/grub/menu.lst nicht möglich ist.
    Bitte überprüfen Sie, ob Sie Schreibrecht für die Datei besitzen und genug Speicherplatz vorhanden ist.


    Wie bekomme ich das nun hin? Und was mache ich mit der anderen Fehlermeldung beüglich DEVFS NOT MOUNTED?
     
  13. #12 Goodspeed, 06.01.2006
    Goodspeed

    Goodspeed Foren Gott
    Moderator

    Dabei seit:
    21.04.2004
    Beiträge:
    4.165
    Zustimmungen:
    1
    Ort:
    Dresden
    Also entweder per

    sudo vi /boot/grub/menu.lst

    oder per

    kdesu nedit

    oder ensprechend was ähnliches ...
     
  14. #13 stoker23, 06.01.2006
    stoker23

    stoker23 Grünschnabel

    Dabei seit:
    06.01.2006
    Beiträge:
    7
    Zustimmungen:
    0
    Okay, gar nicht mal so einfach wenn man noch nie mit Linux gearbeitet hat. Die Command-Line konnte ich jetzt abändern und speichern. Das Hochfahren nach Auswahl von Debian Linux beim Boot-Manager klappt jetzt. Die Fehlermeldung mit UNKNOWN FILESYSTEM DEVFS NOT MOUNTED ist immer noch da. Was sagft das aus und wie bekomme ich das weg?
     
  15. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  16. #14 Goodspeed, 06.01.2006
    Goodspeed

    Goodspeed Foren Gott
    Moderator

    Dabei seit:
    21.04.2004
    Beiträge:
    4.165
    Zustimmungen:
    1
    Ort:
    Dresden
    devfs ist obsolete und wird eigentlich nicht mehr verwendet. "Nachfolger" ist udev.

    Schau mal, an welcher Stelle im Boot-Prozess die Fehlermeldung auftaucht ...
     
  17. #15 stoker23, 07.01.2006
    stoker23

    stoker23 Grünschnabel

    Dabei seit:
    06.01.2006
    Beiträge:
    7
    Zustimmungen:
    0
    Also die Fehlermeldung kommt direkt am Anfang des Bootvorgangs......quasi sofort nach den zwei Pinguinen :-). Kann man das noch irgenwo genau erörtern, oder meintest Du das?
     
Thema:

Kernel Panic nach Knoppix-Installation???

Die Seite wird geladen...

Kernel Panic nach Knoppix-Installation??? - Ähnliche Themen

  1. Kernel Panic GRUB 2

    Kernel Panic GRUB 2: Guten morgen ich habe folgendes Problem: Ich habe mit Hilfe des minimalen CD-Images das System mit Stage3 Images aufgesetzt, neuen Kernel...
  2. Linux Kernel VFS Panic HP Thin Client

    Linux Kernel VFS Panic HP Thin Client: Hallo, ich denke der Thread Titel beschreibt mein Problem schon im Groben. Also ich habe hier einen HP Comaq t 5000 Thin Client vorliegen, auf...
  3. Laufend Kernel-Panic nach routinemäßigem fsck

    Laufend Kernel-Panic nach routinemäßigem fsck: Hallo, ich habe ein komisches Phänomen bei meinem Laptop entdeckt, dass irgendwie mit fsck, NetworkManager und dem iwl4965 bzw. der Firmware...
  4. Crux - Kernel panic - unable to mount root fs

    Crux - Kernel panic - unable to mount root fs: Servus, ich möchte gerne Crux 2.5 installieren, aber ich scheitere nach der Installation beim Bootvorgang. Ich gehe nach dem offiziellen...
  5. Kernelpanic bei XEN installation, modules.dep wird nicht gefunden

    Kernelpanic bei XEN installation, modules.dep wird nicht gefunden: Hi, ich habe Probleme bei einer XEN Installation. Debian 5.0.0 und XEN 3.3.1 Debian als Standard installiert, benötigte Pakete nachinstalliert...