Kernel 2.6.1 - error mit 'make modules_install'

Dieses Thema im Forum "Linux OS" wurde erstellt von Raptor, 03.04.2004.

  1. Raptor

    Raptor Jungspund

    Dabei seit:
    03.04.2004
    Beiträge:
    18
    Zustimmungen:
    0
    Hallo!

    Ich mache gerade ein Kernel Upgrade bei einem Debian und habe nun ein Problem.

    Nachdem ich 'make menuconfig' gemacht hatte, und danach
    'make dep clean bzImage modules' kommt der error bei
    'make modules_install'.
    Mit einer Fehlermeldung beendet das Programm seine Arbeit, die da lautet:



    depmod: *** Unresolved Symbols in /lib/modules/2.6.1/kernel/drivers/parport/parport_pc.ko
    depmod: ..........
    depmod: ..........
    depmod: ..........
    depmod: ..........
    depmod: parport_ieee1284_epp_write_data
    make: *** [_modinst_post] Error 1


    Die Punkte symbolisieren die installierten Module.
    Wie man sehen kann arbeitet das Programm zwischen den 'unresolved symbols'
    weiter bis zur schlussendlichen Fehlermeldung.

    Ich habe schon saemtliche Sites, die google.com zu diesem Thema ausspuckt durchkaemmt, aber leider ohne wirklichen Erfolg.

    Waere echt super, wenn ihr mir helfen koenntet.

    Thx in advance

    Raptor
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. 001

    001 Routinier

    Dabei seit:
    15.02.2004
    Beiträge:
    362
    Zustimmungen:
    0
    Ort:
    syberia
    ok ich versteh nicht sooooo viel davon aber ich glaube das hat mit nem treiber zu tuhn.
    hast du vielleicht nen falschen treiber installiert?
     
  4. Raptor

    Raptor Jungspund

    Dabei seit:
    03.04.2004
    Beiträge:
    18
    Zustimmungen:
    0
    Das mit dem Treiber glaube ich auch.
    Aber ich habe ja noch gar keine installiert.
    Deshalb kann es eigentlich keine falschen Treiber geben.
    Man kann doch alle Treiber nachinstallieren, oder?
    Denn dann werden ich alle Treiber deaktivieren und dann alles per Hand nachinstallieren.
     
  5. 001

    001 Routinier

    Dabei seit:
    15.02.2004
    Beiträge:
    362
    Zustimmungen:
    0
    Ort:
    syberia
    warum deaktivieren hast doch noch garkeine?
    naja wie auch immer einfach mal installieren,
    melde dich dann bitte kurz obs geklapt hat. :)
     
  6. Ylin

    Ylin hm... ja

    Dabei seit:
    29.08.2003
    Beiträge:
    180
    Zustimmungen:
    0
    Er ist doch dabei seinen Kernel zu installieren, nur klappt es nicht. -.-

    @Raptor
    Ich würde einfach mal das Modul, was den Fehler verursacht, ganz rausnehmen oder versuchen, es fest in den Kernel zu kompilieren. Vielleicht klappts ja dann.
     
  7. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  8. Raptor

    Raptor Jungspund

    Dabei seit:
    03.04.2004
    Beiträge:
    18
    Zustimmungen:
    0
    Anbei meine .config als Anhang.
    Hoffe, das hilft.
    Aber wer ein bisschen Ahnung von Linux hat, sollte das hinkriegen.
    :]
     

    Anhänge:

  9. #7 NaRF, 06.04.2004
    Zuletzt bearbeitet: 06.04.2004
    NaRF

    NaRF Hatifschnacke

    Dabei seit:
    15.05.2003
    Beiträge:
    105
    Zustimmungen:
    0
    Ort:
    Friedberg (Hessen)
    versuch doch mal folgendes:
    lösch die entpackten kernelsource (bis auf die config) und entpacke sie neu.
    dann schiebst du wieder die alte konfig in das verzeichnis und dann ganz normal "make && make modules_install".

    natürlich kannst du auch die .config mitlöschen und den kernel komplett neu konfigurieren. macht aber nur unnütze arbeit :)

    mein "unresolved symbols" geheimtipp ;) hoffe es hilft

    btw:

    in der 2.6er reihe ist "make" nen alias für "make dep clean bzimage modules" du brauchst also nur "make && make modules_install" eingeben.
     
Thema:

Kernel 2.6.1 - error mit 'make modules_install'

Die Seite wird geladen...

Kernel 2.6.1 - error mit 'make modules_install' - Ähnliche Themen

  1. Mustek 1200 CU Plus + Kernel 2.6.35.7 = Error during device I/O

    Mustek 1200 CU Plus + Kernel 2.6.35.7 = Error during device I/O: Hallo zusammen, ich habe hier einen alten Mustek 1200 CU Plus Scanner herumfliegen, den ein Arbeitskollege von mir wegwerfen wollte. Wenn...
  2. Echtzeit-Kernel: make error

    Echtzeit-Kernel: make error: Hallo, ich bin gerade dabei mir einen Echtzeit-Kernel zu bauen und bekomme beim übersetzen meiner gepatchten Quellen eine Fehlermeldung, mit der...
  3. openSuse 10.3 Beta: error: Failed build dependencies: kernel-dummy is needed

    openSuse 10.3 Beta: error: Failed build dependencies: kernel-dummy is needed: Morgens, ich probiere gerade openSuse 10.3 und wollte mir nun die passenden Kernel-Sourcen von...
  4. c000021a Error durch Kernel update?

    c000021a Error durch Kernel update?: Hallo, seit dem der Kernel von meinem Ubuntusystem von Version 2.6.17-10 auf 2.5.17-11 upgedatet wurde, bricht der Bootvorgang meines Windows...
  5. Debian weder Testing noch Stable will (SATA Sil3112/Kernelimageerror)

    Debian weder Testing noch Stable will (SATA Sil3112/Kernelimageerror): Hallo, habe bereits einen Server mit Debian, der einwandfrei funktioniert (naja fast ;)). Nun wollt ich das System auch auf meiner...