Kein Sound unter Debian

Dieses Thema im Forum "Sound" wurde erstellt von bueno, 05.02.2007.

  1. #1 bueno, 05.02.2007
    Zuletzt bearbeitet: 05.02.2007
    bueno

    bueno Eroberer

    Dabei seit:
    16.02.2006
    Beiträge:
    69
    Zustimmungen:
    0
    Ort:
    Wien
    Hallo Community!

    Ich habe mir vor 2 Tagen Debian (testing) installier mit Windowmanager: Fluxbox. Mein Problem ist jetzt, dass der Sound nicht funktioniert. Ich bin draufgekommen, als ich mir XMMS geholt habe um ne *.mp3 abzuspielen. Daraufhin habe ich etwas gegoogelt und im Forum gelesen, jedoch nochimmer keine Lösung gefunden. Achja noch zur Info: Ich verwende den 2.6er Kernel

    Ich habe mir bereits ALSA per APT geholt. Hat leider auch nichts gebracht. Meine Soundkarte ist Onboard, und der Chipsatz ist: VIA VT8237. Boxen sind angeschlossen und funktionieren 100% (zumindest unter Windows).

    Auf der ALSA Homepage steht zwar, dass mein Chipsatz unterstützt wird, aber bis jetzt hab ich noch keinen Ton herausbekommen aus meinen Boxen.

    Ich hoffe jemand von euch kann mir helfen, dieses Problem zu beheben...
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. z00k

    z00k I love my slack! Do u?

    Dabei seit:
    24.01.2005
    Beiträge:
    302
    Zustimmungen:
    0
    Ort:
    earth.getLocation("z00k");
    hast du denn auch ALSA konfiguriert?

    Code:
    alsaconf

    gReetZ
     
  4. keks

    keks nicht 1337 genug

    Dabei seit:
    17.01.2007
    Beiträge:
    401
    Zustimmungen:
    0
    Ort:
    Hessen
    imho ganz trivial?
    Code:
    alsamixer
    master + pcm hochdrehen?
     
  5. bueno

    bueno Eroberer

    Dabei seit:
    16.02.2006
    Beiträge:
    69
    Zustimmungen:
    0
    Ort:
    Wien
    bin noch ziemlicher neuling,
    meine Frage wäre jetzt was "master und pcm hochdrehen" ist? Sorry, aber unter master und pcm versehe ich im moment nichts...

    die alsa config werde ich gleichmal durchführen, danke für die antworten.
     
  6. grey

    grey -=[GHOST]=-

    Dabei seit:
    28.07.2006
    Beiträge:
    303
    Zustimmungen:
    0
    Du sollst den Mixer öffnen und dort die Channels Master und PCM lauter stellen ...
     
  7. zeael

    zeael Routinier

    Dabei seit:
    29.12.2006
    Beiträge:
    261
    Zustimmungen:
    0
    Es kann auch sein, dass der nicht in der Gruppe "audio" ist ( in der /etc/groups)..war bei mir schon mal der Fall.
     
  8. bueno

    bueno Eroberer

    Dabei seit:
    16.02.2006
    Beiträge:
    69
    Zustimmungen:
    0
    Ort:
    Wien
    die befehle "alsaconf" und "alsamixer" kennt er nicht...kA wieso
     
  9. #8 gropiuskalle, 06.02.2007
    gropiuskalle

    gropiuskalle terra incognita

    Dabei seit:
    01.07.2006
    Beiträge:
    4.857
    Zustimmungen:
    0
    Ort:
    Berlin
    Probier doch mal, 'alsaconf' als root auszuführen (anders geht das auch nicht) - danach müsstest Du auch den 'alsamixer' aufrufen können (das ginge dann auch als normalsterblicher user) bzw. dessen grafisches frontend 'alsamixergui' (so dieser denn installiert ist). Dort findest Du jeweils Regler für 'Master' und 'PCM', die Du aktivierst und hochdrehst.
     
  10. rikola

    rikola Foren Gott

    Dabei seit:
    23.08.2005
    Beiträge:
    2.133
    Zustimmungen:
    0
    Das Programm 'alsamixer' liegt im Paket 'alsa-utils', Du kannst es mittels
    'apt-get install alsa-utils' installieren (als root, von einer Konsole aus). Dabei sollten auch alle andern alsa-bezogenen Pakete installiert werden, die notwendig sind.
     
  11. #10 cfalke, 17.02.2007
    Zuletzt bearbeitet: 17.02.2007
    cfalke

    cfalke Grünschnabel

    Dabei seit:
    17.02.2007
    Beiträge:
    1
    Zustimmungen:
    0
    Ich hab ebenso das gleiche Problem. Sound onboard via82xx. Treiber sind installiert mit alsa und lassen sich ebenso auch zB in xmms einstellen, aber es gibt einfach kein tönchen von sich. Habs auch schon versucht die klinke in die anderen ausgänge anzuschließen (dachte vlt. wird durch den treiber einfach der ausgang auf nen anderen kanal umgelegt) ebenfalls erfolglos. Keine systemsounds, keine Musik, ein garnichts. Nichma ein leisen knistern oder ploppen :(

    Ach und: hab eben meine Rechte als User überprüft: bin eingetragen in der Audio-Gruppe
     
  12. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  13. #11 Goodspeed, 17.02.2007
    Goodspeed

    Goodspeed Foren Gott
    Moderator

    Dabei seit:
    21.04.2004
    Beiträge:
    4.165
    Zustimmungen:
    1
    Ort:
    Dresden
    Hast Du über alsamixer die Kanäle mal "hochgedreht" und "ungemuted"?
    Digital-Ausgang (soweit im Mixer angezeigt) mal ausgeschaltet (gemutet)?
     
  14. regen

    regen Grünschnabel

    Dabei seit:
    01.03.2007
    Beiträge:
    8
    Zustimmungen:
    0
    also eigendlich solltet ihr erstmal ein lspci rauslassen damit wir sehen können ob das device auch wirklich erkannt wurde.

    wenn es sich beim abspielen um mp3 handelt braucht ihr dazu eine extra libary, das wisst ihr oder?

    wenn ihr direkt aus sourcen compiliert dann seht nach ob ihr auch im ./configure eure karte angegeben habt(--with-cards=xy). Weitere mögliche configure parameter findet ihr mit ./configure --help

    ach ja, --with-oss=no sollte bei stets blockiertem sound dev helfen, das tat es bei mir zumindest.
     
Thema: Kein Sound unter Debian
Besucher kamen mit folgenden Suchen
  1. debian kein sound

    ,
  2. debian ton geht nicht

    ,
  3. debian kein ton

    ,
  4. linux debian kein ton,
  5. debian sound geht nicht
Die Seite wird geladen...

Kein Sound unter Debian - Ähnliche Themen

  1. Kein Sound im Spiel - OpenAL error

    Kein Sound im Spiel - OpenAL error: Ich hab in einem Spiel leider keinen Sound. In der Konsole kommt in einer Endlosschleife immer diese Meldung: OpenAL error: 40964 (Audio_Tick...
  2. kein Sound bei sämtlichen Distributionen...

    kein Sound bei sämtlichen Distributionen...: Mahlzeit an alle UB-Leser, Ich habe ein Notebook von Dell (Alienware) [M17xR4]. Die verbaute Soundkarte hört auf den Namen "Creative Sound...
  3. Debian 6, kein Sound über Boxen, Über Kopfhörer schon.

    Debian 6, kein Sound über Boxen, Über Kopfhörer schon.: Moin Moin, ich habe ein mehr oder weniger großes (für euch wohl kleines?) Problem. Ich bekomme keinen Sound mehr aus meinen Laptop-Boxen. Aus...
  4. Debian Unstable kein Sound mehr auf einmal

    Debian Unstable kein Sound mehr auf einmal: Hallo Leute, ich bin nun seit ein paar Stunden am Verzweifeln! Ich habe alle Wiki/Tips/usw im Netzt abgegrast, kann aber nicht zu meinem Problem...
  5. Kein Surround Sound

    Kein Surround Sound: Hi, ich bekomme unter Totem, Xine und VLC keinen Surround Sound. In der Konsole funktionierts. Unter Totem ist 5.1 Kanal eingestellt. Mit:...