Digitus DN-7003GC Wlan-Adapter installieren

Dieses Thema im Forum "Internet, lokale Netzwerke und Wireless Lan" wurde erstellt von mister wxy, 06.10.2007.

  1. #1 mister wxy, 06.10.2007
    mister wxy

    mister wxy Grünschnabel

    Dabei seit:
    06.09.2007
    Beiträge:
    7
    Zustimmungen:
    0
    Hallo,

    habe vorgestern openSUSE 10.3 mit KDE installiert und habe versucht meinen WLAN-Adapter zu installieren.
    Dies hat aber nicht so richtig geklappt. Nun würde ich gerne von euch wissen, was ich falsch gemacht oder vergessen habe.
    Aber ich bin neu bei openSUSE und habe bis jetzt nur mit Windows Erfahrung gemacht. Also bitte alles für einen Einsteiger erklären, obwohl ich schon ein wenig weiß.:D

    Hier erstmal ein paar Daten:
    Marke: Digitus
    Modellnummer: DN-7003GC
    Chipsatz: SiS163u

    Code:
    tobias@Tobias-PC:~> su
    Passwort:
    Tobias-PC:/home/tobias # lsusb
    Bus 005 Device 010: ID 0457:0163 Silicon Integrated Systems Corp.
    Bus 005 Device 005: ID 04a9:10b6 Canon, Inc.
    Bus 005 Device 004: ID 0644:0200 TEAC Corp.
    Bus 005 Device 001: ID 0000:0000
    Bus 004 Device 001: ID 0000:0000
    Bus 003 Device 003: ID 05d8:4002 Ultima Electronics Corp. Artec Ultima 2000 (GT6801 based)/Lifetec LT9385 Scanner
    Bus 003 Device 002: ID 045e:00e1 Microsoft Corp.
    Bus 003 Device 001: ID 0000:0000
    Bus 002 Device 001: ID 0000:0000
    Bus 001 Device 005: ID 413c:2005 Dell Computer Corp.
    Bus 001 Device 004: ID 045e:00bd Microsoft Corp. Fingerprint Reader
    Bus 001 Device 001: ID 0000:0000
    Tobias-PC:/home/tobias # uname -r
    2.6.22.5-31-default
    Tobias-PC:/home/tobias # cat /etc/SuSE-release
    openSUSE 10.3 (X86-64)
    VERSION = 10.3
    So das sind erstmal die Daten. Folgende Pakete habe ich auch schon installiert:

    Code:
    ndiswrapper
    ndiswrapper-kmp-default
    Ein Windows-Treiber-Paket mit folgenden Dateien habe ich auch runtergeladen:

    Code:
    sis163u.cat
    SiS163u.INF
    SiS163u.sys
    SiSWBase.dll
    SiSWInst.dll
    SiSWPars.dll
    Dann habe ich im Order mit diesen Dateien eine Konsole mit diesem Inhalt ausgeführt:

    Code:
    tobias@Tobias-PC:~/Desktop/Windows XP/Windows XP> su
    Passwort:
    Tobias-PC:/home/tobias/Desktop/Windows XP/Windows XP # ndiswrapper -i 
    SiS163u.INF
    driver sis163u is already installed
    Tobias-PC:/home/tobias/Desktop/Windows XP/Windows XP # ndiswrapper -l
    sis163u : driver installed
            device (0457:0163) present
    Tobias-PC:/home/tobias/Desktop/Windows XP/Windows XP # depmod -a
    Tobias-PC:/home/tobias/Desktop/Windows XP/Windows XP # modprobe ndiswrapper
    Tobias-PC:/home/tobias/Desktop/Windows XP/Windows XP # iwconfig
    lo        no wireless extensions.
    
    eth0      no wireless extensions.
    Und beim letzten Befehl wird dann kein WLAN-Adapter angezeigt, wo doch eigentlich etwas stehen sollte.
    Nun würde ich mich über eine Lösung freuen, die mich weiterbringt.

    Mit freundlichen Grüßen
    Tobias
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. Gast1

    Gast1 Guest

    1. Konsole

    Code:
    sudo tail -f /var/log/messages
    2. Konsole

    Code:
    su
    
    Passwort
    
    rmmod ndiswrapper
    
    modprobe ndiswrapper
    Ausgaben aus _beiden_ Konsolen posten.

    Greetz,

    RM
     
  4. #3 Bâshgob, 06.10.2007
    Bâshgob

    Bâshgob freies Radikal

    Dabei seit:
    29.07.2004
    Beiträge:
    2.334
    Zustimmungen:
    0
    Ort:
    Hannover
  5. Gast1

    Gast1 Guest

    Ich wäre da nicht so skeptisch:

    http://www.google.de/search?q=0457:0163&ie=UTF-8&oe=UTF-8

    und

    Code:
    sis163u : driver installed
            device (0457:0163) present
    sieht auch ganz vernünftig aus, vor allem die zweite Zeile.

    Ich würde mal auf die Ausgabe der beiden Konsolen warten und ein Blick in meine Glaskugel sagt mir, daß da möglicherweise was mit "schlechter Magie" stehen wird.

    Greetz,

    RM
     
  6. #5 Bâshgob, 06.10.2007
    Bâshgob

    Bâshgob freies Radikal

    Dabei seit:
    29.07.2004
    Beiträge:
    2.334
    Zustimmungen:
    0
    Ort:
    Hannover
    Ich hab mich wohl auch verkuckt:

    Code:
    [B]79.[/B] Card: Digitus WLAN USB Adapter,USB 2.0,IEEE 802.11G,54Mbit
        * Info: 128-BIT WEP Encryption,WPA Support SIS Chipset
        * Chipset: sis163u
        * usbid: 0457:0163 Silicon Integrated Systems Corp.
        * Photo: http://www.digitus.info/scripts/digdetail.asp?artnr=DN-7003GC
        * Driver: http://www.services.digitus.info/data/download/treiber/dn7003gv.zip
        * Other: It worked here with ndiswrapper1.4. Just download the file above and install the WINDOWS XP driver
    
    TE: Ist die das? Dann sollte das Teil ja laufen.

    Und ich leg noch ein "dmesg|grep -i usb" sowie ein "lsusb" obendrauf ;)
     
  7. #6 mister wxy, 07.10.2007
    Zuletzt bearbeitet: 07.10.2007
    mister wxy

    mister wxy Grünschnabel

    Dabei seit:
    06.09.2007
    Beiträge:
    7
    Zustimmungen:
    0
    Schonmal danke für eure schnellen Antworten.
    Hier die Ausgaben:

    1. Konsole

    Code:
    tobias@Tobias-PC:~> sudo tail -f /var/log/messages
    Passwort:
    Oct  7 09:56:36 Tobias-PC smartd[3145]: Device: /dev/sdd, not ATA, no IDENTIFY DEVICE Structure
    Oct  7 09:56:36 Tobias-PC smartd[3145]: Device: /dev/sde, opened
    Oct  7 09:56:36 Tobias-PC smartd[3145]: Device: /dev/sde, not ATA, no IDENTIFY DEVICE Structure
    Oct  7 09:56:36 Tobias-PC smartd[3145]: Device: /dev/sdf, opened
    Oct  7 09:56:36 Tobias-PC smartd[3145]: Device: /dev/sdf, not ATA, no IDENTIFY DEVICE Structure
    Oct  7 09:56:36 Tobias-PC smartd[3145]: Monitoring 2 ATA and 0 SCSI devices
    Oct  7 09:56:36 Tobias-PC smartd[3232]: smartd has fork()ed into background mode. New PID=3232.
    Oct  7 09:56:37 Tobias-PC SuSEfirewall2: Firewall rules successfully set
    Oct  7 09:56:38 Tobias-PC hald: mounted /dev/sdf1 on behalf of uid 1000
    Oct  7 09:57:38 Tobias-PC sudo:   tobias : TTY=pts/1 ; PWD=/home/tobias ; USER=root ; COMMAND=/usr/bin/tail -f /var/log/messages

    2. Konsole

    Code:
    tobias@Tobias-PC:~> su
    Passwort:
    Tobias-PC:/home/tobias # rmmod ndiswrapper
    ERROR: Module ndiswrapper does not exist in /proc/modules

    3. Konsole

    Code:
    tobias@Tobias-PC:~> dmesg|grep -i usb
    usbcore: registered new interface driver usbfs
    usbcore: registered new interface driver hub
    usbcore: registered new device driver usb
    USB Universal Host Controller Interface driver v3.0
    uhci_hcd 0000:00:1d.0: new USB bus registered, assigned bus number 1
    usb usb1: new device found, idVendor=0000, idProduct=0000
    usb usb1: new device strings: Mfr=3, Product=2, SerialNumber=1
    usb usb1: Product: UHCI Host Controller
    usb usb1: Manufacturer: Linux 2.6.22.5-31-default uhci_hcd
    usb usb1: SerialNumber: 0000:00:1d.0
    usb usb1: configuration #1 chosen from 1 choice
    hub 1-0:1.0: USB hub found
    uhci_hcd 0000:00:1d.1: new USB bus registered, assigned bus number 2
    usb usb2: new device found, idVendor=0000, idProduct=0000
    usb usb2: new device strings: Mfr=3, Product=2, SerialNumber=1
    usb usb2: Product: UHCI Host Controller
    usb usb2: Manufacturer: Linux 2.6.22.5-31-default uhci_hcd
    usb usb2: SerialNumber: 0000:00:1d.1
    usb usb2: configuration #1 chosen from 1 choice
    hub 2-0:1.0: USB hub found
    uhci_hcd 0000:00:1d.2: new USB bus registered, assigned bus number 3
    usb usb3: new device found, idVendor=0000, idProduct=0000
    usb usb3: new device strings: Mfr=3, Product=2, SerialNumber=1
    usb usb3: Product: UHCI Host Controller
    usb usb3: Manufacturer: Linux 2.6.22.5-31-default uhci_hcd
    usb usb3: SerialNumber: 0000:00:1d.2
    usb usb3: configuration #1 chosen from 1 choice
    hub 3-0:1.0: USB hub found
    uhci_hcd 0000:00:1d.3: new USB bus registered, assigned bus number 4
    usb usb4: new device found, idVendor=0000, idProduct=0000
    usb usb4: new device strings: Mfr=3, Product=2, SerialNumber=1
    usb usb4: Product: UHCI Host Controller
    usb usb4: Manufacturer: Linux 2.6.22.5-31-default uhci_hcd
    usb usb4: SerialNumber: 0000:00:1d.3
    usb usb4: configuration #1 chosen from 1 choice
    hub 4-0:1.0: USB hub found
    usb 1-1: new full speed USB device using uhci_hcd and address 2
    ehci_hcd 0000:00:1d.7: new USB bus registered, assigned bus number 5
    ehci_hcd 0000:00:1d.7: USB 2.0 started, EHCI 1.00, driver 10 Dec 2004
    usb usb5: new device found, idVendor=0000, idProduct=0000
    usb usb5: new device strings: Mfr=3, Product=2, SerialNumber=1
    usb usb5: Product: EHCI Host Controller
    usb usb5: Manufacturer: Linux 2.6.22.5-31-default ehci_hcd
    usb usb5: SerialNumber: 0000:00:1d.7
    usb usb5: configuration #1 chosen from 1 choice
    hub 5-0:1.0: USB hub found
    usb 1-1: device not accepting address 2, error -71
    usb 5-3: new high speed USB device using ehci_hcd and address 4
    usb 5-3: new device found, idVendor=0644, idProduct=0200
    usb 5-3: new device strings: Mfr=1, Product=2, SerialNumber=3
    usb 5-3: Product: CA-200
    usb 5-3: Manufacturer: TEAC
    usb 5-3: SerialNumber: 0000030451F8
    usb 5-3: configuration #1 chosen from 1 choice
    usb 5-4: new high speed USB device using ehci_hcd and address 5
    usb 5-4: new device found, idVendor=04a9, idProduct=10b6
    usb 5-4: new device strings: Mfr=1, Product=2, SerialNumber=3
    usb 5-4: Product: iP4300
    usb 5-4: Manufacturer: Canon
    usb 5-4: SerialNumber: 35D30C
    usb 5-4: configuration #1 chosen from 1 choice
    usb 5-7: new high speed USB device using ehci_hcd and address 8
    usb 5-7: new device found, idVendor=0457, idProduct=0163
    usb 5-7: new device strings: Mfr=0, Product=0, SerialNumber=0
    usb 5-7: configuration #1 chosen from 1 choice
    usb 3-1: new low speed USB device using uhci_hcd and address 2
    usb 3-1: new device found, idVendor=045e, idProduct=00e1
    usb 3-1: new device strings: Mfr=1, Product=2, SerialNumber=0
    usb 3-1: Product: Microsoft Wireless Optical Mouse� 1.00
    usb 3-1: Manufacturer: Microsoft
    usb 3-1: configuration #1 chosen from 1 choice
    usb 3-2: new full speed USB device using uhci_hcd and address 3
    usb 3-2: new device found, idVendor=05d8, idProduct=4002
    usb 3-2: new device strings: Mfr=0, Product=0, SerialNumber=0
    usb 3-2: configuration #1 chosen from 1 choice
    usb 1-1: new full speed USB device using uhci_hcd and address 4
    usb 1-1: new device found, idVendor=045e, idProduct=00bd
    usb 1-1: new device strings: Mfr=1, Product=2, SerialNumber=3
    usb 1-1: Product: Microsoft� Fingerprint Reader
    usb 1-1: Manufacturer: Microsoft
    usb 1-1: SerialNumber: {4256D160-1044-4043-847E-6A3BB756A857}
    usb 1-1: configuration #1 chosen from 1 choice
    usb 1-2: new low speed USB device using uhci_hcd and address 5
    usb 1-2: new device found, idVendor=413c, idProduct=2005
    usb 1-2: new device strings: Mfr=1, Product=2, SerialNumber=0
    usb 1-2: Product: DELL USB Keyboard
    usb 1-2: Manufacturer: DELL
    usb 1-2: configuration #1 chosen from 1 choice
    Initializing USB Mass Storage driver...
    scsi6 : SCSI emulation for USB Mass Storage devices
    usb-storage: device found at 4
    usb-storage: waiting for device to settle before scanning
    drivers/usb/class/usblp.c: usblp0: USB Bidirectional printer dev 5 if 0 alt 0 proto 2 vid 0x04A9 pid 0x10B6
    usbcore: registered new interface driver usblp
    drivers/usb/class/usblp.c: v0.13: USB Printer Device Class driver
    usbcore: registered new interface driver usb-storage
    USB Mass Storage support registered.
    usbcore: registered new interface driver hiddev
    input: USB HID v1.11 Mouse [Microsoft Microsoft Wireless Optical Mouse� 1.00] on usb-0000:00:1d.2-1
    input: DELL DELL USB Keyboard as /class/input/input4
    input: USB HID v1.10 Keyboard [DELL DELL USB Keyboard] on usb-0000:00:1d.0-2
    usbcore: registered new interface driver usbhid
    drivers/hid/usbhid/hid-core.c: v2.6:USB HID core driver
    scsi 6:0:0:0: Direct-Access     TEAC     USB   HS-CF Card 4.00 PQ: 0 ANSI: 0
    scsi 6:0:0:1: Direct-Access     TEAC     USB   HS-xD/SM   4.00 PQ: 0 ANSI: 0
    scsi 6:0:0:2: Direct-Access     TEAC     USB   HS-MS Card 4.00 PQ: 0 ANSI: 0
    scsi 6:0:0:3: Direct-Access     TEAC     USB   HS-SD Card 4.00 PQ: 0 ANSI: 0
    usb-storage: device scan complete

    4. Konsole

    Code:
    tobias@Tobias-PC:~> lsusb
    Bus 005 Device 005: ID 04a9:10b6 Canon, Inc.
    Bus 005 Device 004: ID 0644:0200 TEAC Corp.
    Bus 005 Device 008: ID 0457:0163 Silicon Integrated Systems Corp.
    Bus 005 Device 001: ID 0000:0000
    Bus 004 Device 001: ID 0000:0000
    Bus 003 Device 003: ID 05d8:4002 Ultima Electronics Corp. Artec Ultima 2000 (GT6801 based)/Lifetec LT9385 Scanner
    Bus 003 Device 002: ID 045e:00e1 Microsoft Corp.
    Bus 003 Device 001: ID 0000:0000
    Bus 002 Device 001: ID 0000:0000
    Bus 001 Device 005: ID 413c:2005 Dell Computer Corp.
    Bus 001 Device 004: ID 045e:00bd Microsoft Corp. Fingerprint Reader
    Bus 001 Device 001: ID 0000:0000
    Kann es sein, dass du dich bei dem Kommando in der 2. Konsole verschrieben hast? Also ich kann auch falsch liegen, aber ich könnte es mir vorstellen.

    Gruß
    Tobias
     
  8. Gast1

    Gast1 Guest

    Nein, aber Du hast den zweiten Befehl vergessen.

    Das rmmod sollte nur sicher stellen, daß ndiswrapper nicht geladen ist, wenn Du anschliessend modprobe ausführst.

    Die Meldung besagte nur, daß ndiswrapper zu dem Zeitpunkt nicht geladen war.

    Also nochmal, die Ausgabe ist in dieser Form nichts wert.

    Greetz,

    RM
     
  9. #8 mister wxy, 07.10.2007
    mister wxy

    mister wxy Grünschnabel

    Dabei seit:
    06.09.2007
    Beiträge:
    7
    Zustimmungen:
    0
    Achso entschuldige, das hatte ich irgendwie nicht mehr beachtet.
    Jetzt weiß ich auch, was du mit deiner "Schwarzen Magie" meintest.:D
    Kann es also sein, dass es am 64-Bit System liegt?
    Hier erstmal die Ausgaben:

    1. Konsole

    Code:
    tobias@Tobias-PC:~> sudo tail -f /var/log/messages
    Passwort:
    Oct  7 11:59:16 Tobias-PC smartd[3128]: Device: /dev/sdd, not ATA, no IDENTIFY DEVICE Structure
    Oct  7 11:59:16 Tobias-PC smartd[3128]: Device: /dev/sde, opened
    Oct  7 11:59:16 Tobias-PC smartd[3128]: Device: /dev/sde, not ATA, no IDENTIFY DEVICE Structure
    Oct  7 11:59:16 Tobias-PC smartd[3128]: Device: /dev/sdf, opened
    Oct  7 11:59:16 Tobias-PC smartd[3128]: Device: /dev/sdf, not ATA, no IDENTIFY DEVICE Structure
    Oct  7 11:59:16 Tobias-PC smartd[3128]: Monitoring 2 ATA and 0 SCSI devices
    Oct  7 11:59:17 Tobias-PC smartd[3215]: smartd has fork()ed into background mode. New PID=3215.
    Oct  7 11:59:17 Tobias-PC SuSEfirewall2: Firewall rules successfully set
    Oct  7 11:59:20 Tobias-PC hald: mounted /dev/sdf1 on behalf of uid 1000
    Oct  7 12:00:10 Tobias-PC sudo:   tobias : TTY=pts/1 ; PWD=/home/tobias ; USER=root ; COMMAND=/usr/bin/tail -f /var/log/messages
    Oct  7 12:00:42 Tobias-PC su: (to root) tobias on /dev/pts/2
    Oct  7 12:01:10 Tobias-PC kernel: ndiswrapper version 1.47 loaded (smp=yes)
    Oct  7 12:01:10 Tobias-PC kernel: usb 5-7: reset high speed USB device using ehci_hcd and address 8
    Oct  7 12:01:10 Tobias-PC kernel: ndiswrapper (check_nt_hdr:150): kernel is 64-bit, but Windows driver is not 64-bit;bad magic: 010B
    Oct  7 12:01:10 Tobias-PC kernel: ndiswrapper (load_sys_files:216): couldn't prepare driver 'sis163u'
    Oct  7 12:01:10 Tobias-PC loadndisdriver: loadndisdriver: load_driver(358): couldn't load driver sis163u
    Oct  7 12:01:10 Tobias-PC kernel: ndiswrapper (load_wrap_driver:118): couldn't load driver sis163u; check system log for messages from 'loadndisdriver'
    Oct  7 12:01:10 Tobias-PC kernel: usbcore: registered new interface driver ndiswrapper

    2. Konsole

    Code:
    tobias@Tobias-PC:~> su
    Passwort:
    Tobias-PC:/home/tobias # rmmod ndiswrapper
    ERROR: Module ndiswrapper does not exist in /proc/modules
    Tobias-PC:/home/tobias # modprobe ndiswrapper
     
  10. #9 marsteini, 07.10.2007
    marsteini

    marsteini Videofreak

    Dabei seit:
    30.04.2007
    Beiträge:
    118
    Zustimmungen:
    0
    Ort:
    Regensburg/Burgweining
    Hallo,
    ich verwende einen ähnlichen Stick, nur das GC fehlt. Ich habe rausbekommen, das es auf der Homepage auch nen Linuxtreiber gibt. Unter XP 64 lief bei nicht mal der Windows Treiber, kann also schon dran liegen.

    lg
    marsteini
     
  11. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  12. #10 Gast1, 07.10.2007
    Zuletzt von einem Moderator bearbeitet: 07.10.2007
    Gast1

    Gast1 Guest

    Code:
    ndiswrapper (check_nt_hdr:150): 
    [B]kernel is 64-bit, but Windows driver is not 64-bit;[U]bad magic[/U]:[/B] 010B
    *Glaskugel auf Hochglanz polier*

    Ja und Nein.

    Es liegt daran, daß Du in einem 64 Bit System einen 32 Bit Windowstreiber einbinden willst.

    Nun hast Du zwei Möglichkeiten:

    1. Einen 64 Bit Windowstreiber finden und verwenden.

    2. Ein 32 Bit Linuxsystem installieren.

    (OK, dritte Möglichkeit=> 3. Andere WLAN-Karte kaufen.)

    http://www.sis.com/download/

    Für XP oder Server 2003 gibt es zwar eine extra Sektion 64 Bit, aber keinen Treiber für den WLAN-Stick.

    Naja, manche Betriebssysteme kommen halt etwas später richtig in der 64 Bit Welt an.

    Versuche es mit dem Treiber für Vista, der enthält einen Unterordner "Vista 64".

    Vorher die alte Installation des 32-Bit Treibers entfernen, einfach als root den entsprechenden Unterordner in /etc/ndiswrapper/ löschen.

    Wenn das nicht klappt, dann bleibt Dir nur noch 2 oder 3.

    Greetz,

    RM

    //Edit:

    Den Linuxtreiber habe ich auch gerade entdeckt den schaue ich mir mal an, ob der geeignet sein könnte

    //Edit2:

    Den angebotenen Linuxtreiber kann man wohl vergessen, der ist ja schon fast "antik":

    Code:
    Makefile - Usage of O_TARGET := sis160.o is obsolete in 2.6. Please fix!
    *LMAO*
     
  13. #11 mister wxy, 07.10.2007
    mister wxy

    mister wxy Grünschnabel

    Dabei seit:
    06.09.2007
    Beiträge:
    7
    Zustimmungen:
    0
    Danke für deine Hilfe, aber es kommt das Gleiche bei raus. Es geht also auch nicht mit diesem Treiber.
    Dann werde ich wohl die 32-Bit Version installieren müssen. Gut das ich die ja nicht noch runterladen muss. Hab ich schon fertig.
    Ich werde mich nochmal melden, falls ich wieder Probleme haben werde. Aber trotzdem schon einmal vielen Dank für deine Hilfe

    Gruß
    Tobias
     
Thema:

Digitus DN-7003GC Wlan-Adapter installieren

Die Seite wird geladen...

Digitus DN-7003GC Wlan-Adapter installieren - Ähnliche Themen

  1. [S] Treiber Digitus Wireless Lan PCI Adapter

    [S] Treiber Digitus Wireless Lan PCI Adapter: Hi, Ich bin neu hier und hab es einfach nicht hinbekommen. Nach scuhen im netz bin ich unweigerlich auf dieses Board gestoßen. Also zu...