Auf NTFS Schreiben

Dieses Thema im Forum "SuSE / OpenSuSE" wurde erstellt von devolo01, 11.01.2008.

  1. #1 devolo01, 11.01.2008
    devolo01

    devolo01 Tripel-As

    Dabei seit:
    04.09.2007
    Beiträge:
    150
    Zustimmungen:
    0
    Hi @ all

    Befinde mich mal wieder in einen Kleinen Dilemma wo ich doch nochmal eure Hilfe in Anspruch nehmen möchte.

    Ich Nutze auf meinen System ( Lappi) eine 120 GB Sata HDD

    auf dieser ist Suse 10.3, und Windows XP ( Wegen meines Studiums kann ich es leider nicht Runterhauen da die Software unter Suse nicht Läuft) installiert.

    Nun zu meinen Problem. Wenn ich jetzt von Suse aus Daten auf die /windows/D oder auch /c Partition kopieren möchte geht es leider nicht. Anders herum aber ohne Probs, sprich Daten von /windows/c zu /home/username/windowsdaten.

    Zurzeit behelfe ich mich mit Hilfe von explore2fs unter Windows was ich aber als sehr Umständlich ansehe.

    Daher meine Frage was genau mach ich Falsch das ich auf diese NTFS Partition nicht schreiben sondern nur lesen kann.

    Habe auch schon ein Wenig gegoogled und auch

    ntfs-3g gefunden dieses Installiert aber leider kein erfolg. Alle Informationen die ich sonst gefunden habe beziehen sich leider nur auf 2 HDD die man mounten soll.

    Aber bei mir liegt ja alles auf einer und da kann ich ja /windows nicht mounten oder?

    Danke euch für anregungen und Tips was genau ich zu beachten hätte.

    Gruß Dev
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. Gast1

    Gast1 Guest

    Im Gegenteil, Du musst eine Partition für Lese/Schreibzugriffe sogar mounten, egal ob externe oder interne HDD.
     
  4. sinn3r

    sinn3r Law & Order
    Moderator

    Dabei seit:
    28.12.2006
    Beiträge:
    2.764
    Zustimmungen:
    0
    Ort:
    Wentorf
    Es geht doch sicher um Partitionen...?

    desweiteren ist ein schöner ext2/3 treiber für win xp
    http://www.fs-driver.org/

    damit kannst du ext partitionen unter win ganz normal betreiben.
     
  5. #4 aspire_5652, 11.01.2008
    Zuletzt bearbeitet: 11.01.2008
    aspire_5652

    aspire_5652 Tripel-As

    Dabei seit:
    02.01.2008
    Beiträge:
    198
    Zustimmungen:
    0
  6. #5 gropiuskalle, 11.01.2008
    gropiuskalle

    gropiuskalle terra incognita

    Dabei seit:
    01.07.2006
    Beiträge:
    4.857
    Zustimmungen:
    0
    Ort:
    Berlin
    Dieses HowTo bezeiht sich jedoch auf Ubuntu, d.h. z.B. die Quellen oder auch einzelne Befehle (sudo...) lassen sich nicht auf das von devolo01 verwendete SuSE übertragen, deshalb poste ich sicherheitshalber mal die » SuSE-Anleitung «.
     
  7. #6 devolo01, 11.01.2008
    devolo01

    devolo01 Tripel-As

    Dabei seit:
    04.09.2007
    Beiträge:
    150
    Zustimmungen:
    0
    @sinn3r

    Danke dir für den Hinweiß aber Primär habe ich ja das Prob unter Suse nicht unter Windows dort arbeite ich mit explore2fs

    @kalla werde es mal mit der Anleitung versuchen danke dir

    @ RM wen ich /windows angezeigt bekomme, und darauf lesen kann wie auch Daten von der NTFS Partiton zu meinen /home holen kann ist es doch schon gemountet oder nicht ?

    Danke euch nochmal
     
  8. Mike1

    Mike1 Niederösterreicher

    Dabei seit:
    21.12.2006
    Beiträge:
    1.376
    Zustimmungen:
    0
    Ort:
    Österreich
    ja, wahrscheinlich musst duch auch bloß den ntfs-3g Treiber installieren und in der Zeile der NTFS-Partition in der /etc/fstab das "ntfs" in "ntfs-3g" ändern.
     
  9. Etosch

    Etosch Grünschnabel

    Dabei seit:
    11.01.2008
    Beiträge:
    3
    Zustimmungen:
    0
    Tja, ich schlage mich mit genau dem gleichen Problem ( und einem ähnlichen ) seit heute morgen rum. War inzwischen schon ein paar mal kurz davor Linux wieder von der Platte zu werfen - aber erstens habe ich leckeres Cookies and Cream Eis hier und zweitens bin ich Steinbock. Sind im übrigen meine ersten Gehversuche mit Linux. Daher auch meine Fragen, die ich nirgends nachlesen kann, weil die wahrscheinlich zu simpel für den versierten Anwender sind. Ich bin jedoch so neu, dass ich an den Systemkonfigurationen nichts kaputt machen möchte und daher lieber etwas vorsichtiger bin.

    Erstmal auf alle Fälle Danke an gropiuskalle - seit heute morgen intensiv auf der Suche, aber die Seite hatte ich noch nicht gefunden -> entweder bin ich doof ( keine Antworten darauf bitte ) oder die Dokumentation von opensuse ist vielleicht doch etwas unübersichtlich ...

    Problem 1: NTFS Partition - als User unter SuSE 10.3 besitze ich offenbar nur Leserechte und keine Schreibrechte. Als root besitze ich jedoch Schreibrechte. Nun habe ich ja brav gelernt, nicht als root zu arbeiten - allein es hakt :(

    Meine fstab - von Yast erzeugt:
    Code:
    /dev/disk/by-id/scsi-SATA_ST3500320AS_9QM072LQ-part7 /home                ext3       acl,user_xattr        1 2
    /dev/disk/by-id/scsi-SATA_ST3500320AS_9QM072LQ-part6 /                    ext3       acl,user_xattr        1 1
    /dev/disk/by-id/scsi-SATA_ST3500320AS_9QM072LQ-part1 /windows/C           ntfs-3g    users,gid=users,fmask=133,dmask=022,locale=de_DE.UTF-8 0 0
    /dev/disk/by-id/scsi-SATA_ST3500320AS_9QM072LQ-part5 swap                 swap       defaults              0 0
    proc                 /proc                proc       defaults              0 0
    sysfs                /sys                 sysfs      noauto                0 0
    debugfs              /sys/kernel/debug    debugfs    noauto                0 0
    usbfs                /proc/bus/usb        usbfs      noauto                0 0
    devpts               /dev/pts             devpts     mode=0620,gid=5       0 0
    /dev/fd0             /media/floppy        auto       noauto,user,sync      0 0
    /dev/disk/by-id/scsi-SATA_ST3500320AS_9QM072LQ-part8 /home/axel/Daten     ext3       acl,user_xattr        1 2
    Gefunden hatte ich, dass folgende Änderung mein Problem wahrscheinlich beheben kann:

    Den Bereich:
    Code:
    /dev/disk/by-id/scsi-SATA_ST3500320AS_9QM072LQ-part1 /windows/C           ntfs-3g    users,gid=users,fmask=133,dmask=022,locale=de_DE.UTF-8 0 0
    ändern in:
    Code:
    /dev/disk/by-id/scsi-SATA_ST3500320AS_9QM072LQ-part1 /windows/C           ntfs-3g    locale=de_DE.utf8,uid=1000,umask=0027 0 0
    Ist dieser Eintrag korrekt? Und ähm - dumme Frage am Rande - welchen Sinn hat es, dass es Yast gibt und ich dann die Zeilen doch per Hand eintragen muss, mit Werten, die nun sagen wir mal sich dem Laien nicht offensichtlich aufdrängen?

    Nach dem Link von gropiuskalle sollte es dann aber eher so aussehen, oder?
    Code:
    /dev/disk/by-id/scsi-SATA_ST3500320AS_9QM072LQ-part1 /windows/C           ntfs-3g    user,users,gid=users,umask=0002
    Ähm... wie denn nun? ?(

    Problem 2: Die Partition, die unter Daten eingehängt ist ist ebenfalls nur für root beschreibar. Offensichtlich ist dieser Fehler von mir aber so - sagen wir mal freundlich ausgedrückt: "kreativ", dass ich nirgends dazu eine Hilfe gefunden habe.

    Ich habe mich als user angemeldet und den Ordner Daten unter /home/axel/ erstellt. Daraufhin habe ich Yast gestartet, das Adminpasswort eingegeben, die Partition erstellt und als mountpoint den obigen in Yast eingegeben. Nun gehört das Verzeichnis root und als user kann ich nur lesend darauf zugreifen.

    Als Lösung habe ich jetzt eine Konsole geöffnet ( hat ein wenig gedauert, bis ich eine gefunden hatte und ungefähr eine Ahnung hatte, was man da eingeben könnte ), mir root Rechte mit su geholt, und den Ordner einfach mittels chown an Axel:user übergeben.

    Tja - kann man das so machen, oder bin ich da gerade auf dem Holzweg? Zur Zeit funktioniert es zumindest...

    Vielleicht mag mir ja jemand helfen - vielen Dank im Vorraus!

    Cu, Axel
     
  10. #9 bytepool, 11.01.2008
    Zuletzt bearbeitet: 11.01.2008
    bytepool

    bytepool Code Monkey

    Dabei seit:
    12.07.2003
    Beiträge:
    791
    Zustimmungen:
    0
    Ort:
    /home/sweden/göteborg
    hi,

    @Etosch
    Bei dir scheint doch bis auf die Rechte schon alles zu klappen. Prinzipiell kannst du die Rechte natuerlich nach dem mounten noch aendern (mit chown und chmod), aber angenehmer ist es natuerlich wenn das schon automatisch beim mounten passiert.
    Ich mache das z.B. indem ich explizit den user und die gruppe fuer meine windows partitionen angebe, mit uid=1000,gid=1000. Der erste angelegte user unter Linux hat normalerweise eine UID und GID von 1000. Eventuell kann man da statt der der Nr. auch den (User-)Namen an sich eintragen, ist wohl Geschmacksache wie man's lieber hat.

    edit:
    Ich wuerde also wahrscheinlich einfach nur aus der aktuellen Zeile diese hier machen:
    Code:
    /dev/disk/by-id/scsi-SATA_ST3500320AS_9QM072LQ-part1 /windows/C           ntfs-3g    users,uid=1000,gid=users,fmask=133,dmask=022,locale=de_DE.UTF-8 0 0
    
    Also einfach noch uid=1000 hinzufuegen, damit gibst du dem User mit der uid 1000 die Rechte an /windows/C.
    Ich glaube uid=username funktioniert auch.

    mfg,
    bytepool
     
  11. Gast1

    Gast1 Guest

    Nein, genau das macht man auf NTFS/FAT, welche keine unixoiden Zugriffsrechte kennen, eben nicht.

    Das danach beschriebene mit umask, gid und uid ist der Schlüssel und von chown/chmod sollte man in diesem Fall die Finger lassen.
     
  12. #11 bytepool, 11.01.2008
    Zuletzt bearbeitet: 11.01.2008
    bytepool

    bytepool Code Monkey

    Dabei seit:
    12.07.2003
    Beiträge:
    791
    Zustimmungen:
    0
    Ort:
    /home/sweden/göteborg
    Stimmt, du hast Recht, da war was... Ist natuerlich Bloedsinn meinerseits, sorry fuer die Falschinformation. Ich benutze zum Glueck kaum noch NTFS oder FAT und die letzten Ueberbleibsel werden in naher Zukunft sogar komplett von meiner Platte gebannt.

    mfg,
    bytepool
     
  13. #12 devolo01, 11.01.2008
    devolo01

    devolo01 Tripel-As

    Dabei seit:
    04.09.2007
    Beiträge:
    150
    Zustimmungen:
    0
    Danke euch nocheinmal

    Also wollte jetzt nach dieser Anleitung vorgehen
    Code:
     Einrichtung der NTFS Schreibunterstützung
    [bearbeiten]
    openSUSE 10.3
    
    Zuerst ändern sie die Parameter, mit der die NTFS-Partition eingebunden wird. Hierzu öffnen sie die /etc/fstab und fügen den Parameter umask=0002 ein.
    
    Beispiele
    
    PATA (IDE) und SATA Festplatte
    
    #Device    Mountpoint  Filesystem  Parameters
    /dev/sda1  /windows/C  ntfs-3g     user,users,gid=users,umask=0002  0 0
    
    Verwendung von Disklabels
    
    #Device                 Mountpoint  Filesystem  Parameters
    /dev/disk/by-label/win  /windows/C  ntfs-3g     user,users,gid=users,umask=0002  0 0
    
    Doch meine fstab sieht etwas anders aus als das Beispiel deswegen frag ich lieber

    so sieht meine aus

    Code:
    /dev/disk/by-id/scsi-SATA_ST9120821AS_5PL06QF9-part7 /                    ext3       acl,user_xattr        1 1
    /dev/disk/by-id/scsi-SATA_ST9120821AS_5PL06QF9-part3 /home                ext3       acl,user_xattr        1 2
    /dev/disk/by-id/scsi-SATA_ST9120821AS_5PL06QF9-part1 /windows/C           ntfs-3g    users,gid=users,fmask=133,dmask=022,locale=de_DE.UTF-8 0 0
    /dev/disk/by-id/scsi-SATA_ST9120821AS_5PL06QF9-part5 /windows/D           ntfs-3g    users,gid=users,fmask=133,dmask=022,locale=de_DE.UTF-8 0 0
    /dev/disk/by-id/scsi-SATA_ST9120821AS_5PL06QF9-part6 swap                 swap       defaults              0 0
    proc                 /proc                proc       defaults              0 0
    sysfs                /sys                 sysfs      noauto                0 0
    debugfs              /sys/kernel/debug    debugfs    noauto                0 0
    usbfs                /proc/bus/usb        usbfs      noauto                0 0
    devpts               /dev/pts             devpts     mode=0620,gid=5       0 0
    
    Und ist es dann richtig das es so aussehen muss ?
    Code:
    /dev/disk/by-id/scsi-SATA_ST9120821AS_5PL06QF9-part1 /windows/C           ntfs-3g    users,gid=users,umask=0002  0 0,fmask=133,dmask=022,locale=de_DE.UTF-8 0 0
    
    Kann es aber auch sein das es ein Prob mit den Rechten ist da als root kann ich ohne Probs auf diesen NTFS Partitionen arbeiten ?

    Danke euch noch einmal
     
  14. towo

    towo Haudegen

    Dabei seit:
    16.05.2003
    Beiträge:
    649
    Zustimmungen:
    1
    Ort:
    Pößneck
    Code:
    /dev/disk/by-id/scsi-SATA_ST9120821AS_5PL06QF9-part1 /windows/C           ntfs-3g    users,umask=0,locale=de_DE.UTF-8   0  0
    Dann kann Jeder schreiben.
     
  15. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  16. #14 devolo01, 11.01.2008
    devolo01

    devolo01 Tripel-As

    Dabei seit:
    04.09.2007
    Beiträge:
    150
    Zustimmungen:
    0
    Super Danke euch noch einmal, es funktioniert alles ohne Probs.

    Danke euch Gruß Dev
     
  17. Etosch

    Etosch Grünschnabel

    Dabei seit:
    11.01.2008
    Beiträge:
    3
    Zustimmungen:
    0
    @towo

    Danke - so wie allen anderen auch hier im Thread - tut mir ja leid, dass ich mich so dumm anstelle... aber irgendwie habe ich halt ein Brett vorm Kopf - vielleicht liegt das daran, dass ich zu lange mit Windows zu tun hatte und mir das offensichtliche nicht mehr auffällt...

    Also, das was towo geschreiben hat funktioniert bei mir ohne Probleme.

    Code:
    /dev/disk/by-id/scsi-SATA_ST3500320AS_9QM072LQ-part1 /windows/C           ntfs-3g    users,umask=0,locale=de_DE.UTF-8   0  0
    Und jetzt kommt das für Euch wahrscheinlich Unglaubliche: Ich habe noch ein Problem mit einer anderen Partition...

    Code:
    /dev/disk/by-id/scsi-SATA_ST3500320AS_9QM072LQ-part8 /home/axel/Daten     ext3       acl,user_xattr 1 2
    Diese Partition ist nur durch root beschreibar. Das zu ändern ist für einen Linux Neuling nicht so einfach, wie es Euch wahrscheinlich klingt.

    Ich hab versucht die Parameter uid=1000,gid=100 einzufügen oder als einzige zu setzen, ich habe umask= mit den Parametern 0 oder 000 oder 007 probiert ...

    Alles führt nur dazu, dass ich von Yast z.b. folgende Fehlermeldung erhalte:

    Code:
    Systemfehlercode: -3003
    
    mount -t ext3 -ouid=1000,gid=100,umask=007 /dev/sda8 /home/axel/Daten:
    mount: wrong fs type, bad option, bad superblock on /dev/sda8, 
    missing codepage or helper program, or other error
    Tja - und da steht ich armer Tor nun und hadere mit der Welt, weil ich sowas einfaches anscheinend nicht gebacken bekomme.

    Als Umweg habe ich gefunden, nach dem mounten den zugehörigen Ordner mittels chown mir als Nutzer zu übertragen. Aber weiter oben habe ich gelesen, dass man gerade das nicht machen soll. Tja, vielleicht mag sich ja noch jemand dis Sache mal angucken. Danke im Vorraus.

    Cu, Axel
     
Thema:

Auf NTFS Schreiben

Die Seite wird geladen...

Auf NTFS Schreiben - Ähnliche Themen

  1. Schreiben auf NTFS ???

    Schreiben auf NTFS ???: Hallo Ihr Alle, kann ich auch auf NTFS speichern? Das wäre sehr hilfreich. Gruß, Matz
  2. NTFS lesen und schreiben

    NTFS lesen und schreiben: nachdem ich hier mit cedega einen fehlstart in diesem forum hatte, wollte ich mich einmal entschuldigen. nun ist noch ein problem aufgetreten:...
  3. kann auf ntfs nix schreiben (auch nicht als root)

    kann auf ntfs nix schreiben (auch nicht als root): hall, ich habe mir leztens die neue version von debian runtergeladen, installiert , xampp usw draufgemacht, alles kein problem, nur an der fstab...
  4. Mit Knoppix auf NTFS schreiben.

    Mit Knoppix auf NTFS schreiben.: Hallo leuz. Es sollte doch möglich sein, mit Knoppix 5.1.1 (DVD-Version) auf eine NTFS-Platte zu schreiben. ---------- Mit NTFS-3G ist das...
  5. mit Knoppix auf NTFS schreiben

    mit Knoppix auf NTFS schreiben: Hallo! Ich habe mal eine Frage: Kann man nun endlich zuverlässig mit irgendwelchen Tricks auf NTFS schreiben? kann man sich selbst eine ISO...