x will nicht

Diskutiere x will nicht im Debian/Ubuntu/Knoppix Forum im Bereich Linux Distributionen; also, ich wollte das nun mal wissen und hab mir kurzerhand einmal debian 3 runtergeladen. so, installation ging an und für sich gut. auch...

  1. #1 gelber_hund, 13.09.2002
    gelber_hund

    gelber_hund Pseudo-Root

    Dabei seit:
    07.09.2002
    Beiträge:
    137
    Zustimmungen:
    0
    Ort:
    Hessen
    also, ich wollte das nun mal wissen und hab mir kurzerhand einmal debian 3 runtergeladen. so, installation ging an und für sich gut. auch netzwerkkonfiguration und treiber machten keine probleme.

    nur x bekomme ich nicht zum laufen (scheint ja bei debian nicht ganz einfach zu sein, was man so liest...) naja, ich hab hier mal im forum gesucht, hab allerdings keinen passenden beitrag gefunden, also frag ich mal:

    beim start kommt folgende meldung:

    fatal server error:
    no screens found

    ...

    x connection to: 0.0 broken (xplicit kill or server shutdown)

    ich hab auch mal in die Xfree86-Config-4 geschaut, doch so ganz schlau werde ich daraus nicht.

    hab eine gf3-ti 200 und als treiber "nv" ausgewählt (da fällt diese ja auch drunter)

    ach so, nachdem beim booten x nicht funktioniert startet sich so etwas wie eine art minimaldesktop, wo man einstellungen vornehmen kann (die leider auch zu nichts geführt hatten), jedenfalls geht hier auch die maus nicht

    an sich fände ich die distri ganz interessant, immerhin lernt man dabei um einiges mehr, als wenn alles mit einem klick geregelt ist :D aber ich stehe im moment wirklich wie der ox vorm berg.

    vielleicht hat ja jemand einen rat
     
  2. Anzeige

    Anzeige

    Wenn du mehr über Linux erfahren möchtest, dann solltest du dir mal folgende Shellkommandos anschauen.


    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. Andre

    Andre Foren Gott

    Dabei seit:
    01.04.2002
    Beiträge:
    3.876
    Zustimmungen:
    0
    hab gerade mal nen bissle gegoogelt...
    und das mit dem nv treiber und der geforce scheint nen speziellen kernel zu erfordern...hab aber leider noch keinen Link dazu (oder zu einer Anleitung) gefunden...

    XFree in der Version 4.2 ist auch ein muss!

    ...sorry wenn ich dir noch nich sonderlich weiterhelfen kann, aber ich such mal fleissig weiter ;)

    edit:
    http://channel.debian.de/faq/ch-confighw.html

    hier gehts um die kernel sources des nvidia kernels....
     
  4. #3 Tux-Forever, 13.09.2002
    Tux-Forever

    Tux-Forever Linuxer

    Dabei seit:
    07.07.2002
    Beiträge:
    932
    Zustimmungen:
    0
    Ort:
    Rheinland Pfalz
    also ich habe genau die gleiche grakka wie du und habe es hinbekommen
    bei der installation von debian fragt er dich doch ob du die xfreeconfig oder sowas mit deb.conf konfigurieren willst oder so da habe ich beim ersten mal ja angegeben und hatte das gleiche problem also nochmal installaiert und mal nein dort angegeben ok gut nach der installation lief x immernoch nicht aber wenn Xf86config nochmal x konfigurierst müsste es laufen so war es bei mir
    hoffe ich konnte ein bissel helfen :)

    ps:
    hab noch das normale xfree von debian drauf ;)
     
  5. #4 Dr_Ompaa, 13.09.2002
    Dr_Ompaa

    Dr_Ompaa Hobbyphilosoph

    Dabei seit:
    30.04.2002
    Beiträge:
    473
    Zustimmungen:
    0
    Ort:
    Stuttgart/Germany
    Vielleicht gehts mit xf68cfg?
    Hast du schon XDM drauf (oder kdm, gdm, twm)?
     
  6. #5 gelber_hund, 13.09.2002
    gelber_hund

    gelber_hund Pseudo-Root

    Dabei seit:
    07.09.2002
    Beiträge:
    137
    Zustimmungen:
    0
    Ort:
    Hessen
    kdm, gdm, twm sind installiert (gmd wird als default gestartet. allerdings ohne mausunterstützung, und groß einstellen konnte ich bei dem x configuration tool nichts, jedefalls hat nix geklappt :( )

    nun ja, ich habe mal mit dpkg-reconfigure xserver-xfree86 neu zu konfigurieren und auch mit XF86Config, allerdings kann ich mit einigen dingen nicht direkt etwas anfangen (Horizontale und Vertikale Frequenz, video memory), ich kann mir zwar zusammenreimen, was es bedeutet, allerdings kenne ich nicht die entsprechenden daten zu meinen geräten (ist ja ein dringender verdacht da, dass es daran liegen könnte ;) , wie kann ich denn an diese daten kommen?)
     
  7. Andre

    Andre Foren Gott

    Dabei seit:
    01.04.2002
    Beiträge:
    3.876
    Zustimmungen:
    0
    vieleicht postet dir Tux4ever dir ja mal seine config files??
     
  8. #7 gelber_hund, 14.09.2002
    gelber_hund

    gelber_hund Pseudo-Root

    Dabei seit:
    07.09.2002
    Beiträge:
    137
    Zustimmungen:
    0
    Ort:
    Hessen
    also, Horizontale und Vertikale Frequenz, video memory hab ich mit sisoft sandra rausbekommen (Horizontale und Vertikale Frequenz = 30.0 - 70.0, 50.0 - 160.0 und video memory = 63mb (also 64512k))

    hab das auch bei der config so angegeben, jedoch ohne erfolg.
     
  9. #8 gelber_hund, 14.09.2002
    gelber_hund

    gelber_hund Pseudo-Root

    Dabei seit:
    07.09.2002
    Beiträge:
    137
    Zustimmungen:
    0
    Ort:
    Hessen
    mir ist gerade eine zeile über der oben geschriebenen fehlerzeile aufgefallen, die ich vorher übersehen habe. da heißt es:

    (EE) Screen(s) found, but none have a usable configuration
     
  10. Andre

    Andre Foren Gott

    Dabei seit:
    01.04.2002
    Beiträge:
    3.876
    Zustimmungen:
    0
  11. #10 gelber_hund, 14.09.2002
    gelber_hund

    gelber_hund Pseudo-Root

    Dabei seit:
    07.09.2002
    Beiträge:
    137
    Zustimmungen:
    0
    Ort:
    Hessen
    so, ich habs eben hinbekommen, hab diesmal bei der config einige module rausgelassen und nun gehts. soweit schon mal herzlichen dank :D

    nur diese treiber wollen nun nicht (jo, hab immer noch die "nv" treiber). also, ich hab die *.deb pakete installiert, hat auch geklappt. danach habe ich in der xf86config-4 unter device driver "nv" auf "nvidia" geändert und bei modules "load glx" hinzugefügt.

    jetzt kommt wieder die gleiche meldung "no screens found", wenn ich wieder auf "nv" nehme, startet x.
     
  12. Andre

    Andre Foren Gott

    Dabei seit:
    01.04.2002
    Beiträge:
    3.876
    Zustimmungen:
    0
    hasst du die Horizontale und Vertikale Frequenz usw wieder richtig eingetragen?
     
  13. #12 gelber_hund, 14.09.2002
    gelber_hund

    gelber_hund Pseudo-Root

    Dabei seit:
    07.09.2002
    Beiträge:
    137
    Zustimmungen:
    0
    Ort:
    Hessen
    ja, das hat alles noch gestimmt. nur stand bei driver eben noch "nv", das hab ich in "nvidia" umgeändert.
     
  14. Andre

    Andre Foren Gott

    Dabei seit:
    01.04.2002
    Beiträge:
    3.876
    Zustimmungen:
    0
    hmmmm....


    die module sind aber geladen worden oder???
    lsmode?
     
  15. #14 gelber_hund, 14.09.2002
    gelber_hund

    gelber_hund Pseudo-Root

    Dabei seit:
    07.09.2002
    Beiträge:
    137
    Zustimmungen:
    0
    Ort:
    Hessen
    oh je, da weiß ich nun gar nicht, wo man das überprüfen kann, ob die geladen wurden

    in der config stehen auf jedenfall nur "GLcore" und hinzugefügt von mir "glx".

    installiert sind die treiber aber auf jeden fall, wenn ich im package manager nachsehe, stehen sowohl "nvidia-glx-src", wie auch "nvidia-kernel-src" unter DEBAPT/contrib/X11

    muss ich mit denen vorher noch etwas machen, bevor ich die xf86config-4 verändern kann?
     
  16. Andre

    Andre Foren Gott

    Dabei seit:
    01.04.2002
    Beiträge:
    3.876
    Zustimmungen:
    0
    mach mal als "root"
    lsmod auf der konsole...das zeigt dir die geladenen module....
    da sollte normalerweise was von den teilen zu sehen sein...
     
  17. #16 gelber_hund, 14.09.2002
    gelber_hund

    gelber_hund Pseudo-Root

    Dabei seit:
    07.09.2002
    Beiträge:
    137
    Zustimmungen:
    0
    Ort:
    Hessen
    da kommt nur folgendes:

    Module Size Used by
    dmfe 11684 1
    af_packet 6136 0 (unused)
     
  18. Andre

    Andre Foren Gott

    Dabei seit:
    01.04.2002
    Beiträge:
    3.876
    Zustimmungen:
    0
    puhhh...

    versuch mal root das teil selber zu laden...
    "insmod NVdriver"

    ..ich hoffe er findet das auch ;)
     
  19. #18 gelber_hund, 14.09.2002
    gelber_hund

    gelber_hund Pseudo-Root

    Dabei seit:
    07.09.2002
    Beiträge:
    137
    Zustimmungen:
    0
    Ort:
    Hessen
    leider nein, kein modul mit diesem namen gefunden :(
     
  20. Andre

    Andre Foren Gott

    Dabei seit:
    01.04.2002
    Beiträge:
    3.876
    Zustimmungen:
    0
    also neuer versuch...

    hab diese schicke anleitung gefunden...die sieht so aus als könnte es damit klappen....
    ##############schnipp################
    xraver - 28.03.2002 21:30:36
    Titel: Wie installiere ich die NVidiA Grafikkarten-Treiber?
    Diese Anleitung beschäftigt sich mit der Einrichtung der NVIDIA Treiber vom Hersteller NVIDIA. Folgende Features können danach genutzt werden:
    -Hardware Beschleunigter OpenGL Support
    -TwinView
    -TV-Out

    Für Debian Woody und Sid. Zur Installation muß man als root eingelogt sein.

    1. Was wird benötigt
    -Eine Grafikkarte mit einer NVIDIA GPU
    -XFree86 ab der Version 4.1
    -Linux Kernel ab 2.2.12 oder höher
    -NVIDIA Kernel Treiber ( http://www.nvidia.com/view.asp?PAGE=linux )
    -NVIDIA GLX Treiber ( http://www.nvidia.com/view.asp?PAGE=linux )
    -gcc


    2. Festellen der vorhandenen Konfiguration
    Folgende Punkte der Checkliste sollten zur problemlosen Installation und dem Betrieb der Karte positiv ausfallen. Sollten Fehler auftreten, dann müssen die fehlenden Komponenten wie in Punkt 3 beschrieben nachinstalliert werden.

    Kann der Treiber auf die Karte angewandt werden?
    Folgende GPU's werden vom aktuellen Treiber unterstützt:
    RIVA TNT, RIVA TNT2, RIVA TNT2 Ultra, Vanta, RIVA TNT2 Model 64, Aladin TNT2 und alle Karten der G-Force Klasse.
    Karten mit einem Riva128/128ZX Chip werden nur vom freien "nv" Treiber des XFree86 Projekts unterstützt.
    Um zu überprüfen welche Karte in euren System vorhanden ist nutzt Ihr das Komando lspci.
    So könnte das aussehen:

    Code:


    lspci | grep VGA
    01:05.0 VGA compatible controller: nVidia Corporation NV11 (GeForce2 MX) (rev a1)



    Welche XFree86 Version ist installiert?
    Zum Betrieb wird zwingend XFree86 ab Version 4.1 oder höher benötigt.
    Festsellen lässt sich das durch den Aufruf:

    Code:


    XFree86 -version



    Kernel Headers oder Sourcen vorhanden?
    Um Festzustellen, ob die Kernel-Headers oder Kernel Sourcen vorhanden sind geht ihr einfach in das Verzeichnis /usr/src/ und schaut ob das Verzeichnis linux vorhanden ist.


    Code:


    cd /usr/src/



    Welche Kernel Version ist vorhanden?
    Mit dem Aufruf von uname -r kann man sich problemlos die Kernelversion anzeigen lassen. Es sollte aber ein aktueller 2.4'er Kernel verwendet werden.

    Ist der gcc Kompiler vorhanden?
    Überprüfen lässt sich das mit dem Aufruf:

    Code:


    gcc -v



    3. Nachinstallieren nicht vorhandener Komponenten

    XFree86 ist nicht in der benötigten Version vorhanden.
    XFree86 Version 4.x ist in den Debian Versionen Woody und Sid enthalten.
    Potato-Benutzer werden noch eine eine 3.x Version vorfinden, und müssen sich eine neue Version installieren. Wie das gemacht wird beschreibt ein anderes Turiturial.

    Kernel Sourcen oder Header sind nicht vorhanden.
    Hier solltet ihr euch entscheiden. Möchtet ihr euch später einmal euren eigenen Kernel bauen, so solltet ihr euch die Kernel-Sourcen besorgen.
    Möglich ist das durch den Aufruf von:

    Code:


    apt-get install kernel-source-<version>



    Wollt ihr zum Beispiel den Kernel 2.4.17 verwendem, dann wäre es:

    Code:


    apt-get install kernel-source-2.4.17


    Alternativ könnt ihr euch die Orginal Quellen von http://www.kernel.org besorgen.

    Jetzt bewegt ihr euch in das Verzeichnis /usr/src und entpackt die Kernelquellen.

    Code:


    bzip2 -d kernel-source-2.4.17.tar.bz2
    tar xvf kernel-source-2.4.17.tar


    Die Kernelquellen befinden sich im Verzeichnis kernel-source-2.4.17 .
    Jetzt müssen wir einen link namens linux anlegen.

    Code:


    ln -s kernel-source-2.4.17 linux



    Alternativ kann man auch die Kernel-Headers des verwendeten Kernel verwenden.
    Wenn man z.B. Plattenplatz sparen will, oder seinen Kernel nicht neu bauen will, ist das von Vorteil.
    Die Kernel-Headers besorgen wir uns mit den Aufruf:

    Code:


    apt-get install kernel-headers-<kernel-version>



    Für den Kernel 2.4.17 wäre es dann

    Code:


    apt-get install kernel-headers-2.4.17


    Danach bewegen wir uns in das Verzeichnis /usr/src und legen einen Link an.

    Code:


    ln -s kernel-headers-2.4.17 linux



    Der gcc Kompiler ist nicht vorhanden.
    Den gcc Kompiler könnt ihr durch den folgenden Aufruf installieren:

    Code:


    apt-get install gcc



    4. Installation
    Die Installation der Treiber selber gestaltet sich schnell und einfach.
    Zuerst Installieren wir MesaGL für XFree86 und entfernen Glide.

    Code:


    apt-get install xlibmesa3
    apt-get remove '.*glide.*'



    Jetzt bewegen wir uns in das Verzeichnis /usr/src und downloaden die NVIDIA Treiber.

    Code:


    wget http://205.158.109.140/XFree86_40/1.0-2802/NVIDIA_GLX-1.0-2802.tar.gz
    wget http://205.158.109.140/XFree86_40/1.0-2802/NVIDIA_kernel-1.0-2802.tar.gz


    Hinweiss: Sollte das Programm wget nicht vorhanden sein so lässt sich das duch den folgenden Aufruf nachinstallieren.

    Code:


    apt-get install wget



    Danach werden die Pakete entpackt.

    Code:


    tar xvfz NVIDIA_GLX-1.0-2802.tar.gz
    tar xvfz NVIDIA_kernel-1.0-2802.tar.gz



    Jetzt beginnt die eigentliche Installation.

    Code:


    cd NVIDIA_GLX-1.0-2802
    make install
    cd ..
    cd NVIDIA_kernel-1.0-2802
    make install



    Wenn diese Schritte ohne Fehler abgearbeitet wurden, ist der Treiber installiert.

    5. Konfiguration
    Jetzt muss nur noch die Konfiguration von XFree86 angepasst werden.
    Dazu öffnet ihr die Datei /etc/X11/XF86Config-4 mit einen Editor eurer Wahl. Möglicherweise heißt die Datei auch nur XF86Config.
    Ich bevorzuge mcedit. ( apt-get install mc, falls nicht vorhanden)

    In der Section "Modules" müssen folgende Änderungen vorgenommen werden:
    Die Zeile LOAD "GLcore" entfernen oder ein # voranstellen.
    Die Zeile LOAD "glx" einfügen.

    Weiter unten befindet sich die Section "Device"
    Die müsst ihr wie folgt abändern.

    Code:


    Section "Device"
    Identifier "nvidia"
    Driver "nvidia"
    Option "NvAGP" "3"
    EndSection



    Wenn vorher die nv Treiber des XFree86 Projekt's verwendet wurden dann kann man einfach "nv" durch nvdia ersetzen.
    Das war's. Jetzt müsst ihr X neu starten. Manchmal kommt es vor, daß man nach der Treiberinstallation das System neu starten muss. Sollten Fehler auftreten kann man also einen Neustart in Betracht ziehen.

    6. Tips

    NVIDIA Logo
    Möchte man das NVIDIA Logo beim starten von X nicht sehen, so muss man die Section Device um folgenden Eintrag erweitern:

    Code:


    Option "NoLogo" "1"



    AGP Konfiguration
    Auch die Benutzung des AGP Modus lässt sich beeinflussen.

    Option "NvAgp" "0" # Schaltet den AGP-Support aus.
    Option "NvAgp" "1" # Benutzt NVAGP
    Option "NvAgp" "2" # Benutzt AGPGART - wenn vorhanden
    Option "NvAGP" "3" # Benutze AGPGART - wenn nicht vorhanden dann benutze NVAGP

    Die entsprechende Auswahl kann man in der XFree86Config-4 ändern.
    #########schnapp###########
    PS: thx! an den Author...!
     
  21. #20 gelber_hund, 14.09.2002
    gelber_hund

    gelber_hund Pseudo-Root

    Dabei seit:
    07.09.2002
    Beiträge:
    137
    Zustimmungen:
    0
    Ort:
    Hessen
    ja, das hört sich alles schon vielversprechend an :]

    ging auch soweit alles gut, bis zu dem punkt, an dem NVIDIA_kernel-1.0-2802 installiert werden soll.

    hier bekomme ich einen recht langen warnhinweis, dass ich das NVkernel modul mit einem compiler kompilieren will, der sich vom unterscheidet, mit dem der laufende kernel kompiliert wurde. ich könnte das mit einer option ignorieren oder die CC environment variable auf den compiler umschreiben, mit dem der kernel kompiliert wurde...

    und am ende in fetter roter schrift:
    failed cc sanity check, bailing out!
    make: *** [gcc-check] Error 1

    bei mir scheint auch gar nichts reibungslos zu klappen :rolleyes:
     
Thema:

x will nicht

Die Seite wird geladen...

x will nicht - Ähnliche Themen

  1. bash: ash: Kommando nicht gefunden

    bash: ash: Kommando nicht gefunden: seit einem der letzten updates habe ich beim öffnen eines Terminals die o.a. Fehlermeldung: "bash: ash: Kommando nicht gefunden" Hat jemand einen...
  2. SFTP-Verbindung aufgrund fehlendem Algorithmus nicht möglich

    SFTP-Verbindung aufgrund fehlendem Algorithmus nicht möglich: Eine SFTP-Verbindung zu einem Server (RedHat 7.7) kommt aus einer JAVA_1.8-Anwendung nicht zustande. Caused by: com.jcraft.jsch.JSchException:...
  3. Skript soll nicht doppelt laufen... kill pkill pid cron

    Skript soll nicht doppelt laufen... kill pkill pid cron: Hallo zusammen, per cron möchte ich ein bash-Skript einfach stündlich (neu)starten. Da das Bash-Skript eine while true Schleife enthält und es...
  4. wget: Lädt bestimmte Dateitypen nicht

    wget: Lädt bestimmte Dateitypen nicht: Hallo zusammen, ich habe ein Problem mit wget beim Erstellen eines Mirrors. Bei bestimmten Dateitypen werden die Dateien nicht geladen, sondern...
  5. CentOS: Tilde ~ & Pipe | nicht darstellbar trotz korrekter Tastenkombination

    CentOS: Tilde ~ & Pipe | nicht darstellbar trotz korrekter Tastenkombination: System: Macbook (mojave) -> VM VirtualBox (6.1)-> CentOS-7 x86 64 DVD 1908 Tastatur ist deutsch, Spracheinstellung ist englisch Beschreibung: In...
  1. Diese Seite verwendet Cookies um Inhalte zu personalisieren. Außerdem werden auch Cookies von Diensten Dritter gesetzt. Mit dem weiteren Aufenthalt akzeptierst du diesen Einsatz von Cookies.
    Information ausblenden