Probleme mit apt-get install

nutoka

Mitglied
Beiträge
29
Beim Installieren von neuen Packeten mit apt-get install (Debian)
bekomme ich bei sehr vielen Packenten die Fehlermeldung:

Sorry, but the following packages have unmet dependencies:
(und danach eine Liste von Packeten)!

Was bedeutet diese Fehlermeldung und was kann ich machen, dass sie
nicht mehr vorkommt?

Danke für eure Hilfe!
 

a.m

Grünschnabel
Beiträge
8
benutzt du unstable? zeig bitte die gesamte fehlermeldung. was willst du installieren? hast du schon apt-get -f install versucht?
 

Pumpkin

MädelsvomBarhockerLocker
Beiträge
36
dependencies sind abhängigkeiten, unmet dependensies sind ungelöste abhängigkeiten. sprich du hast z.B. ein programm, welches eine gewisse lib verlangt aber nur bis zu einer gewissen version kompatibel ist
ein zweites programm braucht die gleiche lib aber erst aber der version, ab der das erste programm schon wieder inkompatibel ist, schon eine unmet dependency
(so hab ich das zumindest verstanden)

lösen kann man das mittels
apt-get -f <packetname>
funktioniert aber auch nicht immer......dependencies sind nicht so das wahre unter debian.
es gibt aber auch noch ein programm mit dem die abhängigkeit besser lösen kann. ich habs zwar selber noch nicht ausprobiert, soll aber nicht so schlecht sein: "aptitude"
 

nutoka

Mitglied
Beiträge
29
Ich verwende Woody und wollte mir javaplug ins für Opera installieren! Ich habe mir vorher ein von Sun Java heruntergeladen und wollte es installieren, nur das hat leider nicht gefunkt!

Hab mir ein paar Tage zuvor den Acrobat Reader installiert (nicht mir apt) kann es sein, dass der mir das alles durcheinander gebracht hat?

Wenn ja, wie kann ich ein Programm deinstallieren, dass ich nicht mit apt installiert habe und das auch kein deb file war?

Danke für eure Hilfe!
 

a.m

Grünschnabel
Beiträge
8
also ein fremdes paket sollte apt (und somit auch dpkg) nicht durcheinander bringen, weil sich das ja nicht in seine status datei (/var/lib/dpkg/status/) schreibt, und auch nichts an der paketliste ändert.
 

Ähnliche Themen

Keine grafische Oberfläche (Debian Installation)

Zugriff Ubuntu 16.04. auf Freigabe 18.04. LTS nicht möglich

./easy-wi_install.sh install Script

Autostart auf raspbmc

Firefox Installation fehlgeschlagen

Oben