neuer kernel mittels kernel-image

Pumpkin

Pumpkin

MädelsvomBarhockerLocker
hi!
also bei mir ist ein problem aufgetreten als ich ein kernelimage einspielen wollte.
einspielen war noch kein problem, es wurde (angeblich) richtig gelinkt, und die entsprechenden einträge in die lilo.conf und kernel-image.conf hab ich gemacht (gemäß dialog).
sobald ich nun aber neu boote, hab ich erst einmal die möglichkeit noch auf den alten kernel zurückzugreifen (was ja eigentlich nicht schlecht ist nachdem es eh nicht funktioniert, aber verwirrt hat mich das eigentlich schon) und der neue funktioniert nicht. fehlermeldung:
partition check:
/dev/ide/host0/bus0/target0/lun0:spurios 8259A interrupt: IRQ7
und nach dem tut sich einfach nichts mehr

ich hab danach zwar schon gegoogelt, aber so wirklich schlau bin ich draus nicht geworden....
das system ist übrigends die basisinstallation von debian woody 3.0 mit update auf trusteddebian (kernel-image-2.4.20-1-k7) auf einem 700er duron.
fragt mich bitte nicht was ich mit trusteddebian will..... die idee überkam mich mal wieder bei einem anfall an maßloser selbstüberschätzung :]

vielleicht hat jemand von euch schon erfahrung damit und kann mir einem tip geben woran es liegt?

pumpkin
 
MTS

MTS

Kaiser
öhhh ... ich rate ...
check mal deine lilo.conf ob da die root partition richtig angegeben is ....
ansosnten sag mal wo genau das kommt
 
Pumpkin

Pumpkin

MädelsvomBarhockerLocker
hmm... also ich hab den output von df und den root-eintrag aus der lilo.conf verglichen und das passt eigentlich.
die fehlermeldung kommt, nachdem die festplatte erkannt worden ist. dann versucht er anscheinend die partitionen zu checken und kriegt dabei diesen interrupt. ich hab echt keine ahnung was das ist....
das seltsame daran ist, dass das eigentlich ein fehler-output aus der intel-architektur sein sollte und ich hier aber einen amd verwende, oder sind da die befehlssätze übernommen worden?

pumpkin
 
MTS

MTS

Kaiser
also:
du kannst dich jetzt entscheiden :
1) bei dem was ich gelesen habe könnte das entweder nen problem mit dem Ram / oder mit dem APIC sein; dann solltest du da auf fehlersuche gehen

2) du schenkst dir das mit dem neuen kernel ... das lohnt sich eh nur wenn du die neuen Funktionen auch wirklich brauchst

3) du lässt diese image sache, ziehst dir die kernelsources und stellst dich dem Feind ;)
 
Pumpkin

Pumpkin

MädelsvomBarhockerLocker
hmm...also das mit APIC muss ich mir noch einmal anschauen, das hab ich auch schon gelesen, dass es da irgendwas hat...
so wirklich brauch ich den eh nicht, nur die integrierte ipsec unterstützung wäre interessant gewesen.
im endeffekt wird es eh nichts helfen und ich muss den kernel selber kompilieren.
auf jeden fall danke für deine hilfe!

lets rock
love-smiley-076.gif


pumpkin
 

Ähnliche Themen

kann USB-Stick nicht mounten

invalid card number

Netzwerkkarten Probleme

[Debian] Mount HDs on Boot-Up

Wine Soundprobleme mit SoundMAX AD1986A unter Linux (Asus M2NPV-VM)

Oben