[Debian] Mount HDs on Boot-Up

C

cheza

Jungspund
Tja... das eine Problem in den Griff bekommen taucht schon ein neues (eigtl. habe ich dieses auch schon seit ich das erste habe, jedoch war das erste wichtiger ^^!) auf.

Wenn ich Debian boote, dann erkennt er beim Bootvorgang meine HDs nicht. Er will sie mounten (sind raid HDs die aber mehr oder weniger wie normale IDE HDs laufen. Also sind nicht als "raid X" verbunden oder so.) und sagt dann:

mount: special device hdk1 does not exist

Und das bei 4 HDs. Sobald ich aber selbst eingeloggt bin in Debian kann ich in der Konsole mit "mount -a" alle Platten einwandfrei mounten.

Die fstab datei SOLLTE eigentlich stimmen o_O!
# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
/dev/hda1 / ext3 defaults,errors=remount-ro 0 1
/dev/hda9 /home ext3 defaults 0 2
/dev/hda8 /tmp ext3 defaults 0 2
/dev/hda5 /usr ext3 defaults 0 2
/dev/hda6 /var ext3 defaults 0 2
/dev/hda7 none swap sw 0 0
/dev/hdb1 /media/hd1 ext3 defaults 0 0
/dev/hdc /media/cdrom0 iso9660 ro,user,noauto 0 0
/dev/hdd /media/cdrom1 iso9660 ro,user,noauto 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto 0 0
/dev/hdg1 /media/hd2 ext3 defaults 0 0
/dev/hdh1 /media/hd3 ext3 defaults 0 0
/dev/hdk1 /media/hd4 ext3 defaults 0 0
/dev/hdl1 /media/hd5 ext3 defaults 0 0

und das spuckt mir dmesg aus:
Linux version 2.6.14-2-k7 (Debian 2.6.14-3) (nobse@debian.org) (gcc version 4.0.3 20051023 (prerelease) (Debian 4.0.2-3)) #1 Mon Nov 14 15:33:15 UTC 2005
BIOS-provided physical RAM map:
BIOS-e820: 0000000000000000 - 000000000009e800 (usable)
BIOS-e820: 000000000009e800 - 00000000000a0000 (reserved)
BIOS-e820: 00000000000f0000 - 0000000000100000 (reserved)
BIOS-e820: 0000000000100000 - 000000007fff0000 (usable)
BIOS-e820: 000000007fff0000 - 000000007fff3000 (ACPI NVS)
BIOS-e820: 000000007fff3000 - 0000000080000000 (ACPI data)
BIOS-e820: 00000000fec00000 - 00000000fec01000 (reserved)
BIOS-e820: 00000000fee00000 - 00000000fee01000 (reserved)
BIOS-e820: 00000000ffff0000 - 0000000100000000 (reserved)
1151MB HIGHMEM available.
896MB LOWMEM available.
On node 0 totalpages: 524272
DMA zone: 4096 pages, LIFO batch:1
Normal zone: 225280 pages, LIFO batch:31
HighMem zone: 294896 pages, LIFO batch:31
DMI 2.2 present.
ACPI: RSDP (v000 KT400 ) @ 0x000f74d0
ACPI: RSDT (v001 KT400 AWRDACPI 0x42302e31 AWRD 0x00000000) @ 0x7fff3000
ACPI: FADT (v001 KT400 AWRDACPI 0x42302e31 AWRD 0x00000000) @ 0x7fff3040
ACPI: DSDT (v001 KT400 AWRDACPI 0x00001000 MSFT 0x0100000d) @ 0x00000000
ACPI: PM-Timer IO Port: 0x4008
Allocating PCI resources starting at 88000000 (gap: 80000000:7ec00000)
Built 1 zonelists
Kernel command line: root=/dev/hda1 ro
Found and enabled local APIC!
mapped APIC to ffffd000 (fee00000)
Initializing CPU#0
PID hash table entries: 4096 (order: 12, 65536 bytes)
Detected 1737.655 MHz processor.
Using pmtmr for high-res timesource
Console: colour VGA+ 80x25
Dentry cache hash table entries: 131072 (order: 7, 524288 bytes)
Inode-cache hash table entries: 65536 (order: 6, 262144 bytes)
Memory: 2074564k/2097088k available (1844k kernel code, 21268k reserved, 539k data, 180k init, 1179584k highmem)
Checking if this processor honours the WP bit even in supervisor mode... Ok.
Calibrating delay using timer specific routine.. 3476.87 BogoMIPS (lpj=1738436)
Security Framework v1.0.0 initialized
SELinux: Disabled at boot.
Capability LSM initialized
Mount-cache hash table entries: 512
CPU: After generic identify, caps: 0383fbff c1c3fbff 00000000 00000000 00000000 00000000 00000000
CPU: After vendor identify, caps: 0383fbff c1c3fbff 00000000 00000000 00000000 00000000 00000000
CPU: L1 I Cache: 64K (64 bytes/line), D cache 64K (64 bytes/line)
CPU: L2 Cache: 512K (64 bytes/line)
CPU: After all inits, caps: 0383fbff c1c3fbff 00000000 00000020 00000000 00000000 00000000
Intel machine check architecture supported.
Intel machine check reporting enabled on CPU#0.
mtrr: v2.0 (20020519)
CPU: AMD Athlon(tm) stepping 00
Enabling fast FPU save and restore... done.
Enabling unmasked SIMD FPU exception support... done.
Checking 'hlt' instruction... OK.
ACPI: setting ELCR to 0200 (from 0e20)
checking if image is initramfs... it is
Freeing initrd memory: 1179k freed
softlockup thread 0 started up.
NET: Registered protocol family 16
ACPI: bus type pci registered
PCI: PCI BIOS revision 2.10 entry at 0xfb370, last bus=1
PCI: Using configuration type 1
ACPI: Subsystem revision 20050902
ACPI: Interpreter enabled
ACPI: Using PIC for interrupt routing
ACPI: PCI Root Bridge [PCI0] (0000:00)
PCI: Probing PCI hardware (bus 00)
ACPI: Assume root bridge [\_SB_.PCI0] bus is 0
PCI quirk: region 4000-407f claimed by vt8235 PM
PCI quirk: region 5000-500f claimed by vt8235 SMB
Boot video device is 0000:01:00.0
ACPI: PCI Interrupt Routing Table [\_SB_.PCI0._PRT]
ACPI: PCI Interrupt Link [LNKA] (IRQs 1 3 4 5 6 7 *10 11 12 14 15)
ACPI: PCI Interrupt Link [LNKB] (IRQs 1 3 4 5 6 7 10 *11 12 14 15)
ACPI: PCI Interrupt Link [LNKC] (IRQs 1 3 4 *5 6 7 10 11 12 14 15)
ACPI: PCI Interrupt Link [LNKD] (IRQs 1 3 4 5 6 7 10 *11 12 14 15)
ACPI: PCI Interrupt Link [ALKA] (IRQs 20) *0, disabled.
ACPI: PCI Interrupt Link [ALKB] (IRQs 21) *0, disabled.
ACPI: PCI Interrupt Link [ALKC] (IRQs 22) *0, disabled.
ACPI: PCI Interrupt Link [ALKD] (IRQs 23) *0, disabled.
Linux Plug and Play Support v0.97 (c) Adam Belay
pnp: PnP ACPI init
pnp: PnP ACPI: found 12 devices
PnPBIOS: Disabled by ACPI PNP
PCI: Using ACPI for IRQ routing
PCI: If a device doesn't work, try "pci=routeirq". If it helps, post a report
spurious 8259A interrupt: IRQ7.
pnp: 00:01: ioport range 0x4000-0x407f could not be reserved
pnp: 00:01: ioport range 0x5000-0x500f has been reserved
PCI: Bridge: 0000:00:01.0
IO window: disabled.
MEM window: e8000000-e9ffffff
PREFETCH window: d8000000-e7ffffff
PCI: Setting latency timer of device 0000:00:01.0 to 64
audit: initializing netlink socket (disabled)
audit(1132213287.056:1): initialized
highmem bounce pool size: 64 pages
VFS: Disk quotas dquot_6.5.1
Dquot-cache hash table entries: 1024 (order 0, 4096 bytes)
Initializing Cryptographic API
isapnp: Scanning for PnP cards...
isapnp: No Plug & Play device found
PNP: PS/2 Controller [PNP0303:PS2K] at 0x60,0x64 irq 1
PNP: PS/2 controller doesn't have AUX irq; using default 12
serio: i8042 AUX port at 0x60,0x64 irq 12
serio: i8042 KBD port at 0x60,0x64 irq 1
Serial: 8250/16550 driver $Revision: 1.90 $ 4 ports, IRQ sharing enabled
ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
ttyS1 at I/O 0x2f8 (irq = 3) is a 16550A
ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
ttyS1 at I/O 0x2f8 (irq = 3) is a 16550A
io scheduler noop registered
io scheduler anticipatory registered
io scheduler deadline registered
io scheduler cfq registered
RAMDISK driver initialized: 16 RAM disks of 8192K size 1024 blocksize
NET: Registered protocol family 2
IP route cache hash table entries: 131072 (order: 7, 524288 bytes)
TCP established hash table entries: 524288 (order: 9, 2097152 bytes)
TCP bind hash table entries: 65536 (order: 6, 262144 bytes)
TCP: Hash tables configured (established 524288 bind 65536)
TCP reno registered
TCP bic registered
NET: Registered protocol family 8
NET: Registered protocol family 20
Using IPI Shortcut mode
ACPI wakeup devices:
PCI0 USB0 USB1 USB2 USB6 USB7 USB8 USB9 LAN0 UAR1 LPT1
ACPI: (supports S0 S1 S4 S5)
Freeing unused kernel memory: 180k freed
input: AT Translated Set 2 keyboard on isa0060/serio0
usbcore: registered new driver usbfs
usbcore: registered new driver hub
USB Universal Host Controller Interface driver v2.3
ACPI: PCI Interrupt Link [LNKA] enabled at IRQ 10
PCI: setting IRQ 10 as level-triggered
ACPI: PCI Interrupt 0000:00:10.0[A] -> Link [LNKA] -> GSI 10 (level, low) -> IRQ 10
uhci_hcd 0000:00:10.0: UHCI Host Controller
uhci_hcd 0000:00:10.0: new USB bus registered, assigned bus number 1
uhci_hcd 0000:00:10.0: irq 10, io base 0x0000bc00
hub 1-0:1.0: USB hub found
hub 1-0:1.0: 2 ports detected
ACPI: PCI Interrupt Link [LNKB] enabled at IRQ 11
PCI: setting IRQ 11 as level-triggered
ACPI: PCI Interrupt 0000:00:10.1 -> Link [LNKB] -> GSI 11 (level, low) -> IRQ 11
uhci_hcd 0000:00:10.1: UHCI Host Controller
uhci_hcd 0000:00:10.1: new USB bus registered, assigned bus number 2
uhci_hcd 0000:00:10.1: irq 11, io base 0x0000c000
hub 2-0:1.0: USB hub found
hub 2-0:1.0: 2 ports detected
ACPI: PCI Interrupt Link [LNKC] enabled at IRQ 5
PCI: setting IRQ 5 as level-triggered
ACPI: PCI Interrupt 0000:00:10.2[C] -> Link [LNKC] -> GSI 5 (level, low) -> IRQ 5
uhci_hcd 0000:00:10.2: UHCI Host Controller
uhci_hcd 0000:00:10.2: new USB bus registered, assigned bus number 3
uhci_hcd 0000:00:10.2: irq 5, io base 0x0000c400
hub 3-0:1.0: USB hub found
hub 3-0:1.0: 2 ports detected
ACPI: PCI Interrupt Link [LNKD] enabled at IRQ 11
ACPI: PCI Interrupt 0000:00:10.3[D] -> Link [LNKD] -> GSI 11 (level, low) -> IRQ 11
ehci_hcd 0000:00:10.3: EHCI Host Controller
ehci_hcd 0000:00:10.3: new USB bus registered, assigned bus number 4
ehci_hcd 0000:00:10.3: irq 11, io mem 0xeb102000
ehci_hcd 0000:00:10.3: USB 2.0 initialized, EHCI 1.00, driver 10 Dec 2004
hub 4-0:1.0: USB hub found
hub 4-0:1.0: 6 ports detected
usb 1-1: new low speed USB device using uhci_hcd and address 2
usbcore: registered new driver hiddev
usbcore: registered new driver usbhid
drivers/usb/input/hid-core.c: v2.6:USB HID core driver
mice: PS/2 mouse device common for all mice
Uniform Multi-Platform E-IDE driver Revision: 7.00alpha2
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
VP_IDE: IDE controller at PCI slot 0000:00:11.1
ACPI: PCI Interrupt 0000:00:11.1[A] -> Link [LNKA] -> GSI 10 (level, low) -> IRQ 10
PCI: Via IRQ fixup for 0000:00:11.1, from 255 to 10
VP_IDE: chipset revision 6
VP_IDE: not 100% native mode: will probe irqs later
VP_IDE: VIA vt8235 (rev 00) IDE UDMA133 controller on pci0000:00:11.1
ide0: BM-DMA at 0xc800-0xc807, BIOS settings: hda:DMA, hdb:DMA
ide1: BM-DMA at 0xc808-0xc80f, BIOS settings: hdc:DMA, hdd:DMA
Probing IDE interface ide0...
hda: MAXTOR 4K040H2, ATA DISK drive
hdb: IC35L180AVV207-1, ATA DISK drive
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
Probing IDE interface ide1...
usb 1-1: new low speed USB device using uhci_hcd and address 3
input: USB HID v1.10 Keyboard [Logitech USB Receiver] on usb-0000:00:10.0-1
input: USB HID v1.10 Mouse [Logitech USB Receiver] on usb-0000:00:10.0-1
hdc: PLEXTOR DVDR PX-740A, ATAPI CD/DVD-ROM drive
hdd: PLEXTOR CD-R PX-W4012A, ATAPI CD/DVD-ROM drive
ide1 at 0x170-0x177,0x376 on irq 15
hda: max request size: 128KiB
hda: 78198750 sectors (40037 MB) w/2000KiB Cache, CHS=65535/16/63, UDMA(100)
hda: cache flushes supported
hda: hda1 hda2 < hda5 hda6 hda7 hda8 hda9 >
hdb: max request size: 1024KiB
hdb: 361882080 sectors (185283 MB) w/7965KiB Cache, CHS=22526/255/63, UDMA(100)
hdb: cache flushes supported
hdb: hdb1
kjournald starting. Commit interval 5 seconds
EXT3-fs: mounted filesystem with ordered data mode.
NET: Registered protocol family 1
Adding 2714944k swap on /dev/hda7. Priority:-1 extents:1 across:2714944k
EXT3 FS on hda1, internal journal
hdc: ATAPI 48X DVD-ROM DVD-R CD-R/RW drive, 2048kB Cache, UDMA(33)
Uniform CD-ROM driver Revision: 3.20
hdd: ATAPI 40X CD-ROM CD-R/RW drive, 4096kB Cache, UDMA(33)
kjournald starting. Commit interval 5 seconds
EXT3 FS on hda9, internal journal
EXT3-fs: mounted filesystem with ordered data mode.
kjournald starting. Commit interval 5 seconds
EXT3 FS on hda8, internal journal
EXT3-fs: mounted filesystem with ordered data mode.
kjournald starting. Commit interval 5 seconds
EXT3 FS on hda5, internal journal
EXT3-fs: mounted filesystem with ordered data mode.
kjournald starting. Commit interval 5 seconds
EXT3 FS on hda6, internal journal
EXT3-fs: mounted filesystem with ordered data mode.
kjournald starting. Commit interval 5 seconds
EXT3-fs warning: maximal mount count reached, running e2fsck is recommended
EXT3 FS on hdb1, internal journal
EXT3-fs: mounted filesystem with ordered data mode.
irda_init()
NET: Registered protocol family 23
8139too Fast Ethernet driver 0.9.27
ACPI: PCI Interrupt 0000:00:0c.0[A] -> Link [LNKC] -> GSI 5 (level, low) -> IRQ 5
eth0: RealTek RTL8139 at 0x9000, 00:00:cb:59:0f:1f, IRQ 5
eth0: Identified 8139 chip type 'RTL-8139B'
via-rhine.c:v1.10-LK1.2.0-2.6 June-10-2004 Written by Donald Becker
ACPI: PCI Interrupt 0000:00:12.0[A] -> Link [LNKA] -> GSI 10 (level, low) -> IRQ 10
eth1: VIA Rhine II at 0x1cc00, 00:04:61:43:c0:b0, IRQ 10.
eth1: MII PHY found at address 1, status 0x786d advertising 05e1 Link 45e1.
HPT374: IDE controller at PCI slot 0000:00:0e.0
PCI: Enabling device 0000:00:0e.0 (0005 -> 0007)
ACPI: PCI Interrupt 0000:00:0e.0[A] -> Link [LNKB] -> GSI 11 (level, low) -> IRQ 11
HPT374: chipset revision 7
HPT374: 100% native mode on irq 11
HPT37X: using 33MHz PCI clock
ide2: BM-DMA at 0xa400-0xa407, BIOS settings: hde:pio, hdf:pio
HPT37X: using 33MHz PCI clock
ide3: BM-DMA at 0xa408-0xa40f, BIOS settings: hdg:DMA, hdh:DMA
ACPI: PCI Interrupt 0000:00:0e.1[A] -> Link [LNKB] -> GSI 11 (level, low) -> IRQ 11
HPT37X: using 33MHz PCI clock
ide4: BM-DMA at 0xb800-0xb807, BIOS settings: hdi:pio, hdj:pio
HPT37X: using 33MHz PCI clock
ide5: BM-DMA at 0xb808-0xb80f, BIOS settings: hdk:DMA, hdl:DMA
Probing IDE interface ide2...
Probing IDE interface ide3...
hdg: IC35L080AVVA07-0, ATA DISK drive
hdh: IC35L080AVVA07-0, ATA DISK drive
ide3 at 0x9c00-0x9c07,0xa002 on irq 11
hdg: max request size: 128KiB
hdg: 160836480 sectors (82348 MB) w/1863KiB Cache, CHS=65535/16/63, UDMA(100)
hdg: cache flushes supported
hdg: hdg1
hdh: max request size: 128KiB
hdh: 160836480 sectors (82348 MB) w/1863KiB Cache, CHS=65535/16/63, UDMA(100)
hdh: cache flushes supported
hdh: hdh1
Probing IDE interface ide4...
Probing IDE interface ide5...
hdk: IC35L180AVV207-1, ATA DISK drive
hdl: IC35L180AVV207-1, ATA DISK drive
ide5 at 0xb000-0xb007,0xb402 on irq 11
hdk: max request size: 1024KiB
hdk: 361882080 sectors (185283 MB) w/7965KiB Cache, CHS=22526/255/63, UDMA(100)
hdk: cache flushes supported
hdk: hdk1
hdl: max request size: 1024KiB
hdl: 361882080 sectors (185283 MB) w/7965KiB Cache, CHS=22526/255/63, UDMA(100)
hdl: cache flushes supported
hdl: hdl1
Linux agpgart interface v0.101 (c) Dave Jones
agpgart: Detected VIA KT400/KT400A/KT600 chipset
agpgart: AGP aperture is 128M @ 0xd0000000
pci_hotplug: PCI Hot Plug PCI Core version: 0.5
shpchp: acpi_shpchprm:\_SB_.PCI0 evaluate _BBN fail=0x5
shpchp: acpi_shpchprm:get_device PCI ROOT HID fail=0x5
ACPI: PCI Interrupt 0000:00:0b.0[A] -> Link [LNKD] -> GSI 11 (level, low) -> IRQ 11
gameport: CS46xx Gameport is pci0000:00:0b.0/gameport0, speed 1704kHz
8139cp: 10/100 PCI Ethernet driver v1.2 (Mar 22, 2004)
Real Time Clock Driver v1.12
input: PC Speaker
Floppy drive(s): fd0 is 1.44M
FDC 0 is a post-1991 82077
parport: PnPBIOS parport detected.
parport0: PC-style at 0x378, irq 7 [PCSPP,TRISTATE]
eth1: link up, 100Mbps, full-duplex, lpa 0x45E1
NET: Registered protocol family 10
Disabled Privacy Extensions on device c0320b40(lo)
IPv6 over IPv4 tunneling driver
nvidia: module license 'NVIDIA' taints kernel.
ACPI: PCI Interrupt 0000:01:00.0[A] -> Link [LNKA] -> GSI 10 (level, low) -> IRQ 10
NVRM: loading NVIDIA Linux x86 NVIDIA Kernel Module 1.0-7676 Fri Jul 29 12:58:54 PDT 2005
agpgart: Found an AGP 2.0 compliant device at 0000:00:00.0.
agpgart: Putting AGP V2 device at 0000:00:00.0 into 4x mode
agpgart: Putting AGP V2 device at 0000:01:00.0 into 4x mode
agpgart: Found an AGP 2.0 compliant device at 0000:00:00.0.
agpgart: Putting AGP V2 device at 0000:00:00.0 into 4x mode
agpgart: Putting AGP V2 device at 0000:01:00.0 into 4x mode
eth1: no IPv6 routers present
kjournald starting. Commit interval 5 seconds
EXT3-fs warning: maximal mount count reached, running e2fsck is recommended
EXT3 FS on hdg1, internal journal
EXT3-fs: mounted filesystem with ordered data mode.
kjournald starting. Commit interval 5 seconds
EXT3-fs warning: maximal mount count reached, running e2fsck is recommended
EXT3 FS on hdh1, internal journal
EXT3-fs: mounted filesystem with ordered data mode.
kjournald starting. Commit interval 5 seconds
EXT3-fs warning: maximal mount count reached, running e2fsck is recommended
EXT3 FS on hdk1, internal journal
EXT3-fs: mounted filesystem with ordered data mode.
kjournald starting. Commit interval 5 seconds
EXT3-fs warning: maximal mount count reached, running e2fsck is recommended
EXT3 FS on hdl1, internal journal
EXT3-fs: mounted filesystem with ordered data mode.


Falls jemand eine Ahnung hat woran das liegen könnte, bitte melden ^_^! Gelegentlich komme ich dazu das ich lesen kann: "missing ide_detect" bzw. "missing ide-detect".
Aber selbst wenn er sie nicht automatisch findet... ich habe meine Festplatten doch bereits in der fstab vermerkt......

Sys:
debian 3.1 unstable
kde 3.4.2
gdm display manager
kernel 2.6.14-3

Problem trat erst nach Kernel-Update auf o_O!

big thx

cya cheza
 
W

Wolfgang

Foren Gott
Hallo
Im Grunde steht da, was empfohlen wird.
Stell doch mal den counter auf eine neue Zahl ein.

man tune2fs

-C mount-count
Set the number of times the filesystem has been mounted. Can be used in conjunction with -c to force an fsck on the filesystem at the next reboot.
...

Auch die Option -f solltest du mal verwenden.


Die gesamte Ausgabe von dmesg war hier nicht nötig.
Bitte beim nächsten mal auf die entscheidenden Meldungen reduzieren.
Nicht jeder hat Lust das alles zu lesen, denn du hast ja nichtmal darauf hingewiesen, welche Messages dich stören.

Gruß Wolfgang
 
R

rikola

Foren Gott
Vielleicht wird ein Modul, das zum Ansprechen der Platten benoetigt wird (z.B. ide_detect) erst waehrend des Bootens und zu spaet geladen. Vergleich mal den Inhalt von /etc/modules mit der Ausgabe von lsmod, d.h., stehen in /etc/modules module, die auf IDE Hinweisen? Entweder heissen diese Module im neuen Kernel anders, so dass Deine init-Skripte nicht mehr richtig tun. Oder Du musst Dir selber eine initrd erstellen, die schon beim Booten dem Kernel alle benoetigten Treiber zur Verfuegung stellt. Ich glaube, es gibt auch unter Debian das Skript 'mkinitrd', mit dem man das Bild erstellen kann.

@Wolfgang_1:
Ich denke, dass, wenn man v.a. den Anfang der Nachricht liest, es recht deutlich ist, wo das Problem liegt (dem nicht-automatischen Mounten der Extra-IDE-Platten), was wenig mit tunef2s zu tun hat.
 
C

cheza

Jungspund
@Wolfgang_1
Wenn ich denn genau gewusst hätte, welcher Teil der dmesg für euch "interessant" gewesen wäre hätte ich nur diesen gepostet. Dachte aber, dass man eventuell daraus schlau wird weil ich genau das vermutet hatte was rikola gepostet hatte. Bloß bin ich halt selber noch linux anfänger, komme bis zu einem gewissen Grad mit dem OS auf gleich, aber habe halt noch gewisse Dinge nicht so wirklich durchschaut!

Werde mir mal das mkinitrd ansehen! Thx für die Hilfe ^_^! Hoffe es ist jetzt auch nachvollziehbar warum ich die ganze dmesg gepostet habe.

cya cheza
 
W

Wolfgang

Foren Gott
rikola schrieb:
Vielleicht wird ein Modul, das zum Ansprechen der Platten benoetigt wird (z.B. ide_detect) erst waehrend des Bootens und zu spaet geladen. Vergleich mal den Inhalt von /etc/modules mit der Ausgabe von lsmod, d.h., stehen in /etc/modules module, die auf IDE Hinweisen? Entweder heissen diese Module im neuen Kernel anders, so dass Deine init-Skripte nicht mehr richtig tun. Oder Du musst Dir selber eine initrd erstellen, die schon beim Booten dem Kernel alle benoetigten Treiber zur Verfuegung stellt. Ich glaube, es gibt auch unter Debian das Skript 'mkinitrd', mit dem man das Bild erstellen kann.

@Wolfgang_1:
Ich denke, dass, wenn man v.a. den Anfang der Nachricht liest, es recht deutlich ist, wo das Problem liegt (dem nicht-automatischen Mounten der Extra-IDE-Platten), was wenig mit tunef2s zu tun hat.

Ja, da hast du Recht.
Ich habe das ziemlich schnell überscrollt, und die eigentliche Frage in der ganzen Message übersehen.
eventuell wäre das Subject etwas aussagekräftiger nicht schlecht gewesen. Manchmal ist weniger mehr.

Aber das soll mein ungenaues Lesen, und daraus resultierende Antwort nicht entschuldigen.


Gruß Wolfgang
 

Ähnliche Themen

Problem bei der installation einer Sun Netzwerkkarte

X startet nichtmehr

xrandr: cant open display

UDEV rules - How ?

Debian Routing Problem

Oben