linux-wlan-ng unter suse 9.1

Diskutiere linux-wlan-ng unter suse 9.1 im SuSE / OpenSuSE Forum im Bereich Linux Distributionen; vielleicht erinnern sich noch ein paar ein mein problem mit linux wlan-ng unter suse 8.0 :) jetzt hab ich ein neues problem mit der...

  1. #1 oyster-manu, 26.07.2004
    oyster-manu

    oyster-manu toast

    Dabei seit:
    26.06.2003
    Beiträge:
    1.055
    Zustimmungen:
    0
    vielleicht erinnern sich noch ein paar ein mein problem mit linux wlan-ng unter suse 8.0 :) jetzt hab ich ein neues problem mit der treiberinstallation aber diesmal unter suse 9.1 :D

    ich geh mal die einzelnen schritte durch:

    1. ./Configure:

    build prism usb drivers: yes
    linux source directory: /usr/src/linux-2.6.4-52 das hat sich das script selbst rausgesucht
    (kernel version is 2.6.4-52-default)
    (kernel 2.5/2.6 is highly experimental)
    alternate target to install root directory on host [] nix angegeben
    module install directory /lib/modules/2.6.4-52default das hat sich das script selbst rausgesucht
    prefix for build compiler? [] nix angegeben
    build for debugging: no

    2. make all

    set -e; for d in src doc man etc; do make -C $d ; done
    make[1]: Entering directory `/home/gast/Desktop/linux-wlan-ng-0.2.1pre21/src'
    set -e; for d in mkmeta p80211 prism2 shared wlanctl wland nwepgen wlancfg; do make -C $d ; done
    make[2]: Entering directory `/home/gast/Desktop/linux-wlan-ng-0.2.1pre21/src/mkmeta'
    mkdir -p obj
    make[2]: Leaving directory `/home/gast/Desktop/linux-wlan-ng-0.2.1pre21/src/mkmeta'
    make[2]: Entering directory `/home/gast/Desktop/linux-wlan-ng-0.2.1pre21/src/p80211'
    if test ! -d /home/gast/Desktop/linux-wlan-ng-0.2.1pre21/src/p80211/../.tmp_versions; then \
    cp -rf /usr/src/linux-2.6.4-52/.tmp_versions /home/gast/Desktop/linux-wlan-ng-0.2.1pre21/src/p80211/../ ; \
    fi
    cp: Aufruf von stat fÌr �/usr/src/linux-2.6.4-52/.tmp_versions� nicht möglich: Datei oder Verzeichnis nicht gefunden
    make[2]: *** [default] Fehler 1
    make[2]: Leaving directory `/home/gast/Desktop/linux-wlan-ng-0.2.1pre21/src/p80211'
    make[1]: *** [all] Fehler 2
    make[1]: Leaving directory `/home/gast/Desktop/linux-wlan-ng-0.2.1pre21/src'
    make: *** [all] Fehler 2


    ok, der vermeintliche fehler wurde von mir mal fett unterlegt.
    jetzt das problem:
    wieso findet der das verzeichnis nicht bzw. wieso sucht er danach? (unter suse 8.0 hate ich nie probleme mit nicht gefundenen ordnern)

    ps: linux wlan-ng version ist 0.2.1-pre21
     
  2. Phate

    Phate Frickler/Kellerkommunist

    Dabei seit:
    08.02.2004
    Beiträge:
    261
    Zustimmungen:
    0
    Ort:
    Rheinland
    Gibt es /usr/src/linux-2.6.4-52 überhaupt?
    Existiert ein Link linux auf deine Kernel-sourcen?

    Vielleicht liegts daran...
     
  3. #3 oyster-manu, 27.07.2004
    oyster-manu

    oyster-manu toast

    Dabei seit:
    26.06.2003
    Beiträge:
    1.055
    Zustimmungen:
    0
    das verzeichnis gibt es. ich habe per yast die kernelsourcen installiert, der link müsste also vorhanden sein.
     
  4. #4 oyster-manu, 31.07.2004
    oyster-manu

    oyster-manu toast

    Dabei seit:
    26.06.2003
    Beiträge:
    1.055
    Zustimmungen:
    0
    das verzeichnis gab es doch nicht :/
    allerdings hat sich das configure script auch noch den falschen kernelsourcenpfad rausgesucht. hab einfach den fehlenden ordner per hand erstellt und im script den pfad geändert, schon gings.
    hab mein wlanscript von suse 8.0 benutzt, komme nun auch zum router, aber nicht ins internet. ping www.google.de gibt nichts aus. vermutlich ein dns-problem. werde mich die tage mit beschäftigen.
     
  5. Phate

    Phate Frickler/Kellerkommunist

    Dabei seit:
    08.02.2004
    Beiträge:
    261
    Zustimmungen:
    0
    Ort:
    Rheinland
    Nameserver in die /etc/resolv.conf eintragen.

    Oder ist das unter SuSE anders?
     
  6. #6 oyster-manu, 31.07.2004
    oyster-manu

    oyster-manu toast

    Dabei seit:
    26.06.2003
    Beiträge:
    1.055
    Zustimmungen:
    0
    ja, hab ich. aber trotzdem komm ich nur bis zum router :/
    komischerweise sieht die modules.conf ganz anders aus als bei suse 8.0. unter 8.0 steht noch meine netzwerkkarte drin, unter 9.1 gar nix.
    die lankarte is auch irgendwie komisch. naja, werd mich bald mal mit beschäftigen.
     
  7. #7 oyster-manu, 01.08.2004
    oyster-manu

    oyster-manu toast

    Dabei seit:
    26.06.2003
    Beiträge:
    1.055
    Zustimmungen:
    0
    ich komme doch ins internet, nur nicht auf google.de (die hab ich immer angepingt und es kam keine antwort, andere seiten gehen aber).
    jetzt möchte ich nur noch alles über dhcp laufen lassen. ich hoffe dass ich dann auch wieder auf alle seiten zugreifen kann.
    allerdings hab ich mit dhcp auch noch schwierigkeiten. s. http://www.unixboard.de/vb3/showthread.php?goto=lastpost&t=8970
     
Thema:

linux-wlan-ng unter suse 9.1

Die Seite wird geladen...

linux-wlan-ng unter suse 9.1 - Ähnliche Themen

  1. WPA und linux-wlan-ng

    WPA und linux-wlan-ng: Nun, nachdem WEP immer einfacher geknackt werden kann, wollte ich auf WPA umsteigen, doch leider kann ich die Funktion in linux-wlan-ng nicht...
  2. Linux-Wlan-ng und der neue Kernel?

    Linux-Wlan-ng und der neue Kernel?: Hat jemand erfahrung mit dem 2.6.x und den Linux-wlan-ng treibern?? www.linux-wlan.com
  3. Robots aussperren, Websitescan unterbinden, PHP Checkbox-Captcha?

    Robots aussperren, Websitescan unterbinden, PHP Checkbox-Captcha?: Hallo zusammen, ich hätte gerne einen bestimmten Bereich der Webseite, den Robots oder scriptbasierte Scans von irgendwelchen Suchmaschinen oder...
  4. [gelöst] 2.HDD unter Freebsd partitionieren

    [gelöst] 2.HDD unter Freebsd partitionieren: Hallo Habe eine Testserver mit freeBSD 11.0 auf einer IDE-HDD (ada0) mit ZFS-root hab jetzt eine 2. HDd (SATA) angeschlossen und wollte die...
  5. Installation von COM Ports unter Unix

    Installation von COM Ports unter Unix: Hallo, vorne weg, ich habe von Linux nur Grundkenntnisse und bitte daher etwas um Rücksicht, wenn ich doofe fragen stelle;). Zum Problem: Es gibt...