X startet nichtmehr

Nemesis

Nemesis

N3RD
Hallo,
ich habe versucht CUDA und OPENCL mit meiner Graka zum laufen zu bekommen ... nun hängt er aber schon beim Booten bei "started Update UTMP about System Runlevel Changes."
der Screen wird immer refreshed.
im Xorg.0.log steht:
Code:
[  1284.240]
X.Org X Server 1.18.3
Release Date: 2016-04-04
[  1284.240] X Protocol Version 11, Revision 0
[  1284.240] Build Operating System: Linux 3.16.0-4-amd64 x86_64 Debian
[  1284.240] Current Operating System: Linux Home 4.3.0-1-amd64 #1 SMP Debian 4.3.5-1 (2016-02-06) x86_64
[  1284.240] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-4.3.0-1-amd64 root=UUID=95509552-85de-49f3-8317-21bbb42e55c2 ro quiet
[  1284.240] Build Date: 05 April 2016  07:00:43AM
[  1284.240] xorg-server 2:1.18.3-1 (http://www.debian.org/support)
[  1284.240] Current version of pixman: 0.33.6
[  1284.240]    Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
[  1284.240] Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[  1284.240] (==) Log file: "/var/log/Xorg.0.log", Time: Thu Apr 21 20:23:44 2016
[  1284.240] (==) Using config file: "/etc/X11/xorg.conf"
[  1284.240] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[  1284.240] (==) ServerLayout "Layout0"
[  1284.240] (**) |-->Screen "Screen0" (0)
[  1284.240] (**) |   |-->Monitor "Monitor0"
[  1284.240] (**) |   |-->Device "Device0"
[  1284.241] (**) |-->Input Device "Keyboard0"
[  1284.241] (**) |-->Input Device "Mouse0"
[  1284.241] (**) Option "Xinerama" "0"
[  1284.241] (==) Automatically adding devices
[  1284.241] (==) Automatically enabling devices
[  1284.241] (==) Automatically adding GPU devices
[  1284.241] (==) Max clients allowed: 256, resource mask: 0x1fffff
[  1284.241] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[  1284.241]    Entry deleted from font path.
[  1284.241] (==) FontPath set to:
        /usr/share/fonts/X11/misc,
        /usr/share/fonts/X11/100dpi/:unscaled,
        /usr/share/fonts/X11/75dpi/:unscaled,
        /usr/share/fonts/X11/Type1,
        /usr/share/fonts/X11/100dpi,
        /usr/share/fonts/X11/75dpi,
        built-ins
[  1284.241] (==) ModulePath set to "/usr/lib/xorg/modules"
[  1284.241] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[  1284.241] (WW) Disabling Keyboard0
[  1284.241] (WW) Disabling Mouse0
[  1284.241] (II) Loader magic: 0x558857e38dc0
[  1284.241] (II) Module ABI versions:
[  1284.241]    X.Org ANSI C Emulation: 0.4
[  1284.241]    X.Org Video Driver: 20.0
[  1284.241]    X.Org XInput driver : 22.1
[  1284.241]    X.Org Server Extension : 9.0
[  1284.241] (++) using VT number 7
[  1284.241] (II) systemd-logind: logind integration requires -keeptty and -keeptty was not provided, disabling logind integration
[  1284.242] (II) xfree86: Adding drm device (/dev/dri/card0)
[  1284.243] (--) PCI:*(0:1:0:0) 10de:0191:1043:8233 rev 162, Mem @ 0xfd000000/16777216, 0xd0000000/268435456, 0xfa000000/33554432, I/O @ 0x0000bc00/128, BIOS @ 0x????????/131072
[  1284.243] (II) LoadModule: "glx"
[  1284.243] (II) Loading /usr/lib/xorg/modules/linux/libglx.so
[  1284.256] (II) Module glx: vendor="NVIDIA Corporation"
[  1284.256]    compiled for 4.0.2, module version = 1.0.0
[  1284.256]    Module class: X.Org Server Extension
[  1284.256] (II) NVIDIA GLX Module  352.79  Wed Jan 13 15:54:44 PST 2016
[  1284.256] (II) LoadModule: "nvidia"
[  1284.256] (II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so
[  1284.257] (II) Module nvidia: vendor="NVIDIA Corporation"
[  1284.257]    compiled for 4.0.2, module version = 1.0.0
[  1284.257]    Module class: X.Org Video Driver
[  1284.257] (II) NVIDIA dlloader X Driver  352.79  Wed Jan 13 15:31:15 PST 2016
[  1284.257] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[  1284.260] (II) Loading sub module "fb"
[  1284.260] (II) LoadModule: "fb"
  1284.241] (II) systemd-logind: logind integration requires -keeptty and -keeptty was not provided, disabling logind integration
[  1284.242] (II) xfree86: Adding drm device (/dev/dri/card0)
[  1284.243] (--) PCI:*(0:1:0:0) 10de:0191:1043:8233 rev 162, Mem @ 0xfd000000/16777216, 0xd0000000/268435456, 0xfa000000/33554432, I/O @ 0x0000bc00/128, BIOS @ 0x????????/131072
[  1284.243] (II) LoadModule: "glx"
[  1284.243] (II) Loading /usr/lib/xorg/modules/linux/libglx.so
[  1284.256] (II) Module glx: vendor="NVIDIA Corporation"
[  1284.256]    compiled for 4.0.2, module version = 1.0.0
[  1284.256]    Module class: X.Org Server Extension
[  1284.256] (II) NVIDIA GLX Module  352.79  Wed Jan 13 15:54:44 PST 2016
[  1284.256] (II) LoadModule: "nvidia"
[  1284.256] (II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so
[  1284.257] (II) Module nvidia: vendor="NVIDIA Corporation"
[  1284.257]    compiled for 4.0.2, module version = 1.0.0
[  1284.257]    Module class: X.Org Video Driver
[  1284.257] (II) NVIDIA dlloader X Driver  352.79  Wed Jan 13 15:31:15 PST 2016
[  1284.257] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[  1284.260] (II) Loading sub module "fb"
[  1284.260] (II) LoadModule: "fb"
[  1284.260] (II) Loading /usr/lib/xorg/modules/libfb.so
[  1284.260] (II) Module fb: vendor="X.Org Foundation"
[  1284.260]    compiled for 1.18.3, module version = 1.0.0
[  1284.260]    ABI class: X.Org ANSI C Emulation, version 0.4
[  1284.260] (II) Loading sub module "wfb"
[  1284.260] (II) LoadModule: "wfb"
[  1284.261] (II) Loading /usr/lib/xorg/modules/libwfb.so
[  1284.261] (II) Module wfb: vendor="X.Org Foundation"
[  1284.261]    compiled for 1.18.3, module version = 1.0.0
[  1284.261]    ABI class: X.Org ANSI C Emulation, version 0.4
[  1284.261] (II) Loading sub module "ramdac"
[  1284.261] (II) LoadModule: "ramdac"
[  1284.261] (II) Module "ramdac" already built-in
[  1284.261] (WW) NVIDIA(0): The NVIDIA GeForce 8800 GTX GPU installed in this system is
[  1284.261] (WW) NVIDIA(0):     supported through the NVIDIA 340.xx Legacy drivers. Please
[  1284.261] (WW) NVIDIA(0):     visit http://www.nvidia.com/object/unix.html for more
[  1284.261] (WW) NVIDIA(0):     information.  The 352.79 NVIDIA driver will ignore this
[  1284.261] (WW) NVIDIA(0):     GPU.  Continuing probe...
[  1284.261] (EE) No devices detected.
[  1284.261] (EE)
Fatal server error:
[  1284.261] (EE) no screens found(EE)
[  1284.261] (EE)
Please consult the The X.Org Foundation support
         at http://wiki.x.org
for help.
[  1284.261] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[  1284.261] (EE)
Hm ... kann mir hier jemand weiterhelfen?

Vielen Dank!
 
M

marce

Kaiser
sieht für mich so aus, als wenn du den falschen nvidia-Treiber nutzen würdest.
 
schwedenmann

schwedenmann

Foren Gott
Hallo

Welchen Treiber benutzt du denn ?

und was sagt
lsmod | grep nvidia
lsmod | grep nouveau

mfg
schwedenmann

P.S. Treiber wäre nvidia-legacy-340xx-kernel-dkms
 
Nemesis

Nemesis

N3RD
hm, hat gestimmt, da hätt' ich auch selbst drauf kommen können ... ;)
Hmm ... wie bekomme ich nun raus, ob meine Graka CUDA oder OPENCL kann?
 
schwedenmann

schwedenmann

Foren Gott
Hallo

Cuda kann die 8800 GTX, opencl ist im nividia-kernel mit drin.

mfg
schwedenmann

P.S. googl mal nach 8800GTX und cuda, bzw. opencl
 
Nemesis

Nemesis

N3RD
Das werde ich morgen mal testen, bin gespannt, was die GraKa da so rausholt.

Danke!
 
Nemesis

Nemesis

N3RD
hm ... wenn ich ein Modul mit opencl oder cuda bauen möchte, krieg ich es nichtmehr ans laufen:
die Installation klappt noch und das Modul lässt sich auch laden.
Code:
# modprobe nvidia-legacy-340xx
# lsmod | grep nvi
nvidia              10563584  0
drm                   348160  2 nvidia
wenn ich dann aber XDM neu starten möchte:
failed![....] Restarting xdm (via systemctl): xdm.serviceJob for xdm.service failed because the control process exited with error code. See "systemctl status xdm.service" and "journalctl -xe" for details.# /etc/init.d/xdm restart
im Journal steht auch nichts brauchbares ... aber laut Xorg.0.log kann er das nvidia-Modul nicht laden:
[ 1058.176] (II) LoadModule: "glx"
[ 1058.176] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[ 1058.177] (II) Module glx: vendor="X.Org Foundation"
[ 1058.177] compiled for 1.18.3, module version = 1.0.0
[ 1058.177] ABI class: X.Org Server Extension, version 9.0
[ 1058.177] (==) AIGLX enabled
[ 1058.177] (II) LoadModule: "nvidia"
[ 1058.177] (WW) Warning, couldn't open module nvidia
[ 1058.177] (II) UnloadModule: "nvidia"
[ 1058.177] (II) Unloading nvidia
[ 1058.177] (EE) Failed to load module "nvidia" (module does not exist, 0)
[ 1058.177] (EE) No drivers available.
[ 1058.177] (EE)
Fatal server error:
[ 1058.177] (EE) no screens found(EE)
[ 1058.177] (EE)
Please consult the The X.Org Foundation support
at http://wiki.x.org
for help.
Irgendwie blicke ich gerade nichtmehr so ganz durch ...
 
schwedenmann

schwedenmann

Foren Gott
Hallo

Hast du apt-get install nividia-legacy-340xx-kernel-dkms gemacht ?

mfg
schwedenmann
 
Nemesis

Nemesis

N3RD
ahm, nicht dkms explizit, wurde aber bei der installation von nvidie-legacy-340xx-driver mitinstalliert.
 

Ähnliche Themen

Nvidia Hybrid-Grafikkarte: 3D Beschleunigung will nicht

xserver startet nicht: no screens

xrandr: cant open display

Displayport + externer Monitor zeigt bei startx nichts erst bei DVI

XFCE freezes at startup

Sucheingaben

ubuntu hängt bei update utmp

,

debian 340 legacy failed to load module nvidia module does not exist

,

started update utmp about system runlevel changes raspberry

Oben