Debian und Nforce?

nutoka

Mitglied
Beiträge
29
Ich habe ein MSI-6367 Mainboard mit audio, grafik, lan und usb on
board.
Die Grafik und Netzwerkkarte des Mainboars verwende ich nicht, weil
ich ne andere Grafik- und ne Netzwerkkarte benutze).

Ich habe jetzt immer Probleme mit meiner Usbmaus und meinem Sound!
- Beim Starten vom kde kommt die Fehlermeldung:
"Error while initializing the sound driver:
device /dev/dsp can't be opened (No such device)
The sound server will continue, using the null output device.
- Die USBMaus bleibt immer stecken und nur durch eine Reboot
funktioniert sie wieder! Wenn die Maus stecken bleibt funktionert
auch die Netzwerkkarte (die von mir verwendete) nicht mehr!

Weil ich mir dachte, dass die ganzen Probleme mit dem Mainboard
zusammenhängen, habe ich mir den treiber von nvidia.com als tar.gz
file downgeloadet, ihn entpackt und wollte ihn dann mit make install
installieren, also so wie es in der README steht!

Beim Installieren kommt dann immer die Fehlermeldung:
debian:~/driver/nforce# make install
make -C nvnet install
make[1]: Entering directory `/root/driver/nforce/nvnet'
mkdir -p //lib/modules/2.4.18-bf2.4/kernel/drivers/net
install -b -m 644 -o root nvnet.o
//lib/modules/2.4.18-bf2.4/kernel/drivers/net
install: cannot stat `nvnet.o': No such file or directory
make[1]: *** [install] Error 1
make[1]: Leaving directory `/root/driver/nforce/nvnet'
make: *** [nvnet_install] Error 2

Ich habe auch schon probiert nur mit make zu installieren, da kommt eine ähnliche Fehlermeldung! Auf anraten eines Bekannten habe ich auch mal "make make install" probiert, nur diesen Befehl kennt er garnicht!

Habe ich vielleicht irgenwas vergessen, einen kernel-haeder(version 2.4.18) habe ich mir schon beim installieren des Grafiktreibers downgeloadet und diesen auch verlinkt! Den Grafiktreiber von Nvidia habe ich schon installiert und dort halt alles wunderbar funktioniert!

Weiß wer was diese Fehlermeldung bedeutet, bzw kann mir bitte wer helfen und sagen wie ich den Treiber korrekt installieren kann!

Vielen Dank für eure Hilfe!
 

spunz

Mitglied
Beiträge
31
zum /dev/dsp problem => adduser deinusername audio

zum usb maus problem => schwer zu sagen, wirklich gut funktionieren sollen die nforce bretter ja erst ab kernel 2.4.20?
 

devilz

Pro*phet
Beiträge
12.245
Also ich habe unter Gentoo inzwischen (ab Kernel 2.4.20) absolut keine Problem mit dem Nforce2 :)
Darunter hatte ich einige Probs, aber ab 2.4.20 rennt es sehr gut !
 

nutoka

Mitglied
Beiträge
29
Kernel

Wenn ich von Kernel 2.4.18 auf 20 umsteigen will, wie muß ich da vorgehen? Muß ich mit da die Kernelheaders von der Vesion 20 herunterladen und dann mir meinen eigenen Kernel kompilieren oder gibts da eine einfachere Methode?
 

spunz

Mitglied
Beiträge
31
kernel-source runterladen, alte konfig übernehmen und kernel nach debian oder halt wie überall anders backen.

ev gibts passende optionen oder kernel-patches für den nforce, mangels bedarf hab ich keine infos in diese richtung.
 
G

GetItAll

Gast
Inst

Hallo !

Also der nforce II Chipsatz wird erst ab 2.4.21-rc irgendwas unterstützt.
(Betrifft Dma und div...)
Vorher gibt es keine Kernel Unterstützung, man muß dies per hdparm einschalten.

Es sollte aber auch mit einem Kernel wie 2.4.18 gehen.

Versuch mal in das Verzeichniss nvnet zu wechseln und dort gib ein
"make clean"
In das Verzeichniss nvaudio wechseln, ebenfalls
"make clean"
"cd.."
"make" ( dieses "make" ohne install braucht er unbedingt. Deine Fehlermeldung deutet darauf hin das dieses nicht kompiliert wurde und so findet er auch nichts was er kopieren könnte :-) )
"make install"

Nun sollten die Module inst sein

Prüfen mit "insmod nvnet && insmod nvaudio"

Wegen Dem USB Problem habe ich keine Ahnung.
Aber versuch mal hotplug zu laden mit "apt-get install hotplug"
Dies ist der Manager von USB.
Gibt auch noch andere aber dieser funktioniert bei mir einwandfrei.


Gruß GetItAll
 
Zuletzt bearbeitet von einem Moderator:

Ähnliche Themen

Keine grafische Oberfläche (Debian Installation)

OpenJDK8 unter Debian7.11/sparc64/kernel 3.16 kompilieren

X startet nichtmehr

GCC Crosscompiler unter Debian Wheezy

xrandr: cant open display

Neueste Themen

Oben