XEN - 2 Netzwerkkarten, 2 Bridge, keine Internetverbindung

Dieses Thema im Forum "Internet, lokale Netzwerke und Wireless Lan" wurde erstellt von JoesStar, 28.09.2011.

  1. #1 JoesStar, 28.09.2011
    JoesStar

    JoesStar Grünschnabel

    Dabei seit:
    28.09.2011
    Beiträge:
    1
    Zustimmungen:
    0
    Hallo, ich hab ein Problem. Habe einen Server mit Debian - Squeeze installiert. In dem Server sind zwei Netzwerkkarten. Eine bekommt die IP über DHCP (eth0), die andere statisch (eth1). Sobald ich die zweite Netzwerkkarte hochfahre bekomme ich keine Internetverbindung mehr.

    Szenario:
    Ich möchte über eth0 die normalen Dienste laufen lassen und über eth1 eine DMZ für ssh aufbauen. Eth0 ist an einem Router mit DHCP angebunden, Eth1 bekommt eine statische IP und ist über die zweite Netzwerkkarten meines normalen Rechner (Windows 7) angebunden. Die virtuellen Maschinen sollen über 2 Brücken mit der Dom0 verbunden werden. Die Brücken fahre ich über ein Wrapper-Script (/etc/xen/scripts/hey-network-script) hoch.

    /etc/xen/scripts/hey-network-script
    Code:
    #!/bin/sh
    dir=$(dirname "$0")
    "$dir/network-bridge" "$@" vifnum=0 netdev=eth0 bridge=xenbr0
    "$dir/network-bridge" "$@" vifnum=1 netdev=eth1 bridge=dmz
    /etc/network/interfaces
    Code:
    # The loopback network interface
    auto lo
    iface lo inet loopback
    
    # The primary network interface
    allow-hotplug eth0
    iface eth0 inet dhcp
    
    # The secondary network interface
    auto eth1
    iface eth1 inet static
        address 192.168.3.2
        netmask 255.255.255.0
        network 192.168.3.0
        broadcast 192.168.3.255
        gateway 192.168.3.1
    ifconfig
    dmz Link encap:Ethernet Hardware Adresse 00:30:48:42:64:41
    inet Adresse:192.168.3.2 Bcast:0.0.0.0 Maske:255.255.255.0
    inet6-Adresse: fe80::230:48ff:fe42:6441/64 Gültigkeitsbereich:Verbindung
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metrik:1
    RX packets:363 errors:0 dropped:0 overruns:0 frame:0
    TX packets:51 errors:0 dropped:0 overruns:0 carrier:0
    Kollisionen:0 Sendewarteschlangenlänge:0
    RX bytes:82900 (80.9 KiB) TX bytes:17358 (16.9 KiB)

    lo Link encap:Lokale Schleife
    inet Adresse:127.0.0.1 Maske:255.0.0.0
    inet6-Adresse: ::1/128 Gültigkeitsbereich:Maschine
    UP LOOPBACK RUNNING MTU:16436 Metrik:1
    RX packets:8 errors:0 dropped:0 overruns:0 frame:0
    TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
    Kollisionen:0 Sendewarteschlangenlänge:0
    RX bytes:560 (560.0 B) TX bytes:560 (560.0 B)

    peth0 Link encap:Ethernet Hardware Adresse 00:30:48:42:64:40
    inet6-Adresse: fe80::230:48ff:fe42:6440/64 Gültigkeitsbereich:Verbindung
    UP BROADCAST RUNNING PROMISC MULTICAST MTU:1500 Metrik:1
    RX packets:605 errors:0 dropped:0 overruns:0 frame:0
    TX packets:28 errors:0 dropped:0 overruns:0 carrier:0
    Kollisionen:0 Sendewarteschlangenlänge:100
    RX bytes:145493 (142.0 KiB) TX bytes:2982 (2.9 KiB)

    peth1 Link encap:Ethernet Hardware Adresse 00:30:48:42:64:41
    inet6-Adresse: fe80::230:48ff:fe42:6441/64 Gültigkeitsbereich:Verbindung
    UP BROADCAST RUNNING PROMISC MULTICAST MTU:1500 Metrik:1
    RX packets:473 errors:0 dropped:0 overruns:0 frame:0
    TX packets:146 errors:0 dropped:0 overruns:0 carrier:0
    Kollisionen:0 Sendewarteschlangenlänge:1000
    RX bytes:102010 (99.6 KiB) TX bytes:43976 (42.9 KiB)

    xenbr0 Link encap:Ethernet Hardware Adresse 00:30:48:42:64:40
    inet Adresse:192.168.2.103 Bcast:0.0.0.0 Maske:255.255.255.0
    inet6-Adresse: fe80::230:48ff:fe42:6440/64 Gültigkeitsbereich:Verbindung
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metrik:1
    RX packets:587 errors:0 dropped:0 overruns:0 frame:0
    TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
    Kollisionen:0 Sendewarteschlangenlänge:0
    RX bytes:134924 (131.7 KiB) TX bytes:594 (594.0 B)


    Weder Dom0 noch die DomU's erstmal nur mit der ersten Brücke (xenbr0) verbunden haben keinen Internetzugriff. Sobald ich die zweite Netzwerkkarte deaktiviere oder nicht XEN boote funktioniert die Internetverbindung einwandfrei. Was habe ich falsch gemacht?
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
Thema:

XEN - 2 Netzwerkkarten, 2 Bridge, keine Internetverbindung

Die Seite wird geladen...

XEN - 2 Netzwerkkarten, 2 Bridge, keine Internetverbindung - Ähnliche Themen

  1. Routing mehrere Netzwerkkarten

    Routing mehrere Netzwerkkarten: Guten Abend, nach dem ich das Problem mit dem SIP und der Firewall gelöst habe, stehe ich vor dem Problem mit dem Routing. Der Gateway hat jetzt...
  2. RedHat 3: Reihenfolge der Netzwerkkarten

    RedHat 3: Reihenfolge der Netzwerkkarten: Ich suche nach einer Möglichkeit die Reihenfolge meiner Netzwerkkarten bei RH 3 zu ändern, z. B. eth2 soll als eth0 angesprochen werden....
  3. Virtuelle Netzwerkkarten unter Linux einrichten

    Virtuelle Netzwerkkarten unter Linux einrichten: Hi. Wie richtetet man virtuelle Netzwerkkarten unter Linux ein? A: Aufteilung einer physikalischen Netzwerkkarte in mehrere virtuelle, um...
  4. samba und 2 netzwerkkarten

    samba und 2 netzwerkkarten: Hallo zusammen, Ich möchte 2 getrente netwerke haben wie stelle ich das samba das beizubringen das er auf 2 netzwerkkarten lauschen soll, die...
  5. 2 Netzwerkkarten - default route?

    2 Netzwerkkarten - default route?: Moin, ich wollte mal fragen wie ich folgendes Problem am Besten lösen kann. Und zwar hab ich ein Server mit zwei Netzwerkschnittstellen....