X mit Problemen...

Dieses Thema im Forum "Grafik / Video" wurde erstellt von Kollege, 06.08.2006.

  1. #1 Kollege, 06.08.2006
    Zuletzt bearbeitet: 06.08.2006
    Kollege

    Kollege tiefer vogel

    Dabei seit:
    26.07.2006
    Beiträge:
    53
    Zustimmungen:
    0
    Ort:
    NRW, Erkelenz
    Guten Tag, Unixboard!

    Also momentan scheitere ich an X
    Ich habe xorg-x11 emerged über nacht und jetzt gebe ich:
    #xorgcfg
    ein und dabei gibts dann (EE) :D

    und zwar
    (EE) I810(1): Cannot read V_BIOS (3)
    (EE) I810(1): VBE initialization failed.
    (EE) xf86OpenSerial: cannot open device /dev/mouse
    No such file or directory.
    (EE) xf86OpenSerial: cannot open device /dev/mouse
    No such file or directory.
    FreeFontPath: FPE "(usr/share/fonts/misc" recount is 2, should be 1; fixing.
    Cannot connect to X server.


    Also von wegen Maus, habe ich erst mal cat /dev/input/*** alles abgegrast bis ich mit /dev/psaux den richtigen pfad hatte. damit habe die beiden xf86OpenSerial Fehler weg bekommen. Denn Fehler von wegen I810 habe ich nur mit mässigem Interesse beachtet. Ist ja schliesslich eine Onboard mit shared memory (kotz). Bin also in xorg.conf zum Device mit Treiber "I810" gegangen und habe ihn nach dem Beispiel der anderen Section "Device" auf Driver "vga" geändert, die BusID habe ich gemäss lspci angepasst.
    nach "X -config xorg.conf.new" ergibt sich ein schwarzer Bildschrim mit türkisen Würfeln am oberen Bildschirmrand.... nach Strg+Alt+Backspace sagt meine Konsole mir keinen Fehler :think: Das einzige was noch stört ist das mit FreeFontPath... und dass ich kein vernünftiges Bild habe. ?( Interessanterweise fehlt jetzt "Cannot connect to X server" am Ende, was ja eigentlich Gutes bedeutet...
    Ich habe dann auch mal /var/log/Xorg.0.log von Hand durchsucht aber da sind keine (WW) und (EE) zu finden.

    Hier ist meine xorg.conf:

    Code:
    Section "ServerLayout"
                    Identifier             "X.org Configured"
                    Screen           0   "Screen0" 0 0
                    Screen           1   "Screen1"  1 1
                    InputDevice         "Mouse0" "Corepointer"
                    InputDevice          "Keyboard0" "CoreKeyboard"
    EndSection
    
    Section "Files"
                    RgbPath             "/usr/share/X11/rgb"
                    ModulePath             "/usr/lib64/xorg/modules"
                    FontPath             "usr/share/fonts/misc"             
                    FontPath             "usr/share/fonts/75dpi"
                    FontPath             "usr/share/fonts/100dpi"
                    FontPath             "usr/share/fonts/TTF"
                    FontPath             "usr/share/fonts/Type1"
    EndSection
    
    Section "Module"
                     Load                   "glx"
                     Load                   "dbe"
                     Load                   "dri"
                     Load                   "record"
                     Load                   "xtrap"
                     Load                   "extmod"
                     Load                   "type1"
                     Load                   "freetype"
    EndSection
    
    Section "InputDevice"
                     Identifier            "Keyboard0"
                     Driver                 "kbd"
    EndSection
    
    Section "InputDevice"
                     Identifier          "Mouse0"
                     Driver               "mouse"
                     Option              "Protocol" "auto"
                     Option              "Device" "/dev/psaux"
                     Option              "ZAxisMapping" "4 5 6 7"
    EndSection
    
    Section "Monitor"
                      Identifier           "Monitor0"
                      VendorName   "blablubb"
                      ModelName     "blubbbla"
                      HorizSync         31-81
                      VertRefresh           56-75
    EndSection
    
    Section "Monitor"
                      Identifier           "Monitor1"
                      VendorName   "blablubb"
                      ModelName     "blubbbla"
                      HorizSync         31-81
                      VertRefresh           56-75
    EndSection
    
    Section "Device"
                     Identifier             "Card0"
                     Driver                  "vga"
                     VendorName    "ATI Technologies Inc"
                     BoardName       "Unknown"
                     BusID                  "PCI:1:0:0"
    EndSection
    
    
    Section "Device"
                     Identifier             "Card1"
                     Driver                  "vga"
                     VendorName    "ATI Technologies Inc"
                     BoardName       "Unknown"
                     BusID                  "PCI:1:0:1"
    EndSection
    
    Section "Screen"
                     Device               "Card0"
                     Monitor             "Monitor0"
                     SubSection      "Display"
                            Viewport     0 0
                            Modes         "1280x1024" "1024x768" "800x600" "640x480"
                            Depth          1
                     EndSubSection
    SubSection      "Display"
                            Viewport     0 0
                            Modes         "1280x1024" "1024x768" "800x600" "640x480"
                            Depth          1
                     EndSubSection
    SubSection      "Display"
                            Viewport     0 0
                            Modes         "1280x1024" "1024x768" "800x600" "640x480"
                            Depth          4
                     EndSubSection
    SubSection      "Display"
                            Viewport     0 0
                            Modes         "1280x1024" "1024x768" "800x600" "640x480"
                            Depth          8
                     EndSubSection
    SubSection      "Display"
                            Viewport     0 0
                            Modes         "1280x1024" "1024x768" "800x600" "640x480"
                            Depth          15
                     EndSubSection
    SubSection      "Display"
                            Viewport     0 0
                            Modes         "1280x1024" "1024x768" "800x600" "640x480"
                            Depth          16
                     EndSubSection
    SubSection      "Display"
                            Viewport     0 0
                            Modes         "1280x1024" "1024x768" "800x600" "640x480"
                            Depth          24
                     EndSubSection
    EndSection
    
    
    
    Section "Screen"
                     Device               "Card1"
                     Monitor             "Monitor1"
                     SubSection      "Display"
                            Viewport     0 0
                            Modes         "1280x1024" "1024x768" "800x600" "640x480"
                            Depth          1
                     EndSubSection
                      SubSection      "Display"
                            Viewport     0 0
                            Modes         "1280x1024" "1024x768" "800x600" "640x480"
                            Depth          1
                     EndSubSection
    SubSection      "Display"
                            Viewport     0 0
                            Modes         "1280x1024" "1024x768" "800x600" "640x480"
                            Depth          4
                     EndSubSection
    SubSection      "Display"
                            Viewport     0 0
                            Modes         "1280x1024" "1024x768" "800x600" "640x480"
                            Depth          8
                     EndSubSection
    SubSection      "Display"
                            Viewport     0 0
                            Modes         "1280x1024" "1024x768" "800x600" "640x480"
                            Depth          15
                     EndSubSection
    SubSection      "Display"
                            Viewport     0 0
                            Modes         "1280x1024" "1024x768" "800x600" "640x480"
                            Depth          16
                     EndSubSection
    SubSection      "Display"
                            Viewport     0 0
                            Modes         "1280x1024" "1024x768" "800x600" "640x480"
                            Depth          24
                     EndSubSection
    EndSection
    Sorry, musste alles abtippen weil ich zu doof war die Datei zu brennen oder als DCC zu senden

    Achja meine Graka ist ne ATI Radeon X1600 mit PCIExpress und ich benutze das neueste Xorg... Vielleicht mache ich ja was falsch, eigentlich will ich nur X auf einem Monitor laufen haben. ;(

    Vielleicht kann mir ja einer ein paar nützliche Tips geben....
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 supersucker, 06.08.2006
    supersucker

    supersucker Foren Gott

    Dabei seit:
    21.02.2005
    Beiträge:
    3.873
    Zustimmungen:
    0
    Hast du es schon mal mit

    Code:
    xorgconfig
    statt xorgcfg probiert?
     
  4. #3 Kollege, 06.08.2006
    Zuletzt bearbeitet: 06.08.2006
    Kollege

    Kollege tiefer vogel

    Dabei seit:
    26.07.2006
    Beiträge:
    53
    Zustimmungen:
    0
    Ort:
    NRW, Erkelenz
    Ja
    wenn ich die selbst generierte xorg.conf nehme und zum test starte gibts noch mehr fehler weil wegen BusIDs nicht korrekt sind. Ich habe dann die .conf von xorgcfg benutzt und damit ja auch erfolge erzielt...

    X started ja und gibt keine Fehlermeldung mehr aus (im gegensatz zu der anderen Config!) nachdem ich etwas nachgeholfen habe... Das einzige ist das das Bild verzerrt ist.
     
  5. theton

    theton Bitmuncher

    Dabei seit:
    27.05.2004
    Beiträge:
    4.820
    Zustimmungen:
    0
    Ort:
    Berlin, Germany
    Bild-Verzerrungen entstehen meist durch flasche Sync-Einstellungen fuer den Monitor oder eine falsche Aufloesung. Im uebrigen kann man hier Konfigurationen (und auch Logs), die sooo lang sind, einfach in einen Code-Block packen, damit sie nicht soviel Platz einnehmen.
     
  6. #5 Kollege, 06.08.2006
    Zuletzt bearbeitet: 11.08.2006
    Kollege

    Kollege tiefer vogel

    Dabei seit:
    26.07.2006
    Beiträge:
    53
    Zustimmungen:
    0
    Ort:
    NRW, Erkelenz
    Sorry, aber das mit dem Code habe ich gerade erst heraus gefunden...
    Die Raten sind dem Handbuch des Monitors entnommen.

    [EDIT]

    *freu*
    X startet jetzt :D

    Ich musste mir einen Kernel mit PCI-E Support basteln (lange gebraucht ums zu finden) und danach noch Ati-treiber emergen. Was mich gewundert hat ist bloss dass der Kram auf vga nicht laufen wollte ?(
    Zumindest habe ich jetzt ein startbares X aber noch sind da andere Dinge:

    Code:
    (WW) fglrx: No matching Device Section for Instance (BusID PCI:1:0:1) found
    FATAL: Error inserting fglrx (/lib/modules/2.6.17-gentoo-r4/video/fglrx.ko): operation not permitted
    [drm] failed to load kernel module "fglrx"
    FATAL: Error inserting fglrx (/lib/modules/2.6.17-gentoo-r4/video/fglrx.ko): operation not permitted
    [drm] failed to load kernel module "fglrx"
    (EE) fglrx(0): DRIScreenInit failed!
    
    Die Tastatur hat auch noch was aber das juckt mich momentan noch nicht...
    ...vielleicht kommen die Meldungen ja jemand bekannt vor.

    PS: Ich muss wohl sagen: Daumen hoch Unixboard und Dank an alle Mitglieder die mir bisher geholfen haben. Ohne Euch hätte ich den Mut verloren :D
     
Thema:

X mit Problemen...

Die Seite wird geladen...

X mit Problemen... - Ähnliche Themen

  1. Exe-Dateien stoppen im Router führt zu Problemen

    Exe-Dateien stoppen im Router führt zu Problemen: Hier meine Routereinstellungen. Dort kann ich exe-Dateien scheinbar sperren, also deren heimlichen Download auf unsere Rechner verhindern. Und...
  2. MSI NVidia GeForce NX7600GT TD512Z mit Problemen...

    MSI NVidia GeForce NX7600GT TD512Z mit Problemen...: Guten Tag, Manche haben es vielleicht schon in anderen Foren gelesen, jedoch konnte man mir dort nicht helfen, deshalb frage ich jetzt hier:...
  3. Mal wieder Firefox mit Flash-Soundproblemen

    Mal wieder Firefox mit Flash-Soundproblemen: so als Erstes: - hab Debian Sarge - ALSA - Firefox 1.5.0.7 - Shockwave Flash 0.9 Mein Problem ist folgendes: Wenn ich keinen Sound abspiele...
  4. Neuling mit problemen ^^

    Neuling mit problemen ^^: Hallo ihr alle Ich hab mir heute zum ersten mal Open Suse auf dem pc installiert aber leider erkennt linux mein laufwerk nicht es kann im linux...
  5. ubuntu neuling mit wlan problemen

    ubuntu neuling mit wlan problemen: hey hey ho @ all war ein mittelmässiger windows user und bin nun auf ubuntu umgestiegen und besser klar als isch dacht. bin eigentlich sehr...