USB-Storage Device /SCSI

Dieses Thema im Forum "Mandriva" wurde erstellt von saiki, 08.05.2003.

  1. saiki

    saiki Bratwurstgriller

    Dabei seit:
    18.03.2003
    Beiträge:
    934
    Zustimmungen:
    0
    Ort:
    Sachsen/ Meerane
    Also, ich habe hier an meinem Rechner (mdk9.1) ein kleines Problem.
    Ich habe eine Archos Jukebox 6000 (6GB) per USB mit dem Rechner verbunden. Unter usbview wird sie auch angezeigt, das sie vorhanden sei.

    Nun will ich sie mounten ('mount -t vfat /dev/sda1 /mnt/removable'), aber da kommt nur:

    mount: Gerätedatei /dev/sda1 existiert nicht

    Das verwirrt mich allerdings, da im MCC im Hardwaredings unter Festplatten 'sda' steht.

    Weiterhin stehen dort 2 identische Geräte 'USB/IDE Bridge (ATA/ATAPI)', allerdings eines unter "Scanner", das andere unter 'Unbekannt/Andere'.

    Dann habe ich mal probiert, mittels 'cdrecord -scanbus' etwas herauszufinden. Resultat: cdrecord stürzt ab und läßt sich nicht mehr abbrechen.

    Ich habe irgendwie die Vermutung, das es mit dem SCSI-Modul zusammenhängt und/oder das irgendwas 2 mal geladen wird und sich nicht verträgt (2 identische Geräte, unterschiedl. Kat.).

    Ich habe aber keine Ahnung, wo ich mit suchen anfangen soll.
    Bitte helft mir
    ;(
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. devilz

    devilz Pro*phet
    Administrator

    Dabei seit:
    01.05.2002
    Beiträge:
    12.244
    Zustimmungen:
    0
    Ort:
    Hessen
    mach mal in der konsole ein dmesg
    und poste mal den output zu dem USB Gerät !
     
  4. saiki

    saiki Bratwurstgriller

    Dabei seit:
    18.03.2003
    Beiträge:
    934
    Zustimmungen:
    0
    Ort:
    Sachsen/ Meerane
    In dmesg steht nichts von einem USB-Gerät, auch nicht von sda.
     
  5. devilz

    devilz Pro*phet
    Administrator

    Dabei seit:
    01.05.2002
    Beiträge:
    12.244
    Zustimmungen:
    0
    Ort:
    Hessen
    Dann zieh das Gerät mal ab ..... schließ es wieder an ...
    und mach gleich mal dmesg ....

    Da sollte dann sowas kommen :

    scsi1 : SCSI emulation for USB Mass Storage devices
    Vendor: Maxtor 4 Model: D060H3 Rev: DAH0
    Type: Direct-Access ANSI SCSI revision: 02
    Attached scsi disk sda at scsi1, channel 0, id 0, lun 0
    SCSI device sda: 120069936 512-byte hdwr sectors (61476 MB)
    /dev/scsi/host1/bus0/target0/lun0: p1
    WARNING: USB Mass Storage data integrity not assured
    USB Mass Storage device found at 2
     
  6. saiki

    saiki Bratwurstgriller

    Dabei seit:
    18.03.2003
    Beiträge:
    934
    Zustimmungen:
    0
    Ort:
    Sachsen/ Meerane
    Also wenn ich die Jukebox abziehe, kommt folgendes:

    usb.c: USB disconnect on device 00:02.2-1 address 2


    Und das kommt nach dem verbinden:

    hub.c: new USB device 00:02.2-1, assigned address 3
    WARNING: USB Mass Storage data integrity not assured
    USB Mass Storage device found at 3


    Ich bin ratlos...?(
     
  7. devilz

    devilz Pro*phet
    Administrator

    Dabei seit:
    01.05.2002
    Beiträge:
    12.244
    Zustimmungen:
    0
    Ort:
    Hessen
    Dann lädt er anscheinend das SCSI Module nicht, oder er erkennt das Device nicht :(
     
  8. #7 saiki, 08.05.2003
    Zuletzt bearbeitet: 09.05.2003
    saiki

    saiki Bratwurstgriller

    Dabei seit:
    18.03.2003
    Beiträge:
    934
    Zustimmungen:
    0
    Ort:
    Sachsen/ Meerane
    Wie heißt das SCSI-Modul? Ich hatte mal eines (noch aus 9.0er Zeiten) das hies scsi-hostadapter. Das gibt es aber nicht.

    lsmod ausgabe (nur die SCSI Sachen, zumindest die, wo ich denke das es welche sind):

    scsimon 9344 0 (unused)

    usb-storage 72984 0

    scsi_mod 103316 3 [sr_mod sd_mod scsimon usb-storage]

    usb-ohci 20584 0 (unused)

    usbcore 73024 1 [mod_quickcam usb-storage usb-ohci]



    PS: Ich hasse Windows, ohne mittlere Maustaste einfügen ist assig, vorallem auf einem Notebook...

    PSS: Ich habe noch etwas festgestellt:

    1. dmesg:
    hub.c: new USB device 00:02.3-1, assigned address 5
    scsi0 : SCSI emulation for USB Mass Storage devices
    usb_control/bulk_msg: timeout
    usb_control/bulk_msg: timeout
    usb_control/bulk_msg: timeout
    usb_control/bulk_msg: timeout
    usb_control/bulk_msg: timeout
    usb_control/bulk_msg: timeout
    usb_control/bulk_msg: timeout
    usb_control/bulk_msg: timeout
    usb_control/bulk_msg: timeout
    usb_control/bulk_msg: timeout
    usb_control/bulk_msg: timeout
    usb_control/bulk_msg: timeout
    usb_control/bulk_msg: timeout
    usb_control/bulk_msg: timeout
    usb_control/bulk_msg: timeout
    usb_control/bulk_msg: timeout
    usb_control/bulk_msg: timeout
    usb_control/bulk_msg: timeout

    2: In /dev gibt es kein sda oder sda#.
    Das ist irgendwie merkwürdig.
     
  9. saiki

    saiki Bratwurstgriller

    Dabei seit:
    18.03.2003
    Beiträge:
    934
    Zustimmungen:
    0
    Ort:
    Sachsen/ Meerane
    Irgendwie gibt dmesg jetzt folgendes aus:

    usbdevfs: USBDEVFS_CONTROL failed dev 5 rqt 128 rq 6 len 18 ret -110
    Attached scsi generic sg0 at scsi0, channel 0, id 0, lun 0, type -1
    resize_dma_pool: unknown device type -1
     
  10. devilz

    devilz Pro*phet
    Administrator

    Dabei seit:
    01.05.2002
    Beiträge:
    12.244
    Zustimmungen:
    0
    Ort:
    Hessen
    mal versucht das generic scsi device zu mounten ?

    mount /dev/sg0 ....
     
  11. saiki

    saiki Bratwurstgriller

    Dabei seit:
    18.03.2003
    Beiträge:
    934
    Zustimmungen:
    0
    Ort:
    Sachsen/ Meerane
    Ja, da kommt, das es kein blockorientiertes Gerät sei und es nicht ginge.

    'cdrecord -scanbus' bringt jetzt sowas:

    Cdrecord 2.0 (i586-mandrake-linux-gnu) Copyright (C) 1995-2002 Jörg Schilling
    cdrecord: No such file or directory. Cannot open '/dev/pg*'. Cannot open SCSI driver.
    cdrecord: For possible targets try 'cdrecord -scanbus'. Make sure you are root.
    cdrecord: For possible transport specifiers try 'cdrecord dev=help'.

    Allerdings hab ich die Jukebox momentan nicht angeschlossen!
     
  12. devilz

    devilz Pro*phet
    Administrator

    Dabei seit:
    01.05.2002
    Beiträge:
    12.244
    Zustimmungen:
    0
    Ort:
    Hessen
    *lol*

    Also du solltest die Box schon angeschlossen haben und zu mounten ...
     
  13. saiki

    saiki Bratwurstgriller

    Dabei seit:
    18.03.2003
    Beiträge:
    934
    Zustimmungen:
    0
    Ort:
    Sachsen/ Meerane
    So, jetzt mal eine positive Nachricht von dmesg:

    hub.c: new USB device 00:02.3-1, assigned address 2
    scsi0 : SCSI emulation for USB Mass Storage devices
    Vendor: TOSHIBA Model: MK6015MAP Rev: U8.1
    Type: Direct-Access ANSI SCSI revision: 02
    WARNING: USB Mass Storage data integrity not assured
    USB Mass Storage device found at 2
    Attached scsi disk sda at scsi0, channel 0, id 0, lun 0
    SCSI device sda: 11733120 512-byte hdwr sectors (6007 MB)
    /dev/scsi/host0/bus0/target0/lun0:


    So weit, so gut. Das Teil ist also richtig erkannt worden, aber wie mounte ich es jetzt?

    /dev/sda# , /dev/sg# geht nicht.
     
  14. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  15. devilz

    devilz Pro*phet
    Administrator

    Dabei seit:
    01.05.2002
    Beiträge:
    12.244
    Zustimmungen:
    0
    Ort:
    Hessen
    mach mal " ls -Al /dev/scsi/host0/bus0/target0/lun0/"
    und poste das hier !
     
  16. #14 saiki, 09.05.2003
    Zuletzt bearbeitet: 09.05.2003
    saiki

    saiki Bratwurstgriller

    Dabei seit:
    18.03.2003
    Beiträge:
    934
    Zustimmungen:
    0
    Ort:
    Sachsen/ Meerane
    Da steht folgendes da:

    insgesamt 0



    Mehr nicht. ?( irgendwie bin ich jetzt ganz schön verwirrt ?(

    [EDIT]

    Ein cat /proc/scsi/usb-storage-0/0 bringt jetzt folgendes, das mich aber noch ratloser macht, den eigentlich sollte es funktionieren:

    Host scsi0: usb-storage
    Vendor: In-System Design
    Product: USB Storage Adapter
    Serial Number: C828305AA5E2FF2B
    Protocol: ISD200 ATA/ATAPI
    Transport: Bulk
    GUID: 05ab0031c828305aa5e2ff2b
    Attached: Yes
    [/EDIT]
     
Thema:

USB-Storage Device /SCSI

Die Seite wird geladen...

USB-Storage Device /SCSI - Ähnliche Themen

  1. Solaris 10 - usb-storage

    Solaris 10 - usb-storage: Hoi ... Ich hab heute mal meine Digitalcamera an meiner Blade angeschlossen und wollte die mal mounten, allerdings funktioniert das irgendwie...
  2. Kalifornisches Startup Olio Devices stellt intelligente Linux-Luxusuhr vor

    Kalifornisches Startup Olio Devices stellt intelligente Linux-Luxusuhr vor: Die Firma Olio Devices Inc. bietet vier Modelle ihrer Luxus-Smartwatch »Model One« an, die anstatt auf Android Wear, Pebble oder Tizen direkt auf...
  3. Mozilla initiiert Open Web Device Compliance Review Board

    Mozilla initiiert Open Web Device Compliance Review Board: Mozilla und einige Partner der Mobilfunk-Branche initiieren eine Art Qualitätskontrollstelle, welche die API-Kompatibilität und die...
  4. Matrox - mehr als ein Framebuffer Device

    Matrox - mehr als ein Framebuffer Device: Moin, ich habe : - PC mit Debian 3.2.x - OnBoard VGA (mW Intel) - Matrox Grafikkarte mit 2 x VGA ich möchte gerne für jeden Anschluss einen...
  5. Brenner device ermitteln

    Brenner device ermitteln: Hallo Mit welchen Programmen, bzw. aus welchen logs kann man eigentlich für ein Programm sicher das device des Brenners ermitteln, wenn ev....