4GByte USB Stick lässt sich nicht mounten

Dieses Thema im Forum "SuSE / OpenSuSE" wurde erstellt von bast1e, 31.08.2006.

  1. bast1e

    bast1e Eroberer

    Dabei seit:
    03.12.2003
    Beiträge:
    74
    Zustimmungen:
    0
    Ort:
    Germany
    Hi,

    ich habe einen 4GByte USB Stick, der zwar an Windows Rechnern funktioniert, sich jedoch unter Linux nicht mounten lässt - hier mal die Ausgabe von dmesg:
    wenn ich /dev/sda auf /mnt/usb mounten will, passiert einfach nichts - woran kann das liegen?

    mfg bastie
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 lordlamer, 31.08.2006
    lordlamer

    lordlamer Haudegen

    Dabei seit:
    15.05.2003
    Beiträge:
    703
    Zustimmungen:
    0
    Ort:
    hamburg
    passiert nix glaub ich nicht ;) wenn nichts passiert hat er ihn ja gemountet. wenn ne fehlermeldung kommt dann musst du sie mal zeigen.

    hast du mal geschaut das du nicht sda sondern sda1 mountest?

    mfg frank
     
  4. bast1e

    bast1e Eroberer

    Dabei seit:
    03.12.2003
    Beiträge:
    74
    Zustimmungen:
    0
    Ort:
    Germany
    naja - also er nimmt den befehl an und scheint, als ob er ihn ausführt aber er wird halt nicht beendet, kriege also keinen prompt wieder...

    bei sda1 sagt er existiert nicht :(
     
  5. rikola

    rikola Foren Gott

    Dabei seit:
    23.08.2005
    Beiträge:
    2.133
    Zustimmungen:
    0
    Koenntest Du die Fehlermeldungen per cut-and-paste an uns weitergeben?
    Deine Ausgabe von dmesg sagt, dass das Geraet eine Partition hat, die Du ueber /dev/sda1 ansprechen kannst. Von daher ist
    Code:
    mount /dev/sda1 /existierendes/leeres/Verzeichnis
    
    die richtige Art, das Geraet einzuhaengen. Wenn sich SuSE beschwert, liegt das vermutlich daran, dass es subfs benutzt und Geraete automatisch einhaengt (gib mal im Konqueror die Adresse 'media:/' ein). Wenn du den Stick dennoch von Hand mounten willst, schau erstmal mittels
    'ls -la /dev/sda1' nach, ob diese Datei existiert. Wenn nicht (was die Fehlermeldung vermuten laesst), leg sie mittels
    Code:
    mknod /dev/sda1 c 94 1
    
    (als root) an. Die Angaben ueber 'c 94 1' findest Du in der Datei 'linux-kernel/Documentation/devices.txt', wobei 'linux-kernel' der Pfad zur Quelle des Linux-Kernels ist.

    Kann sein, dass die Datei beim naechsten Neustart nicht mehr da ist, ich weiss nicht, wie weit SuSE da geht mit dem Clever-sein.
     
  6. bast1e

    bast1e Eroberer

    Dabei seit:
    03.12.2003
    Beiträge:
    74
    Zustimmungen:
    0
    Ort:
    Germany
    hi,

    also bei media:/
    kommt nur das dvdlw, nen paar nfs mounts und meine 3 festplattenpartitionen.

    habe dev/sda1 mit dem befehl erstellt, beim mounten kommt:
    mount: /dev/sda1 ist kein blockorientiertes Gerät

    wenn ich /dev/sda mounten wollte kam keinerlei meldung
     
  7. theton

    theton Bitmuncher

    Dabei seit:
    27.05.2004
    Beiträge:
    4.820
    Zustimmungen:
    0
    Ort:
    Berlin, Germany
    Devices fuer USB-Sticks muss man im Normalfall nicht mit mknod anlegen. Das machen die entsprechenden Module (in diesem Fall usb-storage) automatisch. Also einfach /dev/sda1 mounten und fertig. Gibt's beim mounten keine Fehlermeldung kannst du dich mit 'df -ah' davon ueberzeugen, dass er wirklich eingehaengt ist.
     
  8. MrBoe

    MrBoe Routinier

    Dabei seit:
    13.06.2006
    Beiträge:
    399
    Zustimmungen:
    0
    Ort:
    braunschweig/nds/de/world
    Was sagt den ein
    ?
     
  9. bast1e

    bast1e Eroberer

    Dabei seit:
    03.12.2003
    Beiträge:
    74
    Zustimmungen:
    0
    Ort:
    Germany
    8 0 4152360 sda
    8 1 4144738 sda1

    sagt das von den sdas (nach dem mknod)

    beim mounten wird er einfach nicht fertig

    df -a gibt alles mögliche aus, nur nichts mit sda und/oder dem mountpunkt
     
  10. MrBoe

    MrBoe Routinier

    Dabei seit:
    13.06.2006
    Beiträge:
    399
    Zustimmungen:
    0
    Ort:
    braunschweig/nds/de/world
    Is nur so ne Idee:

    Was ist den für ein Dateisystem auf dem Stick? Hast du die Unterstützung dafür vielleicht nicht?

    Was macht (vorrausgesetzt das Verzeichnis "/windows" ist da) ein als root ausgeführtes
    ?
     
  11. bast1e

    bast1e Eroberer

    Dabei seit:
    03.12.2003
    Beiträge:
    74
    Zustimmungen:
    0
    Ort:
    Germany
    hi,

    hab die standard suse linux 10.1 installation gemacht - bei dem mount mit -t auto passiert das selbe wie sonst auch - er wird nicht fertig, macht auch nichts, ein neues prompt gibts leider auch nicht :-/

    dateisystem ist fat32
     
  12. theton

    theton Bitmuncher

    Dabei seit:
    27.05.2004
    Beiträge:
    4.820
    Zustimmungen:
    0
    Ort:
    Berlin, Germany
    'mount -t vfat /dev/sda1 /windows' und dabei mal einen Blick in die messages werfen. In einem zweiten Terminal also vorher 'tail -f /var/log/messages' eingeben damit du beim mount die Log-Outputs sehen kannst.
     
  13. #12 bast1e, 02.09.2006
    Zuletzt bearbeitet: 02.09.2006
    bast1e

    bast1e Eroberer

    Dabei seit:
    03.12.2003
    Beiträge:
    74
    Zustimmungen:
    0
    Ort:
    Germany
    hi,

    da kommt das:
    mfg bastie

    edit: das kommt einige male
     
  14. theton

    theton Bitmuncher

    Dabei seit:
    27.05.2004
    Beiträge:
    4.820
    Zustimmungen:
    0
    Ort:
    Berlin, Germany
    Und was sagt 'df -ah' nachdem du das gemacht hast?
     
  15. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  16. bast1e

    bast1e Eroberer

    Dabei seit:
    03.12.2003
    Beiträge:
    74
    Zustimmungen:
    0
    Ort:
    Germany
    nichts über /dev/sda - hab meinen letzten beitrag editiert, da kamen weitere meldungen
     
  17. theton

    theton Bitmuncher

    Dabei seit:
    27.05.2004
    Beiträge:
    4.820
    Zustimmungen:
    0
    Ort:
    Berlin, Germany
    Code:
    Sep 2 09:51:54 schlepptopf kernel: sd 9:0:0:0: SCSI error: return code = 0x50000
    Sep 2 09:51:54 schlepptopf kernel: end_request: I/O error, dev sda, sector 8289344
    Sep 2 09:51:54 schlepptopf kernel: Buffer I/O error on device sda1, logical block 8289281
    
    Sieht mir nach einer beschaedigten Partition und/oder Platte aus. Zeigt dir 'fdisk -l' eine saubere Partitionstabelle an oder bekommst du Meldungen wegen ueberlappenden Partitionen o.ae. (Windows ignoriert die ja geflissentlich und sorgt damit oft dafuer, dass Daten unlesbar werden)?
     
Thema:

4GByte USB Stick lässt sich nicht mounten

Die Seite wird geladen...

4GByte USB Stick lässt sich nicht mounten - Ähnliche Themen

  1. USB Stick gesperrt

    USB Stick gesperrt: ′
  2. Mobiles Linux auf USB-Stick

    Mobiles Linux auf USB-Stick: Hallo, ich würde mir gerne auf einem USB-Stick eine Partition einrichten, auf der ein bootbares Linux ist. ich hatte schon ein Knoppix drauf,...
  3. MagicStick erhält Ubuntu Core als Alternative

    MagicStick erhält Ubuntu Core als Alternative: MagicStick ist ein derzeit auf Indiegogo finanzierter PC-Stick, der ein TV-Gerät in einen Smart-TV verwandeln soll. Wegen des großen Erfolgs ist...
  4. SSD auf einen (geringfügig) kleineren USB-Stick wiederherstellen

    SSD auf einen (geringfügig) kleineren USB-Stick wiederherstellen: Hallo, ich habe hier ein Ubuntu, instaliert auf einer SSD. Für einige Systemtests möchte ich das System auf einen USb-Stick klonen, der leider...
  5. Bootpartition von CentOS7 auf USB-Stick vergrößern

    Bootpartition von CentOS7 auf USB-Stick vergrößern: Hallo, ich knabbere mir schon seit einer Weile an folgendem Problem: auf einem HP Microserver G1610T habe ich CentOS7 installiert. Aus...