ssh login schlägt fehl

Dieses Thema im Forum "Security Talk" wurde erstellt von Voodoo, 11.04.2006.

  1. #1 Voodoo, 11.04.2006
    Zuletzt bearbeitet: 30.05.2006
    Voodoo

    Voodoo Jungspund

    Dabei seit:
    22.03.2006
    Beiträge:
    24
    Zustimmungen:
    0
    moin

    ich habe ein merkwürdiges Problem und zwar kann man sich auf einen Rechner von mir nur per ssh key einlogen. Doch bei einem User geht das nicht!
    Und zwar ist das der User xyz aus der gruppe xyz. Alles ist genau so eingestellt wie bei den anderen(die anderen user sind auch von der gruppe xyz).

    der public key liegt in /home/devel/.ssh und heißt authorized_keys.
    Hat jemand ein Tip?? Oder mal so ein ähnliches Porblem gehabt??

    Bitte um Hilfe
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 Goodspeed, 11.04.2006
    Goodspeed

    Goodspeed Foren Gott
    Moderator

    Dabei seit:
    21.04.2004
    Beiträge:
    4.165
    Zustimmungen:
    1
    Ort:
    Dresden
    Geht ich recht in der Annahme, dass Du einen private-key zum Einloggen als verschiedene User nutzt?
    Welche Fehlermeldung kommt denn?
    Schau mal, ob es in der authorized_keys irgendwelche Zeilenumbrüche gibt, die es nicht geben sollte.
    Und check auch mal die Berechtigungen und Owner von .ssh und authorized_keys ...
     
  4. #3 Voodoo, 11.04.2006
    Zuletzt bearbeitet: 30.05.2006
    Voodoo

    Voodoo Jungspund

    Dabei seit:
    22.03.2006
    Beiträge:
    24
    Zustimmungen:
    0
    jo ich benutzt ein privatkey und zwar log ich mich per putty ein(das bricht immer beim einlog versuch ab).
    Zeilen, Rechte und Gruppen hab ich überprüft sieht alles richtig aus.

    das gibt putty zurück
    Code:
    login as: xyz
    Server refused our key
    No supported authentication methods left to try!
    
    und wenn ich auf der maschine selber per konsole einlogen will dann kommt diese ausgabe(das ist aber bei jedem user so)
    Code:
    eingabe : ssh xyz@rechner
    ausgabe : Permission denied (publickey,gssapi-with-mic)
    
     
  5. #4 Goodspeed, 11.04.2006
    Goodspeed

    Goodspeed Foren Gott
    Moderator

    Dabei seit:
    21.04.2004
    Beiträge:
    4.165
    Zustimmungen:
    1
    Ort:
    Dresden
    Also kein Zeilenumbruch in den authorized_keys?
    Im Zweifelsfall würde ich das File von nem funktionierenden Account kopieren und den Owner anpassen ...
    Naja ... entweder Du gibst den falschen private-key mit, oder der public-key stimmt nicht ganz ...
     
  6. rikola

    rikola Foren Gott

    Dabei seit:
    23.08.2005
    Beiträge:
    2.133
    Zustimmungen:
    0
    Hast Du Verwalterrechte auf dem Zielrechner? Dann starte sshd doch mal mit '-d' und sie unter /var/log nach, ob dort ein deutlicherer Hinweis ist, weswegen der Schluessel nicht angenommen wird.
     
  7. #6 Voodoo, 11.04.2006
    Zuletzt bearbeitet: 30.05.2006
    Voodoo

    Voodoo Jungspund

    Dabei seit:
    22.03.2006
    Beiträge:
    24
    Zustimmungen:
    0
    also ich hab jetzt neue keys erstellt und wenn ihc mich das erste mal auf dem server (von sich selber aus) einloge kommt diese Meldun
    Code:
    ssh xyt@rechner
    The authenticity of host 'rechner (xxx.xxx.xxx.xxx)' can't be established.
    RSA key fingerprint is ff:3c:0d:78:a6:09:53:a2:4d:8b:60:ff:50:65:f0:87.
    Are you sure you want to continue connecting (yes/no)? y
    Please type 'yes' or 'no': yes
    Warning: Permanently added 'rechner,xxx.xxx.xxx.xxx' (RSA) to the list of known hosts.
    Permission denied (publickey,gssapi-with-mic).
    
    
     
  8. rikola

    rikola Foren Gott

    Dabei seit:
    23.08.2005
    Beiträge:
    2.133
    Zustimmungen:
    0
    Hast Du nun Verwalterrechte? Dann waere wirklich das einfachste, dass Du mal in der log-Datei nachguckst (und ssh mit -d oder -dd o.ae. laufen laesst).
     
  9. #8 Voodoo, 11.04.2006
    Zuletzt bearbeitet: 30.05.2006
    Voodoo

    Voodoo Jungspund

    Dabei seit:
    22.03.2006
    Beiträge:
    24
    Zustimmungen:
    0
    jo hab ich und das hier steht ziemlich oft in der log datei

    Code:
    Apr 11 13:34:47 rechner sshd[28686]: Authentication refused: bad ownership or modes for directory /home/devel
    
     
  10. #9 Goodspeed, 11.04.2006
    Goodspeed

    Goodspeed Foren Gott
    Moderator

    Dabei seit:
    21.04.2004
    Beiträge:
    4.165
    Zustimmungen:
    1
    Ort:
    Dresden
    Welche Recht hat das Verzeichniss denn??
     
  11. Voodoo

    Voodoo Jungspund

    Dabei seit:
    22.03.2006
    Beiträge:
    24
    Zustimmungen:
    0
    also hab es hinbekommen das verzeichnis devel hatte die werte 770 hab es auf 700 gesetzt dann ging es. aber ich brauche auf das verzeichnis die rechte 770 ist das möglich ??? 700 bringt mir leider nix da die normalen user in der gruppe devel sind und auch auf den ordner zugreifen sollen.
     
  12. #11 Goodspeed, 11.04.2006
    Goodspeed

    Goodspeed Foren Gott
    Moderator

    Dabei seit:
    21.04.2004
    Beiträge:
    4.165
    Zustimmungen:
    1
    Ort:
    Dresden
    Leserechte kannste ja vergeben ... aber Scheibrechte sollte kein anderer User in nem fremden Home haben ... sonst könnte man ja auch das .ssh-Verzeichniss manipulieren.
    Im Zweifelsfall musste halt ein extra Verzeichniss anlegen ...
     
  13. rikola

    rikola Foren Gott

    Dabei seit:
    23.08.2005
    Beiträge:
    2.133
    Zustimmungen:
    0
    Wenn die anderen nur lesend zugreifen sollen, dann versuch es mal mit mode 755 oder 750. Andernfalls muesstest Du den Wert von StrictModes in /etc/ssh/sshd_config of "no" setzen. Das solltest Du allerdings nicht tun, ist eine dicke Sicherheitsluecke. Koenntest Du zum Datenaustausch nicht ein anderes Verzeichnis benutzen, oder cvs bzw. svn? Da die Gruppe devel heisst, ist letzteres doch sehr naheliegend.
     
  14. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  15. Voodoo

    Voodoo Jungspund

    Dabei seit:
    22.03.2006
    Beiträge:
    24
    Zustimmungen:
    0
    also das verzeichnis .ssh hat die rechte 700. da kann doch eigentlich keiner dann ran?? auch wenn das homeverzeichnis des users frei ist für den user selbst und die gruppe des users.
     
  16. rikola

    rikola Foren Gott

    Dabei seit:
    23.08.2005
    Beiträge:
    2.133
    Zustimmungen:
    0
    An sich schon. Die openbsd-FAQ sclagen folgendes vor:
    Code:
        $ chmod go-w $HOME $HOME/.ssh
        $ chmod 600 $HOME/.ssh/authorized_keys
    
    Ist das bei Dir der Fall?
    Wenn nicht, dann starte doch (endlich...) mal sshd mit der Option -ddd, und guck dann nach, worueber sich sshd in der log-Datei beschwert. Das ist zumindest das, was google ziemlich weit oben ausspuckt.
     
Thema:

ssh login schlägt fehl

Die Seite wird geladen...

ssh login schlägt fehl - Ähnliche Themen

  1. Starten eines X Programmes über rlogin schlägt fehl

    Starten eines X Programmes über rlogin schlägt fehl: Hi Folks, ich benötige dringend Eure Hilfe. Ich möchte mit von meinem Debian aus zu einem Solaris System verbinden. Dort will ich ein X...
  2. login mit cyradm schlägt fehl

    login mit cyradm schlägt fehl: habe die pakete von cyrus22 installiert und es läuft. versuche mich anzumelden mit. su cyrus cyradm localhost werde dann aufgefordert das IMAP...
  3. Solaris Login mit Active Directory User

    Solaris Login mit Active Directory User: Hallo zusammen, Ich arbeite daran unsere Solaris Systeme ans AD anzubinden. Teilweise ist mir das schon gelungen, teilweise stehe ich aber auch...
  4. Frage zu QNX - habe login nie gefunden

    Frage zu QNX - habe login nie gefunden: ′
  5. SSH Login nur mit einer bestimmten IP die in einer Textdatei gespeichert wird

    SSH Login nur mit einer bestimmten IP die in einer Textdatei gespeichert wird: Hallo Ich bin andauernd Opfer einer Brute Force Attacke. Die IPs die fehlerhafte Logins produzieren werden nach dem 3ten Versuch gesperrt. Aber...