SSH Zugang ohne Passwort

Dieses Thema im Forum "RedHat,Fedora & CentOS" wurde erstellt von wizzardxx, 15.01.2008.

  1. #1 wizzardxx, 15.01.2008
    wizzardxx

    wizzardxx Mitglied

    Dabei seit:
    04.04.2003
    Beiträge:
    32
    Zustimmungen:
    0
    Hallo zusammen,

    ich habe folgendes Problem:
    Ich möchte mich von einem Linux Server zu einem anderen per shh ohne Passwort abfrage verbinden. Was immer ich auch mache kommt immer wieder die frage nach dem Passwort.

    Fogendes habe ich gemacht:

    1. Server = Samba Fileserver -Fedora Core 8
    2. Server = Backupserver -Fedora Core 8

    Auf dem Fileserver den Key erzeugt mit: ssh-keygen -t rsa -b 1024
    Alles mit Enter bestätigt

    Auf dem Backupserver zuvor im user home Verzeichnis einen Ornder .ssh angelegt.

    Den id_rsa.pub vom Fileserver in das home verzeichnis des users kopiert
    scp ~/.ssh/id_rsa.pub backup@192.168.1.221:~/.ssh/id_rsa.client

    passwort des users backup eingegen.

    in der console steht: id_rsa.pub 100% 255 0,2KB/s 00:00

    Auf den Backupserver einlogen: ssh backup@192.168.1.221
    Passwort eingeben - Enter

    Ins home verzeichnes des users wechseln wo die Datei liegt.

    cd /home/backup/.ssh

    Den Schlüssel bekannt machen:

    cat id_rsa.client >> authorized_keys
    Enter

    Die id_rsa.client löschen
    rm id_rsa.client
    exit

    Wenn ich mich jetzt vom Fileserver mit:
    ssh backup@192.168.1.221
    einloggen will kommt trotzdem wieder die Frage nach dem Passwort.

    Was mache ich bloß falsch? Ich sitze jetzt schon den 2.Tag daran.
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. Rvg

    Rvg Doppel-As

    Dabei seit:
    11.07.2004
    Beiträge:
    141
    Zustimmungen:
    0
    hast du auf dem backup-Server ja sicher auskommentiert (sshd_config)?
    sonst, was sagt ssh -v?
     
  4. #3 Floetkowski, 15.01.2008
    Floetkowski

    Floetkowski Mitglied

    Dabei seit:
    23.04.2007
    Beiträge:
    30
    Zustimmungen:
    0
    was is der sinn von nem ssh server ohne passwort?
    dann nimm lieber telnet^^
     
  5. #4 wizzardxx, 15.01.2008
    wizzardxx

    wizzardxx Mitglied

    Dabei seit:
    04.04.2003
    Beiträge:
    32
    Zustimmungen:
    0
    PubkeyAuthentication yes
    AuthorizedKeysFile .ssh/authorized_keys

    Sind beide auskommentiert
    ssh -v sagt folgendes:

    OpenSSH_4.7p1, OpenSSL 0.9.8b 04 May 2006
    usage: ssh [-1246AaCfgKkMNnqsTtVvXxY] [-b bind_address] [-c cipher_spec]
    [-D [bind_address:]port] [-e escape_char] [-F configfile]
    [-i identity_file] [-L [bind_address:]port:host:hostport]
    [-l login_name] [-m mac_spec] [-O ctl_cmd] [-o option] [-p port]
    [-R [bind_address:]port:host:hostport] [-S ctl_path]
    [-w local_tun[:remote_tun]] [user@]hostname [command]

    @Floetkowski
    ssh ohne passwort brauche ich für ein automatisches Backup welches zu einer bestimmten Uhrzeit per rsync läuft.
     
  6. Gast1

    Gast1 Guest

    *In Glaskugel blick*

    Vermutlich will Rvg die Version von ssh wissen, deshalb

    Code:
    ssh -V
    Greetz,

    RM

    P.S. @Floetkowski

    Du möchtest Dich darüber informieren, wieso SSH mit einer Authentifizierung über Pubkeys

    a) nicht zwingend eine lokale Passphrase (!=Passwort) und erst recht kein Passwort benötigt

    und

    b) trotzdem ein höheres Maß an Sicherheit gegenüber einem Remote-Angriff als _JEDE_ Verbindung über telnet bietet.
     
  7. #6 wizzardxx, 15.01.2008
    wizzardxx

    wizzardxx Mitglied

    Dabei seit:
    04.04.2003
    Beiträge:
    32
    Zustimmungen:
    0
    Ok dann hier nochmal die kurzfassung ;-)

    OpenSSH_4.7p1, OpenSSL 0.9.8b 04 May 2006
     
  8. #7 bytepool, 15.01.2008
    bytepool

    bytepool Code Monkey

    Dabei seit:
    12.07.2003
    Beiträge:
    791
    Zustimmungen:
    0
    Ort:
    /home/sweden/göteborg
    Ich will auch mal ;)
    Ich glaube Rvg wollte eher dass er mal mit aktiviertem debug output (-v) versucht eine Verbindung herzustellen, das koennte dann naemlich eventuell Aufschluss darueber geben was falsch laeuft.

    mfg,
    bytepool
     
  9. #8 wizzardxx, 15.01.2008
    wizzardxx

    wizzardxx Mitglied

    Dabei seit:
    04.04.2003
    Beiträge:
    32
    Zustimmungen:
    0
    Was beudetet dieses debug output (-v)?
    Was genau muss man da machen?
     
  10. Rvg

    Rvg Doppel-As

    Dabei seit:
    11.07.2004
    Beiträge:
    141
    Zustimmungen:
    0
    *hust* sorry, japp letzteres. wobei ich mir vorstellen kann, das pam da seine finger drin hat
     
  11. Gast1

    Gast1 Guest

    Den Parameter -v _zusätzlich_ zu den anderen Angaben hinzufügen, die man sonst beim Login eingibt.

    Greetz,

    RM
     
  12. #11 wizzardxx, 15.01.2008
    wizzardxx

    wizzardxx Mitglied

    Dabei seit:
    04.04.2003
    Beiträge:
    32
    Zustimmungen:
    0
    Oh ha... ist ja krass.

    [root@fileserver ~]# ssh backup@192.168.1.221 -v
    OpenSSH_4.7p1, OpenSSL 0.9.8b 04 May 2006
    debug1: Reading configuration data /etc/ssh/ssh_config
    debug1: Applying options for *
    debug1: Connecting to 192.168.1.221 [192.168.1.221] port 22.
    debug1: Connection established.
    debug1: permanently_set_uid: 0/0
    debug1: identity file /root/.ssh/identity type -1
    debug1: identity file /root/.ssh/id_rsa type 1
    debug1: identity file /root/.ssh/id_dsa type -1
    debug1: Remote protocol version 2.0, remote software version OpenSSH_4.7
    debug1: match: OpenSSH_4.7 pat OpenSSH*
    debug1: Enabling compatibility mode for protocol 2.0
    debug1: Local version string SSH-2.0-OpenSSH_4.7
    debug1: SSH2_MSG_KEXINIT sent
    debug1: SSH2_MSG_KEXINIT received
    debug1: kex: server->client aes128-cbc hmac-md5 none
    debug1: kex: client->server aes128-cbc hmac-md5 none
    debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent
    debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
    debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
    debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
    debug1: Host '192.168.1.221' is known and matches the RSA host key.
    debug1: Found key in /root/.ssh/known_hosts:1
    debug1: ssh_rsa_verify: signature correct
    debug1: SSH2_MSG_NEWKEYS sent
    debug1: expecting SSH2_MSG_NEWKEYS
    debug1: SSH2_MSG_NEWKEYS received
    debug1: SSH2_MSG_SERVICE_REQUEST sent
    debug1: SSH2_MSG_SERVICE_ACCEPT received
    debug1: Authentications that can continue: publickey,gssapi-with-mic,password
    debug1: Next authentication method: gssapi-with-mic
    Address 192.168.1.221 maps to localhost, but this does not map back to the addre ss - POSSIBLE BREAK-IN ATTEMPT!
    debug1: Unspecified GSS failure. Minor code may provide more information
    No credentials cache found

    debug1: Unspecified GSS failure. Minor code may provide more information
    No credentials cache found

    debug1: Unspecified GSS failure. Minor code may provide more information


    debug1: Next authentication method: publickey
    debug1: Trying private key: /root/.ssh/identity
    debug1: Offering public key: /root/.ssh/id_rsa
    debug1: Authentications that can continue: publickey,gssapi-with-mic,password
    debug1: Trying private key: /root/.ssh/id_dsa
    debug1: Next authentication method: password
    backup@192.168.1.221's password:
     
  13. #12 ezekiel, 15.01.2008
    ezekiel

    ezekiel Jungspund

    Dabei seit:
    05.11.2006
    Beiträge:
    29
    Zustimmungen:
    0
    die letzte zeile des logs sagt wohl aus, dass du passwort-logins nicht verboten hast

    vi /etc/ssh/sshd_config:
    Code:
      Wir deaktivieren die kennwortbasierte Authentifizierung und verwenden nur noch die auf dem Austausch des öffentlichen Schlüssels basierende Authentifizierung, die wir im letzten Abschnitt eingerichtet haben.
    
    # disable password authentication 
    PasswordAuthentication no 
    habe ich aus der debian-anleitung, an der man sich meiner Meinung ganz gut orientieren kann: http://www.debianhowto.de/doku.php/de:howtos:woody:ssh

    was mir auch noch auffällt:
    Code:
    debug1: Authentications that can continue: publickey,gssapi-with-mic,password
    debug1: Next authentication method: gssapi-with-mic
    Address 192.168.1.221 maps to localhost, but this does not map back to the addre ss - POSSIBLE BREAK-IN ATTEMPT!
    sieht so aus als ob du nen zertifikat erstellt hast, ich denke, der client muss nen zertifikat erstellen und du das zur liste hinzufügen... meine ich zumindest beim link gelesen zu haben

    mfg
     
  14. #13 wizzardxx, 15.01.2008
    Zuletzt bearbeitet: 15.01.2008
    wizzardxx

    wizzardxx Mitglied

    Dabei seit:
    04.04.2003
    Beiträge:
    32
    Zustimmungen:
    0
    # disable password authentication
    PasswordAuthentication no

    Habe ich gemacht. Ergebnis ist aber das gleiche.
    Wenn ich das beim Backupserver mache dann kann ich mich garnicht mehr per ssh einloggen.

    Ich habe das vor einem Jahr schon mal 2 Redhat 9 Kisten gemacht und da klappte das auf anhieb. Hatte das extra noch mal schriftlich Dokumentiert falls ich es noch mal brauche. Fedora Core 8 muckt jetzt jedoch.
     
  15. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  16. #14 bytepool, 15.01.2008
    bytepool

    bytepool Code Monkey

    Dabei seit:
    12.07.2003
    Beiträge:
    791
    Zustimmungen:
    0
    Ort:
    /home/sweden/göteborg
    hi,

    Sind die Pfade denn korrekt? Ich frage weil du im ersten Post alle Schritte nur mit ~ beschrieben hast, aber nicht gesagt hast als wer du angemeldet warst.

    mfg,
    bytepool
     
  17. #15 wizzardxx, 15.01.2008
    wizzardxx

    wizzardxx Mitglied

    Dabei seit:
    04.04.2003
    Beiträge:
    32
    Zustimmungen:
    0
    Das hier liegt im root/.ssh Verzeichnis auf dem Filserver wo ich den Key erstellt habe (als root):

    [root@fileserver .ssh]# ls
    id_rsa id_rsa.pub known_hosts

    Und auf dem Backupserver liegt die authorized_keys
    in /home/backup/.ssh

    Den schlüssel habe ich mit dem user backup bekannt gemacht.
    Alos cat /home/backups/.ssh/id_rsa.client >> authorized_keys
     
Thema:

SSH Zugang ohne Passwort

Die Seite wird geladen...

SSH Zugang ohne Passwort - Ähnliche Themen

  1. Wie NetBSD auf einem Rechner ohne Internet Zugang einrichten

    Wie NetBSD auf einem Rechner ohne Internet Zugang einrichten: Ich hab hier einen kleinen Rechner stehen der nur auf das lokales netz zugreifen kann. Wie kriege ich am einfachsten die Pakete (das auf dem...
  2. Problem: debian install auf laptop, ohne internet zugang

    Problem: debian install auf laptop, ohne internet zugang: Hallo zusammen. Ich habe mir ein LG LW40 Laptop gekauft. (Intel Centrino, 60 Gb Sata platte, Marvell Yukon 88E8053 Netzwerkkarte) Nun habe ich...
  3. Artikel: Webzugang für Gäste: Per Kiosk-Browser oder Porteus

    Artikel: Webzugang für Gäste: Per Kiosk-Browser oder Porteus: Wer eine allgemein zugängliche Surfstation anbietet, will den Verwaltungsaufwand so gering wie möglich halten. Dieser Beitrag zeigt und gewichtet...
  4. Samba 4 Gast Zugang unter Ubuntu funktioniert nicht

    Samba 4 Gast Zugang unter Ubuntu funktioniert nicht: Hallo zusammen, ich habe unter Ubuntu 14.04 meinen Samba Server konfiguriert wie hier beschrieben um einen Gast Zugang zu einer Freigabe zu...
  5. AMI Firmware-Source-Code und UEFI-Schlüssel frei zugänglich

    AMI Firmware-Source-Code und UEFI-Schlüssel frei zugänglich: Auf einem taiwanesischen FTP-Server sollen ungesichert aktuelle Versionen der AMI Bios-Firmware und entsprechende UEFI-Schlüssel frei zugänglich...