SSH per DSA Keyfile ohne Passwort

Dieses Thema im Forum "Internet, lokale Netzwerke und Wireless Lan" wurde erstellt von LinusX, 29.03.2010.

  1. LinusX

    LinusX Jungspund

    Dabei seit:
    05.08.2007
    Beiträge:
    24
    Zustimmungen:
    0
    Hallo,

    ich versuche nun schon seit knapp einer Woche eine SSH Verbindung zu einem Linuxrechner aufzubauen ohne eine Passwort eingeben zu müssen. Ich habe mich an die zahlreichen Howtos gehalten die ja überall zu finden sind. Bloß aus irgendeinem Grund wird beim Verbindungsaufbau immer noch nach einem Passwort verlangt! Hier die kurze Beschreibung wie ich vorgegangen bin.

    1. auf dem SSh-Client: DSA-Keyfiles erzeugen:

    #: ssh-keygen -b 2048

    2. keine Passphrase eingegeben- (2x ENTER)

    3.id_dsa.pub File auf SSH-Server kopiert:

    4.cat id_dsa_pub >> /home/user/.ssl/authorized_keys

    4. Berechtigungen angepasst: chmod 700 ~/user/.ssl
    chmod 600 /user/authorized_keys

    5. Verbindung testen:

    #ssh -i /.ssh/id_dsa zielrechner

    leider kommt dann jedes Mal eine Passwort abfrage: (keine Passphrase abfrage) Gebe ich das Passwort manuell ein, funktioniert der Zugriff ohne Probleme. Ich habe auch schon die sshd.conf von einer der Maschinen kopiert, bei denen es geht. Hat leider nichts gebracht.

    Ich benötige diese Art von Anmeldung für meine Nagios-Umgebung. Um Testscripte durchzuführen. Das Witzige ist das diese Methode bei 2 von 7 Unix-Maschinen tatsächlich funktioniert!! Bei den restlichen 5 geht es leider nicht. Habe auch schon rsa versucht, genau das selbe! Was kann das Problem sein.

    hier noch was mir die Console ausspuckt bei -vvv

    ########### LOG mit -vvv bei SSH Verbindungsaufbau #############

    Next authentication method: publickey
    debug1: Offering public key: /etc/nagios/.ssh/id_dsa
    debug3: send_pubkey_test
    debug2: we sent a publickey packet, wait for reply
    debug1: Authentications that can continue: publickey,keyboard-interactive
    debug2: we did not send a packet, disable method
    debug3: authmethod_lookup keyboard-interactive
    debug3: remaining preferred: password
    debug3: authmethod_is_enabled keyboard-interactive
    debug1: Next authentication method: keyboard-interactive
    debug2: userauth_kbdint
    debug2: we sent a keyboard-interactive packet, wait for reply
    debug2: input_userauth_info_req
    debug2: input_userauth_info_req: num_prompts 1
    Password:
    ################################################




    Bitte um Hilfe..

    Gruß und Danke
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 sim4000, 29.03.2010
    sim4000

    sim4000 Lebende Foren Legende

    Dabei seit:
    12.04.2006
    Beiträge:
    1.933
    Zustimmungen:
    0
    Ort:
    In meinem Zimmer
    Die authorized_keys Datei muss in den Ordner ~/.ssh und nicht in ~/.ssl. ;)
     
  4. LinusX

    LinusX Jungspund

    Dabei seit:
    05.08.2007
    Beiträge:
    24
    Zustimmungen:
    0
    oops habe mich verschrieben! liegt im Ordner /.ssh !!

    Mich verwundert nur die Zeile: debug2: "we did not send a packet, disable method" sehr.

    Ich habe in anderen Foren schon davon gelesen und immer waren es Berechtigungen! Teilweise auch wenn die Berechtigungen der Verzeichnisse zu hoch waren.

    Irgendeine Idee?

    Trotzdem Danke
     
  5. #4 sim4000, 29.03.2010
    sim4000

    sim4000 Lebende Foren Legende

    Dabei seit:
    12.04.2006
    Beiträge:
    1.933
    Zustimmungen:
    0
    Ort:
    In meinem Zimmer
    Ist den die Key Auth in der /etc/sshd_config aktiviert?

    //edit
    Ach steht da ja...
     
  6. #5 schwedenmann, 29.03.2010
    schwedenmann

    schwedenmann Foren Gott

    Dabei seit:
    18.11.2003
    Beiträge:
    2.635
    Zustimmungen:
    2
    Ort:
    Wegberg
  7. #6 HeadCrash, 29.03.2010
    HeadCrash

    HeadCrash Routinier

    Dabei seit:
    16.05.2009
    Beiträge:
    482
    Zustimmungen:
    1
    Ort:
    Bayern
    Wie sehen die Rechte für den Privatteil des Keys aus, und was sagt das Logfile des sshds?

    mfg
    HeadCrash
     
  8. Lord_x

    Lord_x Guest

  9. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  10. defcon

    defcon Kaiser
    Moderator

    Dabei seit:
    22.08.2005
    Beiträge:
    1.486
    Zustimmungen:
    1
    Ort:
    Bruchsal
  11. #9 saeckereier, 30.03.2010
    saeckereier

    saeckereier Graue Eminenz

    Dabei seit:
    08.05.2005
    Beiträge:
    1.920
    Zustimmungen:
    0
    Ort:
    Im schönen Norden
    ~/user/.ssh hast du weiter oben geschrieben, richtig wäre aber ~/.ssh also /home/user/.ssh
    Poste bitte die Ausgabe von ls -l ~/.ssh und ls -ld ~/.ssh (inklusive Aufruf des ls Kommandos)
     
Thema:

SSH per DSA Keyfile ohne Passwort

Die Seite wird geladen...

SSH per DSA Keyfile ohne Passwort - Ähnliche Themen

  1. Verschlüsselung mit Keyfile

    Verschlüsselung mit Keyfile: Hallo, ich hoffe ich bin im richtigen Unterforum. Ansonsten bitte einfach verschieben. Ich möchte zwar ein Bash-Skript programmieren aber suche...
  2. Luks keyfile over ssh

    Luks keyfile over ssh: Moin, will mir ein script basteln um auf meinem Homeserver die Luks partionen aufzuschließen via keyfile welches sich nicht auf dem Rechner...
  3. sftp mit putty keyfile

    sftp mit putty keyfile: Hallo, Ich muss mich mit einem sftp Server verbinden. Dazu hab ich die Server ip, username, password und eine server.ppk Datei. Gebe ich nur...
  4. Verschlüsselung mit Keyfiles auf USB-Stick

    Verschlüsselung mit Keyfiles auf USB-Stick: Hallo zusammen! Wie ist es möglich, einen USB-Stick wie eine Art Schlüssel für den PC zu verwenden? Ich habe es bereits mit TrueCrypt und...
  5. FTP/FTPS ohne ip_conntrack_ftp oder nf_conntrack_ftp mit iptables

    FTP/FTPS ohne ip_conntrack_ftp oder nf_conntrack_ftp mit iptables: Guten Tag, kennt jemand von euch eine Möglichkeit wie ich vsftpd nutzen kann zusammen mit einer Firewall ohne die im Betreff angegebenen...