proftpd startet... kann mich jedoch nicht verbinden

Dieses Thema im Forum "Web- & File-Services" wurde erstellt von Peggie, 14.04.2008.

  1. Peggie

    Peggie Mitglied

    Dabei seit:
    14.04.2008
    Beiträge:
    42
    Zustimmungen:
    0
    Hallo,

    proftpd startet problemlos.
    Im Ftp Client bekomme ich jedoch die Meldung

    Code:
    Fehler:	Herstellen der Verbindung zum Server fehlgeschlagen
    Status:	Nächsten Versuch abwarten...
    Status:	Verbinde mit 78.46.66.107:21...
    Status:	Verbindung hergestellt, warte auf Willkommensnachricht...
    Fehler:	Herstellen der Verbindung zum Server fehlgeschlagen
    Status:	Nächsten Versuch abwarten...
    Status:	Verbinde mit 78.46.66.107:21...
    Status:	Verbindung hergestellt, warte auf Willkommensnachricht...
    Fehler:	Herstellen der Verbindung zum Server fehlgeschlagen
    Ich finde den Fehler nicht... Firewall ist deaktiviert und dennoch antwortet der server nicht.

    ich habe am standardport 21 nix geändert

    Habt ihr einen Tip`?
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 supersucker, 14.04.2008
    supersucker

    supersucker Foren Gott

    Dabei seit:
    21.02.2005
    Beiträge:
    3.873
    Zustimmungen:
    0
    Was sagen denn die proftpd-Serverlogs?
     
  4. #3 Tomekk228, 14.04.2008
    Tomekk228

    Tomekk228 Lebende Foren Legende

    Dabei seit:
    14.08.2007
    Beiträge:
    2.417
    Zustimmungen:
    0
    Ort:
    /home/tomekk/
    Distri?
    Router oder Modem oder Root?
     
  5. #4 Peggie, 14.04.2008
    Zuletzt bearbeitet: 14.04.2008
    Peggie

    Peggie Mitglied

    Dabei seit:
    14.04.2008
    Beiträge:
    42
    Zustimmungen:
    0
    leider finde ich keine unter /var/logs/proftpd

    er legt keine an
    .
    .
    .
    EDIT (autom. Beitragszusammenführung) :
    .

    Fedora 8
    Root
     
  6. #5 supersucker, 14.04.2008
    supersucker

    supersucker Foren Gott

    Dabei seit:
    21.02.2005
    Beiträge:
    3.873
    Zustimmungen:
    0
    Hmm,

    das glaub ich nicht.

    Poste mal die proftp-Konfiguration.
     
  7. #6 Peggie, 14.04.2008
    Zuletzt bearbeitet: 15.04.2008
    Peggie

    Peggie Mitglied

    Dabei seit:
    14.04.2008
    Beiträge:
    42
    Zustimmungen:
    0
    Code:
    # This is the ProFTPD configuration file
    ServerName			"ProFTPD server"
    ServerIdent			on "FTP Server ready."
    ServerAdmin			root@localhost
    ServerType			standalone
    DefaultServer			on
    AccessGrantMsg			"User %u logged in."
    DeferWelcome			off
    DefaultRoot			~ !adm
    AuthPAMConfig			proftpd
    AuthOrder			mod_auth_pam.c* mod_auth_unix.c
    IdentLookups			off
    UseReverseDNS			off
    Port				21
    Umask				022
    ListOptions			"-a"
    AllowRetrieveRestart		on
    AllowStoreRestart		on
    MaxInstances			20
    User				nobody
    Group				nobody
    UseSendfile			no
    ScoreboardFile			/var/run/proftpd.score
    <Global>
      AllowOverwrite		yes
      <Limit ALL SITE_CHMOD>
        AllowAll
      </Limit>
    </Global>
    LogFormat			default	"%h %l %u %t \"%r\" %s %b"
    LogFormat			auth	"%v [%P] %h %t \"%r\" %s"
    <IfModule mod_dso.c>
       LoadModule mod_sql.c
       LoadModule mod_sql_mysql.c
    #   LoadModule mod_sql_postgres.c
        SQLAuthTypes Plaintext
    
        SQLAuthenticate users*
    
        SQLConnectInfo ftp@localhost proftpd *****
    
        SQLDefaultGID 65534
    
        SQLDefaultUID 65534
    
        SQLMinUserGID  100
    
        SQLMinUserUID            500
    
        SQLUserInfo ftp username password uid gid homedir shell
    
    SQLLOGFILE /var/log/proftpd.sql.log
    </IfModule>
    UseIPv6 off
    
    WtmpLog off
    TransferLog /var/log/proftpd/xferlog
    ExtendedLog /var/log/proftpd/auth.log AUTH auth
    ExtendedLog /var/log/proftpd/access.log WRITE,READ write
    ExtendedLog /var/log/proftpd/paranoid.log ALL default
    SQLLogFile /var/log/proftpd/sql.log
    
    <Anonymous ~ftp>
      User				ftp
      Group				ftp
      AccessGrantMsg		"Anonymous login ok, restrictions apply."
      UserAlias			anonymous ftp
      MaxClients			10 "Sorry, max %m users -- try again later"
      DisplayLogin			/welcome.msg
      DisplayFirstChdir		.message
      DisplayReadme			README*
      DirFakeUser			on ftp
      DirFakeGroup			on ftp
      <Limit WRITE SITE_CHMOD>
        DenyAll
      </Limit>
      <Directory uploads/*>
        AllowOverwrite		no
        <Limit READ>
          DenyAll
        </Limit>
    
        <Limit STOR>
          AllowAll
        </Limit>
      </Directory>
      WtmpLog			off
      ExtendedLog		/var/log/proftpd/access.log WRITE,READ default
      ExtendedLog		/var/log/proftpd/auth.log AUTH auth
    
    </Anonymous>
    
    
     
  8. #7 supersucker, 14.04.2008
    supersucker

    supersucker Foren Gott

    Dabei seit:
    21.02.2005
    Beiträge:
    3.873
    Zustimmungen:
    0
    Ähem,

    also ich sehe hier so einiges an logfiles:

    Poste mal die beiden

     
  9. Peggie

    Peggie Mitglied

    Dabei seit:
    14.04.2008
    Beiträge:
    42
    Zustimmungen:
    0
    ja ich weiß.... aber proftpd erstellt sie eben nicht... das ja mein problem... der ordner ist leer...

    Code:
    find / -name access.log -print
    
    findet die datei auch nirgendwo anders
     
  10. #9 supersucker, 14.04.2008
    supersucker

    supersucker Foren Gott

    Dabei seit:
    21.02.2005
    Beiträge:
    3.873
    Zustimmungen:
    0
    Gibt es denn das Verzeichnis /var/log/proftpd?

    Wenn nein:

    -> erstellen
    -> Eigentümer des Verzeichnisses sollte der User sein unter dem proftp läuft
     
  11. #10 Peggie, 14.04.2008
    Zuletzt bearbeitet: 14.04.2008
    Peggie

    Peggie Mitglied

    Dabei seit:
    14.04.2008
    Beiträge:
    42
    Zustimmungen:
    0
    habe ich gemacht...
    leider werden nach wie vor keine logs erstellt
    .
    .
    .
    EDIT (autom. Beitragszusammenführung) :
    .

    selbst nach chmod 777 auf das verzeichnis /var/log/proftpd erstellt er keine...

    mach ich irgendwas verkehrt? bin ich zu dumm?
     
  12. #11 supersucker, 14.04.2008
    supersucker

    supersucker Foren Gott

    Dabei seit:
    21.02.2005
    Beiträge:
    3.873
    Zustimmungen:
    0
    Ok,

    jetzt mal ganz von vorne.

    -> Wie hast du den proftpd installiert?
    -> Wie startest du ihn?
    -> Sicher, das er auch wirklich läuft?

    Was sagt

    Code:
    ps aux | grep -i proftp
    nach einem Start?

    Wenn er läuft, funktioniert ein

    Code:
    telnet localhost 21
    vom gleichen Rechner aus? (-> Ausgabe posten)
     
  13. Peggie

    Peggie Mitglied

    Dabei seit:
    14.04.2008
    Beiträge:
    42
    Zustimmungen:
    0
    Code:
    [root@localhost]# ps aux | grep -i proftp
    nobody    3516  0.0  0.0  59548  1372 ?        Ss   15:53   0:00 proftpd: (accepting connections)
    root      3523  0.0  0.0  84308   848 pts/0    R+   15:53   0:00 grep -i proftp
    
    so wie ich das sehe läuft er....

    Code:
    telnet localhost 21
    Trying 127.0.0.1...
    Connected to localhost.
    Escape character is '^]'.
    Connection closed by foreign host.
    
    Über den Paketmanager, SQL Support nachträglich installiert

    direkt über
    Code:
    /etc/rc.d/init.d/proftpd start
    
    nicht mit letzter sicherheit:

    Code:
    /etc/rc.d/init.d/proftpd start
    proftpd starten:                                           [  OK  ]
    
    Ich bekomme über die console keine Fehlermeldung.... Leider erstellt er aber auch keine logs in der ich nachlesen könnte.... das verzeichnis ist nach wie vor auf 777. ich habe den eindruck das in meiner .conf irgendwas nicht stimmt
     
  14. #13 supersucker, 14.04.2008
    supersucker

    supersucker Foren Gott

    Dabei seit:
    21.02.2005
    Beiträge:
    3.873
    Zustimmungen:
    0
    Ok,

    das ist wirklich merkwürdig, weil das

    und das

    sagen, das er läuft......

    Hmm, muß ich mal drüber nachdenken, evtl. fällt mir später noch was ein....
     
  15. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  16. #14 Peggie, 14.04.2008
    Zuletzt bearbeitet: 14.04.2008
    Peggie

    Peggie Mitglied

    Dabei seit:
    14.04.2008
    Beiträge:
    42
    Zustimmungen:
    0
    lag am SELinux.... nun muss ich nur noch die entsprechendes regeln erstellen...
    hab aber erstmal selinux auf "nur warnen"

    connecten kann ich mich (anonymous funzt)
    wenn ich mich connecte dauert es beim login ein paar sekunden (wahrscheinlich durchsucht er die datenbank)

    danach jedoch sagt er mir:
    Code:
    Status:	Verbinde mit 78.46.66.107:21...
    Status:	Verbindung hergestellt, warte auf Willkommensnachricht...
    Antwort:	220 FTP Server ready.
    Befehl:	USER exampleuser
    Antwort:	331 Password required for exampleuser
    Befehl:	PASS ******
    Antwort:	530 Login incorrect.
    Fehler:	Herstellen der Verbindung zum Server fehlgeschlagen
    In der proftpd.sql.log finde ich auch nix ungewöhnliches:
    Hier ein Auszug:

    Code:
    Apr 14 20:47:17 mod_sql/4.2.2[5377]: defaulting to 'mysql' backend
    Apr 14 20:47:17 mod_sql/4.2.2[5377]: backend module 'mod_sql_mysql/4.0.7'
    Apr 14 20:47:17 mod_sql/4.2.2[5377]: backend api    'mod_sql_api_v1'
    Apr 14 20:47:17 mod_sql/4.2.2[5377]: >>> sql_sess_init
    Apr 14 20:47:17 mod_sql/4.2.2[5377]: entering 	mysql cmd_defineconnection
    Apr 14 20:47:17 mod_sql/4.2.2[5377]:   name: 'default'
    Apr 14 20:47:17 mod_sql/4.2.2[5377]:   user: 'proftpd'
    Apr 14 20:47:17 mod_sql/4.2.2[5377]:   host: 'localhost'
    Apr 14 20:47:17 mod_sql/4.2.2[5377]:     db: 'ftp'
    Apr 14 20:47:17 mod_sql/4.2.2[5377]:   port: '3306'
    Apr 14 20:47:17 mod_sql/4.2.2[5377]:    ttl: '0'
    Apr 14 20:47:17 mod_sql/4.2.2[5377]: exiting 	mysql cmd_defineconnection
    Apr 14 20:47:17 mod_sql/4.2.2[5377]: entering 	mysql cmd_open
    Apr 14 20:47:17 mod_sql/4.2.2[5377]: connection 'default' opened
    Apr 14 20:47:17 mod_sql/4.2.2[5377]: connection 'default' count is now 1
    Apr 14 20:47:17 mod_sql/4.2.2[5377]: exiting 	mysql cmd_open
    Apr 14 20:47:17 mod_sql/4.2.2[5377]: backend successfully connected.
    Apr 14 20:47:17 mod_sql/4.2.2[5377]: mod_sql engine     : on
    Apr 14 20:47:17 mod_sql/4.2.2[5377]: negative_cache     : off
    Apr 14 20:47:17 mod_sql/4.2.2[5377]: authenticate       : users 
    Apr 14 20:47:17 mod_sql/4.2.2[5377]: usertable          : ftp
    Apr 14 20:47:17 mod_sql/4.2.2[5377]: userid field       : username
    Apr 14 20:47:17 mod_sql/4.2.2[5377]: password field     : password
    Apr 14 20:47:17 mod_sql/4.2.2[5377]: uid field          : uid
    Apr 14 20:47:17 mod_sql/4.2.2[5377]: gid field          : gid
    Apr 14 20:47:17 mod_sql/4.2.2[5377]: homedir field      : homedir
    Apr 14 20:47:17 mod_sql/4.2.2[5377]: shell field        : shell
    Apr 14 20:47:17 mod_sql/4.2.2[5377]: homedirondemand    : false
    Apr 14 20:47:17 mod_sql/4.2.2[5377]: SQLMinUserUID      : 500
    Apr 14 20:47:17 mod_sql/4.2.2[5377]: SQLMinUserGID      : 100
    Apr 14 20:47:17 mod_sql/4.2.2[5377]: <<< sql_sess_init
    Apr 14 20:47:17 mod_sql/4.2.2[5377]: >>> sql_pre_pass
    Apr 14 20:47:17 mod_sql/4.2.2[5377]: <<< sql_pre_pass
    Apr 14 20:47:17 mod_sql/4.2.2[5377]: entering 	mysql cmd_exit
    Apr 14 20:47:17 mod_sql/4.2.2[5377]: entering 	mysql cmd_close
    Apr 14 20:47:17 mod_sql/4.2.2[5377]: connection 'default' closed
    Apr 14 20:47:17 mod_sql/4.2.2[5377]: connection 'default' count is now 0
    Apr 14 20:47:17 mod_sql/4.2.2[5377]: exiting 	mysql cmd_close
    Apr 14 20:47:17 mod_sql/4.2.2[5377]: exiting 	mysql cmd_exit
    
     
  17. Peggie

    Peggie Mitglied

    Dabei seit:
    14.04.2008
    Beiträge:
    42
    Zustimmungen:
    0
    Auszug aus der paranoid.log (die nun endlich erstellt wird als ich das verzeichnis gewechselt habe)
    Code:
    ::ffff:88.217.91.106 UNKNOWN nobody [15/Apr/2008:15:26:10 +0200] "USER anonymous" 331 -
    ::ffff:88.217.91.106 UNKNOWN ftp [15/Apr/2008:15:26:10 +0200] "PASS anon@localhost" 230 -
    ::ffff:88.217.91.106 UNKNOWN ftp [15/Apr/2008:15:26:10 +0200] "PWD" 257 -
    ::ffff:88.217.91.106 UNKNOWN ftp [15/Apr/2008:15:26:10 +0200] "TYPE I" 200 -
    ::ffff:88.217.91.106 UNKNOWN ftp [15/Apr/2008:15:26:10 +0200] "PASV" 227 -
    ::ffff:88.217.91.106 UNKNOWN ftp [15/Apr/2008:15:26:11 +0200] "LIST" 226 304
    ::ffff:88.217.91.106 UNKNOWN nobody [15/Apr/2008:15:26:40 +0200] "USER exampleuser" 331 -
    ::ffff:88.217.91.106 UNKNOWN nobody [15/Apr/2008:15:26:40 +0200] "PASS (hidden)" 530 -
    
    
     
Thema:

proftpd startet... kann mich jedoch nicht verbinden

Die Seite wird geladen...

proftpd startet... kann mich jedoch nicht verbinden - Ähnliche Themen

  1. proftpd startet nicht

    proftpd startet nicht: mysql sock datei finden hi, immer wenn ich proftpd starten will bekomme ich: /etc/init.d/proftpd start shell-init: could not get current...
  2. Ich bekomme proFTPd nicht gestartet, bekomme immer eine Fehlermeldung

    Ich bekomme proFTPd nicht gestartet, bekomme immer eine Fehlermeldung: Hallo zusammen, ich hab da mal ne Frage. Jedesmal wenn ich proFTPd ( Fedora Core 3 )starten will, kommt folgende Warnmeldung Konnte...
  3. proftpd Verwaltung

    proftpd Verwaltung: Mahlzeit, ich finde leider keine Lösung ich hoffe Ihr habt eine Idee. Ich habe ca. 30 proftpd Server. Bis jetzt läuft die Authentifizierung...
  4. Proftpd/TLS Probleme

    Proftpd/TLS Probleme: Tach Leute, bitte bedenkt, das ich Anfänger bin und gerade ein wenig Linux Erfahrung sammeln mag. Ich habe mir proftpd auf dem Server...
  5. proftpd tls Zertifikat einbinden

    proftpd tls Zertifikat einbinden: Hallo zusammen, da meine ftp Proxy proiblem macht (CentOS 5.5) habe ich einen neuen aufgesetzt (CentOS 6.2 64 bit). Problem: proftpd läuft....