Probleme mit FFmpeg

Dieses Thema im Forum "RedHat,Fedora & CentOS" wurde erstellt von Snakell, 27.07.2012.

  1. #1 Snakell, 27.07.2012
    Snakell

    Snakell Grünschnabel

    Dabei seit:
    27.07.2012
    Beiträge:
    3
    Zustimmungen:
    0
    Hallo an Alle,

    ich hoffe ich bin hier richtig mit meinem Problem.
    Und zwar hatte ich auf meinen CentOS Server für Mysql und PHP ein Update gemacht. (auf PHP Version 5.4.5)
    Zuvor hatte ich PHP 5.2 drauf und mein FFMpeg funktionierte tadellos. Doch nun bekomme ich folgende Fehlermeldung:

    PHP Warning: PHP Startup: ffmpeg: Unable to initialize module
    Module compiled with module API=20050922
    PHP compiled with module API=20100525

    Gut, dachte ich mir und kompilierte ffmpeg-php neu welches auch funktionierte und mir wurde eine neue ffmpeg.so in meinem extention-dir angelegt.
    Httpd Service neu gestartet und erhalte wieder die gleiche Fehlermeldung. Ich kann so oft neu kompilieren wie ich möchte, der Fehler geht nicht weg.

    Eines vorweg: Ich weiss was dieser Fehler bedeutet, dass ffmpeg mit einer anderen Version kompiliert wurde. Deshalb habe ich es ja auch mit der neuen Version von PHP neu kompiliert aber ohne Erfolg.

    Ich weiss im Moment nicht weiter, brauche aber unbedingt ffmpeg.

    weiter Details:
    - es ist nur eine PHP Version installiert (/usr/bin/php), mit which php ermittelt
    - ffmpeg.so liegt im extension-dir
    - modul ist über die PHP.ini eingebunden
    - FFMpeg ist installiert und läuft jedoch ffmpeg-php bekomme ich nicht mehr zum laufen
    - PHP Version 5.4.5
    - CentOS 5
    - alle anderen Module/Extensions funktionieren ohne Probleme

    Vielleicht weiss jemand Rat und kann helfen.

    Viele Grüsse

    P.S. ich habe schon bei Google gesucht wie ein Irrer aber leider nichts gefunden, ausser das man ffmpeg-php neu kompilieren soll (was ich ja schon mehrfach versucht habe)
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 marcellus, 27.07.2012
    marcellus

    marcellus Kaiser

    Dabei seit:
    09.05.2007
    Beiträge:
    1.392
    Zustimmungen:
    0
    Wenn du einfach ein system update machst sollte das vom paketmanager zur verfügung gestellte ffmpeg auch ein update bekommen, so das alles passt.

    Kanns sein, dass du jetzt mehrere php versionen installiert hast und ffmpeg gegen die alte version linkt?
     
  4. #3 Snakell, 27.07.2012
    Snakell

    Snakell Grünschnabel

    Dabei seit:
    27.07.2012
    Beiträge:
    3
    Zustimmungen:
    0
    Hallo marcellus,

    erstmal vielen Dank für deine Antwort. Wenn du mit system update "yum update" meinst, dann habe ich dies schon gemacht. Ich hatte ja auch alle anderen module neu kompiliert und es lief alles ohne Probleme bis auf ffmpeg.
    Laut "which php" ist auch nur die eine Version von PHP vorhanden (hatte die alte deinstalliert).

    Ich weiss nicht, was ich noch probieren kann, das mir ffmpeg-php mit dem neuen PHP kompiliert wird damit die API Versionen die gleichen sind.
     
  5. #4 marcellus, 27.07.2012
    marcellus

    marcellus Kaiser

    Dabei seit:
    09.05.2007
    Beiträge:
    1.392
    Zustimmungen:
    0
    Wenn das nichts bringt dann deinstallier ffmpeg-php, führ im Verzeichnis zum kompilieren "make clean" aus und probiers noch einmal. Wenn keine alte version von php vorhanden ist kann er ja nicht dagegen linken.
     
  6. #5 Snakell, 28.07.2012
    Snakell

    Snakell Grünschnabel

    Dabei seit:
    27.07.2012
    Beiträge:
    3
    Zustimmungen:
    0
    Hallo marcellus,

    vielen vielen Dank. Das wars. Nach "make clean" und "phpize clean" hat alles wunderbar funktioniert und mein ffmpeg läuft jetzt unter PHP 5.4.5.

    vielen dank
     
Thema:

Probleme mit FFmpeg

Die Seite wird geladen...

Probleme mit FFmpeg - Ähnliche Themen

  1. Probleme mit FFmpeg / PHP/ 70 Load / iowait

    Probleme mit FFmpeg / PHP/ 70 Load / iowait: Hallo liebe Community, Wir haben ein kleines Problem mit unserem Debian Server und braeuchten dringend einen Ratschlag :) Ich fang einfach...
  2. ffmpeg macht probleme

    ffmpeg macht probleme: Hi, ffmpeg funktioniert bei mir soweit einwandfrei, aber die libxvid macht probleme :/ Folgende Zeile gebe ich ein; ffmpeg -i...
  3. grub-pc Probleme bei upgrade

    grub-pc Probleme bei upgrade: Hallo, ich habe beim dist-upgrade folgendes Problem: ---------- Nach dieser Operation werden 0 B Plattenplatz zusätzlich benutzt. Trigger für...
  4. Probleme mit YUM

    Probleme mit YUM: Hallo, ich habe CentOs 7 als Dualboot mit Windows 7 auf einen Dell Latitude E5510 installiert. Dies hat soweit auch alles geklappt. Leider habe...
  5. Forscher analysieren Durchsatzprobleme im Linux-Scheduler

    Forscher analysieren Durchsatzprobleme im Linux-Scheduler: Eine Gruppe von Forschern hat Fälle identifiziert, in denen der Scheduler im Linux-Kernel falsche Entscheidungen trifft und die CPUs nicht so gut...