Probleme mit apt-get upgrade

Dieses Thema im Forum "Debian/Ubuntu/Knoppix" wurde erstellt von kago, 17.03.2007.

  1. kago

    kago Jungspund

    Dabei seit:
    17.03.2007
    Beiträge:
    23
    Zustimmungen:
    0
    Hallo Leute!

    erstmal will ich sagen, dass ich zwar ein linux noob bin.. aber ich lerne ja hoffentlich dazu

    habe folgendes problem beim upgraden:

    Code:
    84-16-251-35:~# apt-get upgrade          Paketlisten werden gelesen... Fertig
    Abhängigkeitsbaum wird aufgebaut... Fertig
    0 aktualisiert, 0 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.
    1 nicht vollständig installiert oder entfernt.
    Es müssen 0B Archive geholt werden.
    Nach dem Auspacken werden 0B Plattenplatz zusätzlich benutzt.
    Möchten Sie fortfahren? [J/n] J
    Richte ssh ein (3.8.1p1-8.sarge.6) ...
    /var/run/sshd must be owned by root and not group or world-writable.
    invoke-rc.d: initscript ssh, action "restart" failed.
    dpkg: Fehler beim Bearbeiten von ssh (--configure):
     Unterprozess post-installation script gab den Fehlerwert 1 zurück
    Fehler traten auf beim Bearbeiten von:
     ssh
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    
    hatte vorher bereits ein abgrade nagefangen.. war ein wenig weiter bekommen hatte ein error nach welchem das os normal weiter lief also dachte ich mir nix dabei

    dieses:
    Code:
    Fehler traten auf beim Bearbeiten von:
     ssh
    
    tritt übrigens neuerdings bei allen versuchen etwas zu installieren auf...
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 Nemesis, 17.03.2007
    Nemesis

    Nemesis N3RD

    Dabei seit:
    28.01.2005
    Beiträge:
    2.165
    Zustimmungen:
    0
    was sagt
    Code:
    ls -l /var/run/sshd
     
  4. kago

    kago Jungspund

    Dabei seit:
    17.03.2007
    Beiträge:
    23
    Zustimmungen:
    0
    hallo
    erstmal danke für die schnelle antwort...

    da kommt:

    Code:
    84-16-251-35:~# ls -l /var/run/sshd
    insgesamt 0
    
     
  5. #4 Nemesis, 17.03.2007
    Nemesis

    Nemesis N3RD

    Dabei seit:
    28.01.2005
    Beiträge:
    2.165
    Zustimmungen:
    0
    was was wolltest du eigentlich mit dem "apt-get upgrade" erziehlen?

    mach mal "aptitude reinstall ssh"
     
  6. #5 kago, 17.03.2007
    Zuletzt bearbeitet: 17.03.2007
    kago

    kago Jungspund

    Dabei seit:
    17.03.2007
    Beiträge:
    23
    Zustimmungen:
    0
    also ich wollte eine application isntallieren, da kam aber dieser fehler mit ssh und ich dachte mir: das kannst du vielleicht beheben indem du das system upgradest..

    ich weiss: ein funktionierendes system soll man nich ändern, aber vllt wäre es dannach doch stabiler gewesehn

    //EDIT:
    das kommt beim reinstall:

    Code:
    84-16-251-35:~# aptitude reinstall ssh
    Paketlisten werden gelesen... Fertig
    Abhängigkeitsbaum wird aufgebaut       
    Lese erweiterte Statusinformationen      
    Initialisiere Paketstatus... Fertig
    Lese Task-Beschreibungen... Fertig 
    Die folgenden Pakete sind nicht verwendet und werden ENTFERNT:
      libmysqlclient14 libmysqlclient14-dev 
    Die folgenden Pakete werden ERNEUT INSTALLIERT:
      ssh 
    0 Pakete aktualisiert, 0 zusätzlich installiert, 1 erneut installiert, 2 werden entfernt und 0 nicht aktualisiert.
    Muss 0B an Archiven herunterladen.Nach dem Entpacken werden 18,2MB frei werden.
    Wollen Sie fortsetzen? [Y/n/?] Y
    Schreibe erweiterte Statusinformation... Fertig
    (Lese Datenbank ... 28464 Dateien und Verzeichnisse sind derzeit installiert.)
    Entferne libmysqlclient14-dev ...
    Entferne libmysqlclient14 ...
    Richte ssh ein (3.8.1p1-8.sarge.6) ...
    /var/run/sshd must be owned by root and not group or world-writable.
    invoke-rc.d: initscript ssh, action "restart" failed.
    dpkg: Fehler beim Bearbeiten von ssh (--configure):
     Unterprozess post-installation script gab den Fehlerwert 1 zurück
    Fehler traten auf beim Bearbeiten von:
     ssh
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    Während der Paketinstallation sind Probleme aufgetreten.  Versuche zu lösen:
    Richte ssh ein (3.8.1p1-8.sarge.6) ...
    /var/run/sshd must be owned by root and not group or world-writable.
    invoke-rc.d: initscript ssh, action "restart" failed.
    dpkg: Fehler beim Bearbeiten von ssh (--configure):
     Unterprozess post-installation script gab den Fehlerwert 1 zurück
    Fehler traten auf beim Bearbeiten von:
     ssh
    Paketlisten werden gelesen... Fertig           
    Abhängigkeitsbaum wird aufgebaut       
    Lese erweiterte Statusinformationen       
    Initialisiere Paketstatus... Fertig
    Lese Task-Beschreibungen... Fertig 
    
     
  7. #6 uverein, 17.03.2007
    uverein

    uverein Grünschnabel

    Dabei seit:
    17.03.2007
    Beiträge:
    6
    Zustimmungen:
    0
    Ort:
    Pfalz
    ls -l sollte etwa folgendes ergeben:

    drwxr-xr-x 2 root root 4096 2004-11-28 16:33 sshd

    dann sollte es auch funktionieren. Wenn nicht als root "chmod 755 /var/run/sshd" eingeben und apt-get nochmal probieren.
     
  8. kago

    kago Jungspund

    Dabei seit:
    17.03.2007
    Beiträge:
    23
    Zustimmungen:
    0
    genau genommen steht da nur:
    84-16-251-35:~# ls -l
    insgesamt 2016
    drwxr-xr-x 2 r00t root 4096 2006-12-02 22:37 css
    -rw-r--r-- 1 r00t root 199 2005-07-07 15:31 dbootstrap_settings
     
  9. #8 Nemesis, 17.03.2007
    Nemesis

    Nemesis N3RD

    Dabei seit:
    28.01.2005
    Beiträge:
    2.165
    Zustimmungen:
    0
    was soll das bringen? die datei existiert bei ihm anscheinend garnicht.

    wenn du "ls -l" in ~ aufrufst, wird dir nur angezeigt, was sich in ~ befindet und wie die dateirechte gesetzt sind.
     
  10. #9 kago, 17.03.2007
    Zuletzt bearbeitet: 17.03.2007
    kago

    kago Jungspund

    Dabei seit:
    17.03.2007
    Beiträge:
    23
    Zustimmungen:
    0
    moment ich sehe grad dass da ein gewisse r00t erwähnt wird.. das bin ich nicht

    ich habe nur 3 benutzer angelegt: jwm, ts und ftpuser
    .
    .
    .
    EDIT (autom. Beitragszusammenführung) :
    .

    :D ich weiss wer und was root ist..

    nein ich meine bei 'ls -l'
    kommt:
    drwxr-xr-x 2 r00t root 4096 2006-12-02 22:37 css

    r00t <-- mit null....
     
  11. #10 Nemesis, 17.03.2007
    Nemesis

    Nemesis N3RD

    Dabei seit:
    28.01.2005
    Beiträge:
    2.165
    Zustimmungen:
    0
    naja, dann wirst du oder ein script den user angelegt haben. ka wo der herkommt.
     
  12. kago

    kago Jungspund

    Dabei seit:
    17.03.2007
    Beiträge:
    23
    Zustimmungen:
    0
    hmm ok gut.. also liegt es nicht daran?

    komisch.. vorher konnte ich doch probemlos solche dinge installieren..

    mir fällt wieder auf wesewegen genau ich zum upgrade kam: letzendlich wollte ich python darauf installieren
     
  13. #12 Nemesis, 17.03.2007
    Nemesis

    Nemesis N3RD

    Dabei seit:
    28.01.2005
    Beiträge:
    2.165
    Zustimmungen:
    0
    an was soll das liegen? dass da ein user namens r00t erstellt wurde? naja, ich wage das mal zu bezweifeln ;)

    du meintest dann sicher "apt-get update" das ist ein unterschied zu "apt-get upgrade"
     
  14. kago

    kago Jungspund

    Dabei seit:
    17.03.2007
    Beiträge:
    23
    Zustimmungen:
    0
    apt-get update habe ich gemacht.. kamen nur ein paar fixes rein... also upgrade an sich kann ich sein lassen..

    das problem ist einfach dass ich nix fast nix mehr mit apt-get machen kann ;)

    da wird doch immer diese fehler meldung kommen :(
     
  15. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  16. #14 Nemesis, 17.03.2007
    Nemesis

    Nemesis N3RD

    Dabei seit:
    28.01.2005
    Beiträge:
    2.165
    Zustimmungen:
    0
    mist, das is ja openssh-server.

    das ganze nochmal

    aptitude reinstall openssh-server
     
  17. kago

    kago Jungspund

    Dabei seit:
    17.03.2007
    Beiträge:
    23
    Zustimmungen:
    0
    da kommt:

    Code:
    84-16-251-35:~# aptitude reinstall openssh-server
    Paketlisten werden gelesen... Fertig
    Abhängigkeitsbaum wird aufgebaut       
    Lese erweiterte Statusinformationen      
    Initialisiere Paketstatus... Fertig
    Lese Task-Beschreibungen... Fertig 
    Konnte kein Paket finden, dessen Name oder Beschreibung auf »openssh-server« passt.
    Es werden keine Pakete installiert, aktualisiert oder entfernt.
    0 Pakete aktualisiert, 0 zusätzlich installiert, 0 werden entfernt und 0 nicht aktualisiert.
    Muss 0B an Archiven herunterladen.Nach dem Entpacken werden 0B zusätzlich belegt sein.
    Schreibe erweiterte Statusinformation... Fertig
    Richte ssh ein (3.8.1p1-8.sarge.6) ...
    /var/run/sshd must be owned by root and not group or world-writable.
    invoke-rc.d: initscript ssh, action "restart" failed.
    dpkg: Fehler beim Bearbeiten von ssh (--configure):
     Unterprozess post-installation script gab den Fehlerwert 1 zurück
    Fehler traten auf beim Bearbeiten von:
     ssh
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    Während der Paketinstallation sind Probleme aufgetreten.  Versuche zu lösen:
    Richte ssh ein (3.8.1p1-8.sarge.6) ...
    /var/run/sshd must be owned by root and not group or world-writable.
    invoke-rc.d: initscript ssh, action "restart" failed.
    dpkg: Fehler beim Bearbeiten von ssh (--configure):
     Unterprozess post-installation script gab den Fehlerwert 1 zurück
    Fehler traten auf beim Bearbeiten von:
     ssh
    Paketlisten werden gelesen... Fertig           
    Abhängigkeitsbaum wird aufgebaut       
    Lese erweiterte Statusinformationen       
    Initialisiere Paketstatus... Fertig
    Lese Task-Beschreibungen... Fertig 
    
    ok ich hab mich mal an den notruf support von meinem hoster gewandt.. vllt werden die ja schlauer.. machen sowas laut vertrag kostenlos...
     
Thema:

Probleme mit apt-get upgrade

Die Seite wird geladen...

Probleme mit apt-get upgrade - Ähnliche Themen

  1. apt-get update probleme

    apt-get update probleme: Hi, wen ich apt-get update machen will bekomme ich neudings: ---------- Fehl http://ftp.de.debian.org etch Release.gpg Konnte nicht mit...
  2. probleme mit apt-get install

    probleme mit apt-get install: hallo zusammen, nachdem ich ein backup zurück auf meinen server gespielt habe kann ich apt-get nicht mehr richtig verwenden: bei apt-get...
  3. probleme beim apt-get mit gpg...

    probleme beim apt-get mit gpg...: Guten Abend, ich habe heute neu debian aufgesetzt.. das ganz aktuelle.. nun wenn ich apt-get update aufrufe..: ---------- Es wurden...
  4. probleme mit apt-get -f

    probleme mit apt-get -f: hallo, ich habe mir vor einigen wochen auf mein debian eine neue version von kde versucht zuinstallieren. da es aber nicht so geklappt hat habe...
  5. apt-get probleme

    apt-get probleme: bei meinem frisch aufgesetztem Debian Sarge gibt es immer wieder probleme wenn ich ein dist-upgrade mache der fehler blieb bei 3 maligen...