Debian 6 - Paketabhängigkeiten zerschossen

Dieses Thema im Forum "Debian/Ubuntu/Knoppix" wurde erstellt von Gast123, 08.10.2012.

  1. #1 Gast123, 08.10.2012
    Gast123

    Gast123 Guest

    Hallo Leute,

    ich wollte gerade auf meinem Debian System diverse Software installieren.
    Leider kommt immer ein Problem mit dem Paket.
    libsfscale0
    Zum Beispiel:
    Code:
     apt-get -f install
    Paketlisten werden gelesen... Fertig
    Abhängigkeitsbaum wird aufgebaut       
    Statusinformationen werden eingelesen... Fertig
    Abhängigkeiten werden korrigiert... Fertig
    Die folgenden zusätzlichen Pakete werden installiert:
      libsfscale0
    Die folgenden NEUEN Pakete werden installiert:
      libsfscale0
    0 aktualisiert, 1 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.
    1 nicht vollständig installiert oder entfernt.
    Es müssen noch 0 B von 230 kB an Archiven heruntergeladen werden.
    Nach dieser Operation werden 721 kB Plattenplatz zusätzlich benutzt.
    Möchten Sie fortfahren [J/n]? 
    (Lese Datenbank ... 70509 Dateien und Verzeichnisse sind derzeit installiert.)
    Vorbereitung zum Ersetzen von libswscale0 4:0.5.9-1 (durch .../libsfscale0_4%3a0.5.9-1_i386.deb) ...
    Ersatz für libswscale0 wird entpackt ...
    libswscale0 (4:0.5.9-1) wird eingerichtet ...
    dpkg: Fehler beim Bearbeiten von libsfscale0 (--configure):
     Kein Paket namens »libsfscale0« installiert, kann nicht konfiguriert werden
    configured to not write apport reports
                                          Fehler traten auf beim Bearbeiten von:
     libsfscale0
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    
    Dieses Problem kann anscheinend nicht aufgelößt werden.
    Weis jemand, wie ich den Paketmanager wieder zum funktionieren bekomme, ohne das System neu installieren zu müssen?

    Denke Euch,

    Schard
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 schwedenmann, 08.10.2012
    schwedenmann

    schwedenmann Foren Gott

    Dabei seit:
    18.11.2003
    Beiträge:
    2.635
    Zustimmungen:
    2
    Ort:
    Wegberg
    Hallo

    Versuch mal libswcal0 zuerst zu installieren, per apt, aptitude, oder manuell per dpkg, danach dann libsfscale0

    mfg
    schwedenmann
     
  4. #3 Gast123, 08.10.2012
    Gast123

    Gast123 Guest

    Moin,

    das hatte ich schon versucht.
    Wenn ich versuche libswscale0 zu installieren, will er sofort libsfscale0 installieren, was jedoch nicht funktioniert.
    (Analoge Fehlermeldung)

    MfG

    Schard
     
  5. #4 Remidemi, 09.10.2012
    Remidemi

    Remidemi Routinier

    Dabei seit:
    17.03.2008
    Beiträge:
    352
    Zustimmungen:
    0
    Ort:
    Südpfalz
    Hi

    Und Installation von libswscale0 ohne Abhängigkeitenen aufzulösen?

    apt-get install --no-install-recommend libswscale0
     
  6. #5 tgruene, 09.10.2012
    tgruene

    tgruene Routinier

    Dabei seit:
    02.02.2012
    Beiträge:
    418
    Zustimmungen:
    0
    Du koenntest es auch mal mit aptitude statt apt-get versuchen. Ich meine mich zu erinnern, dass aptitude einen besseren Algorithmus zur Aufloesung von Abhaengigkeiten hat. Und wenn nicht zu viel davon abhaengt, kannst Du auch mal beide Pakete deinstallieren und dann neu installieren.
     
  7. #6 Goodspeed, 09.10.2012
    Goodspeed

    Goodspeed Foren Gott
    Moderator

    Dabei seit:
    21.04.2004
    Beiträge:
    4.165
    Zustimmungen:
    1
    Ort:
    Dresden
    libsfscale0 gibt es im Debian-Repo nicht ... wo haste das denn her??
     
  8. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  9. #7 Gast123, 11.10.2012
    Gast123

    Gast123 Guest

    Gelöst

    @tgruene
    Ich habe jetzt mit aptitude das Paket deinstalliert, samt allen Abhängigkeiten und die von mir benötigte Software dann wieder installiert.
    Jetzt gibts keine Probleme mehr. ;)

    @Goodspeed
    libsfscale0 ist augenscheinlich eine Abhängigkeit einiger Programme.
    Debian scheint stattdessen das Paket libswscale0 als Ersatz zu verwenden (s.o.).
    Ich habe mich bei meiner recherche im Netz auch gewundert, das nirgendwo das Paket libsfscale0 zu finden war. :think:
     
  10. #8 Goodspeed, 11.10.2012
    Goodspeed

    Goodspeed Foren Gott
    Moderator

    Dabei seit:
    21.04.2004
    Beiträge:
    4.165
    Zustimmungen:
    1
    Ort:
    Dresden
    Ja aber das Paket libsfscale0_4%3a0.5.9-1_i386.deb hast Du ja auf Deinem System rumliegen ... das muss doch irgendwo herkommen ...

    Kannst ja auch mal
    Code:
    dpkg --purge libsfscale0 
    
    versuchen ... ggf. mit "--force-all"-Schalter.
     
Thema:

Debian 6 - Paketabhängigkeiten zerschossen

Die Seite wird geladen...

Debian 6 - Paketabhängigkeiten zerschossen - Ähnliche Themen

  1. Wiederherstellen von überschriebenen Dokumenten auf debian samba

    Wiederherstellen von überschriebenen Dokumenten auf debian samba: Ich habe ein Problem. Vor Kurzem hat der Trojaner cryptologer einen Schaden eingerichtet. Glücklicherweise gab es eine Sicherung auf...
  2. Debian Samba 4.2.10+dfsg-0+deb8u3 Password wrong -Windows DC

    Debian Samba 4.2.10+dfsg-0+deb8u3 Password wrong -Windows DC: Hallo, ich habe einen debian Samba-Server mit share´s ohne Domäne aufgesetzt, d.h. "standalone". Wenn ich von Windows-Clients mit...
  3. Debian VM Klonen und parallel betreiben? Systemanpassungen

    Debian VM Klonen und parallel betreiben? Systemanpassungen: Hallo, ich habe vor eine Debian Maschine als Prototyp aufzusetzen... (als vSphere VM).... Diese Maschine will ich dann x-mal klonen und in div....
  4. LinuxDistribution: Bunsenlabs (Debian 8.2 mit Openbox)

    LinuxDistribution: Bunsenlabs (Debian 8.2 mit Openbox): Für alle die eine superschnelle minimalistische Distribution suchen, die auch auf schwachen Rechnern läuft, ich bin fündig geworden. Bin gestern...
  5. Update auf Apache >=2.4.12 unter Debian Jessie

    Update auf Apache >=2.4.12 unter Debian Jessie: Hi, aufgrund eines Bugs in Apache 2.4 benötige ich zum Deployment von Seafile unter Debian Jessie das Paket apache2 in der Version >= 2.4.12...