Nach dem Restore eines Linux Images Boot Probleme

Dieses Thema im Forum "Linux OS" wurde erstellt von Proseitanos, 08.06.2006.

  1. #1 Proseitanos, 08.06.2006
    Proseitanos

    Proseitanos Grünschnabel

    Dabei seit:
    08.06.2006
    Beiträge:
    2
    Zustimmungen:
    0
    HI,:hilfe2:

    Also ich habe zu Testzwecken einmal suse Linux 8.2 installiert, welches ich dann via partimage in einem Image File gesichert habe.

    Den MBR Sicherte ich mit folgenden Befehlen:

    dd if=/dev/hda of=/mountpoint/NameDesFiles.mbr bs=512 count=1

    Dann habe ich eine neue Festplatte genommen und angefangen das Image File wieder mit Partimage zu Restoren.
    So Ich habe nachgesehen und soweit sind alle Daten wieder auf der Festplatte vorhanden.

    Ich versuchte zu booten, was nicht gelang.

    Nun stellte ich den zuvor gesicherten MBR mir folgenden Befehlen wieder her:

    dd if=/mountpoint/NameDesFiles.mbr of=/dev/hda bs=512 count=1




    So ich wollte also als nächstes Booten und es geschah folgendes:

    Es Tauchte eine Befehlszeile auf in der am anfang Grub >
    stand. Ich konnte doch leider mit meinen momentanen Kenntnissen nicht diesen Grub Bootmanager davon überzeugen von meiner Hda2 zu booten =\

    Kann mir vielleicht jemand weiter helfen ?!

    Vielen dank schonmal im Voraus


    \\ Edit: Die sicherung sowie das Restore erfolgte über Knoppix 5.0.1
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 supersucker, 08.06.2006
    supersucker

    supersucker Foren Gott

    Dabei seit:
    21.02.2005
    Beiträge:
    3.873
    Zustimmungen:
    0
    Wenn das Ding wirklich auf hda2 liegt, dann in der grub-shell:

    Code:
    root (hd0,1)
    setup (hd0)
    quit
    evtl. noch die menu.lst anpassen.
     
  4. #3 Wolfgang, 08.06.2006
    Wolfgang

    Wolfgang Foren Gott

    Dabei seit:
    24.04.2005
    Beiträge:
    3.978
    Zustimmungen:
    0
    Ort:
    Erfurt
    Hallo

    Hier hast du den Bootcode + Partitionstabelle + Endsignatur deiner altenFestplatte gesichert.
    Ich habe hier im Board schon mehrfach darauf hingewiesen, dass :

    Bootcode -> bis Offset 446
    Partitionstabelle -> von Offset 447 bis Offset 510
    Endsignatur -> Offset 511 bis Offset 512

    * eine erweiterte Partition zählt wie eine primäre, und enthält für die beinhalteten logischen Partitionen ihre eigene Partitionstabelle!

    Hier hast du die gesamte primäre Festplattengeometrie deiner alten Festplatte wieder hergestellt.
    Das bedeutet im Klartext:
    Wenn du eine andere Plattengeometrie hast, bzw. deine primäre Partitionen anders verteilt sind, stimmt die nun eingetragene Partitionstabelle nicht mehr.

    Lösung:
    Schau dir mit einer LiveCD nochmal die Ausgabe von
    fdisk -l /dev/hda an.
    Achte auf die Anfang und End Zylinder . Es darf keine Überlappungen geben.
    Installier von dieser LiveCD den Grub neu.
    Schau dir die menu.lst an und prüfe ob alles richtig eingetragen ist.

    ACHTUNG: Du musst dazu die Partition mounten und die richtige menu.lst ansehen. Also nicht die deiner LiveCD! Auch musst diese bei der Installation von grub angegeben werden.
    Den grub von deiner gemounteten Partition aufrufen!

    Beispiel: Du hast den Suse in deiner LiveCD in /mnt/hda2/ gemountet und dein boot liegt in dieser Partition:
    /mnt/hda2/sbin/grub-install --root-directory=/mnt/hda2 /dev/hd0

    HTH
    Gruß Wolfgang
     
  5. #4 Proseitanos, 08.06.2006
    Proseitanos

    Proseitanos Grünschnabel

    Dabei seit:
    08.06.2006
    Beiträge:
    2
    Zustimmungen:
    0
    Alles klar dann werde ich das nun mal probieren, danke für die schnellen Antworten. Ich werde mich melden wnen es geklappt bzw. wenn es nicht geklappt hat ;D
     
  6. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
Thema:

Nach dem Restore eines Linux Images Boot Probleme

Die Seite wird geladen...

Nach dem Restore eines Linux Images Boot Probleme - Ähnliche Themen

  1. nach backup restore probleme beim installieren

    nach backup restore probleme beim installieren: Moin! Ich habe mir gestern Ubuntu neu installiert. Zum Schluß hab ich noch das backup wieder aufgespielt. Jetzt kann ich nix mehr installieren....
  2. Keine Benachrichtigungen im Vollbild Modus

    Keine Benachrichtigungen im Vollbild Modus: Arch Linux Plasma 5.8 Weiss einer ob das gehen sollte, bzw kann mal einer testen ob es bei ihm geht, gerne auch mit anderen kde/plasma versionen....
  3. SRV Records nicht erstellt nach dcpromo

    SRV Records nicht erstellt nach dcpromo: Hallo zusammen, leider sind beim Join meines 2. DC in eine Samba 4 Domäne die SRV-DNS Records nicht erstellt worden... Hatte jemand schonmal das...
  4. CentOS 7: Falsche Metric bei regelbasiertem Routing nach Server-Reboot

    CentOS 7: Falsche Metric bei regelbasiertem Routing nach Server-Reboot: Hallo zusammen Ich möchte unseren existierenden SFTP Server durch einen neuen Server mit CentOS 7 ersetzen. Da der Server einerseits direkt via...
  5. Nicht erkannte Zeichen nach Update

    Nicht erkannte Zeichen nach Update: Hi, nachdem ich mein Kali Linux geupdated habe, ist mir aufgefallen dass viele Zeichen auf verschiedenen Nutzeroberflächen nur fehlerhaft...