Externe Festplatte automatisch "starten"

Dieses Thema im Forum "SuSE / OpenSuSE" wurde erstellt von Smelly, 21.11.2006.

  1. Smelly

    Smelly Eroberer

    Dabei seit:
    10.11.2006
    Beiträge:
    53
    Zustimmungen:
    0
    Hallo
    Ich hab eine externe Festplatte über USB an meinen Pc angeschlossen.
    Hab da meine Musik drauf und amaroK eine Sammluung aus meinem Musik-Ordner erstellen lassen.
    Ich muss aber jedesmal wenn ich den Pc hochfahre die Festplatte erst über den Arbeitsplatz "starten" damit amaroK die Dateien findet.
    Kann man das irgendwie einstellen dass das automatisch passiert?
    Ich benutze Suse 10.1 KDE 3.5.1
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 damager, 21.11.2006
    damager

    damager Moderator

    Dabei seit:
    27.08.2003
    Beiträge:
    3.065
    Zustimmungen:
    0
    Ort:
    Munich
    du musst nur dafür sorgen das die platte beim system-start gemountet (und nicht gestartet) wird :]
    dafür ist nur ein passender eintrag in der /etc/fstab oder über yast2 > system > partitionieren anzulegen.
     
  4. Smelly

    Smelly Eroberer

    Dabei seit:
    10.11.2006
    Beiträge:
    53
    Zustimmungen:
    0
    Hab mir schon gedacht dass es mounten heißt. Nur lieber umschreiben als Begriffe falsch verwenden ;)

    Und was ist dieser passende Eintrag?
     
  5. #4 damager, 21.11.2006
    damager

    damager Moderator

    Dabei seit:
    27.08.2003
    Beiträge:
    3.065
    Zustimmungen:
    0
    Ort:
    Munich
    woher soll ich dein system kennen?
    es schon mal mit dem genannten yast2-weg probiert?

    die externe platte bekommt am system einen device-namen zugeordnet. bei usb dürfte es irgendwas mit /dev/sd(x)(n). beispiel: /dev/sda1
    den bekommst raus indem du als dmesg eintipperst kurz nach dem du die platte angesteckt hast. diese musst du dann mit dem passenden filesystem-typ in die /etc/fstab eintragen.

    beispiel (für eine fat-formatierte platte und als erstes usb-storage-device :
    ausserdem fertige lösungen erwarten ist uncool :sly:

    mein tipp um es besser zu verstehen:
    http://www.linuxfibel.de/filesys.htm
     
  6. Smelly

    Smelly Eroberer

    Dabei seit:
    10.11.2006
    Beiträge:
    53
    Zustimmungen:
    0
    Ok, danke, die Seite hat mir sehr viel geholfen!
    Werde es dann gleich mal versuchen.
     
  7. Smelly

    Smelly Eroberer

    Dabei seit:
    10.11.2006
    Beiträge:
    53
    Zustimmungen:
    0
    Ok, habs mithilfe der fstab geschafft.
    Vielen Dank für die Hilfe :)
     
  8. #7 patlkli, 21.11.2006
    patlkli

    patlkli Linux-Freak

    Dabei seit:
    23.11.2005
    Beiträge:
    158
    Zustimmungen:
    0
    Ort:
    Landshut
    Na dann, sehr gut! Aber bitte vermeide Doppelposts...
     
  9. #8 Smelly, 22.11.2006
    Zuletzt bearbeitet: 22.11.2006
    Smelly

    Smelly Eroberer

    Dabei seit:
    10.11.2006
    Beiträge:
    53
    Zustimmungen:
    0
    Ok, sry.

    Hab aber jetzt ein Problem.
    Am Anfang ging alles ohne Probleme.
    Aber auf einmal, und ohne erkennbaren Grund konnten erst keine Umlaute und das ß in Ordner und Dateinamen angezeigt werden, auf der Festplatte, und nach einem Reboot hatte ich gar keine Berechtigung mehr überhaupt auf die Festplatte zuzugreifen.

    Das ist der Eintrag den ich in meiner fstab hinzugefügt hab, ist da irgendwas falsch, oder fehlt da was?
    Was mich halt verwirrt ist dass am Anfang alles funktioniert hat.


    Ok, ein Freund hat mir jetzt geholfen, jetzt geht es wieder, aber das Problem mit den Umlauten bleibt bestehen...
    Kann sich das einer erklären?
     
  10. #9 damager, 22.11.2006
    damager

    damager Moderator

    Dabei seit:
    27.08.2003
    Beiträge:
    3.065
    Zustimmungen:
    0
    Ort:
    Munich
  11. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  12. Smelly

    Smelly Eroberer

    Dabei seit:
    10.11.2006
    Beiträge:
    53
    Zustimmungen:
    0
    Hm, danke, aber funktioniert nicht. Hab nochmal weitergegoogelt, aber habe immer nur Stimmen gehört die das selbe Problem hatten, es aber auch nicht beheben konnten.
    --> wieder "per Hand" mounten.
    Vielen Dank für die Hilfe trotzdem!
     
  13. #11 Smelly, 11.12.2006
    Zuletzt bearbeitet: 11.12.2006
    Smelly

    Smelly Eroberer

    Dabei seit:
    10.11.2006
    Beiträge:
    53
    Zustimmungen:
    0
    Nochmal übersichtlicher mein neues Problem mit meiner Externen Festplatte(wer den alten Beitrag gelesen hat weiß warum):
    Hab jetzt openSUSE 10.2. drauf.
    Hab diesen Eintrag in der fstab:
    Code:
    /dev/sde1            /media/EXTERNE       vfat       users,gid=users,umask=0002,utf8=true 0 0
    Wenn ich den Pc hochfahre dann mountet er die Externe Festplatte ganz normale in /media/EXTERNE und ich kann sie VLC zum Beispiel auch Verzeichnisse öffnen und alles klappt wunderbar.
    Wenn man zu diesem Zeitpunkt in Yast unter Software -> Partitionieren schaut, dann steht da auch unter Gerät /dev/sde1 und bei mounten /media/EXTERNE also genau das was auch in der fstab steht.
    Wenn ich jetzt ne zeitlang Musik damit höre oder so, dann hört die Musik irgendwann auf. Wenn ich dann in /media auf EXTERNE klicke dann findet er das auch nicht mehr, ich kann gar nicht mehr auf die Festplatte zugreifen. In Yast/Partitionieren isse dann gar nicht mehr aufgelistet.
    Wenn ich sie dann aus und wieder einstecke, dann hat sie bei Partitionieren die Bezeichnung /dev/sdf1 und wird dementsprechend natürlich nicht mehr gemountet.
    Habe jetzt in der fstab auch noch den Eintrag:
    Code:
    /dev/sdf1            /media/EXTERNE       vfat       user,users,gid=users,umask=0002,utf8=true 0 0
    durch Yast hinzugefügt und jetzt ist sie als /dev/sdf1 gemountet, aber das kann ja nicht die Lösung des Problems sein.
    Wieso wird sie mittendrin einfach nicht mehr erkannt, und wieso hat sie nach nem "Neustart" (Aus und wieder einstecken) eine andere Bezeichnung?

    Edit: Hab beide fstab Einträge mal entfernt, aber unter sysinfo:/ bei Rechtsklick --> Eigenschaften der Externen eingestellt dass sie durch den Benutzer mountbar ist, und automatisch gemountet wird.
    Sie verschwindet aber immer noch irgendwann einfach so.
    Wenn ich sie aber aus- und wieder einstecke, dann bekommt sie keine neue Bezeichnung, sie ist jetzt immer /dev/sde1


    Kann mir wirklich keiner helfen?


    Hoffentlich letzter Edit hier!:
    Also nachdem ich mein amarok zum laufen bekommen habe, und nicht mehr über VLC Musik höre, läuft die Festplatte wunderbar. Ich hoffe das lag wirklich an VLC!
     
Thema:

Externe Festplatte automatisch "starten"

Die Seite wird geladen...

Externe Festplatte automatisch "starten" - Ähnliche Themen

  1. Linux-Treiber für externe Festplatte von Intenso?

    Linux-Treiber für externe Festplatte von Intenso?: Hallo, an Weihnachten hat es jemand gut mit mir gemeint und mir die externe Festplatte Intenso Memory Center 3.5" mit 3TB geschenkt. Unter...
  2. Ordner auf der externen Festplatte spiegeln.

    Ordner auf der externen Festplatte spiegeln.: Hallo, mit welchem Programm kann ich Ordner oder auch ganz interne Platten auf einer externen Festlplatte spiegeln? Allerdings nicht einfach...
  3. Problem mit externer Festplatte

    Problem mit externer Festplatte: Hallo, Linuxuser aus aller Welt... Ich habe heute von einer Freundin eine Festplatte erhalten, von der ich Daten extrahieren soll. Das hübsche...
  4. Externe Festplatte nicht mehr nutzbar / kaputt

    Externe Festplatte nicht mehr nutzbar / kaputt: Hallo, nachdem ich heute meine gute WD MyPassport externe Festplatte während der Nutzung der Ubuntu 10.10 Installations CD am PC hatte, will das...
  5. Externe Festplatte mountet nicht mehr !

    Externe Festplatte mountet nicht mehr !: Moin, hab schon Google zum verzweifeln gebracht. Also habe heute Debian 6 mit Xfce neu installieren müssen. Vorher ging es wunderbar mit...