deinstallieren von paketen und libs

Dieses Thema im Forum "Debian/Ubuntu/Knoppix" wurde erstellt von ElfQuest, 08.05.2007.

  1. #1 ElfQuest, 08.05.2007
    ElfQuest

    ElfQuest Linux-Dau

    Dabei seit:
    25.07.2005
    Beiträge:
    32
    Zustimmungen:
    0
    Ort:
    Saarbrücken
    Hallo, ich habe gestern mein Kubuntu amd64 durch eine i386 version ersetzt, da es einfach für Anfänger zu viele schwierigkeiten gab, ich habe wohl aus versehen ein amd64 paket oder ein nicht passendes Paket installiert, jedenfalls funktioniert adept nicht mehr, der bringt immer wenn ich die "Änderungen anwenden" möchte diese Fehlermeldung

    Code:
    Beim Durchführen der Änderungen ist ein Fehler
     aufgetreten. Möglicherweise gab es ein Problem beim
     Herunterladen einiger Pakete oder die Durchführung der
     Aktualisierung würde andere Pakete beeinträchtigen. 
    Nach langem hin und her habe ich gesehen, dass er ein Problem mit libasound2 und den Abhängigkeiten hat.

    Darauf hin habe ich
    Code:
     apt-get remove libasound2 
    das gewünschte resultat trat leider nicht ein, stattdessen habe ich das in der Ausgabe

    Code:
     
    Paketlisten werden gelesen... Fertig
    Abhängigkeitsbaum wird aufgebaut... Fertig
    Sie möchten wahrscheinlich »apt-get -f install« aufrufen, um dies zu korrigieren:
    Die folgenden Pakete haben nichterfüllte Abhängigkeiten:
      alsa-utils: Hängt ab: libasound2 (> 1.0.10) soll aber nicht installiert werden
      artsbuilder: Hängt ab: libasound2 (> 1.0.10) soll aber nicht installiert werden
      kaudiocreator: Hängt ab: libasound2 (> 1.0.10) soll aber nicht installiert werden
      kdelibs4c2a: Hängt ab: libasound2 (> 1.0.10) soll aber nicht installiert werden
      kdemultimedia-kio-plugins: Hängt ab: libasound2 (> 1.0.10) soll aber nicht installiert werden
      kmix: Hängt ab: libasound2 (> 1.0.10) soll aber nicht installiert werden
      konq-plugins: Hängt ab: libasound2 (> 1.0.10) soll aber nicht installiert werden
      kscd: Hängt ab: libasound2 (> 1.0.10) soll aber nicht installiert werden
      libakode2: Hängt ab: libasound2 (> 1.0.10) soll aber nicht installiert werden
      libarts1c2a: Hängt ab: libasound2 (> 1.0.10) soll aber nicht installiert werden
      libesd-alsa0: Hängt ab: libasound2 (> 1.0.10) soll aber nicht installiert werden
      libgcj7: Hängt ab: libasound2 (> 1.0.10) soll aber nicht installiert werden
      libk3b2: Hängt ab: libasound2 (> 1.0.10) soll aber nicht installiert werden
      libxine-main1: Hängt ab: libasound2 (> 1.0.10) soll aber nicht installiert werden
      libxxf86dga1: Hängt ab: x-common ist aber nicht installierbar
      libxxf86vm1: Hängt ab: x-common ist aber nicht installierbar
      wine: Hängt ab: libasound2 (> 1.0.10) soll aber nicht installiert werden
    E: Nichterfüllte Abhängigkeiten. Versuchen Sie »apt-get -f install« ohne jeglich Pakete (oder geben Sie eine Lösung an).
    elfquest@questbook:~$ clear
    elfquest@questbook:~$ sudo apt-get remove libasound2
    Paketlisten werden gelesen... Fertig
    Abhängigkeitsbaum wird aufgebaut... Fertig
    Sie möchten wahrscheinlich »apt-get -f install« aufrufen, um dies zu korrigieren:
    Die folgenden Pakete haben nichterfüllte Abhängigkeiten:
    
    
    Frage: Was ist das und wie werde ich es wieder los?
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 bitmuncher, 08.05.2007
    bitmuncher

    bitmuncher Der Stillgelegte

    Dabei seit:
    08.05.2007
    Beiträge:
    3.171
    Zustimmungen:
    0
    Versuchs mal mit 'apt-get -f install', wie es ja dort auch geschrieben steht.
     
  4. Zedar

    Zedar Conquer All

    Dabei seit:
    26.02.2007
    Beiträge:
    207
    Zustimmungen:
    0
    Ort:
    Gemünden
    Musst du das Paket eigentlich löschen? Da sind ziemlich viel Pakete, die davon abhängen.
     
Thema:

deinstallieren von paketen und libs

Die Seite wird geladen...

deinstallieren von paketen und libs - Ähnliche Themen

  1. alte samba3 version samt Konfiguration total deinstallieren un samba4 installieren

    alte samba3 version samt Konfiguration total deinstallieren un samba4 installieren: vor kurzem habe ich versucht auf ubuntu 12.04 Server samba pdc für Windows Workstations zu installieren. Da ich Windows 8 pro habe überlege ich...
  2. Alte Kernel-versionen deinstallieren

    Alte Kernel-versionen deinstallieren: Hi! Also ich verwende Ubuntu 9.10 und mache regelmäßig mit führe regelmäßig updates mit dem hauseigenen automatischen Update-Programm durch!...
  3. zuletzt per apt-get installierte Pakete deinstallieren

    zuletzt per apt-get installierte Pakete deinstallieren: Hallo, ich habe mir gerade über diese Anleitung (http://www.computerhilfen.de/hilfen-6-293714-0.html) auf Ubuntu 9.04 KDE 4.3 installiert um es...
  4. GRUB deinstallieren

    GRUB deinstallieren: Hi! Ich habe ein Laptop mit einer Dualboot-Konfiguration mit Win XP und openSUSE 11, möchte aber aufgrund der zu kleinen Festplatte Linux...
  5. Amarok 2 Beta deinstallieren

    Amarok 2 Beta deinstallieren: Moin Leute, ich habe folgendes Problem: Gestern hab ich per yaourt amarok geupdated. Das Problem besteht jetzt darin, dass die Betaversion mir...