[Debian] Netzwerk

Dieses Thema im Forum "Internet, lokale Netzwerke und Wireless Lan" wurde erstellt von Muffi, 14.03.2007.

  1. #1 Muffi, 14.03.2007
    Zuletzt bearbeitet: 14.03.2007
    Muffi

    Muffi Jungspund

    Dabei seit:
    12.07.2006
    Beiträge:
    17
    Zustimmungen:
    0
    [Debian] Netzwerkeinstellungen gehen verloren

    Hallo zusammen,

    ich habe hier ein Sarge-System mit Kernel 2.8.6-3 laufen. Auf dem Board befindet sich eine Intel-82541PI-Gigabit-Netzwerkkarte. Der Karte habe ich eine feste IP zugewiesen.

    Code:
    # The primary network interface
    auto eth0
    iface eth0 inet static
    address 10.200.40.2
    netmask 255.255.255.0
    broadcast 10.200.40.255
    network 10.200.40.0
    gateway 10.1.0.254
    (eigentlich halte ich es für sinnvoller, die Gateway-Zeile auszukommentieren, aber ich wurde überstimmt. Angeblich bringt das keine Besserung, allerdings habe ich das noch nicht mit eigenen Augen gesehen)

    Dazu wird noch per Skript beim Systemstart das Standardgateway auf 10.1.0.254 gesetzt. Sprich:
    Code:
    /sbin/route add -host 10.1.0.254 eth0
    /sbin/route add default gw 10.1.0.254
    (eigentlich würde es ausreichen, eine Route ins 10.1.0.0-Netz zu setzen, aber das 10.200.0.0-Netz darf eh nicht nach draußen).

    Funktioniert auch alles wunderbar. Zudem befindet sich im Netzwerk ein DHCP-Server. Nach gewisser Zeit gibt es allerdings das Problem, dass sich eth0 "zurückversetzt". Sprich: Die zugewiesene IP-Adresse wegwirft und sich mit dem DHCP vergnügt und sich mit ihm konfiguriert. Also bekommt die Box eine Adresse und verwirft alle Routen (klar, wäre ja auch sinnlos, die zu behalten). Das einzige, was ich ausmachen konnte, war der folgende Eintrag in den Kernel-Logs:

    Code:
    Mar 14 09:17:02 localhost kernel: e1000: eth0: e1000_watchdog: NIC Link is Up 1000 Mbps Full Duplex
    Dabei fällt auf, dass der Link vorher nie als down gemeldet war. Es gibt allerdings keine regelmäßigen Abstände, in denen das Problem auftritt. Mal läuft es ein paar Stunden, sogar Tage, mal nur zehn Minuten.

    Habt ihr eine Ahnung, woran es liegen kann, dass die Box dauernd ihre IP wegwirft und mit dem DHCP fremdgeht? Ich will doch nur, dass sie ihre feste IP behält... ;)

    Edit: Ich hab jetzt erst gesehen, dass ich den Absenden-Knopf gedrückt hatte, bevor ich den Threadtitel zu ende getippt hatte. Bitte seht mir das nach. ;)
    .
    .
    .
    EDIT (autom. Beitragszusammenführung) :
    .

    Fast vergessen: Ein
    Code:
    /etc/init.d/networking restart
    behebt das Problem dann zeitweise. Allerdings kommt eine Meldung "Network unreachable" (klar, Gateway nicht erreichbar, weil unbekannt) und danach eine "Failed to bring up eth0". Die hängt aber nur mit dem erfolglosen Setzen der Route zusammen, oder? Mehr ist mir nicht aufgefallen, was die Meldung verursachen könnte.
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. blur

    blur Tripel-As

    Dabei seit:
    01.12.2006
    Beiträge:
    156
    Zustimmungen:
    0
    Moin, moin,

    das ein Interface seine IP vergisst und sich eine neue per DHCP besorgt, ist nicht normal. Da muss irgendetwas nicht ganz richtig sein. Gibt es mehrere Interfaces? Welche? Läuft auf der Kiste vielleicht selber ein DHCP-Daemon?

    Gruß
    Blur
     
Thema:

[Debian] Netzwerk

Die Seite wird geladen...

[Debian] Netzwerk - Ähnliche Themen

  1. [Debian] USB-Festplatte automatisch erkennen

    [Debian] USB-Festplatte automatisch erkennen: Hallo, ich habe ein Problem mit einer USB-Festplatte an meinem Debian-Server. Es handelt sich dabei um eine 3 TB USB 3.0-Festplatte (GPT)....
  2. [Debian] User + gruppe mit rechten anlegen?

    [Debian] User + gruppe mit rechten anlegen?: Hallo, liebes Unixboard Ich habe folgendes problem ich hab en Root ssh login verboten. So das es nicht möglich ist mit root einzuloggen. ich...
  3. [Debian] - Eigener Server, ISPConfig wie var/www/ mounten?

    [Debian] - Eigener Server, ISPConfig wie var/www/ mounten?: Hallo Zusammen Ich bin erst kürzlich von Windows zu Debian 5.0 Lenny umgestiegen um meinen eigenen Server zu haben, Jetzt hab ich aber das...
  4. [Debian] Samba Problem mit Erreichbarkeit per Hostname

    [Debian] Samba Problem mit Erreichbarkeit per Hostname: Hi, unmittelbar nach dem Booten besteht die Chance, dass der Server nicht über den Hostname \\hostname erreichbar ist - über die IP lässt sich...
  5. [Debian] Xvfb + KDE3

    [Debian] Xvfb + KDE3: Hi, ich habe atm einen kleinen Server laufen, da es sich hierbei um einen Fileserver (Samba) handelt arbeite ich auch mit ACLs und die kann man...