CentOS 7 Grafikkarte auswählen

Dieses Thema im Forum "RedHat,Fedora & CentOS" wurde erstellt von biro, 25.09.2014.

  1. biro

    biro Grünschnabel

    Dabei seit:
    25.09.2014
    Beiträge:
    4
    Zustimmungen:
    0
    Hallo Zusammen,

    ich bin neu hier und auch neu in der Linux-Welt und möchte erstmal alle begrüßen.

    Nun zu meinem Problem:
    Ich habe zuhause eine Workstation für wissenschaftliche Berechnungen. Darauf habe ich CentOS 7 installiert.

    Dabei habe ich zwei Probleme:
    1.
    Über die OnBoard Grafikkarte (Matrox G200) erhalte ich ein Bild, über lspci wird diese auch richtig angezeigt. Leider weiß ich nicht, welcher Treiber dafür verwendet werden. Auf jedenfall "reagiert" das Bild verzögert (bzw. ziemlich langsam) auf Benutzereingaben, als würde ich den Computer über Netzwerk verwenden. Liegt das an den Treibern oder daran, dass diese Grafikeinheit nur für rudimentäre Zwecke zu verwenden ist (Es handelt sich um ein Supermicro Serverboard X9DRi-F).

    2.
    Ich verwende in diesem PC eine weitere Grafikkarte (Radeon R9 290X). Diese wird über lspci auch richtig angezeigt, aber ich bekomme kein Bild, wenn an diese einen Bildschirm angeschlossen wird. Aber dazu muss ich sagen, dass ich auch beim Systemstart kein Bild über die Radeon habe. Nur über die OnBoard Grafik. Eine BIOS Einstellung zur Auswahl der Grafikkarte steht zwar in der Anleitung, aber fehlt im BIOS (ein Update wollte ich noch ausführen).

    Eine Google-Suche bringt zwar viele Ergebnisse zur Konfiguration des X Servers, aber nicht, wie ich zwischen den beiden Grafikkarten wähle (Geht das überhaupt ?).
    Kann mir jemand sagen, wie ich den X Server so einrichte, dass ich ein Bild über die Radeon bekomme. ATI Treiber will ich vorerst nicht installieren, die Probleme um diese Sache sind mir bewusst.

    Für eure Hilfe danke ich schonmal im voraus.

    Viele Grüße
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 schwedenmann, 25.09.2014
    schwedenmann

    schwedenmann Foren Gott

    Dabei seit:
    18.11.2003
    Beiträge:
    2.635
    Zustimmungen:
    2
    Ort:
    Wegberg
    Hallo

    Der Treiber ist mga für Matroxkarten
    Du müßtest also : lsmod | grep mga bzw. lsmod | grep matrox eine Ausgabe erhalten, ob der Treiebr geladen ist.

    Dann solltest du dir mal die logs von xorg ansehen, was die zu dem Problem sagen

    Wen du im Bios die onboardgraka nicht abstellen kannst, brauchts du andere erst gar nicht einbauen, es wird afaik immer die onboard genutzt.

    mfg
    schwedenmann
     
  4. biro

    biro Grünschnabel

    Dabei seit:
    25.09.2014
    Beiträge:
    4
    Zustimmungen:
    0
    Danke für deine Antwort.

    Was ich bei meinem ersten Post vergessen habe, ich kann die OnBoard-Grafik über einen Jumper deaktivieren.


    Verstehe ich das jetzt richtig, dass ich die OnBoard-Grafik auf jeden Fall deaktivieren muss um die Radeon-Grafikkarte zu nutzen ?
     
  5. #4 biro, 25.09.2014
    Zuletzt bearbeitet: 26.09.2014
    biro

    biro Grünschnabel

    Dabei seit:
    25.09.2014
    Beiträge:
    4
    Zustimmungen:
    0
    Ich habe die beiden Befehle mal ausprobiert.
    Für lsmod | grep mga erhalte ich folgende Ausgabe:
    (Ich entschuldige mich für die Ausgabe, ich habe alles abschreiben müssen, da ich kein Internet an meiner Workstation habe)

    Code:
    mgag200                42283   2
    syscopyarea            12529   1   mgag200
    sysfillrect                12701   1   mgag200
    sysimgblt                12640   1   mgag200
    drm_kms_helper     52758   1   mgag200
    ttm                        83948    1   mgag200
    drm                      297829   4   ttm,drm_kms_helper,mgag200
    i2c_algo_bit            13413   2   igb,mgag200
    i2c_core                 40325    6   drm,igb,i2c_i801,drm_kms_helper,mgag200,i2c_algo_bit
    
    für lsmod | grep matrox erhalte ich überhaupt keine Ausgabe

    Ich verstehe zwar nicht, was in der ersten Ausgabe steht, aber es sieht mir nicht nach meiner Grafikkarte aus!
    Kann mir jemand weiterhelfen ?


    Leider ist mir gerade noch ein Problem aufgefallen, was vielleicht das "Trägheitsproblem" erklärt. Während ich am Computer nichts tue und auch kein weiteres Programm läuft wird trotzdem dauerhaft auf die Festplatte zugegriffen ?
    Gibt es da ein bekanntes Problem ?
     
  6. #5 Lord_x, 26.09.2014
    Zuletzt von einem Moderator bearbeitet: 26.09.2014
    Lord_x

    Lord_x Guest

    Hier wird vermutlich nur der normale VESA Treiber angesprochen!

    BIOS Update zuerst machen! Das ist wichtig!

    Ja dann musst du mit der Onboard leben.

    Würde ich so machen ja.

    Weil das geladene Modul nicht matrox heisst!

    Doch das Modul heisst "mgag200" Matrox G200.

    Nein eigentlich nicht.

    Du solltest dir dringend Internet auf diesem PC verschaffen und mal ein komplettes Update machen. (BIOS, CentOS etc.) Danach würde ich die interne Grafikkarte deaktivieren (entweder im BIOS oder per Jumper) und für die ATI verwenden. Ist die interne deaktiviert, muss auf der ATI ein Bild kommen! Wenn nicht, stimmt da etwas nicht. Weiter sollte CentOS dann automatisch Xorg mit dem Treiber "readon" starten. Sollte das alles nicht klappen, kannst du auch den offiziellen Treiber von ATI versuchen. Dieser hat den Namen "fglrx". Vielleicht kannst du auch mal eine aktuelle Live-CD (z.B. Ubuntu 14.04) starten und schauen was da erkannt wird.
     
  7. biro

    biro Grünschnabel

    Dabei seit:
    25.09.2014
    Beiträge:
    4
    Zustimmungen:
    0
    vielen Dank für deine ausführliche Antwort Lord_x,

    wenn ich zuhause bin will ich die von dir angesprochenen Punkte ausprobieren und danach melde ich mich nochmal.
    Nur noch eine Frage:
    Wenn nur der normale VESA-Treiber geladen ist, wie kann ich das ändern, sodass "mga" als Treiber verwendet wird ?

    Gestern habe ich versucht Ubuntu 14.04 (Desktop) von DVD zu starten. Hat nicht funktioniert, ich habe nur einen grauen Bildschirm erhalten. Die Servervariante wiederum hat funktioniert, jedoch gibt es da kein Live-System. Kann es sein, dass die Desktop Variante irgendeine Hardware nicht unterstüzt ? Am Xeon sollte es nicht liegen, dieser sollte laut Homepage auch in der Desktop Variante unterstützt werden.
     
  8. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
Thema: CentOS 7 Grafikkarte auswählen
Besucher kamen mit folgenden Suchen
  1. centOs 7.2 erfahrungen

    ,
  2. grafikkarte in centos 7 einstellen

    ,
  3. centos grafikkartentreiber

    ,
  4. grafikkarten treiber centos
Die Seite wird geladen...

CentOS 7 Grafikkarte auswählen - Ähnliche Themen

  1. Centos 7.2.15.11 - yum install ecryptfs-utils-gui

    Centos 7.2.15.11 - yum install ecryptfs-utils-gui: Hallo ich habe hier eine alte Informationseite >>> https://www.centos.org/docs/5/html/5.4/technical-notes/ecryptfs-utils.html dort wird so die...
  2. Centosbefehle

    Centosbefehle: Hallo ich habe ein Centos 7.2.15.11 image (mit Hdclone von Miray gemacht) Ich möchte das Image auf eine existierende Ubuntu installation...
  3. Welche Paketquellen sind empfohlen? -CentOS 7.2.15.11

    Welche Paketquellen sind empfohlen? -CentOS 7.2.15.11: Hallo liebes Forum. Es scheint mir wie eine plumpe Anfängerfrage, jedoch habe ich zu dem Thema nichts sinnvolles gefunden. Ich habe CentOS...
  4. linux-firmware-nonfree in Centos 15.11 (64 Bit)

    linux-firmware-nonfree in Centos 15.11 (64 Bit): Hallo wie kann man linux-firmware-nonfree in Centos 15.11 (64 Bit) installieren?
  5. Centos 15.11 und grub anpassen

    Centos 15.11 und grub anpassen: Hallo ich habe Centos 15.11 (64 bit) Ich möchte grub anpassen und zwar so das ich nicht im Grubmenü an Stelle 0 stehe , sondern an Stelle 4 Wie...