Brother HL2030 nach einiger Zeit nicht mehr "ready"

Dieses Thema im Forum "Drucker / Scanner" wurde erstellt von Spear_Hawk, 27.09.2006.

  1. #1 Spear_Hawk, 27.09.2006
    Spear_Hawk

    Spear_Hawk Grünschnabel

    Dabei seit:
    13.03.2006
    Beiträge:
    9
    Zustimmungen:
    0
    Ort:
    Irgendwo in Deutschland
    Hallo @all,

    ich habe auf meinem Debian Server den Drucker Brother HL2030 angeschlossen und per Samba freigegeben. Funktioniert alles wunderbar, ich kann von Windows aus auf diesen Drucker zugreifen und auf dem Linux System selber kann ich natürlich auch Drucken. Mein Problem ist jezt, dass der Drucker nach einer gewissen Zeit in den Stromsparmodus geht, was er ja auch OK ist, nur kann ich dann nach einer längeren Zeit im Stromsparmodus nicht mehr Drucken. Die Druckaufträge hängen zwar in der Warteschlange auf dem Server aber gleichzeitig steht da noch "HL2030 is not ready" wenn ich mir die Warteschlange anschaue mit lpq. Der Server sendet die Druckaufträge nicht an den Drucker, welcher dann somit auch nicht aus dem Stromsparmodus aufwachen kann, da er ja nichts bekommt. Ich krieg den Drucker dann nur wieder zum laufen, wenn ich den Befehl /usr/bin enable HL2030 ausführe, ein Aus- und wieder Einschalten oder reboot bringt nichts. Danach funktioniert es wieder bis er halt wieder in diesen Stromsparmodus fällt X(

    Ich könnte mir jetzt zwar ein Script schreiben, welches jede Minute prüft ob der Drucker noch ready ist und ansonsten den oben genannten Befehl ausführt um ihn wieder zu aktivieren, aber das find ich ein bischen unschön. Gibt es vielleicht noch eine andere Möglichkeit z.B. in einer Cups config Datei oder sonst einer config Datei einfach was zu
    ändern ?(

    Gruß
    spear_hawk
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. Lumpi

    Lumpi Haudegen

    Dabei seit:
    14.06.2006
    Beiträge:
    663
    Zustimmungen:
    0
    Ort:
    Dessau
    Hallo

    Was passiert, wenn du den Spooler (Warteschlange) vom Server deaktivierst?
    IMHO werden dann die Druckaufträge direkt an den Drucker geschickt.

    Gruß Lumpi
     
  4. #3 Spear_Hawk, 28.09.2006
    Spear_Hawk

    Spear_Hawk Grünschnabel

    Dabei seit:
    13.03.2006
    Beiträge:
    9
    Zustimmungen:
    0
    Ort:
    Irgendwo in Deutschland
    Hallo

    das wäre ne Idee, aber wie soll ich den Spooler deaktivieren? ich find da irgendwie nichts. Wäre für ne kurze Beschreibung, wie ich den Spooler deaktivieren kann, dankbar.

    Gruß
    spear_hawk
     
  5. Lumpi

    Lumpi Haudegen

    Dabei seit:
    14.06.2006
    Beiträge:
    663
    Zustimmungen:
    0
    Ort:
    Dessau
    Hallo,

    Mein vorheriger Post war Knete ;)
    Mittels der Warteschlange konfigurierst du IMHO den drucker.
    Ohne hast du keinen ;)

    Mir fällt mom aber nicht sinnvolles ein, ausser den
    Sleep-Modus am Drucker zu deaktivieren.
    Aber das wäre nur zu empfehlen, wo du
    nicht die Stromrechnung zahlst :D

    Gruß Lumpi
     
  6. #5 Spear_Hawk, 30.09.2006
    Spear_Hawk

    Spear_Hawk Grünschnabel

    Dabei seit:
    13.03.2006
    Beiträge:
    9
    Zustimmungen:
    0
    Ort:
    Irgendwo in Deutschland
    Hallo,

    Stimmt, man bracht ja einen Spooler zu Drucken.

    Ich habs das Problem jetzt dann halt doch per Skript gelöst:

    Code:
    #!/bin/bash
    
    zeile=`lpq | grep HL2030`
    
    #echo $zeile   #Testausgabe der Variable $zeile
    
    if [ "$zeile" = "HL2030 is not ready" ]; then /usr/bin/enable HL2030
    fi
    
    Das Skript las ich dann per cron jede Minute ausführen und dann funzt des auch soweit mal.

    Falls jemand noch eine Idee hat, wie man das auch ohne Skript lösen kann, dann bitte posten!!!

    Gruß
    spear_hawk
     
  7. #6 root1992, 30.09.2006
    root1992

    root1992 von IT-Lehrern besessen

    Dabei seit:
    02.01.2006
    Beiträge:
    1.138
    Zustimmungen:
    0
    Ort:
    Märchenwald
    Ich habe ein ähnliches "Problem" ich habe zwar einen Kyo.
    Wenn ich länger nichts drucke zeigt er sleeping an. Wenn ich dann etwas drucke macht er nichts. Wenn ich wie sonst auf "go" drücke macht er auch nichts. Ich öffne dann immer die "Obere Abdeckung", dann wacht er auf und schreit und druckt.

    Aber meistens denke ich dran und wenn er sleeping anzeigt drücke ich auf "go" und dann kann ich ganz normal drucken.
     
  8. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
Thema:

Brother HL2030 nach einiger Zeit nicht mehr "ready"

Die Seite wird geladen...

Brother HL2030 nach einiger Zeit nicht mehr "ready" - Ähnliche Themen

  1. Drucken mit Brother MFC-425CN

    Drucken mit Brother MFC-425CN: Hallo, da ich inzwischen mit UBUNTU immer weniger zufrieden war habe ich nach einer Alternative gesucht und CentOS 6.3 gefunden. Seit einigen...
  2. Brother HL3040CN druckt nicht

    Brother HL3040CN druckt nicht: Moinsen, ich habe einen Brother HL3040CN, angeschlossen via Netzwerk(ping klappt) und er will einfach nicht drucken. Die treiber von der Brother...
  3. KompatibleTonerkartusche für Brother HL 2140

    KompatibleTonerkartusche für Brother HL 2140: Hallo Community, ich erstelle einen neuen Thread, weil ich hier nicht in Uralt-thread schreiben will. bin auf der Suche nach einer kompatiblen...
  4. Brother HL-2030 im Netzwerk installieren

    Brother HL-2030 im Netzwerk installieren: Hallo, ich bin noch Linuxanfänger und habe hier zwei PCs, die über einen Switch vernetzt sind. Es gibt keinen DHCP-Server, ich habe beiden PCs...
  5. Installation Multifunktionsgerät Brother dcp 135 c

    Installation Multifunktionsgerät Brother dcp 135 c: Hallo, ich bin ein neuer Open suse 11.1 Nutzer. Mein Multifuktionsgerät brother dcpß 135 c habe ich angeschlossen und die Druckertreiber...