Boot-Problem mit Win XP und Ubuntu

Dieses Thema im Forum "Installation & Basiskonfiguration" wurde erstellt von Death-Gaze, 13.07.2007.

  1. #1 Death-Gaze, 13.07.2007
    Death-Gaze

    Death-Gaze Jungspund

    Dabei seit:
    13.07.2007
    Beiträge:
    18
    Zustimmungen:
    0
    Hallo,

    vielleicht kann mir ja hier jemand helfen.

    Ich habe meine Festplatte heute formatiert und anschließend auf eine PArtition Windows XP installiert. Danach hab ich die Ubuntu DVD eingelegt, das OS gestartet und anschließend über den "Installieren-Button" installiert. Am Ende der Installation kam die Meldung, dass "Grub" nicht installiert werden konnte bzw. wurde.
    Jetzt habe ich das Problem, dass beim Starten des Rechners automatisch Windows XP gestartet wird. Lege ich wieder die Ubuntu DVD ein, überspringt er das Auswahlfenster (z.B. "Starten und Installieren") und startet Linux. Diese Version ist aber scheinbar nicht die, die ich installiert habe :think:

    Kann mir da jemand helfen?

    Mein Ziel war es eigentlich, die Festplatte in drei Partitionen aufzuteilen:

    1. Windows XP (20 GB)
    2. Ubuntu (20 GB)
    3. Gemeinsame Daten (rund 130 GB)

    Weiterhin sollte das Ganze so ablaufen, dass ich beim Start des Rechners wählen kann, welches OS ich nutzen möchte.


    Wäre echt super, wenn mir hier jemand helfen könnte :hilfe2:

    Grüße
    Oliver


    P.S.: Vielleicht wichtig: bin Linux Newbie :brav:
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. MTS

    MTS Kaiser

    Dabei seit:
    09.11.2002
    Beiträge:
    1.242
    Zustimmungen:
    0
    Ort:
    NRW, Bochum
    Den Teil verstehe ich nicht. Könntest du das noch einmal anders erläutern ?

    Allgemein: Mit der Ubuntu CD kannst du dein installiertes Linux booten.
    Von dort aus kannst du Grub manuell installieren. Danach wird beim Boot immer ein Menü zur Auswahl erscheinen
     
  4. mali

    mali noob @ linux

    Dabei seit:
    22.12.2006
    Beiträge:
    306
    Zustimmungen:
    0
    Ort:
    Leverkusen
    genau und hier mal eine sehr interessante Hilfe --> GRUB-Manual
     
  5. #4 Death-Gaze, 15.07.2007
    Death-Gaze

    Death-Gaze Jungspund

    Dabei seit:
    13.07.2007
    Beiträge:
    18
    Zustimmungen:
    0
    Also gut, ich versuchs mal Schritt für Schritt zu erklären, was ich da verbrochen habe...

    Ich hab meine 200 GB Festplatte formatiert und in vier Partitionen aufgeteilt:

    3x 20 GB
    1x 135 GB

    Auf die erste 20er Partition kam dann Windows XP (Laufwerk C) drauf.

    Dann bin ich wie folgt vorgegangen:

    - Neustart mit eingelegter Ubuntu DVD

    - Deutsche Sprache und "Starten und Installieren" ausgewählt

    - Auf dem Ubuntu Desktop den Menüpunkt "Installieren" gewählt

    - Sprache, Uhrzeit/ Datum und Keyboard eingestellt

    - Manuelle Wahl der Partition:

    Laufwerk D:

    Device: /dev/hda5

    Type: ext3

    Mount Point: /

    Dann auf "vor" und installiert.

    - Anzeige erreicht 100%, binrgt aber die Meldung, dass GRUB nicht installiert wurde bzw. werden konnte.

    - Neustart >>> Automatisches Booten von Win XP

    - Win XP funktioniert wie gewohnt, alles läuft.

    - Nochmals Neustart >>> Wieder XP

    - Neustart mit Ubuntu DVD im Laufwerk >>> Ubuntu bootet, überspringt das Auswahlmenü einfach und startet von der Disk aus in Englisch.
    >>> 100%ig nicht die von mir installierte Ubuntu Version (Gaim Einstellungen sind nicht mehr vorhanden, Firefox hat nichts in der Chronik, usw.)

    - Neustart >>> XP

    - Neustart mit Booten von der Ubuntu DVD: Auswahlmenü erschei9nt wieder, Auswahl "deutsch" und "Starten und Installieren"

    - Versuch, Ubuntu nochmals zu installieren

    - Im Installationsmenü "Partitionen vorbereiten" wird auf Laufwerk D unter "used" 2800 MB angezeigt, ergo müsste Ubuntu ja tatsächlich installiert worden sein.

    Jetzt die Frage, wie erreiche ich es, dass ich beim Starten des Rechners wirklich zwischen Win und Linux auswählen kann?


    Kleine Anmerkung noch: Deutsche Anleitungen und Hilfen wären mir lieber, da ich im Englischen nicht soooo bewandert bin.


    Achja, noch eine Anmerkung, selbst nach der Ubuntu Installation braucht das OS sehr lange, um gestartet zu werden, also bis man auf dem Dektop ist...



    Danke vielmals für eure Hilfe :))
     
  6. #5 schwedenmann, 15.07.2007
    schwedenmann

    schwedenmann Foren Gott

    Dabei seit:
    18.11.2003
    Beiträge:
    2.635
    Zustimmungen:
    2
    Ort:
    Wegberg
    grub installieren

    Hallo

    boote mit eienr Livecd

    Konsole aufmachen

    root werden per sudo su (jetzte Return)

    mount /dev/hda5 /mnt
    chroot /mount
    grub-install dev/hda
    exit
    umount /mnt

    jetzt bist du wieder in der Livecd, grub sollte jetzt in MBR sitzen und es sollte ein Auswahlmenü erscheinen.


    mfg
    schwedenmann
     
  7. #6 Death-Gaze, 15.07.2007
    Zuletzt bearbeitet: 15.07.2007
    Death-Gaze

    Death-Gaze Jungspund

    Dabei seit:
    13.07.2007
    Beiträge:
    18
    Zustimmungen:
    0
    Irgendwie schein ich da was falsch gemacht zu haben >.>:

    ubuntu@ubuntu:~$ sudo su
    root@ubuntu:/home/ubuntu# mount /dev /hda5 /mnt
    Usage: mount -V : print version
    mount -h : print this help
    mount : list mounted filesystems
    mount -l : idem, including volume labels
    So far the informational part. Next the mounting.
    The command is `mount [-t fstype] something somewhere'.
    Details found in /etc/fstab may be omitted.
    mount -a [-t|-O] ... : mount all stuff from /etc/fstab
    mount device : mount device at the known place
    mount directory : mount known device here
    mount -t type dev dir : ordinary mount command
    Note that one does not really mount a device, one mounts
    a filesystem (of the given type) found on the device.
    One can also mount an already visible directory tree elsewhere:
    mount --bind olddir newdir
    or move a subtree:
    mount --move olddir newdir
    A device can be given by name, say /dev/hda1 or /dev/cdrom,
    or by label, using -L label or by uuid, using -U uuid .
    Other options: [-nfFrsvw] [-o options] [-p passwdfd].
    For many more details, say man 8 mount .
    root@ubuntu:/home/ubuntu# chroot /mount
    chroot: Es ist nicht möglich, das Wurzelverzeichnis in /mount zu ändern: No such file or directory
    root@ubuntu:/home/ubuntu# grub-install dev/hda
    Format of install_device not recognized.
    Usage: grub-install [OPTION] install_device
    Install GRUB on your drive.

    -h, --help print this message and exit
    -v, --version print the version information and exit
    --root-directory=DIR install GRUB images under the directory DIR
    instead of the root directory
    --grub-shell=FILE use FILE as the grub shell
    --no-floppy do not probe any floppy drive
    --force-lba force GRUB to use LBA mode even for a buggy
    BIOS
    --recheck probe a device map even if it already exists

    INSTALL_DEVICE can be a GRUB device name or a system device filename.

    grub-install copies GRUB images into the DIR/boot directory specfied by
    --root-directory, and uses the grub shell to install grub into the boot
    sector.

    Report bugs to <bug-grub@gnu.org>.
    root@ubuntu:/home/ubuntu# exit
    exit
    ubuntu@ubuntu:~$ umount /mnt
    umount: /mnt is not in the fstab (and you are not root)
    ubuntu@ubuntu:~$
     
  8. sudeki

    sudeki Doppel-As

    Dabei seit:
    18.04.2007
    Beiträge:
    114
    Zustimmungen:
    0
    Ort:
    Hamburg
    Ich würde behaupten auf den ersten Blick der fehler liegt hier:
    /dev/hda5 muss das heißen, nicht /dev /hda5

    Du hast da ein Leerzeichen reingemacht zwischen /dev und /hda5, das gehört da nicht hin :)
    Probiers mal ;)
     
  9. #8 Death-Gaze, 15.07.2007
    Death-Gaze

    Death-Gaze Jungspund

    Dabei seit:
    13.07.2007
    Beiträge:
    18
    Zustimmungen:
    0
    Jetzt hab ichs genauso eingegeben, wie schwedenmann es vorgegeben hat, aber es passiert immernoch nichts:(


    ubuntu@ubuntu:~$ sudo su
    root@ubuntu:/home/ubuntu# mount /dev/hda5 /mnt
    mount: /dev/hda5 already mounted or /mnt busy
    mount: according to mtab, /dev/hda5 is already mounted on /mnt
    root@ubuntu:/home/ubuntu# chroot /mount
    chroot: Es ist nicht möglich, das Wurzelverzeichnis in /mount zu ändern: No such file or directory
    root@ubuntu:/home/ubuntu# grub-install dev/hda
    Format of install_device not recognized.
    Usage: grub-install [OPTION] install_device
    Install GRUB on your drive.

    -h, --help print this message and exit
    -v, --version print the version information and exit
    --root-directory=DIR install GRUB images under the directory DIR
    instead of the root directory
    --grub-shell=FILE use FILE as the grub shell
    --no-floppy do not probe any floppy drive
    --force-lba force GRUB to use LBA mode even for a buggy
    BIOS
    --recheck probe a device map even if it already exists

    INSTALL_DEVICE can be a GRUB device name or a system device filename.

    grub-install copies GRUB images into the DIR/boot directory specfied by
    --root-directory, and uses the grub shell to install grub into the boot
    sector.

    Report bugs to <bug-grub@gnu.org>.
    root@ubuntu:/home/ubuntu# exit
    exit
    ubuntu@ubuntu:~$ umount /mnt
    umount: /mnt is not in the fstab (and you are not root)
    ubuntu@ubuntu:~$
     
  10. #9 sudeki, 15.07.2007
    Zuletzt bearbeitet: 15.07.2007
    sudeki

    sudeki Doppel-As

    Dabei seit:
    18.04.2007
    Beiträge:
    114
    Zustimmungen:
    0
    Ort:
    Hamburg
    Hmm, vielleicht meinte er anstatt chroot /mount -> chroot /mnt probier mal :) und ich denke es müsste:
    grub-install /dev/hda heißen (sicher bin ich mir da aber nicht);)

    nochmal zur erklärung:

    /dev/hda5 ist deine ubnutu partition?
    wenn ja dann, als root:

    mount /dev/hda5 /mnt <-- lädt die partition in den ordner /mnt
    chroot /mnt <-- du gibst den befehl dass das / verzeichnis nun /mnt ist
    grub-install /dev/hda <-- du installierst grub auf /dev/hda
    exit <-- verlässt root
    umount /mnt <-- unmountest /mnt und solltest wieder in der livecd sein
     
  11. #10 Death-Gaze, 15.07.2007
    Death-Gaze

    Death-Gaze Jungspund

    Dabei seit:
    13.07.2007
    Beiträge:
    18
    Zustimmungen:
    0
    Ok, das mit dem chroot /mnt scheint gestimmt zu haben, zumindest bringt er keine "Fehlermeldung" mehr. Das mit dem grub-install /dev/hda scheint aber nicht zu stimmen, hier macht erstere Version scheinbar mehr Sinn.
    Ich habs nochmal versucht und hab das Gefühl, dass an der letzten Zeile etwas nicht stimmt (mount /mnt), da danach nichts passiert -.-


    ubuntu@ubuntu:~$ sudo su
    root@ubuntu:/home/ubuntu# mount /dev/hda5 /mnt
    mount: /dev/hda5 already mounted or /mnt busy
    mount: according to mtab, /dev/hda5 is already mounted on /mnt
    root@ubuntu:/home/ubuntu# chroot /mnt
    root@ubuntu:/# grub-install dev/hda
    Format of install_device not recognized.
    Usage: grub-install [OPTION] install_device
    Install GRUB on your drive.

    -h, --help print this message and exit
    -v, --version print the version information and exit
    --root-directory=DIR install GRUB images under the directory DIR
    instead of the root directory
    --grub-shell=FILE use FILE as the grub shell
    --no-floppy do not probe any floppy drive
    --force-lba force GRUB to use LBA mode even for a buggy
    BIOS
    --recheck probe a device map even if it already exists

    INSTALL_DEVICE can be a GRUB device name or a system device filename.

    grub-install copies GRUB images into the DIR/boot directory specfied by
    --root-directory, and uses the grub shell to install grub into the boot
    sector.

    Report bugs to <bug-grub@gnu.org>.
    root@ubuntu:/# exit
    exit
    root@ubuntu:/home/ubuntu# umount /mnt
    root@ubuntu:/home/ubuntu#
     
  12. sudeki

    sudeki Doppel-As

    Dabei seit:
    18.04.2007
    Beiträge:
    114
    Zustimmungen:
    0
    Ort:
    Hamburg
    Bitte beachte dass es /dev/hda sein muss, nicht dev/hda ;)
    Er sagt dir bei mount nur, dass die platte schon gemountet ist.
     
  13. #12 Death-Gaze, 15.07.2007
    Death-Gaze

    Death-Gaze Jungspund

    Dabei seit:
    13.07.2007
    Beiträge:
    18
    Zustimmungen:
    0
    grub-install /dev/hda hab ich ausprobiert, dann kommt nur das hier:

    ubuntu@ubuntu:~$ sudo su
    root@ubuntu:/home/ubuntu# mount /dev/hda5 /mnt
    root@ubuntu:/home/ubuntu# chroot /mnt
    root@ubuntu:/# grub-install /dev/hda
    /dev/hda: Not found or not a block device.
    root@ubuntu:/#
     
  14. sudeki

    sudeki Doppel-As

    Dabei seit:
    18.04.2007
    Beiträge:
    114
    Zustimmungen:
    0
    Ort:
    Hamburg
    und was gibt fdisk -lu /dev/hda bzw. fdisk -lu /dev/sda ? (als root)
     
  15. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  16. #14 Death-Gaze, 15.07.2007
    Death-Gaze

    Death-Gaze Jungspund

    Dabei seit:
    13.07.2007
    Beiträge:
    18
    Zustimmungen:
    0
    Einmal das hier:

    ubuntu@ubuntu:~$ sudo su
    root@ubuntu:/home/ubuntu# fdisk -lu /dev/hda

    Disk /dev/hda: 200.0 GB, 200049647616 bytes
    255 heads, 63 sectors/track, 24321 cylinders, total 390721968 sectors
    Units = sectors of 1 * 512 = 512 bytes

    Device Boot Start End Blocks Id System
    /dev/hda1 * 63 41945714 20972826 7 HPFS/NTFS
    /dev/hda2 41945715 390700799 174377542+ f W95 Ext'd (LBA)
    /dev/hda5 41945778 83891429 20972826 e W95 FAT16 (LBA)
    /dev/hda6 83891493 125837144 20972826 e W95 FAT16 (LBA)
    root@ubuntu:/home/ubuntu#

    Und einmal das hier:

    ubuntu@ubuntu:~$ sudo su
    root@ubuntu:/home/ubuntu# fdisk -lu /dev/sda
    root@ubuntu:/home/ubuntu#
     
  17. sudeki

    sudeki Doppel-As

    Dabei seit:
    18.04.2007
    Beiträge:
    114
    Zustimmungen:
    0
    Ort:
    Hamburg
    hrm..probiers mal mit ein: grub-install --recheck /dev/hda (root)
     
Thema:

Boot-Problem mit Win XP und Ubuntu

Die Seite wird geladen...

Boot-Problem mit Win XP und Ubuntu - Ähnliche Themen

  1. Boot-Problem mit Ubuntu

    Boot-Problem mit Ubuntu: Hab mir gestern Suse installiert, in der Hoffnung dort wuerde mein Scanner sofort erkannt werden. Naja, war nicht der Fall. Und als ich dann...
  2. SuSE Boot-Problem

    SuSE Boot-Problem: Hi, Also mein SuSE 10.2 will irgendwie, nachdem ich ein paar Updates eingespielt habe, den X-Server nicht mehr starten. Ich seh immer nur wieder...
  3. Slackware 10.0: Boot-Problem

    Slackware 10.0: Boot-Problem: Hi, Ich wollte mir Slackware installieren, hab auch allesfertig konfiguriert, aber jetzt habe ich das problem das ich beim booten die Meldung...
  4. Gentoo Boot-Problem: cardmgr -> Kernel Panic

    Gentoo Boot-Problem: cardmgr -> Kernel Panic: Hi, ich hab versucht Gentoo zu installieren, was auch ganz gut lief. Jetzt wollte ich booten, und es hat am Anfang auch alles perfekt...
  5. Linux/Windows parallel = Boot-Problem

    Linux/Windows parallel = Boot-Problem: Hallo! Ich habe mir RedHat 9 besorgt und auch alles super installiert gekriegt! Nun habe ich mir auf meiner Festplatte noch PLatz für eine...