Apt: Automatisches Auflösen von Abhängigkeiten

Dieses Thema im Forum "Debian/Ubuntu/Knoppix" wurde erstellt von Senior.X, 13.10.2009.

  1. #1 Senior.X, 13.10.2009
    Senior.X

    Senior.X Grünschnabel

    Dabei seit:
    29.07.2009
    Beiträge:
    4
    Zustimmungen:
    0
    Guten Abend,

    ich habe vor kurzem Debian 5 neu installiert (Grundsystem). Anschließend habe ich KDE nachinstalliert. Bis jetzt habe ich versucht, lokale Pakete mit APT zu installieren, was jedoch scheiterte, da die Abhängigkeiten nicht automatisch aufgelöst werden.

    Code:
    lemon:/home/senior_x# apt-get install iceweasel
    Paketlisten werden gelesen... Fertig
    Abhängigkeitsbaum wird aufgebaut
    Lese Status-Informationen ein... Fertig
    Probieren Sie »apt-get -f install«, um dies zu korrigieren:
    Die folgenden Pakete haben nicht erfüllte Abhängigkeiten:
      gdebi: Hängt ab: python-central (>= 0.6.11) aber 0.6.8 soll installiert werden
             Hängt ab: gdebi-core (= 0.5.9debian1) soll aber nicht installiert werden
             Hängt ab: python-gtk2 (>= 2.6.3-2) soll aber nicht installiert werden
             Hängt ab: python-vte (>= 1:0.11.15-4) soll aber nicht installiert werden
             Hängt ab: gksu (>= 2.0.0-1ubuntu3) soll aber nicht installiert werden
             Hängt ab: gnome-icon-theme (>= 2.14.0-1) soll aber nicht installiert werden
             Empfiehlt: libgnome2-perl soll aber nicht installiert werden
      iceweasel: Hängt ab: libnspr4-0d (>= 1.8.0.10) soll aber nicht installiert werden
                 Hängt ab: xulrunner-1.9 (>= 1.9.0.3-1) soll aber nicht installiert werden
      skype: Hängt ab: libqt4-dbus (>= 4.4.3) soll aber nicht installiert werden
             Hängt ab: libqt4-network (>= 4.4.3) soll aber nicht installiert werden
             Hängt ab: libqtcore4 (>= 4.4.3) soll aber nicht installiert werden
             Hängt ab: libqtgui4 (>= 4.4.3) soll aber nicht installiert werden
    E: Nicht erfüllte Abhängigkeiten. Versuchen Sie »apt-get -f install« ohne jegliche Pakete (oder geben Sie eine Lösung an).
    lemon:/home/senior_x#            
    
    Was mache ich falsch?

    senior_x

    P.S: Ich habe schon in anderen Foren gestöbert aber nichts passendes gefunden.
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. Emess

    Emess Turmspringer

    Dabei seit:
    08.10.2006
    Beiträge:
    1.045
    Zustimmungen:
    0
    Ort:
    Odenwald
    schon probiert?
     
  4. #3 Senior.X, 13.10.2009
    Senior.X

    Senior.X Grünschnabel

    Dabei seit:
    29.07.2009
    Beiträge:
    4
    Zustimmungen:
    0
    Ja, habe ich:

    Code:
    lemon:/home/senior_x# apt-get -f  install iceweasel
    Paketlisten werden gelesen... Fertig
    Abhängigkeitsbaum wird aufgebaut
    Lese Status-Informationen ein... Fertig
    Probieren Sie »apt-get -f install«, um dies zu korrigieren:
    Die folgenden Pakete haben nicht erfüllte Abhängigkeiten:
      gdebi: Hängt ab: python-central (>= 0.6.11) aber 0.6.8 soll installiert werden
             Hängt ab: gdebi-core (= 0.5.9debian1) soll aber nicht installiert werden
             Hängt ab: python-gtk2 (>= 2.6.3-2) soll aber nicht installiert werden
             Hängt ab: python-vte (>= 1:0.11.15-4) soll aber nicht installiert werden
             Hängt ab: gksu (>= 2.0.0-1ubuntu3) soll aber nicht installiert werden
             Hängt ab: gnome-icon-theme (>= 2.14.0-1) soll aber nicht installiert werden
             Empfiehlt: libgnome2-perl soll aber nicht installiert werden
      iceweasel: Hängt ab: libnspr4-0d (>= 1.8.0.10) soll aber nicht installiert werden
                 Hängt ab: xulrunner-1.9 (>= 1.9.0.3-1) soll aber nicht installiert werden
      skype: Hängt ab: libqt4-dbus (>= 4.4.3) soll aber nicht installiert werden
             Hängt ab: libqt4-network (>= 4.4.3) soll aber nicht installiert werden
             Hängt ab: libqtcore4 (>= 4.4.3) soll aber nicht installiert werden
             Hängt ab: libqtgui4 (>= 4.4.3) soll aber nicht installiert werden
    E: Nicht erfüllte Abhängigkeiten. Versuchen Sie »apt-get -f install« ohne jegliche Pakete (oder geben Sie eine Lösung an).
    lemon:/home/senior_x#
    
    :-\
     
  5. sinn3r

    sinn3r Law & Order
    Moderator

    Dabei seit:
    28.12.2006
    Beiträge:
    2.764
    Zustimmungen:
    0
    Ort:
    Wentorf
    zackbam!
     
  6. #5 Senior.X, 13.10.2009
    Senior.X

    Senior.X Grünschnabel

    Dabei seit:
    29.07.2009
    Beiträge:
    4
    Zustimmungen:
    0
    Oh, ich hatte meine gloreichen Momente

    Ein dickes Entschuldigung/Vielen Dank an euch beide.
     
  7. sinn3r

    sinn3r Law & Order
    Moderator

    Dabei seit:
    28.12.2006
    Beiträge:
    2.764
    Zustimmungen:
    0
    Ort:
    Wentorf
    Immer wieder gerne, Hauptsache ist ja, dass dein Problem gelöst ist... ;)
     
  8. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  9. #7 T-Virus, 13.10.2009
    T-Virus

    T-Virus Free Software Fan :p

    Dabei seit:
    06.01.2009
    Beiträge:
    107
    Zustimmungen:
    0
    War nicht mal die rede davon, dass man ab Lenny nur noch aptitude verwenden sollte?
    Ich nutze nur aptitude und habe bisher keine solche Probleme gehabt.

    T-Virus
     
  10. nikaya

    nikaya Guest

    Ist schon seit Sarge die Empfehlung von Debian. Aber mittlerweile sollen die Unterschiede zwischen Aptitude und apt-get nicht mehr so groß sein. Und große Inkonsistenzen am System entstehen wohl auch nicht mehr bei gemischtem Betrieb. Einige Tools wie module-assistant greifen standardmäßig immer noch auf apt-get zurück.

    Ich habe mich an Aptitude gewöhnt und bleibe dabei.
     
Thema:

Apt: Automatisches Auflösen von Abhängigkeiten

Die Seite wird geladen...

Apt: Automatisches Auflösen von Abhängigkeiten - Ähnliche Themen

  1. openldap automatisches anlegen von Home-Ordner

    openldap automatisches anlegen von Home-Ordner: Hi! Also ich habe auf einem Ubuntu 8.10 Server openldap installiert und mit phpldapadmin konfiguriert. Mit diesem Webinterface habe ich dann...
  2. Automatisches mounten von Partition unter Gnom unterbinden

    Automatisches mounten von Partition unter Gnom unterbinden: Hallo Vorweg, es geht um Gnome unter Ututo (argent. Gentoo-Derivat) und as automatsiche Mounten von Partitionen. Da ich eher wmaker, fluxbox...
  3. [UNRAR] Automatisches löschen der .rar-Dateien nach dem Entpacken

    [UNRAR] Automatisches löschen der .rar-Dateien nach dem Entpacken: Hallo, ich konnte mich einige Zeit ohne Hilfe in der weiten Welt von Linux mehr oder weniger zurecht finden aber jetzt habe ich mal wieder ein...
  4. Automatisches umtauschen von Umlauten.

    Automatisches umtauschen von Umlauten.: Hi, hat hier jemand vielleicht mal son Skript geschrieben das Umlaute in Dateinamen in normale Buchstaben umtauscht. Für ganze...
  5. Automatisches FTP Backup

    Automatisches FTP Backup: Hallo, bei uns mir Zuhause hängen zwei Server im Netz, und ich möchte, das einer (der mit Ubuntu läuft) cih automatisch jede Woche mit dem...