Apache ignoriert htaccess

Dieses Thema im Forum "Web- & File-Services" wurde erstellt von gu4rdi4n, 27.10.2008.

  1. #1 gu4rdi4n, 27.10.2008
    gu4rdi4n

    gu4rdi4n Freak

    Dabei seit:
    29.11.2006
    Beiträge:
    116
    Zustimmungen:
    0
    Ort:
    Elsfleth
    hi,
    ich habe auf meinem Rechner (Ubuntu-8.04) einen Apache-Server laufen (Apache2 über apt-get).
    Die /etc/apache2/http.conf ist leer, und wie es aussieht wird stattdessen eine /etc/apache2/apache2.conf benutzt.
    In keiner von beiden Datein enthält irgendetwas über AllowOverride, also sollte Apache den Standart "AllowOverride All" benutzen.

    Nun habe ich in einem Ordner "/var/www/foo" (welcher z.b. sensible Daten enthält) die Datei .htaccess dem Inhalt
    Code:
    Deny from all
    
    kann aber trotzdem den Unterordner mittels "http://localhost/foo/bar" oder die Datei "http://localhost/foo/bla.ini" ohne Hindernisse aufrufen.
    Aber Warum?
    Die .htaccess sollte dies doch unterbinden, oder?
    Was mache ich Falsch?

    (Und bevor überflüssige Fragen auftauchen: Ja, /var/www ist http://localhost/ und wird auch über den Apache2 gesteuert.)


    Ich danke für jede Hilfe.
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 bitmuncher, 27.10.2008
    bitmuncher

    bitmuncher Der Stillgelegte

    Dabei seit:
    08.05.2007
    Beiträge:
    3.171
    Zustimmungen:
    0
    Wie sehen die AllowOverride-Settings für das VirtualHost aus?
     
  4. #3 gu4rdi4n, 27.10.2008
    gu4rdi4n

    gu4rdi4n Freak

    Dabei seit:
    29.11.2006
    Beiträge:
    116
    Zustimmungen:
    0
    Ort:
    Elsfleth
    Es existieren keine (jedenfalls finde ich keine), daher sollten sie dem Apache2-Standart entsprechen.


    Ich hab das gesamte /etc/apache2 Verzeichniss mal (tar.gz-)verpackt und an diesen Post angehängt.
    Wenn es noch Fragen bezüglich der Einstellungen gibt könnt ihr selbst nachschauen.
     

    Anhänge:

  5. #4 bitmuncher, 27.10.2008
    bitmuncher

    bitmuncher Der Stillgelegte

    Dabei seit:
    08.05.2007
    Beiträge:
    3.171
    Zustimmungen:
    0
    Siehe deine sites-available/default
    Code:
            <Directory /var/www/>
                    Options Indexes FollowSymLinks MultiViews
                    AllowOverride None
                    Order allow,deny
                    allow from all
            </Directory>
    
    Damit geht .htaccess natürlich nicht. Die gesetzte Direktive AllowOverride legt fest, ob und welche Direktiven in dem benutzereigenen .htaccess-Datei übersteuert werden dürfen und welche nicht. D.h. also, dass bei dir keine Einstellung durch die .htacess festgelegt werden kann. Mögliche Werte:

    - All : Erlaubt das Setzen aller Direktiven, die in der Datei .htaccess erlaubt sind.
    - None : .htaccess-Dateien werden komplett ignoriert.
    - AuthConfig : Erlaubt die Verwendung von Autorisierungs-Anweisungen
    - FileInfo : Erlaubt die Verwendung von Direktiven zur Steuerung der Dokumenttypen
    - Indexes : Erlaubt die Verwendung von Direktiven zur Steuerung von Verzeichnisindizes
    - Limit : Erlaubt die Verwendung von Direktiven zur Steuerung des Zugriffs von Hosts
    - Options : Erlaubt die Verwendung von Direktiven zur Steuerung spezieller Verzeichniseigenschaften

    Siehe dazu auch die Doku vom Apache.
     
  6. #5 gu4rdi4n, 27.10.2008
    gu4rdi4n

    gu4rdi4n Freak

    Dabei seit:
    29.11.2006
    Beiträge:
    116
    Zustimmungen:
    0
    Ort:
    Elsfleth
    ah, danke.

    Erklären was das bedeutet musst du nicht, ich habe nur nicht gewusst das es in der sites-available/default drin steht, sondern hab nur in der apache2.conf gesucht.

    Jedenfalls funktioniert es jetzt, und dafür bin ich Dankbar. :-)
     
  7. #6 bitmuncher, 27.10.2008
    bitmuncher

    bitmuncher Der Stillgelegte

    Dabei seit:
    08.05.2007
    Beiträge:
    3.171
    Zustimmungen:
    0
    Tipp für die Zukunft... Um eine Direktive in einem Konfigurationsordner zu suchen, hilft meist ein

    Code:
    grep -r "suchstring" /mein/ordner
    Das ergibt dann z.B. bei deiner Konfiguration:

    Code:
    bitmuncher@admin-laptop:/data/bitmuncher/apache2$ grep -r "AllowOverride" ./
    ./mods-available/alias.conf:    AllowOverride None
    ./mods-available/userdir.conf:                AllowOverride FileInfo AuthConfig Limit
    ./sites-enabled/000-default:            AllowOverride None
    ./sites-enabled/000-default:            AllowOverride None
    ./sites-enabled/000-default:            AllowOverride None
    ./sites-enabled/000-default:        AllowOverride None
    ./apache2.conf:# for additional configuration directives.  See also the AllowOverride
    ./apache2.conf:#        AllowOverride None
    ./sites-available/default:              AllowOverride None
    ./sites-available/default:              AllowOverride None
    ./sites-available/default:              AllowOverride None
    ./sites-available/default:        AllowOverride None
    ./mods-enabled/alias.conf:    AllowOverride None
    
     
  8. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
Thema: Apache ignoriert htaccess
Besucher kamen mit folgenden Suchen
  1. apache2.tar.gz

Die Seite wird geladen...

Apache ignoriert htaccess - Ähnliche Themen

  1. apache2 ignoriert .haccess Datei einfach

    apache2 ignoriert .haccess Datei einfach: Ich habe eine kleines Problem mit meinem Apache2 unter Ubuntu hoary . Er ignoriert einfach alle .htaccess files . AuthUserFile .htpasswd...
  2. Update auf Apache >=2.4.12 unter Debian Jessie

    Update auf Apache >=2.4.12 unter Debian Jessie: Hi, aufgrund eines Bugs in Apache 2.4 benötige ich zum Deployment von Seafile unter Debian Jessie das Paket apache2 in der Version >= 2.4.12...
  3. Centos und Apache (VirtualHost)

    Centos und Apache (VirtualHost): Hallo, ich bin gerade dabei die Firmenseiten unserer Unternehmensgruppe neu zu gestalten. Insgesammt sind es 3 Unternehmen. Als Server wurde mir...
  4. Apache Software Foundation gibt sich neues Logo

    Apache Software Foundation gibt sich neues Logo: Die Apache Software Foundation hat ihr Webseitendesign überarbeitet und sich ein neues Logo gegeben. Die Organisation sieht sich mit über 350...
  5. Apache Log-Meldung File does not exist

    Apache Log-Meldung File does not exist: Hallo zusammen, in der Logdatei von Apache wird folgende Meldung ausgegeben: … [Thu Jan 07 14:36:03 2016] [error] [client 111.222.333.444] File...