Probleme mit virtual hosts

Dieses Thema im Forum "Web- & File-Services" wurde erstellt von kuahmelcher, 13.10.2014.

  1. #1 kuahmelcher, 13.10.2014
    kuahmelcher

    kuahmelcher Grünschnabel

    Dabei seit:
    19.08.2014
    Beiträge:
    6
    Zustimmungen:
    0
    Guten Abend Forum,

    ich habe ein Problem damit einen virtual host einzurichten.

    Bedingungen: Apache Version 2.4.7, Linux 3.8.13.16 (Debian Wheezy)

    Ich habe im Verzeichnis /etc/apache2/sites-available zwei Konfigurations-Dateien liegen: 000-default.conf und ssl.conf

    Der Inhalt der 000-default.conf ist:

    PHP:
        <VirtualHost *:80>
                
    ServerAdmin webmaster@localhost
                DocumentRoot 
    /var/www
                ErrorLog 
    ${APACHE_LOG_DIR}/error.log
                CustomLog 
    ${APACHE_LOG_DIR}/access.log combined     
                
    <Directory /var/www/>
                        
    Options Indexes FollowSymLinks MultiViews
                        AllowOverride All
                        Order allow
    ,deny
                        allow from all
                
    </Directory>   
        </
    VirtualHost>

    Wenn ich nun versuche einen zweiten virtuellen Host anzulegen (z.B. nach DIESER Anleitung: http://www.raspipress.com/2013/08/a...bdomains-to-your-raspberry-pi-apache2-server/), dann ist KEINE Seite mehr erreichbar, weder die alten, noch die "neue" Seite, die unter einer Subdomain erreichbar sein soll.

    Ich habe alle Dateirechte gesetzt (www-data/755), brav immer den Apache neu gestartet (service apache2 reload) und mit a2ensite einen Link zur entsprechenden .conf-Datei erstellt.

    Die entsprechende conf-Datei siehr z.B. SO aus:


    PHP:
        <VirtualHost *:80>
                
    ServerAdmin webmaster@localhost
                ServerName subdomain
    .altedomain.de
                DocumentRoot 
    /var/www/subdomain.altedomain.de
        
    </VirtualHost>


    Was läuft schief? Ist vielleicht die erste Zeile der "neuen" conf-Datei falsch? WAS muss da 'rein?

    Danke und Gruß, kuahmelcher

    P.S.: Die ssl.conf lauscht auf Port 443 und sollte dabei doch KEINE ROlle spielen - oder?
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 Hannes3, 13.10.2014
    Hannes3

    Hannes3 Doppel-As

    Dabei seit:
    23.06.2004
    Beiträge:
    112
    Zustimmungen:
    0
    Ort:
    Erfurt
Thema:

Probleme mit virtual hosts

Die Seite wird geladen...

Probleme mit virtual hosts - Ähnliche Themen

  1. USB-Probleme mit Virtualbox

    USB-Probleme mit Virtualbox: [gelöst] USB-Probleme mit Virtualbox Moin, ich habe mit meiner Virtualbox das Problem, dass sie angeschlossene USB-Geräte erkennt, ich sie aber...
  2. Probleme mit Virtual Box und Suse 10.3

    Probleme mit Virtual Box und Suse 10.3: Hi @ all habe mir Über Yast die Virtual Box installiert, soweit auch alles okay wollte mir jetzt DSL Emulieren auch alles reingehauten was ich...
  3. probleme bei linux und microsoft virtual pc

    probleme bei linux und microsoft virtual pc: hi leutz, ich setze unter Windows XP Professional SP1 und Microsoft Virtual PC und Linux ein. Allerdings fallen gewisse Dienste nach einer...
  4. Apache2: Probleme mit Virtual Hosts

    Apache2: Probleme mit Virtual Hosts: Hallo Zusammen, ich bin Apache-Einsteiger und habe ein Problem mit Virtual Hosts. Ich mach jetzt schon einige Tage dran rum und komme nicht...
  5. grub-pc Probleme bei upgrade

    grub-pc Probleme bei upgrade: Hallo, ich habe beim dist-upgrade folgendes Problem: ---------- Nach dieser Operation werden 0 B Plattenplatz zusätzlich benutzt. Trigger für...